14:00:40 <efried> #startmeeting nova
14:00:40 <openstack> Meeting started Thu Jul 25 14:00:40 2019 UTC and is due to finish in 60 minutes.  The chair is efried. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:41 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:43 <openstack> The meeting name has been set to 'nova'
14:00:55 <takashin> o/
14:01:00 <cdent> ahoy hoy
14:01:06 <efried> #link agenda https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting
14:01:09 <artom> o/
14:02:12 <dansmith> Oj <- here but on a call
14:02:20 <efried> cute
14:03:03 <efried> dansmith getting away with murder as usual
14:03:15 <cdent> https://youtu.be/8K2JYdY2Hok?t=13
14:03:23 <dansmith> um
14:04:31 <artom> dansmith, so you drive white Ford Bronco, right?
14:04:50 <dansmith> oooh, OJ, I see. <groan>
14:05:23 <efried> yeah, sorry about that
14:05:26 <efried> okay, let's go
14:05:35 <efried> #topic Last meeting
14:05:35 <efried> #link Minutes from last meeting: http://eavesdrop.openstack.org/meetings/nova/2019/nova.2019-07-18-21.00.html
14:05:39 <efried> any old bidniss?
14:05:40 * mriedem shows up late
14:06:11 <efried> #topic Release News
14:06:11 <efried> Spec freeze today
14:06:11 <efried> #link spec review notice on ML (with handy review.o.o search) http://lists.openstack.org/pipermail/openstack-discuss/2019-July/008019.html
14:06:44 <efried> Above thread draws attention to four specs (two in the original post, two in mriedem's response) that stand a chance of making it today.
14:07:08 <efried> if you are core-like, please cast your eyes thereupon
14:07:16 <efried> (or even if you're not)
14:08:09 <efried> but it would be polite of us to at least ack the remainder, if nothing else then with a -1 "this isn't far enough along to make freeze, please propose to backlog" or similar.
14:08:38 <efried> Any discussion on spec freeze?
14:08:47 <mriedem> i'll be updating those other 2 i pointed out
14:08:51 <mriedem> since they just need cleaning
14:09:02 <efried> Thanks mriedem.
14:09:33 <efried> Any other release news (other than stable, which is later)?
14:10:08 <efried> #topic Bugs (stuck/critical)
14:10:08 <efried> No Critical bugs
14:10:08 <efried> #link 67 new untriaged bugs (-2 since the last meeting): https://bugs.launchpad.net/nova/+bugs?search=Search&field.status=New
14:10:08 <efried> #link 3 untagged untriaged bugs (-1 since the last meeting): https://bugs.launchpad.net/nova/+bugs?field.tag=-*&field.status%3Alist=NEW
14:10:22 <efried> any bug discussion?
14:10:50 <efried> #topic Gate status
14:10:50 <efried> #link check queue gate status http://status.openstack.org/elastic-recheck/index.html
14:10:50 <efried> #link 3rd party CI status (seems to be back in action) http://ciwatch.mmedvede.net/project?project=nova
14:11:16 <mriedem> not really gate related, but ci related, i've got a change up which converts nova-next to zuulv3 native https://review.opendev.org/#/c/670196/
14:11:21 <efried> gate hasn't been *horrible* lately. Spurious failure rates feel normal-ish, but response time seems somewhat improved.
14:11:22 <mriedem> i plan on eventually doing that for nova-lvm next
14:11:56 <cdent> (obvmwareciexcuse: all the internal quota is used up on internal testing)
14:12:09 <cdent> (someone is "working to get more")
14:12:33 <efried> mriedem: yay, anything that reduces the amount of sh-in-yaml is a win as far as I'm concerned.
14:12:43 <efried> I'm probably not qualified to +2 that one, but I'll have a look.
14:12:46 <mriedem> also,
14:13:03 <mriedem> long-term i think that will allow us to break apart the now-getting-big post_stack_test.sh
14:13:08 <mriedem> into separate ansible tasks
14:14:16 <efried> what's the zoomed-out result of that?
14:14:21 <efried> Shorter jobs on more nodes?
14:14:25 <mriedem> no
14:14:32 <mriedem> manageability of the script
14:14:38 <mriedem> i.e. not a huge ass bash script
14:14:41 <efried> ack
14:16:00 <efried> #topic Reminders
14:16:00 <efried> any?
14:16:30 <efried> #topic Stable branch status
14:16:30 <efried> #link stable/stein: https://review.openstack.org/#/q/status:open+(project:openstack/os-vif+OR+project:openstack/python-novaclient+OR+project:openstack/nova)+branch:stable/stein
14:16:30 <efried> #link stable/rocky: https://review.openstack.org/#/q/status:open+(project:openstack/os-vif+OR+project:openstack/python-novaclient+OR+project:openstack/nova)+branch:stable/rocky
14:16:30 <efried> #link stable/queens: https://review.openstack.org/#/q/status:open+(project:openstack/os-vif+OR+project:openstack/python-novaclient+OR+project:openstack/nova)+branch:stable/queens
14:16:36 <efried> mriedem: stable news?
14:16:45 <mriedem> mel and i flushed a few stein backports
14:16:54 <mriedem> but probably not any release plans right now
14:17:30 <efried> oh, that reminds me, back on release news - are we (nova) responsible for any "libraries" that need a pro forma m-2 release?
14:17:47 <efried> like novaclient or os-vif?
14:18:05 <mriedem> idk if the release team automatically does those, but i'd assume they don't, so it's probably not a bad idea to do a release, though we just recently did a novaclient release
14:18:09 <mriedem> but idk about os-vif
14:18:19 <mriedem> so todo to look at releasing os-vif
14:19:30 <efried> Oh, it's cycle-with-intermediary libs that need a release http://lists.openstack.org/pipermail/openstack-discuss/2019-July/008018.html
14:20:24 <efried> python-novaclient is cycle-with-intermediary
14:20:33 <efried> ...as is os-vif
14:20:35 <efried> so yeah.
14:20:59 <efried> and based on --^ it looks like we're probably responsible for making sure those get proposed, or we'll be shunted to cycle-with-rc
14:21:03 <efried> so
14:21:28 <efried> #action efried to (delegate or) ensure releases as appropriate for python-novaclient and os-vif
14:21:42 <efried> moving on
14:21:48 <mriedem> like i said, we just did novaclient so i don't think we need another now
14:21:51 <mriedem> but os-vif probably
14:22:04 <efried> ack
14:22:24 <efried> I'll poke (and possibly delegate to) sean about it.
14:22:29 <efried> #topic Sub/related team Highlights
14:22:29 <efried> Placement (cdent)
14:22:29 <efried> #link latest pupdate http://lists.openstack.org/pipermail/openstack-discuss/2019-July/007907.html
14:22:59 <cdent> nothing critical to report. tssurya has made some progress on consumer types
14:23:47 <cdent> all the nested magic stuff that we planned to do is done, so if there are nova folk who need/want to use it, it's there and we should talk about it
14:24:40 <cdent> eof
14:25:02 <efried> Yeah, I was sort of hoping that
14:25:02 <efried> #link NUMA modeling spec https://review.opendev.org/#/c/552924/
14:25:02 <efried> would get refreshed in time to do something in Train, but that hasn't happened.
14:25:41 <efried> which means we may want to re-look at
14:25:41 <efried> #link best-effort VGPU affinity spec https://review.opendev.org/552924
14:25:55 <efried> doh
14:25:58 <efried> #undo
14:25:59 <openstack> Removing item from minutes: #link https://review.opendev.org/552924
14:26:09 <efried> #link best-effort VGPU affinity spec https://review.opendev.org/#/c/650963/
14:26:55 <efried> I know RH is pretty interested in getting some kind of VGPU affinity landed in Train.
14:27:07 <efried> How are other cores feeling about making this go?
14:27:10 <efried> mriedem: dansmith
14:27:29 <mriedem> shrug
14:27:36 <dansmith> I thought you already nak'd it?
14:27:59 <efried> I -1d, I did not -2
14:28:02 <mriedem> i would have to reload the context since at one time it was talking about limits and all sorts of crap
14:28:13 <mriedem> idk if it was a new weigher or passing limits down to compute or what
14:28:29 <dansmith> so, I think that bauzas has probably refocused at this point as a result of that, given proximity to the deadline
14:28:30 <efried> and my -1 was based on the possibility of doing the real stuff in Train.
14:28:41 <dansmith> so restarting now is probably going to be rough
14:28:56 <dansmith> (and yes, I wanted you to make a call one way or the other, so I'm not complaining)
14:29:03 <dansmith> mriedem: yep, that's what it is
14:29:37 <mriedem> i also think our plate is already full so...
14:29:46 <mriedem> and i'm still not getting reviews on my mega series so...
14:29:48 <mriedem> double meh
14:30:24 <mriedem> RH should be focused on numa aware live migration imo
14:30:28 <mriedem> and windriver
14:30:34 <artom> I am :)
14:30:34 <mriedem> since starlingx assumes we're just going to deliver it
14:30:36 <mriedem> on a platter
14:30:51 <artom> (When I'm not putting out product fires, which have abated for a bit)
14:32:32 <mriedem> moving on?
14:32:38 <efried> Okay, well, I'll leave this alone for now, and bauzas can request a SFE if necessary.
14:32:55 <efried> API (gmann)
14:32:55 <efried> No update this week. I was in opensource/openstack days Tokyo for full week.
14:33:05 <efried> gmann: anything to add?
14:34:14 <efried> #topic Stuck Reviews
14:34:15 <efried> any?
14:35:16 <efried> #topic Review status page
14:35:16 <efried> #link http://status.openstack.org/reviews/#nova
14:35:16 <efried> Count: 462 (+1); Top score: 1331 (-102)
14:35:16 <efried> #help Pick a patch near the top, shepherd it to closure
14:35:42 <efried> I just abandoned the top one since it had had no activity for >1y
14:36:13 <efried> #topic Open discussion
14:36:30 <efried> Can we talk summit/PTG for a bit?
14:37:05 <efried> It is not at all clear whether we're going to have critical mass to warrant a room at the PTG.
14:37:40 <efried> I'm not sure whether I'll be able to attend.
14:37:41 <mriedem> i've been told to not think about booking until late sept/oct
14:37:52 <mriedem> so i'm not sure i'll be there yet
14:38:04 <efried> mriedem: and give up discounted ticket price??
14:38:09 <mriedem> heh...
14:38:16 <mriedem> i know lots of people aren't going
14:38:31 <efried> and yet, we have to tell them whether we want a room in like two weeks.
14:38:35 <mriedem> well,
14:38:51 <mriedem> i know alex_xu and Fred Li (huawei) have organized meetups in china,
14:39:02 <mriedem> so what i'd probably do is reach out to them to see if they have ideas on local numbers for ptg attendance
14:39:14 <artom> Where's that etherpad of people going/not going?
14:39:17 <mriedem> you'd likely not need a huge ballroom like we normally have, but at least a side meeting room
14:39:23 <efried> #link shanghai nova ptg etherpad https://etherpad.openstack.org/p/nova-shanghai-ptg
14:39:25 <mriedem> i can ask alex/fred in wechat if that helps
14:39:43 <efried> thanks, that would be neat. Alex has acked on the etherpad
14:41:00 <mriedem> i've asked in a wechat room
14:41:05 <mriedem> will let you know
14:41:35 <efried> tbh this is the main thing that's keeping me up nights.
14:41:36 <mriedem> also pinged shane wang
14:42:31 <mriedem> bauzas: isn't in there but i thought he was requesting approval
14:42:37 <artom> efried, the PTG attendee situation>
14:42:37 <dansmith> efried: what, lack of critical mass at ptg?
14:42:50 <dansmith> efried: if so, I don't think you need to worry about that, just MHO
14:43:36 <dansmith> nobody (including the foundation, I expect) is surprised that attendance is going to be very low at this one, so it's going to be whatever it's going to be
14:44:16 <mriedem> efried: yeah i'll let you know what i hear, if there are choices on room size i'd say not a ballroom but a meeting room is probably fine
14:44:17 <efried> Yeah, like on a personal level my family and I are not very happy (understatement) about the prospect of a trip to China in general. If we wind up not running a room, I'd feel better about saying no.
14:44:54 <mriedem> if you personally can't travel that's a different thing, but alex could run the room or something
14:44:58 <dansmith> efried: there will be people there regardless
14:45:01 <mriedem> like they have at local bug smash events
14:45:09 <dansmith> right, alex or any of the people already saying they're going
14:45:14 <dansmith> opportunity to step up and all
14:45:23 <mriedem> right - good management speak there dan
14:45:23 <efried> oo, I like that line.
14:45:32 * dansmith puffs up his chest
14:45:34 <efried> And who knows who will be PTL by then
14:45:34 <mriedem> that's twice in one week
14:45:49 <mriedem> ibm can sniff new first line management potential already
14:46:37 <clarkb> mriedem: there are a range of room sizes
14:46:58 <mriedem> ok, so i'd just say "not a cavernous hall please"
14:47:06 <mriedem> whoever makes it makes it
14:47:13 <mriedem> pick a room lead later
14:47:31 <mriedem> do as much pre-ptg in ML like placement did last time as possible
14:47:53 <efried> ++
14:47:58 <efried> Okay, any other open discussion?
14:48:21 * mriedem awkwardly hugs eric to make him feel....different
14:48:44 <efried> mission accomplished
14:48:46 <efried> Thanks all.
14:48:47 <efried> o/
14:48:47 <efried> #endmeeting