21:01:10 <efried> #startmeeting nova
21:01:11 <openstack> Meeting started Thu Jun 20 21:01:10 2019 UTC and is due to finish in 60 minutes.  The chair is efried. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:01:14 <openstack> The meeting name has been set to 'nova'
21:01:21 <mriedem> o/
21:01:22 <takashin> o/
21:03:05 <mriedem> this is going very well
21:03:34 <efried> so far so good
21:03:43 <mriedem> i blame aspiers for distracting you
21:04:42 <dustinc> o/!
21:05:10 <efried> It's actually code that was distracting me.
21:05:10 <mriedem> is that a stick figure holding some kind of dead varmint?
21:05:24 <efried> #link agenda (updated moments ago) https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting
21:05:42 <efried> #topic Last meeting
21:05:42 <efried> #link Minutes from last meeting: http://eavesdrop.openstack.org/meetings/nova/2019/nova.2019-06-13-14.00.html
21:05:47 <dustinc> gold medal for showing up maybe
21:06:02 <mriedem> dustinc: that's a bronze at best
21:06:10 <dustinc> it's probably not even metal
21:06:10 <efried> actions from last time:
21:06:10 <efried> efried to (delegate? or) send email complaining about climbing bug numbers
21:06:10 <efried> artom to create etherpad for "plz someone else own this" and link to low-hanging fruit section of wiki
21:06:10 <efried> artom to create etherpad for "plz someone else own this" and link from near low-hanging fruit section of wiki
21:06:42 <mriedem> looks like both were successful
21:06:43 <efried> That first thing happened, and (whether in response to that, or the discussion during meeting, or whatever) things happened -- more on that later.
21:06:52 <efried> Yes, the latter also happened - got a link handy?
21:06:55 <mriedem> nope!
21:07:02 <mriedem> i know at least one old ass patch merged b/c of it though
21:07:39 <efried> #link https://wiki.openstack.org/wiki/Nova/Mentoring#Work_Items_for_New_Contributors
21:07:39 <efried> #link https://etherpad.openstack.org/p/nova-reviews-looking-for-owner
21:07:44 <efried> Thanks artom-in-absentia
21:08:16 <efried> #topic Release News
21:08:22 <mriedem> ah i don't think that mentoring wiki is linked from https://wiki.openstack.org/wiki/Nova
21:08:26 <mriedem> hard to find
21:08:40 <mriedem> oh nvm it is, sort of hidden
21:09:25 <efried> Spec freeze is closer than you think. We should probably do another review push soon. But I'm not going to try to get votes on that with four of us here.
21:09:31 <efried> any other release news?
21:09:57 <mriedem> https://wiki.openstack.org/wiki/Nova/Train_Release_Schedule july 25 yeah?
21:09:59 <mriedem> 4 weeks
21:10:05 <mriedem> i feel like we've got enough damn specs
21:10:11 <dustinc> I am still working on the use sdk spec, hoping to push big update today or tomorrow
21:10:33 <dustinc> been distracted a bit by other work but pushing everything else off to get that done asap
21:10:49 <mriedem> as a data point,
21:11:02 <efried> agree mriedem - a spec sprint at this point should be "get merged the ones that are gonna merge, defer ones that aren't"
21:11:04 <mriedem> we have 26 approved blueprints for train, https://blueprints.launchpad.net/nova/train - and 5 of those are complete. some of the already-approved blueprints are huge though
21:11:34 <efried> That's a smaller number than last year. How many pending?
21:11:37 <mriedem> it might be good to comb through what's close-ish and try to focus on putting those over the line
21:11:45 <mriedem> 42 targeted in lp
21:11:51 <mriedem> idk how many open specs there are
21:12:07 <mriedem> i know alex and intel are pushing on the virtual pmem stuff
21:12:27 <efried> 30 open patches in the specs repo with a path of specs/train/approved
21:12:34 <efried> not all of those are actual specs
21:12:47 <efried> five are -2
21:13:12 <mriedem> i would say if we do another review sprint day,
21:13:29 <mriedem> come with an etherpad pre-loaded with categories of ready-ness and priority so we can focus on what's close to get over the line
21:13:37 <efried> ack
21:13:38 <mriedem> b/c i'm not going to start reviewing these RMD specs seriously at this point
21:13:58 <efried> yeah, those are dead, the only thing left of RMD is providers.yaml -- which is in need of an update
21:15:00 <efried> #action efried to put together a spec review etherpad with status and closeness kind of info, and propose a spec review day to push close ones over the line and clear not-close ones off the radar. Kind of thing.
21:15:16 <efried> #topic Bugs (stuck/critical)
21:15:16 <efried> No Critical bugs
21:15:16 <efried> #link 62 new untriaged bugs (down 27!! since the last meeting): https://bugs.launchpad.net/nova/+bugs?search=Search&field.status=New
21:15:16 <efried> #link 1 untagged untriaged bugs (down 11!! since the last meeting): https://bugs.launchpad.net/nova/+bugs?field.tag=-*&field.status%3Alist=NEW
21:15:42 <efried> #success Big improvement in bug triage this week!
21:16:08 <efried> mm, maybe successbot doesn't live here. shrug
21:17:10 <efried> #link check queue gate status http://status.openstack.org/elastic-recheck/index.html
21:17:20 <efried> This one has been sucking lately http://status.openstack.org/elastic-recheck/index.html#1694501
21:18:16 <efried> #link 3rd party CI status http://ciwatch.mmedvede.net/project?project=nova&time=7+days
21:19:03 <efried> that's odd, results from the last couple dozen aren't showing, though they have results.
21:19:14 <efried> will see if I can track down mmedvede
21:19:23 <mriedem> there is an email in the ML about that site
21:19:25 <mriedem> being stale
21:19:27 <efried> oh
21:19:44 <efried> hm, not seeing it.
21:20:39 <efried> he set that up because tintri went dead. Now...?
21:20:47 <mriedem> now i can't find the email either
21:20:55 <efried> yeah, I think you made that up.
21:21:01 <efried> #topic Reminders
21:21:06 <efried> any?
21:21:21 <efried> #topic Stable branch status
21:21:21 <efried> #link stable/stein: https://review.openstack.org/#/q/status:open+(project:openstack/os-vif+OR+project:openstack/python-novaclient+OR+project:openstack/nova)+branch:stable/stein
21:21:21 <efried> #link stable/rocky: https://review.openstack.org/#/q/status:open+(project:openstack/os-vif+OR+project:openstack/python-novaclient+OR+project:openstack/nova)+branch:stable/rocky
21:21:21 <efried> #link stable/queens: https://review.openstack.org/#/q/status:open+(project:openstack/os-vif+OR+project:openstack/python-novaclient+OR+project:openstack/nova)+branch:stable/queens
21:21:27 <efried> mriedem: anything to note about stable?
21:21:30 <mriedem> there was a rocky release
21:21:42 <efried> \o/
21:21:48 <mriedem> https://review.opendev.org/#/c/665514/
21:21:58 <mriedem> next step is flushing the stable/queens reviews and doing a release
21:22:22 <efried> neat
21:22:37 <efried> #topic Sub/related team Highlights
21:22:37 <efried> Placement (cdent)
21:22:37 <efried> #link latest pupdate http://lists.openstack.org/pipermail/openstack-discuss/2019-June/007147.html
21:22:50 <efried> #link Spec for the rest of nested magic is ready to merge (he says, hopefully) https://review.opendev.org/#/c/662191/
21:24:07 <efried> fwiw, this ^ and the
21:24:07 <efried> #link code for root_required, series starting at https://review.opendev.org/#/c/665491/
21:24:07 <efried> piece of it have been what's been taking up my chair time for the past week or so.
21:24:55 <efried> #link rg/rp mappings is merged, series starting at https://review.opendev.org/#/c/662785/
21:25:03 <efried> microversion 1.34 ^
21:25:10 <efried> someone should start using that
21:25:11 <efried> in nova
21:25:26 <efried> oh, mriedem, re root_required, this bud's for you.
21:25:39 <efried> It's specifically for your use cases like MULTI_ATTACH
21:25:54 <mriedem> you know i'm not actively working on that yeah... ?
21:26:23 <efried> Yeah, but you started it.
21:26:23 <efried> so, you should review it or profess adequate guilt for not doing so
21:26:42 <mriedem> i don't feel too guilty about putting up a WIP idea and then watching you guys go nuts with it
21:27:02 <efried> cold
21:27:04 <efried> so cold
21:27:06 <mriedem> ice cold
21:27:17 * dustinc shivers
21:27:17 <efried> API (gmann)
21:27:17 <efried> Updates on ML- #link http://lists.openstack.org/pipermail/openstack-discuss/2019-June/007249.html
21:27:19 <mriedem> i might be turning into cdent with the "do we really need this yet? is someone wanting it?"
21:27:30 <efried> I f'in thought *YOU* wanted it
21:27:41 <mriedem> oh my
21:27:45 <mriedem> i had a solution
21:27:51 <mriedem> hacky but it was a solution
21:28:22 <efried> and somehow you sleep at night
21:28:28 <mriedem> i don't actually
21:28:44 <efried> gmann: anything to add on API?
21:29:02 <efried> #topic Stuck Reviews
21:29:02 <efried> Any?
21:29:23 <efried> #topic Review status page
21:29:23 <efried> #link http://status.openstack.org/reviews/#nova
21:29:23 <efried> Count: 462 (-1); Top score: 1504 (-185)
21:29:23 <efried> #help Pick a patch near the top, shepherd it to closure
21:29:34 <efried> I've noticed action here, thank you
21:29:55 <efried> the overall count hasn't gone down much but I guess that's because patches are coming in fast as well.
21:30:27 <efried> #topic Open discussion
21:30:29 <efried> go
21:31:12 <efried> okay
21:31:18 <efried> thanks all
21:31:25 <efried> and by "all" I mean the three of you.
21:31:29 <efried> o/
21:31:29 <efried> #endmeeting