21:00:18 <efried> #startmeeting nova
21:00:19 <openstack> Meeting started Thu May 23 21:00:18 2019 UTC and is due to finish in 60 minutes.  The chair is efried. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:22 <openstack> The meeting name has been set to 'nova'
21:00:26 <mriedem> .
21:00:43 <efried> #link agenda https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting
21:00:49 <edleafe> \o
21:01:00 <tssurya> o/
21:02:41 <efried> small party.
21:02:50 <efried> at least the cool kids are here.
21:02:52 <efried> and me
21:02:53 <edleafe> more beer for us!
21:03:17 <efried> okay, let's go
21:03:18 <efried> #topic Last meeting
21:03:18 <efried> #link Minutes from last meeting: http://eavesdrop.openstack.org/meetings/nova/2019/nova.2019-05-16-14.00.html
21:03:30 <efried> #link merged cycle themes this morning http://specs.openstack.org/openstack/nova-specs/priorities/train-priorities.html
21:03:30 <efried> as promised last meeting
21:03:44 <efried> fup bug 1827083
21:03:45 <openstack> bug 1827083 in OpenStack-Gate "ERROR: Could not install packages due to an EnvironmentError: HTTPSConnectionPool(host='git.openstack.org', port=443): Max retries exceeded with url: /cgit/openstack/requirements/plain/upper-constraints.txt (Caused by NewConnectionError('<pip._vendor.urllib3.connection.VerifiedHTTPSConnection object at 0x7febbf6ae630>: Failed to establish a new connection: [Errno -3] Temporary failure in name resolution',)) in vexxhost-sjc1" [Undecided,Confirmed] https://launchpad.net/bugs/1827083
21:03:45 <efried> https://review.opendev.org/#/c/659181/ is merged - does that mean the bug can be closed?
21:03:45 <patchbot> patch 659181 - opendev/base-jobs - Only use ipv6 dns if nodepool uses ipv6 (MERGED) - 1 patch set
21:03:51 <efried> mriedem: ^
21:03:58 <mriedem> it's worked around,
21:04:04 <mriedem> i don't think we need to continue talking about it in our nova meeting
21:04:20 <efried> okay.
21:04:36 <efried> Review requested for a couple of patches (artom):
21:04:36 <efried> https://review.opendev.org/#/c/643023/
21:04:36 <efried> https://review.opendev.org/#/c/643024/
21:04:36 <efried> Need second +2/+W
21:04:37 <patchbot> patch 643023 - nova - Move get_pci_mapping_for_migration to MigrationCon... - 5 patch sets
21:04:38 <patchbot> patch 643024 - nova - Allow driver to properly unplug VIFs on destinatio... - 6 patch sets
21:04:52 <efried> These were requested a couple weeks ago. Progress has been made.
21:05:02 <efried> any other old business?
21:05:17 <efried> #topic Release News
21:06:15 <efried> I think the next major thing we're tracking is spec freeze at t-2, July 25th.
21:06:24 <efried> Seems like a long way off right now...
21:06:25 <takashin> o/
21:06:33 <efried> anything else release-y?
21:06:40 <sean-k-mooney> efried: we are doing spec freeze at m1 then
21:07:06 <efried> um, isn't that m2?
21:07:11 <mriedem> yes it's 2
21:07:14 <mriedem> https://wiki.openstack.org/wiki/Nova/Train_Release_Schedule
21:07:41 <sean-k-mooney> ah ok sorry yes m1 is june 6th
21:07:41 <efried> I wouldn't be opposed to doing a "spec proposal freeze" at m1 like keystone
21:08:13 <efried> but not married to the idea.
21:08:20 <efried> #topic Bugs (stuck/critical)
21:08:30 <efried> No Critical bugs
21:08:30 <efried> #link 85 new untriaged bugs (up 7! since the last meeting): https://bugs.launchpad.net/nova/+bugs?search=Search&field.status=New
21:08:30 <efried> #link 11 untagged untriaged bugs (up 1 since the last meeting): https://bugs.launchpad.net/nova/+bugs?field.tag=-*&field.status%3Alist=NEW
21:08:59 <efried> Gate status
21:08:59 <efried> #link check queue gate status http://status.openstack.org/elastic-recheck/index.html
21:09:20 <efried> I said last week that the gate was pretty healthy, thereby cursing it.
21:09:29 <efried> Not seeing a high percentage of spurious failures, but ye gods is it slow.
21:09:42 <mriedem> there was a problem yesterday
21:09:42 <sean-k-mooney> there was a reset yesterday
21:09:49 <sean-k-mooney> hopefully that will help
21:10:35 <efried> okay. I didn't notice it being any faster today. But maybe it's catching up on the backlog
21:10:57 <efried> #link 3rd party CI status http://ciwatch.mmedvede.net/project?project=nova&time=7+days
21:11:00 <melwitt> it's hours in queue before going to a node these days
21:11:26 <efried> yeah
21:11:51 <efried> could it be ipv6 dns workaround? :)
21:12:53 <efried> nova-multi-cell looks fairly ill for the past two or three days. It's non-voting, so maybe we don't care.
21:13:10 <efried> anything else for bugs or CI?
21:13:23 <efried> #topic Reminders
21:13:31 <efried> I got nothin. Anyone?
21:13:52 <efried> #topic Stable branch status
21:13:52 <efried> #link Stein regressions: http://lists.openstack.org/pipermail/openstack-discuss/2019-April/005637.html
21:13:52 <efried> bug 1824435 still pending
21:13:54 <openstack> bug 1824435 in OpenStack Compute (nova) stein "fill_virtual_interface_list migration fails on second attempt" [High,Triaged] https://launchpad.net/bugs/1824435
21:14:12 <efried> this is marked as high, not sure it really is.
21:14:21 <efried> #link stable/stein: https://review.openstack.org/#/q/status:open+(project:openstack/os-vif+OR+project:openstack/python-novaclient+OR+project:openstack/nova)+branch:stable/stein
21:14:21 <efried> #link stable/rocky: https://review.openstack.org/#/q/status:open+(project:openstack/os-vif+OR+project:openstack/python-novaclient+OR+project:openstack/nova)+branch:stable/rocky
21:14:21 <efried> #link stable/queens: https://review.openstack.org/#/q/status:open+(project:openstack/os-vif+OR+project:openstack/python-novaclient+OR+project:openstack/nova)+branch:stable/queens
21:14:35 <mriedem> dropped that bug to medium
21:14:43 <mriedem> imacdonnell comments on https://review.opendev.org/#/c/653065/
21:14:44 <efried> I've dropped pike off of the list ^ since it's -em now. There was one -W patch in there
21:14:44 <patchbot> patch 653065 - nova - Do not create default security group during instan... - 2 patch sets
21:14:48 <mriedem> but i haven't had time to dig into it
21:14:54 <efried> thanks mriedem
21:14:56 <mriedem> regarding stein,
21:15:04 <mriedem> i'm going to propose a release once the approved changes here https://review.opendev.org/#/q/status:open+project:openstack/nova+branch:stable/stein+label:Code-Review=2 are merged
21:15:28 <efried> ight.
21:16:00 <efried> #topic Sub/related team Highlights
21:16:09 <efried> Placement (cdent)
21:16:15 <efried> #link latest pupdate http://lists.openstack.org/pipermail/openstack-discuss/2019-May/006388.html
21:16:26 <efried> From last time:
21:16:28 <efried> #link WIP spec for nested magic https://review.opendev.org/#/c/658510/
21:16:29 <patchbot> patch 658510 - placement - WIP: Spec for nested magic - 2 patch sets
21:16:41 <efried> I'm working on a new rev for ^ right now, should have it up in the next hour or so.
21:16:51 <efried> the theme will be simplification
21:16:57 <efried> #link spec for rg/rp mapping https://review.opendev.org/#/c/657582/
21:16:58 <patchbot> patch 657582 - placement - Resource provider - request group mapping in alloc... - 1 patch set
21:17:06 <efried> Needs an owner
21:17:28 <efried> edleafe or anyone have further nova-related placement info to impart?
21:17:51 <efried> API (gmann)
21:17:54 <edleafe> Not I
21:18:10 <efried> nothing in the agenda, no gmann in channel, anyone have anything here?
21:18:22 <efried> (Discussions about API changes coming up later)
21:18:27 <mriedem> i,
21:18:36 <mriedem> will probably be proposing a simple spec to filter hypervisors by compute service host,
21:18:55 <mriedem> watcher has to jump through a few hoops to get from compute service host to hypervisor which could be optimized with a filter parameter in the api
21:19:26 <efried> ack
21:19:39 <efried> #topic Stuck Reviews
21:19:49 <efried> #link host/node validation in the API on server create http://lists.openstack.org/pipermail/openstack-discuss/2019-May/006518.html
21:20:03 <efried> last I saw on the ML, consensus was "do it early"
21:20:19 <efried> right?
21:20:23 <mriedem> yeah i'm not sure there is much to talk about here, seems everyone wants option 3
21:20:28 <mriedem> validate host via hostmapping,
21:20:30 <mriedem> validate node via placement
21:20:39 <sean-k-mooney> i like ^
21:20:40 <mriedem> optimize later with request spec destination node_uuid magic
21:20:49 <efried> ++
21:21:06 <efried> #topic Review status page
21:21:18 <efried> #link nova review status http://status.openstack.org/reviews/#nova
21:21:25 <efried> no progress on this from me since last week, sorry.
21:21:49 <efried> I think we asked fungi to respin the data, and he did, though it doesn't look like it has changed substantially.
21:22:07 <efried> We still don't know how the list is generated or how the fields are calculated.
21:22:20 <efried> I'll get around to it eventually. Meantime, if anyone else wants to hack, the code is at openstack/reviewday.
21:22:30 <efried> #topic Open discussion
21:22:38 <efried> #link WIP TC Vision Reflection https://review.opendev.org/658932
21:22:39 <patchbot> patch 658932 - nova - WIP: TC Vision Reflection - 3 patch sets
21:22:40 <fungi> yeah, something had broken the installed dependencies for reviewday on the status host
21:22:42 <efried> No movement on this since last week.
21:22:43 <sean-k-mooney> efried: the hover text shows how teh score was dervied
21:22:53 <fungi> that's fixed so it should be refreshing roughly every 10 minutes again
21:23:11 <efried> sean-k-mooney: oh dang, nice spot.
21:23:16 <efried> thanks fungi
21:24:01 <dasp> asking for possibly more reviews on https://review.opendev.org/#/c/658903/ (Directly download and upload images to RBD), given the spec freeze soon
21:24:02 <patchbot> patch 658903 - nova-specs - Directly download and upload images to RBD - 1 patch set
21:24:38 <melwitt> oh yeah, that's on my list. thanks for reminding
21:24:53 <efried> ack, added self
21:25:06 <efried> (stephenfin) Approval for specless blueprint to remove nova-consoleauth https://blueprints.launchpad.net/nova/+spec/remove-consoleauth
21:25:25 <dasp> existing review pointed out that a lot of "helper" functions already exists in code for boot-from-volume stuff, making implementation even easier than before (potentially). Thanks!
21:25:37 <efried> stephenfin said he wouldn't be around to defend himself, but we should tag him with any actions
21:25:41 <efried> so like all of them
21:25:54 <sean-k-mooney> sounds fair
21:25:55 <efried> There was a brief discussion about this today in -nova, /me finds...
21:26:12 <efried> http://eavesdrop.openstack.org/irclogs/%23openstack-nova/%23openstack-nova.2019-05-23.log.html#t2019-05-23T16:34:49
21:26:40 <efried> was any conclusion reached? Can we approve the blueprint?
21:27:18 <mriedem> it would be nice to have *any* anecdotal evidence that people have upgraded through to the point of not using the nova-consoleauth service at all,
21:27:26 <mriedem> because there was a ton of confusion over that after rocky was released
21:27:52 <mriedem> i know mnaser is past that point but don't know if he's killed all nova-consoleauth services
21:28:06 <sean-k-mooney> i guess we shoudl check with some of the deployment tools and see if they have made the switch by defualt and have an automated upgrade path
21:28:11 <mriedem> also no idea how far along/behind the deployment projects are in this regard
21:28:12 <melwitt> yeah, that is my hesitation as well. in theory it should be OK to remove it now but it's been bumpy and could use some reassurance
21:28:48 <mriedem> so before moving forward, i'd want to know how OSA, kolla and tripleo are regarding this first
21:28:50 <efried> okay, hypothetically what if someone is still using it? How careful do we really need to be? It's been deprecated for two releases and we've made efforts to reach out.
21:29:04 <efried> mmph, okay.
21:29:26 <mriedem> removing cells v1 is easy b/c we mostly knew who was using it and most tooling didn't support it,
21:29:37 <mriedem> nova-network is in a similar boat in that people have moved to neutron long ago,
21:29:43 <efried> I guess
21:29:43 <efried> #action stephenfin to find out how OSA, kolla, and TripleO are positioned wrt nova-consoleauth
21:29:43 <efried> which is easy for me to say.
21:29:45 <mriedem> but nova-consoleauth was required everywhere up until rocky
21:29:54 <sean-k-mooney> perhaps the ar to tag stepehen with is email the list and as the deployment prject to confrim what there current support is for deploying without it
21:30:09 <efried> just so
21:30:19 <efried> okay, I guess we move on.
21:31:09 <efried> (melwitt): Seeking approval for specless blueprint to add --before option to nova-manage db archive_deleted_rows https://blueprints.launchpad.net/nova/+spec/nova-archive-before
21:31:34 <efried> #link code for nova-archive-before https://review.opendev.org/#/c/556751/
21:31:35 <patchbot> patch 556751 - nova - Add --before to nova-manage db archive_deleted_rows - 14 patch sets
21:31:38 <melwitt> this started out as a wishlist bug and the author went ahead and created a specless bp for it
21:32:12 <melwitt> being able to archive deleted rows based on time is something I think a lot of people want, I know the folks in RDO cloud really need it
21:32:14 <efried> code looks pretty ready. mriedem and dansmith have had review eyes on it.
21:32:21 <mriedem> huh, ok
21:32:22 <dansmith> yeah
21:32:27 <mriedem> the bp is just paperwork at this point
21:32:32 <mriedem> i think everyone was in line with it already anyway
21:32:36 <dansmith> bp seems unnecessary to me, but.. whatever
21:32:44 <efried> okay, then let's approve it and move on...
21:32:47 <melwitt> yeah. just wanted to bring it up here instead of ninja approving it
21:32:55 <efried> wfm
21:33:08 <efried> done
21:33:14 <melwitt> thanks
21:33:33 <efried> Any other opens?
21:34:21 <efried> cool, thanks all
21:34:21 <efried> o/
21:34:21 <efried> #endmeeting