14:00:01 <gibi> #startmeeting nova
14:00:02 <openstack> Meeting started Thu Dec 14 14:00:01 2017 UTC and is due to finish in 60 minutes.  The chair is gibi. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:05 <openstack> The meeting name has been set to 'nova'
14:00:09 <tssurya> o/
14:00:22 <mriedem> o/ kind o
14:00:23 <mriedem> *of
14:00:25 <gmann> o/
14:00:29 <takashin> o/
14:00:32 <cdent> o/
14:00:33 <edleafe> \o
14:00:34 <cleong> o/
14:00:49 <bauzas> o/
14:00:51 <gibi> I will be your host today
14:01:49 <gibi> let's get started
14:01:51 <gibi> #topic release news
14:02:00 <gibi> #link Queens release schedule: https://wiki.openstack.org/wiki/Nova/Queens_Release_Schedule
14:02:07 <gibi> #info Blueprints: 52 targeted, 52 approved, 13 complete (2 completed since the last meeting)
14:02:16 <gibi> steady progress on bps
14:02:32 <gibi> #link Dev ML thread on making the release cycle 1 year instead of 6 months: http://lists.openstack.org/pipermail/openstack-dev/2017-December/125473.html
14:02:42 <gibi> ML thread that worth to read
14:02:49 <bauzas> Definitely
14:02:54 <cdent> don't just read, comment too
14:03:04 <cdent> there aren't enough regular developers commenting on it, yet
14:03:52 <gibi> moving forward
14:04:01 <gibi> #topic bugs
14:04:05 <gibi> no critical bugs
14:04:07 <bauzas> Well it's also due to some language issue
14:04:34 <gibi> #info 32 new untriaged bugs (up 8 since the last meeting)
14:05:16 <gibi> gate seems OK
14:05:35 <gibi> there was a frequently failing funtional test http://status.openstack.org/elastic-recheck/index.html#1736976
14:05:45 <gibi> but the fix is on master now
14:06:07 <gibi> 3rd party CI
14:06:08 * edleafe was bitten by that
14:06:30 <mriedem> 3rd party ci was ok except zkvm hiccups this week
14:06:34 <mriedem> but that's fixed now i'm told
14:06:44 <gibi> mriedem: thanks
14:06:53 <gibi> anything else about bugs or CI?
14:06:59 <mriedem> we've got'em
14:07:28 <mriedem> i guess i've got one series,
14:07:34 <mriedem> https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:master+topic:bug/1737779
14:07:38 <mriedem> ^ unblocks the trove gate
14:07:53 <mriedem> and fixes issues with resize with a volume attached with the new attach flow
14:08:30 <mriedem> found out last night that fibrechannel backends in cinder are busted with the new flow too
14:08:32 <mriedem> but that's a cinder bug
14:08:40 <mriedem> https://review.openstack.org/#/c/527852/
14:08:43 <mriedem> just FYI if you love FC
14:08:50 <cdent> only fibrechannel? weird
14:09:50 <mriedem> i'm sure there are others
14:09:56 <mriedem> basically anything that brick returns for a host connector,
14:10:00 <mriedem> where the value in the dict is nota string
14:10:02 <mriedem> cinder explodes
14:10:32 <gibi> any other bugs to mention?
14:10:40 <mriedem> nope
14:10:51 <gibi> OK, then moving forward
14:10:53 <gibi> #topic reminders
14:11:12 <gibi> bluerpint status are tracked in #link https://etherpad.openstack.org/p/nova-queens-blueprint-status
14:11:43 <mriedem> we have 2 more bps that are basically done too
14:11:48 <mriedem> so numbers are better than listed
14:12:08 <mriedem> thanks for everyone pushing
14:12:21 <gibi> #topic stable branch status
14:12:30 <gibi> #link stable/pike: https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:stable/pike,n,z
14:12:36 <gibi> link Etherpad for bugs tracked for Pike backports: https://etherpad.openstack.org/p/nova-pike-bug-fix-backports
14:12:42 <gibi> #link Pike 16.0.4 release request https://review.openstack.org/#/c/527275/
14:13:16 <gibi> 16.0.4 contains CVE fixes
14:13:40 <gibi> #link stable/ocata: https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:stable/ocata,n,z
14:13:46 <gibi> #link stable/newton: https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:stable/newton,n,z
14:13:54 <gibi> #action mriedem to send an email to the dev list about what we need to get to newton EOL
14:14:20 <gibi> anything to discuss regarding stable branches?
14:14:52 <mriedem> nope
14:15:02 <gibi> #topic subteam highlights
14:15:15 <gibi> Cells v2
14:15:40 <gibi> do we have anybody awake from the cells subteam?
14:15:45 <mriedem> i am
14:15:47 <mriedem> not sure if dansmith is
14:15:55 <mriedem> we have some bugs
14:16:01 <mriedem> reviews are up, working through them
14:16:11 <mriedem> i think that's it
14:16:15 <gibi> mriedem: thanks
14:16:25 <gibi> Scheduler
14:16:28 <edleafe> Got a status update on nested resource providers. Good progress, but still a lot of work to do.
14:16:31 <edleafe> Alternate host series has mostly merged, just two more to go
14:16:33 <edleafe> cdent got a brain dump from efried_cya_jan on the provider_tree work and will write up a summary
14:16:36 <edleafe> Trying to stay focused until the holidays pull us all away
14:16:39 <edleafe> that's it
14:16:42 <bauzas> Vacations for dansmith
14:16:56 <gibi> edleafe: thanks
14:17:02 <gibi> API
14:17:14 <gibi> gmann and I had a really short meeting
14:17:24 <gmann> gibi: yea not much on API
14:17:36 <gmann> we just floated the reviews
14:18:06 <gibi> Notification
14:18:14 <gibi> short meeting also
14:18:35 <gibi> discussed bugs including the one I mentioned in the gate status topic
14:18:52 <gibi> nothing else really
14:19:05 <gibi> Cinder
14:19:11 <gibi> (mriedem) - new attach flow is merged, some bugs have shaken out, they are being worked (both in nova and cinder)
14:19:47 <gibi> mriedem: anything else you want to add?
14:19:58 <mriedem> nope
14:20:03 <mriedem> well
14:20:08 <mriedem> ildikov is working the multiattach patches
14:20:22 <mriedem> but they are still wip until more reviews happen i think
14:20:44 <mriedem> we need to get the tempest test resurrected for multiattach too
14:21:04 <mriedem> https://review.openstack.org/#/c/266605/
14:21:36 <gibi> mriedem: thanks
14:21:39 <gibi> #topic stuck reviews
14:21:43 <gibi> nothing on the agenda
14:22:09 <gibi> #topic open discussion
14:22:16 <gibi> nothing on the agenda
14:22:27 <gibi> do we have someting to discuss?
14:23:47 <gibi> I guess it means, no
14:23:50 * edleafe stares out the window
14:23:59 <gibi> then let's close this meeting
14:24:05 <gibi> thanks for the participation
14:24:11 <cdent> thansk gibi
14:24:12 <gibi> #endmeeting