21:00:17 <mriedem> #startmeeting nova
21:00:18 <openstack> Meeting started Thu Apr 13 21:00:17 2017 UTC and is due to finish in 60 minutes.  The chair is mriedem. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:19 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:20 <dansmith> o/
21:00:21 <openstack> The meeting name has been set to 'nova'
21:00:25 * bauzas yawns
21:00:28 <takashin> o/
21:00:30 <mriedem> wake up
21:00:47 <bauzas> before I go go ?
21:00:48 <dtp> o/
21:00:49 <mriedem> takashin is up and it's 6am
21:00:52 <dansmith> bauzas: nice
21:00:58 * Vek waves
21:01:03 <melwitt> o/
21:01:35 <mriedem> ok let's get started
21:01:37 <mriedem> #link agenda https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting
21:01:43 <mriedem> #topic release news
21:01:49 <mriedem> #link Pike release schedule: https://wiki.openstack.org/wiki/Nova/Pike_Release_Schedule
21:02:02 <mriedem> important date right now is spec freeze is today
21:02:12 <mriedem> there are some specs out there with +2s
21:02:18 <mriedem> so we're still going through them
21:02:23 <mriedem> also, today is the pike-1 milestone
21:02:27 <mriedem> i haven't tagged it yet though
21:02:33 <mriedem> need to get a fix in from dansmith first i think
21:02:51 <mriedem> this https://review.openstack.org/#/c/456227/
21:02:51 <dansmith> I think my latest rev might actually pass all my own tests
21:02:58 <mriedem> that would be nice
21:03:20 <mriedem> #info Blueprints: 71 targeted, 54 approved, 2 completed
21:03:30 <mriedem> #info Open spec reviews: 58 (down 3 from last week)
21:03:42 <bauzas> I'm about to +W another spec
21:03:54 <mriedem> so looking into my crystal ball, we'll probably be around 60 approved blueprints for pike
21:04:09 <mriedem> any questions about the release?
21:04:22 <mriedem> #topic bugs
21:04:29 <mriedem> #help Our backlog of new untriaged bugs is high (83). Need help with triage of new bugs.
21:04:58 <mriedem> which reminds me that i talked with macsz about doing a post-spec freeze bug cleaning day
21:05:15 <mriedem> #action mriedem to think about a day to do a bug cleaning day (not fixes, just cleanup launchpad)
21:05:34 <mriedem> that would be good to get done before the summit and bug smash which is the week after the summit
21:05:56 <mriedem> gate status, things are ok now - there was a big live migration blow up from the devstack UCA change but clarkb fixed that
21:05:59 <mriedem> the fix merged this morning
21:06:03 <mriedem> well, morning CDT
21:06:17 <mriedem> 3rd party CI status seems same as usual, no news
21:06:24 <mriedem> anyone have anything for bugs?
21:06:31 <clarkb> and so far with UCA aren't seeing the libvirt crashes that we had before
21:06:35 <clarkb> so hopefully overall its much happier
21:06:39 <mriedem> oh cool
21:06:46 <mriedem> i look forward to new race failures :)
21:07:04 <mriedem> #topic reminders
21:07:09 <mriedem> #info Spec freeze is April 13 (today)
21:07:16 <mriedem> #link Pike Review Priorities etherpad: https://etherpad.openstack.org/p/pike-nova-priorities-tracking
21:07:35 <mriedem> once we're past the spec freeze hump we can get back into code review priorities
21:07:44 <mriedem> #link Forum planning: https://wiki.openstack.org/wiki/Forum/Boston2017
21:07:50 <mriedem> #link https://etherpad.openstack.org/p/BOS-Nova-brainstorming Forum discussion planning for nova (add your name if you are going)
21:07:58 <mriedem> #info Proposed forum topics: http://forumtopics.openstack.org/
21:08:06 <mriedem> ^ is mostly complete and in the summit schedule app now
21:08:28 <mriedem> next steps there will be to start creating etherpads for forum sessions and fill with content
21:08:47 <mriedem> i don't know yet if we'll have a wiki page for all of the etherpads, but i assume we will
21:08:52 <mriedem> #info More information on planning: http://lists.openstack.org/pipermail/openstack-dev/2017-March/114703.html
21:09:05 <mriedem> any questions about the summit?
21:09:15 <mriedem> #topic Stable branch status: https://etherpad.openstack.org/p/stable-tracker
21:09:26 <bauzas> hopefully the sessions will be tagged by the related projects names...
21:09:30 <mriedem> i should remove https://etherpad.openstack.org/p/stable-tracker since we don't use it anymore
21:09:48 <mriedem> bauzas: maybe, but idk, they aren't vertical project sessions
21:09:51 <mriedem> is the point
21:10:00 <mriedem> you're living in the past
21:10:05 <mriedem> stable/ocata: https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:stable/ocata,n,z
21:10:13 <mriedem> #info Ocata 15.0.3 released, contains fixes for regressions introduced in 15.0.0
21:10:30 <mriedem> so if you're about to release your distro's ocata based product, you might want to pick up some fixes :)
21:10:40 <mriedem> stable/newton: https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:stable/newton,n,z
21:10:54 <mriedem> #info stable/mitaka is EOL now
21:11:08 <mriedem> the stable/mitaka branch exists but will be deleted in due time
21:11:23 <mriedem> #action mriedem to check if we should do a final mitaka release for nova or novaclient
21:11:33 <mriedem> #topic subteam highlights
21:11:39 <mriedem> dansmith: cells v2
21:11:45 <dansmith> we had a meeting,
21:11:58 <dansmith> we discussed a lot of regressions that have been fixed, as well as outstanding things
21:12:06 <dansmith> the big multicell patchset is largely landed,
21:12:17 <dansmith> and the next big thing will be the quotas stuff from melwitt RSN
21:12:29 <mriedem> that reminds me, you said you'd review https://review.openstack.org/#/c/453025/ after the cells meeting and never did
21:12:31 <mriedem> tsk tsk
21:12:32 <dansmith> otherwise pretty much on course I think
21:12:37 <dansmith> I say lots of things
21:12:41 * dansmith clicks
21:12:43 <mriedem> heh, touche
21:13:07 <mriedem> ok scheduler, i'll fill in for ed who took an early long weekend
21:13:12 <mriedem> Went over current specs and reviews. No big controversy on any of them,  since we saved discussion of the "placement doing claims" spec for a  hangout after the meeting.
21:13:28 <mriedem> cdent shook his tiny little fist at the news that _gryf was assigned to  different tasks and will no longer be able to work on OpenStack.
21:13:39 <mriedem> Agreed that we need to create a functional test for the local delete case. (https://bugs.launchpad.net/nova/+bug/1679750 )
21:13:41 <openstack> Launchpad bug 1679750 in OpenStack Compute (nova) "Allocations are not cleaned up in placement for instance 'local delete' case" [Medium,Confirmed]
21:13:43 <cdent> that fist has since grown :(
21:13:57 <mriedem> that's it for scheduler
21:14:06 <mriedem> oh and the traits api change landed this week
21:14:08 <mriedem> that's news
21:14:23 <mriedem> Live Migration (tdurakov)
21:14:30 <mriedem> one thing
21:14:31 <mriedem> Spec to review - Live migration completion timeout(config part): https://review.openstack.org/#/c/438467/
21:14:41 <mriedem> that has a +2 on it
21:14:48 <mriedem> API (sdague/alex_xu)
21:15:01 * mriedem fills in for api
21:15:03 <mriedem> Mostly talked about getting rid of os-cloudpipe when we get rid of os-certificates and the nova-cert service
21:15:04 <bauzas> mriedem: that's the one I'm about to +W
21:15:12 <mriedem> bauzas: ok
21:15:50 <mriedem> also had a hangout today with johnthetubaguy, sdague, lbragstad and myself to go over johnthetubaguy's mega remove policy scope checks spec,
21:16:00 <mriedem> and sort of went down a tangent about bigger root issues with policy
21:16:20 <Vek> oh, that'll be...fun
21:16:23 <mriedem> there are going to be some rbac sessions at the summit too
21:16:48 <mriedem> notification updates from gibi, he says there was no meeting because no one showed up
21:16:57 <mriedem> most depressing status update ever gibi
21:16:58 <efried> Nobody notified them
21:17:08 <Vek> heh
21:17:16 * cdent gives efried a cookie
21:17:20 <mriedem> the instance tag payload stuff is probably a priority for notifications right now
21:17:24 <Vek> they're still standardizing those notifications, I guess
21:17:55 <mriedem> this is what i'm thinking of https://review.openstack.org/#/c/407228/
21:18:01 <mriedem> there are a few things dependent on that
21:18:16 <mriedem> i need to go back to see the replies on my -1
21:18:29 <mriedem> efried: powervm
21:18:32 <efried> First driver change set https://review.openstack.org/#/c/438119/ has +2 from mriedem - ready for broader review.
21:18:36 <efried> https://review.openstack.org/#/c/438598/ has been reviewed by mriedem, first round of comments addressed - ready for further review.
21:19:03 <efried> Slowing momentum on keeping the pile updated, since many review comments are carrying forward to other change sets.
21:19:14 <mriedem> probably a good idea
21:19:20 <efried> That's it from me.
21:19:26 <mriedem> ok
21:19:28 <mriedem> Cinder (mriedem, johnthetubaguy, ildikov) - Review focus is on the new detach flow: https://review.openstack.org/#/c/438750/
21:19:46 <mriedem> we had the nova/cinder meeting earlier today, and agreed to split ^ into several changes
21:19:59 <mriedem> one per operation, i.e. swap, detach_volume, delete instance, live migration, etc
21:20:17 <mriedem> that's what spurred my questions about why we don't terminate the connection on shelve offload in the ML
21:20:25 <mriedem> and turns out it's been a known issue forever we just never fixed
21:20:31 <mriedem> because we are just bad people
21:21:07 <mriedem> oh also shameless plug for this spec https://review.openstack.org/#/c/453272/
21:21:12 <mriedem> which is a cross-project effort for nova/cinder
21:21:23 <mriedem> the nova side change is straight-forward enough io
21:21:25 <mriedem> *imo
21:21:33 <mriedem> ok
21:21:36 <mriedem> #topic stuck reviews
21:21:43 <mriedem> there was nothing on the agenda
21:21:51 <mriedem> anyone have a change people are fighting over?
21:22:03 <mriedem> nope
21:22:07 <mriedem> #topic open discussion
21:22:17 <mriedem> nothing on the agenda
21:22:26 <mriedem> did anyone have anything?
21:22:50 <mriedem> ok, well, let's end it, thanks everyone
21:22:54 <mriedem> #endmeeting