21:00:22 <mriedem> #startmeeting nova
21:00:23 <openstack> Meeting started Thu Sep 15 21:00:22 2016 UTC and is due to finish in 60 minutes.  The chair is mriedem. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:24 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:26 <openstack> The meeting name has been set to 'nova'
21:00:34 <takashin> o/
21:00:40 * Vek waves
21:00:41 <auggy> o/
21:00:48 <diana_clarke> o/
21:00:57 <alaski> o/
21:01:00 <bauzas> \o
21:01:06 <melwitt> o/
21:01:16 <woodster_> o/
21:01:30 <rkmrhj> o/
21:01:41 <mriedem> alright let's get started
21:01:43 <edleafe> \o
21:01:44 <mriedem> #link agenda https://wiki.openstack.org/wiki/Meetings/Nova
21:01:54 <mriedem> #topic release news
21:01:58 <mikal> .
21:02:03 <mriedem> #link Newton release schedule: https://wiki.openstack.org/wiki/Nova/Newton_Release_Schedule
21:02:12 <mriedem> #info Sep 12-16: PTL self-nominations open for Ocata
21:02:19 <mriedem> #info Sep 15: RC1 - end of day today, PST
21:02:36 <mriedem> #link newton-rc-potential bugs: https://etherpad.openstack.org/p/nova-newton-rc-potential
21:02:48 <mriedem> https://review.openstack.org/#/c/370681/ is the last thing for rc1
21:02:50 <edleafe> You look so small, mikal
21:03:26 <mriedem> ^ is a regression with setting mtu on ovs/linuxbridge vifs with the libvirt driver
21:03:30 <mriedem> which is using os-vif now
21:03:35 <mriedem> and os-vif doesn't allow overriding the mtu
21:03:42 <mriedem> john has that workaround up until ocata
21:03:53 <mriedem> i think i'm going to address a thing in the unit tests and then +W
21:04:11 <mriedem> ovs and lb jobs have passed on that change at least
21:04:43 <mriedem> questions?
21:04:51 <bauzas> given the impact, would it be worth trying to first cut RC1 and then backport the above to rc2?
21:05:05 <bauzas> I'm bit chilly about the possible impact
21:05:45 <mriedem> ovs and lb jobs have passed on it
21:05:47 <mriedem> so i think we're good
21:06:10 <mriedem> there are some issues with the patch if/when we add more support, like vhostuser
21:06:20 <mriedem> but by that time we should have this hack out and os-vif should set the mtu
21:06:36 <mriedem> so basically no new vif type support until that's fixed in os-vi
21:06:38 <mriedem> *os-vif
21:06:45 <bauzas> yeah
21:06:59 <mriedem> sean-k-mooney will probably care since he wants vhostuser support
21:07:04 <mriedem> and he's os-vif core
21:07:14 <tonyb> mriedem: which wont be far off and can easily land in newton right?
21:07:25 <mriedem> huh?
21:07:34 <mriedem> what won't be far off?
21:07:38 <tonyb> mriedem: the os-vif fix landing
21:07:41 <mriedem> no
21:07:45 <mriedem> it would require a new release
21:07:50 <mriedem> and all the reqs stuff
21:08:08 <mriedem> and you'd have to raise the minimum on os-vif in stable
21:08:10 <mriedem> which we don't want
21:08:16 <tonyb> mriedem: ahh the reqs stuff :(
21:08:20 <mriedem> ha
21:08:23 <mriedem> yeah, that stuff
21:08:28 * tonyb has a sad
21:08:30 <mriedem> that was my morning, but another story
21:08:42 <mriedem> ok so let's move on
21:08:53 <mriedem> #topic bugs
21:09:05 <mriedem> the gate is sad with neutron grenade failures,
21:09:11 <mriedem> the neutron team has been looking at that all day
21:09:48 <mriedem> https://bugs.launchpad.net/neutron/+bug/1623732/
21:09:49 <openstack> Launchpad bug 1623732 in neutron "test_network_basic_ops to fail with SSHTimeout" [Critical,In progress] - Assigned to Armando Migliaccio (armando-migliaccio)
21:10:02 <mriedem> #info neutron grenade is super sad https://bugs.launchpad.net/neutron/+bug/1623732/
21:10:42 <mriedem> the only critical bug is the mtu one above
21:10:44 <mriedem> for rc1
21:11:01 <mriedem> 3rd party ci status - vmware ci was flaky this week
21:11:05 <mriedem> and has been off and on this release
21:11:17 <mriedem> but not an immediate blocker
21:11:38 <mriedem> #topic summit planning
21:11:42 <mriedem> #link Etherpad for Ocata summit topics: https://etherpad.openstack.org/p/ocata-nova-summit-ideas
21:11:52 <mriedem> ^ is already getting busy
21:11:59 <mriedem> #info Cross project summit session ideas are due by 10/1: http://lists.openstack.org/pipermail/openstack-dev/2016-September/103657.html
21:12:22 <mriedem> so if you have xp session ideas/needs, get those posted in the next 2 weeks
21:12:32 * bauzas needs to delay his flight on the friday afternoon...
21:12:59 <mriedem> i know how you can delay a flight, but you have to be on the plane...
21:13:05 <mriedem> #topic reminders
21:13:08 <mriedem> #help https://wiki.openstack.org/wiki/Nova/BugTriage#Weekly_bug_skimming_duty Volunteers for 1 week of bug skimming duty?
21:13:39 <mriedem> thanks to all triaging new bugs this week, especially bauzas
21:13:45 <mriedem> <3
21:14:08 <mriedem> #topic Stable branch status: https://etherpad.openstack.org/p/stable-tracker
21:14:09 * dansmith staggers in late
21:14:23 <mriedem> we have quite a few stable/mitaka backports ready for review
21:14:24 <mriedem> stable/mitaka: https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:stable/mitaka,n,z
21:14:29 <mriedem> mikal: ^
21:14:30 <mriedem> :)
21:14:33 <mriedem> nudge nudge
21:14:51 <mikal> mriedem: I live to obey
21:14:58 <mikal> mriedem: by which I mean, I'll try to get to them
21:15:02 <mriedem> thanks
21:15:08 <tonyb> mriedem: I'll look at the also
21:15:08 <mriedem> we're about 1 month from liberty-eol
21:15:12 <mikal> tonyb will remind me
21:15:43 <bauzas> that's a bit early to ask, but when are we planning to allow newton backports ?
21:15:44 <tonyb> mikal: I live to obey
21:15:53 <mriedem> i'm going to skip subteam highlights, some meetings were skipped and those that weren't were basically talking about rc blockers
21:16:02 <mriedem> bauzas: after it's released
21:16:12 <bauzas> mriedem: k, wanted to be sure
21:16:23 <mriedem> so 10/7
21:16:42 <mriedem> #topic stuck reviews
21:16:44 <edleafe> mriedem: yeah, that was the case for the scheduler subteam
21:16:58 <mriedem> there were no stuck reviews on the agenda
21:17:08 <mriedem> this week most everything is stuck by design
21:17:16 <mriedem> moving on
21:17:19 <mriedem> #topic open discussion
21:17:22 <mriedem> a few things
21:17:38 <mriedem> a newton retrospective,
21:17:39 <mriedem> I'd like to hold a Newton retrospective next week, maybe at 1400 UTC -  any preferences on dates/times? This would just be an informal meeting  to go over what went well and what needs improvement as we head into  Ocata.
21:17:48 <mriedem> Or would it be better to spitball pre-summit and then go over the  retrospective in person in a fishbowl session at the summit? If we came  prepared then we can more effectively use the 40 minute session to talk  about things to change.
21:18:05 <dansmith> I vote for summit, even though I know not everyone will be there
21:18:13 <dansmith> I think in-person for those kinds of things works well
21:18:21 <dansmith> I'd like to specifically talk about placement
21:18:24 <dansmith> in a retrospective manner
21:18:30 <alaski> yeah. in person is easier, but does leave people out
21:18:46 <mriedem> so,
21:18:51 <alaski> might be worth doing both
21:18:54 <mriedem> we could have an etherpad with what went well, what needs to change,
21:19:00 <bauzas> could we imagine a bridge call ?
21:19:05 <dansmith> we could do general before, and specific ones at the summit?
21:19:07 <mriedem> people can post and we can hash it out in person at the summit?
21:19:09 <dansmith> like placement at summit
21:19:13 <dansmith> mriedem: or that
21:19:18 <alaski> mriedem: +1
21:19:20 <bauzas> or what dansmith proposed
21:19:32 <bauzas> or what mriedem proposed
21:19:34 <bauzas> :p
21:19:39 <mriedem> i just don't want to spend all 40 minutes in a session complaining :)
21:19:47 <mriedem> retrospectives at work are usually 90% complaining
21:20:00 <mriedem> "joe brought in muffins one day, that was a thing"
21:20:01 <dansmith> sure, but keeping to one topic will help with that a bit
21:20:04 <mikal> In retrospect, I hate you all?
21:20:25 <auggy> maybe if there's an agenda of sorts and some ideas on what we want the outcome to be?
21:20:30 <tonyb> mriedem: you'd need to find a strong moderator ;P
21:20:40 <mriedem> yes there would need to be an agenda
21:20:42 <auggy> or rather, like what we want to get out of the session
21:20:50 <mriedem> and an etherpad to fill out before that could help
21:21:01 <dansmith> yeah
21:21:05 <edleafe> mikal: new information only, please
21:21:15 <mriedem> are people comfortable with an etherpad? or would they like a private form thingy?
21:21:32 <mriedem> i'm totally find with people dumping on me in an etherpad in public if it matters
21:21:32 <bauzas> etherpads are private if you don't set your nick :)
21:21:36 <mriedem> *fine
21:21:43 <auggy> i think an etherpad is good, lets people have some discussions early on
21:21:49 <mriedem> alright
21:22:00 <mriedem> #action mriedem to start a newton retrospective etherpad and post it on the ML
21:22:14 <mriedem> and we'll plan that as one of the fb sessions in barcelona
21:22:21 * auggy gets ready to complain about the lack of donuts in newton
21:22:43 <bauzas> auggy: lack of apples, rather ?
21:22:45 <tonyb> auggy: but we *had* donuts!
21:22:52 <dansmith> that's true
21:22:54 <mriedem> we had costco cake
21:22:56 <dansmith> tonyb: fixed the donus situation
21:22:59 <auggy> :)
21:23:06 <tonyb> auggy: cburgess plied us with donuts in Austin
21:23:11 <mriedem> oh right
21:23:13 <mriedem> forgot about that
21:23:18 <mriedem> austin was long ago
21:23:20 <cburgess> What?
21:23:21 <cburgess> Oh..
21:23:22 <mriedem> moving on
21:23:22 <cburgess> Yeah..
21:23:23 <dansmith> oh right tonyb was the cake
21:23:24 <cburgess> donuts..
21:23:30 <mriedem> Ocata planning - when do people want to meet for summit session topics?  What blueprints carried over from Newton that we should approve early? https://blueprints.launchpad.net/nova/ocata
21:23:34 * Vek shivers upon contemplating what will happen when spammers discover etherpad...
21:23:36 <cburgess> I'll have to see if I can find some in Barcelona.
21:23:58 <mikal> cburgess: we also accept tapas
21:23:59 <mriedem> we're going to have to cull the etherpad of ideas
21:24:12 <mriedem> i think i might start filtering that list next week
21:24:37 <mriedem> and then maybe the week of the 26th we go over sessions?
21:24:47 <mriedem> dansmith: alaski: bauzas: jaypipes: ^?
21:24:50 <dansmith> yup
21:24:54 <dansmith> fine with me
21:24:57 <mriedem> ok
21:24:58 <bauzas> wfm
21:24:59 <dansmith> i'm lost thinking about afternoon donuts
21:25:01 <alaski> works for me
21:25:38 <mriedem> #action mriedem to filter the list of summit sessions next week and meet the week of the 26th
21:26:04 <mriedem> last topic was a review request for https://review.openstack.org/#/c/354617/
21:26:13 <rkmrhj> Hi all, about this patch:
21:26:33 <rkmrhj> I reported a bug that "unexpected volume detaching" will happen by booting instance failure. https://bugs.launchpad.net/nova/+bug/1587285
21:26:34 <openstack> Launchpad bug 1587285 in OpenStack Compute (nova) "Volume status will be changed to "available" in spite of still attached to VM instance" [Medium,In progress] - Assigned to Rikimaru Honjo (honjo-rikimaru-c6)
21:26:55 <rkmrhj> So I committed a patch 4 weeks ago, but it is only one person who reviewed my patch.  https://review.openstack.org/#/c/354617/
21:27:07 <rkmrhj> If anyone can review my patch, please do it.
21:27:15 <rkmrhj> I'd like to fix this issue until Newton release and backport to stable/mitaka.
21:27:55 <dansmith> rkmrhj: this isn't a regression in newton, so probably needs to be done after newton and backported to both
21:28:07 <mriedem> it's huge
21:28:13 <mriedem> so backporting is going to be questionable
21:28:23 <mriedem> and an object version bump https://review.openstack.org/#/c/354617/9/nova/objects/block_device.py
21:28:24 <dansmith> mriedem: well, this fix is, but the thing needing fixing
21:28:28 <jaypipes> o/
21:28:35 <dansmith> mriedem: I think this is probably overdone and could be done lighter
21:28:55 <mriedem> ok i haven't looked at the root issue and what the proposed fix is
21:29:26 <mriedem> sounds like dansmith has ideas for a fix
21:29:29 <dansmith> mriedem: definitely don't want to apply this to rc2 given its size and impact, so.. backport is what we hope for I think
21:30:09 <bauzas> I can see a cinder call ?
21:30:27 <rkmrhj> dansmith: please point out on gerrit if you have comment.
21:30:36 <dansmith> this approach is really racy and leaky I think, and very heavyweight
21:30:41 <dansmith> but yeah, I'll review when we're done here
21:31:06 <mriedem> ok yeah the compute_utils stuff looks ray
21:31:07 <mriedem> *racy
21:31:10 <cburgess> I will comment that this bug scares me. As in the implication of this bug happening to a clients AZ concerns me deeply.
21:31:10 <rkmrhj> dansmith: thanks!
21:31:17 <mriedem> #action dansmith to review https://review.openstack.org/#/c/354617/
21:32:07 <mriedem> ok anyone else have other topics?
21:32:32 <mriedem> nope
21:32:32 <mriedem> ok
21:32:34 <mriedem> thanks all
21:32:36 <mriedem> #endmeeting