20:59:59 <mriedem> #startmeeting nova
21:00:00 <openstack> Meeting started Thu Jun  9 20:59:59 2016 UTC and is due to finish in 60 minutes.  The chair is mriedem. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:04 <openstack> The meeting name has been set to 'nova'
21:00:10 <rlrossit> o/
21:00:11 <takashin> o/
21:00:13 <claudiub> o/
21:00:14 * bauzas yawns
21:00:15 * Vek glances around
21:00:16 <diana_clarke> o/
21:00:18 <edleafe> \o
21:00:24 <MikeG451> o/
21:00:30 <raj_singh> o/
21:00:40 <mrda> o/
21:00:43 <sdague> o/
21:00:49 <alaski> o/ but may have to drop out
21:00:57 <melwitt> o/
21:01:11 <mriedem> well hello
21:01:14 <mriedem> #link agenda https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting
21:01:15 <auggy> o/
21:01:27 <mriedem> should be relatively short today
21:01:29 <mikal> .
21:01:31 <mriedem> #topic release news
21:01:35 <Vek> that's a relief :)
21:01:37 <mriedem> #link Newton release schedule: https://wiki.openstack.org/wiki/Nova/Newton_Release_Schedule
21:01:47 <mriedem> #info June 30: non-priority feature freeze (3 weeks from today)
21:02:05 <mriedem> We have 86 approved blueprints: https://blueprints.launchpad.net/nova/newton - 9 are completed, 13 have not started, 2 are blocked
21:02:20 <mtanino> hi
21:02:26 <mriedem> depending on when i took those numbers that might be 10 completed with glance v2 being complete now
21:02:28 <mriedem> but still
21:02:34 <mriedem> lots of approved blueprints, lots of stuff not started
21:02:38 <mriedem> 3 weeks left on most of it
21:02:52 <mriedem> questions?
21:03:05 <mriedem> #topic bugs
21:03:06 <tonyb> Am I too late to create a specless bp?
21:03:13 <mriedem> tonyb: probably
21:03:21 <mriedem> tonyb: unless it's related to a priority
21:03:26 <tonyb> mriedem: okay I'll save it for ocata
21:03:34 <mriedem> tonyb: you can always create an queue it up for later
21:03:42 <mriedem> so bugs
21:03:46 <woodster_> o/
21:03:59 <mriedem> looks like some triage happened since last week, down to 15 new bugs
21:04:01 <mriedem> which is nice
21:04:26 <mriedem> http://tinyurl.com/z2uln6v
21:04:43 <jlvillal> o/
21:04:47 <mriedem> any critical bugs that anyone knows of?
21:04:52 <mriedem> markus is on vacation
21:04:55 <mriedem> auggy: ?
21:05:07 <auggy> i'm not aware of anything
21:05:13 <mriedem> ok
21:05:23 <mriedem> as far as gate status,
21:05:40 <mriedem> the live migration job, at least for local disk, will be fixed with https://review.openstack.org/#/c/310707/
21:05:47 <mriedem> i'm waiting for jenkins to pass unit tests on that before re-approving again
21:06:07 <mriedem> and i have https://review.openstack.org/#/c/327886/ to skip NFS in that job
21:06:12 <mriedem> because the NFS setup is busted with 16.04
21:06:18 <mriedem> if anyone wants to sort that out, please help
21:06:23 <sdague> the only thing that's close to critical is the security one that needs a backport
21:06:36 <mriedem> backport to liberty, right?
21:06:59 <mriedem> i just put up the mitaka o.c 3.7.1 release request https://review.openstack.org/#/c/327944/
21:07:21 <sdague> backport to liberty is an open question
21:07:26 <mriedem> i don't have any news on third party CI
21:07:31 <mriedem> vmware's CI is having issues
21:08:10 <mriedem> sdague: there is a liberty patch https://review.openstack.org/#/c/327624/ but it needs work
21:08:29 <mriedem> i can work on that at some point, needs the oslo.concurrency changes
21:08:33 <sdague> and it needs an o.c backport
21:08:36 <mriedem> #action follow up on https://review.openstack.org/#/c/327624/
21:08:37 <sdague> which is going to be more work
21:08:48 <sdague> 2.6.0 is the liberty version
21:08:52 <mriedem> crap
21:08:58 <mriedem> is there anything i can own that requires *less* work?
21:09:22 <mriedem> #topic reminders
21:09:28 <mriedem> #link Newton review focus list: https://etherpad.openstack.org/p/newton-nova-priorities-tracking
21:09:36 <mriedem> please keep that up to date
21:09:41 <mriedem> and prioritized
21:09:50 <mriedem> #help https://wiki.openstack.org/wiki/Nova/BugTriage#Weekly_bug_skimming_duty Volunteers for 1 week of bug skimming duty?
21:10:10 <mriedem> looks like next week is open if someone wants that
21:10:11 <mriedem> just update the wiki
21:10:18 <tjones> we are looking into the issue on vmware ci with not being able to get the glance image.  sorry it's taking so long
21:10:24 <mriedem> tjones: ack
21:10:30 <tjones> :-(
21:10:33 <mriedem> #topic stable branch status
21:10:42 <mriedem> besides the cve backports
21:10:49 <mriedem> there was a liberty release yesterday
21:10:51 <mriedem> for nova
21:11:12 <mriedem> and i've got a mitaka 13.0.1 release queued up but was waiting on the fix for this cve backport to get in
21:11:24 <mriedem> #topic subteam highlights
21:11:31 <mriedem> alaski: status on baby lucas?
21:11:40 <mriedem> or cells v2 meeting
21:11:41 <alaski> just finished eating, so I can update here
21:11:57 <alaski> lots of work in progress as usual
21:12:07 <alaski> a few highlights
21:12:21 <alaski> we discussed instance.name being blank in the api until after scheduling
21:12:34 <alaski> because it can rely on instance.id which relies on the db to generate it
21:12:56 <alaski> we also discussed a new discover nova-manage command for adding new hosts to a cell
21:13:08 <alaski> it would find any unmapped hosts and map them
21:13:22 <alaski> and there will be no meeting next week
21:13:34 <mriedem> is there a patch up for the tags thing?
21:13:44 <mriedem> from 2-4 weeks ago?
21:13:46 <alaski> I have not seen one yet
21:13:51 <mriedem> a bug?
21:14:08 <alaski> melwitt was going to take that I believe but she was doing something else first
21:14:11 <alaski> I can open a bug though
21:14:13 <mriedem> #action alaski to create a bug for the tags / cells v2 issue
21:14:15 <mriedem> cool
21:14:33 <mriedem> edleafe: scheduler meeting highlights from this week?
21:14:33 <alaski> those are the highlights
21:14:39 <edleafe> jaypipes, dansmith and cdent are re-working how the inventory and allocations are migrated.
21:14:48 <edleafe> Much discussion at the meeting on the placement API and the change to using that instead of RPC
21:15:04 <edleafe> I pushed POC code for the live migrate multiple host BP
21:15:21 <edleafe> So lots of specs and patches to review
21:15:48 <mriedem> ok
21:16:01 <cdent> things are moving now, lots of related things merging. is cool.
21:16:14 <mriedem> is anyone around that attended the live migration meeting?
21:16:16 <bauzas> becomes hard to follow tho
21:16:17 <mriedem> i was at the first half
21:16:23 <edleafe> bauzas: +1
21:16:29 <mriedem> yeah jay's update in the ML is helpful
21:16:33 <mriedem> given all the changes
21:17:00 <mriedem> re: the live migration meeting, the imagebackend refactor series is ready for more review,
21:17:08 <mriedem> we talked about the live migration job, which i already noted here
21:17:28 <mriedem> i think paul was looking for some people to work on some blueprints, namely the post-copy one (i think)
21:17:39 <mriedem> and i missed the 2nd half of the meeting so can't talk to that :)
21:17:55 <mriedem> sdague: want to say anything about the api meeting?
21:18:12 <sdague> sure
21:18:28 <sdague> api-ref keeps coming along, we're down to < 100 tags left to process
21:18:35 <sdague> http://burndown.dague.org/
21:18:53 <sdague> site keeps getting more accurate - http://developer.openstack.org/api-ref/compute/
21:19:05 <mriedem> heh, yeah i actually use it now :)
21:19:08 <sdague> we also talked about the removal of extensions facility
21:19:08 <mriedem> when writing tempest tests
21:19:27 <sdague> which has been deprecated
21:19:48 <sdague> and once we remove the code for it, then we can massively simplify the API stack
21:20:03 <sdague> https://review.openstack.org/#/c/327302/ is starting down that process
21:20:24 <sdague> https://review.openstack.org/#/c/327188/ is the kind of simplifications we'll get
21:20:57 <sdague> the goal is to stop servers being extendable by release
21:21:05 <sdague> because that's the bulk of the mess and confusion
21:21:16 <mriedem> amen
21:21:26 <sdague> also, all of alaski's oslo.policy changes are merged
21:21:31 <mriedem> oh nice
21:21:35 <alaski> \o/
21:21:36 <mriedem> is there a release request up?
21:21:38 <sdague> yes
21:21:43 <mriedem> and g-r bump?
21:21:45 <sdague> I don't think it has yet processed
21:21:48 <alaski> yeah, hopefully will be this week
21:21:52 <mriedem> great
21:22:02 <sdague> /end
21:22:06 <sdague> that's it from API
21:22:10 <mriedem> thanks
21:22:14 <mriedem> rlrossit: notifications?
21:22:24 <rlrossit> #link https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:master+topic:bp/versioned-notification-transformation-newton
21:22:37 <rlrossit> johnthetubaguy has been helping out and +2ing a lot of things
21:22:42 <rlrossit> we're reaching consensus on most of it
21:22:57 <rlrossit> just need to iron a few things more out on instance.delete notification
21:23:02 <rlrossit> other than that, moving along well
21:23:20 <mriedem> ok, sounds good
21:23:27 <mriedem> #topic stuck reviews
21:23:31 <mriedem> nothing on the agenda
21:23:40 <mriedem> anything someone feels a burning desire to bring up here?
21:23:52 <mriedem> #topic open discussion
21:23:58 <mriedem> nothing on the agenda
21:24:01 <mriedem> so i'll open it up
21:24:08 <auggy> o/
21:24:16 <mriedem> hi
21:24:33 <mriedem> you in the back, speak up
21:24:41 <auggy> just a reminder that the mentoring wiki page is more up to date than it has been in the past
21:24:52 <auggy> so if new folks pop into the channel looking for stuff to do then feel free to point them there :)
21:24:53 <mriedem> link?
21:24:56 <auggy> sorry slow typing for some reason
21:25:07 <auggy> https://wiki.openstack.org/wiki/Nova/Mentoring
21:25:31 <auggy> also many of the subteam sections still need to be updated, so if your subteam has tasks good for new contributors, feel free to update it
21:25:35 <auggy> or ping me and i'll update it :)
21:26:03 <auggy> that's all i had
21:26:08 <mriedem> thanks for working on that
21:26:12 <mriedem> i know people have been asking
21:26:15 <bauzas> no longer an etherpad then ?
21:26:35 <mriedem> bauzas: we said at the summit we wanted to move off of etherpads
21:26:38 <mriedem> since they aren't index
21:26:40 <mriedem> *indexed
21:26:43 <bauzas> cool by me
21:27:01 <mriedem> anyone have anything else?
21:27:20 <mriedem> sounds like a no. alright, thanks everyone.
21:27:21 <tonyb> privsep? but we can talk about that in the nova channel if y'all like
21:27:29 <mriedem> as far as?
21:27:37 <mriedem> conversions?
21:27:39 <tonyb> first implementation ....
21:27:51 <mriedem> tonyb: just because i asked for a volunteer in the list doesn't mean it has to be you
21:27:58 <mriedem> but you have proximity to gus
21:28:01 <mrda> lol
21:28:20 <tonyb> mriedem: meh I'm happy to do it
21:28:21 <mriedem> but yeah, we can move to the nova channel
21:28:34 <mriedem> thanks everyone
21:28:36 <mriedem> #endmeeting