14:01:00 <johnthetubaguy> #startmeeting nova
14:01:01 <openstack> Meeting started Thu Feb 11 14:01:00 2016 UTC and is due to finish in 60 minutes.  The chair is johnthetubaguy. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:02 <dims> o/
14:01:04 <sdague> o/
14:01:05 <raildo> \o
14:01:05 <openstack> The meeting name has been set to 'nova'
14:01:06 <claudiub> o/
14:01:07 <johnthetubaguy> welcome one and all
14:01:07 <markus_z> o/
14:01:08 <bauzas> \o
14:01:09 <edleafe> \o
14:01:10 <cdent> o/
14:01:11 <jichen> o/
14:01:12 <andrearosa> hi
14:01:12 <takashin> o/
14:01:17 <pkoniszewski> o/
14:01:20 <flip214> hi
14:01:22 <johnthetubaguy> #topic Release Status
14:01:30 <scottda> hi
14:01:37 <johnthetubaguy> #info Mar 1-3, Mitaka-3 and feature freeze, Final release for client libraries, Soft String Freeze, etc.
14:01:40 <alaski> o/
14:01:55 <johnthetubaguy> so not long now till we hit full FF, etc
14:02:04 <johnthetubaguy> #link http://docs.openstack.org/releases/schedules/mitaka.html
14:02:19 <johnthetubaguy> general libraries have a different deadline, see above
14:02:28 * jroll lurks
14:02:40 <johnthetubaguy> so I have had a -2 fest, to try and execute the Feature freeze
14:02:45 <johnthetubaguy> currently we look like this:
14:02:47 <johnthetubaguy> #link https://blueprints.launchpad.net/nova/mitaka
14:03:05 <PaulMurray> o/
14:03:05 <johnthetubaguy> or another view:
14:03:07 <johnthetubaguy> #link http://5885fef486164bb8596d-41634d3e64ee11f37e8658ed1b4d12ec.r44.cf3.rackcdn.com/release_status.html
14:03:38 <johnthetubaguy> so I think at this point the aim is:
14:03:43 <johnthetubaguy> focus our efforts on the priorities
14:03:48 <johnthetubaguy> review and coding efforts
14:03:50 <johnthetubaguy> mostly review
14:04:09 <johnthetubaguy> #link http://specs.openstack.org/openstack/nova-specs/priorities/mitaka-priorities.html
14:04:12 <johnthetubaguy> and bug fixes
14:04:26 <johnthetubaguy> so lets stop things like python 3.4, mox, etc
14:04:33 <johnthetubaguy> so we have time to get the priorities in
14:04:45 <johnthetubaguy> any questions?
14:04:48 <sdague> you still wanted the conf changes to move forward?
14:04:52 <rlrossit> o/
14:05:11 <johnthetubaguy> yeah, good point sdague, I really like the idea of us improving the CONF option docs
14:05:14 <sdague> it would be good to send out an email to folks about which of the low hanging fruit mass code changes we're stopping and which we're keeping
14:05:16 <johnthetubaguy> so I kinda want to keep that going, if we can
14:05:32 <sdague> I agree to put the pause button on py34 and mox
14:05:35 <johnthetubaguy> #action johnthetubaguy to send email about which low-hanging fruit things are stopping
14:05:36 <markus_z> they are very low risk
14:05:44 <edleafe> It seems that review bandwidth is the problem with the conf stuff
14:05:47 <johnthetubaguy> yeah, same for objects changes, etc, I think we pause those now
14:06:01 <johnthetubaguy> edleafe: yeah, there are lots of changes, but its worth it for the docs
14:06:35 <johnthetubaguy> I would rather we got those, than removed [] calls, I mean I would like both, but thats not possible
14:06:42 <johnthetubaguy> cools, lets keep moving
14:06:45 <johnthetubaguy> #topic Regular Reminders
14:06:51 <johnthetubaguy> #link https://etherpad.openstack.org/p/mitaka-nova-priorities-tracking
14:06:54 <johnthetubaguy> you know what to do.
14:06:58 <johnthetubaguy> #topic Bugs
14:07:09 <markus_z> no criticals I know of
14:07:30 <auggy> ^^
14:07:30 <markus_z> but a lot of open bugs which don't have a further triage how important they are
14:07:32 <johnthetubaguy> so I know dansmith had something on here about reducing our CI load
14:07:50 <johnthetubaguy> markus_z: oh thats good feedback, thats important at this point in time
14:08:11 <johnthetubaguy> #help please help with bug triage, lots of Open bugs without triage at this point
14:08:35 <johnthetubaguy> I am thinking we consider the mitaka-rc-potential tag again, for possible release blockers
14:08:42 <johnthetubaguy> but we are a little away from needing that I hope
14:08:48 <johnthetubaguy> so back to the gate
14:09:13 <sdague> johnthetubaguy: right, nova was using 21 nodes on every check result. There are ~600 nodes available in the system. A 3 patch series consumes 10% of all test resources. a 10 patch series 1/3.
14:09:17 <johnthetubaguy> sdague: I think there is a question about the v2.0 API jobs, I wonder if we can combine them with postres or something, or did we do that already?
14:09:31 <sdague> johnthetubaguy: honestly, I just had them moved to experimental
14:09:47 <sdague> because they did not seem to be finding anything beyond our functional tests
14:09:58 <johnthetubaguy> OK, thats fair enough
14:10:03 <sdague> that takes us down to 19
14:10:15 <johnthetubaguy> I mean we can always run them on API patches we are worried about, so thats cool
14:10:26 <johnthetubaguy> hmm, 19 still feels bad
14:10:28 <sdague> they only test for legacy v2 regressions really
14:10:33 <johnthetubaguy> yeah
14:10:52 <sdague> I proposed on the list to get rid of large-ops entirely (for reasons explained on mailing list)
14:11:34 <johnthetubaguy> is there a point where we get the foundation to help pay for more capacity for our CI, although I am sure we can be more efficient
14:12:24 <HenryG> Run it only on Sundays?
14:12:30 <johnthetubaguy> OK, so I think this is an important topic, but lets take this offline
14:12:34 <sdague> yep
14:12:38 <sdague> that's fine
14:12:38 <jroll> fwiw, foundation doesn't pay for CI capacity, it's donated
14:12:41 <johnthetubaguy> #help need help reducing the number of nodes we use
14:12:48 <johnthetubaguy> jroll: at the moment, yes
14:13:00 <jroll> aha :)
14:13:15 <johnthetubaguy> jroll: I am thinking about doing both, but then I would said that :)
14:13:29 <jroll> yeah, I see you now
14:13:43 <johnthetubaguy> #topic Stuck Reviews
14:14:07 <johnthetubaguy> flip214: DRBD process question I think?
14:14:22 <flip214> johnthetubaguy: yes, but I guess we don't need to discuss that here
14:14:26 <flip214> with all the audience waiting.
14:14:31 <johnthetubaguy> flip214: to get DRBD merged, you need an approved blueprint, basically
14:14:34 <flip214> after the meeting in #-nova is good enough
14:14:47 <johnthetubaguy> blueprint approval only lasts one release
14:14:53 <johnthetubaguy> #link http://docs.openstack.org/developer/nova/process.html
14:15:00 <johnthetubaguy> but yeah, lets talk specific in channel
14:15:04 <flip214> thanks
14:15:14 <flip214> I'm done then
14:15:26 <johnthetubaguy> ping me there anytime I am around if there is a process question, happy to answer those quickly rather than waiting
14:15:30 <johnthetubaguy> #topic Open
14:16:10 <johnthetubaguy> so there is a note about the get-me-a-network work neutron have been doing
14:16:36 <johnthetubaguy> jaypipes I think was saying he would find someone to work on the Nova side of this, now Neutron have an API ready for us
14:16:54 <johnthetubaguy> unless anyone else is keen
14:17:16 <johnthetubaguy> #link https://review.openstack.org/#/q/topic:bp/get-me-a-network
14:17:25 * mriedem joins late
14:17:28 <johnthetubaguy> #help need folks to work on the Nova side of get-me-a-network
14:17:44 <johnthetubaguy> so thats the end of the agenda
14:17:50 <markus_z> I forgot to ask for help with the general bug skimming
14:17:53 <markus_z> #link https://wiki.openstack.org/wiki/Nova/BugTriage#Weekly_bug_skimming_duty
14:18:07 <markus_z> auggy did it already for 3 weeks and I'm in the hospital next week
14:18:13 <dims> sdague : did we get relief from all the dhcp lease issues?
14:18:17 <johnthetubaguy> markus_z: ah oops, I missed out the link before
14:18:29 <dims> i had stopped tracking :)
14:18:50 <sdague> dims: I think we're under control there, I proposed backports today
14:18:51 <bauzas> is the LRU thing fixed that ? I thought yes
14:18:56 <sdague> https://review.openstack.org/#/c/278992/
14:18:56 <patchbot> sdague: https://review.openstack.org/#/c/278992/ - nova (stable/kilo) - Spread allocations of fixed ips
14:18:59 <dims> sdague : awesome thanks
14:19:04 <cdent> johnthetubaguy: at the cross project meeting this week there was some discussion of getting nova involved in the general quota discussions that cinder and others are having
14:19:10 <johnthetubaguy> sdague: we are still seeing a few ssh things?
14:19:20 <cdent> I was insufficiently informed to provided much but said I would relay the concern
14:19:21 <sdague> johnthetubaguy: we are, it's massively reduced
14:19:31 <johnthetubaguy> cdent: we did debate that quite a bit at the last summit
14:19:43 <sdague> and a bunch is on grenade, where we don't have these patches in stable yet
14:19:50 <auggy> I don't mind continuing to help out bug skimming but as we still have 80+ bugs in new status it'd be great to have more eyes on things
14:19:59 <johnthetubaguy> sdague: ah, nice, hence the backport, gotcha
14:20:10 <bauzas> sdague: so the kilo patch is about helping the kilo jobs, right?
14:20:13 <johnthetubaguy> auggy: +1 for more eyes
14:20:21 <mriedem> bauzas: and liberty grenade
14:20:23 <sdague> bauzas: it will help kilo and liberty (because grenade)
14:20:28 <bauzas> oh right
14:20:29 <sdague> and liberty ... same thing
14:20:30 <mriedem> sdague: i'll look at those backports this morning
14:20:33 <sdague> mriedem: thanks
14:20:36 <alaski> cdent: what is the thrust of those convos?
14:20:39 <bauzas> for liberty, got it
14:20:42 <johnthetubaguy> cdent: so I was super worried we were excluding the use case I cared about, but it seemed like its one I was making up
14:20:57 <johnthetubaguy> cdent: I know cinder has some issues with their implementation, but was there other things
14:21:12 <johnthetubaguy> ah, yeah, alaski's question basically
14:21:12 <cdent> alaski: I don't know, it was a passing reference to long terms plans for quota a global thing
14:21:19 <johnthetubaguy> oh, that...
14:21:48 <johnthetubaguy> cdent: if someone creates a quota system that actually works, then cool
14:22:07 <jroll> it's more about beginning the discussions about doing (nested) quotas well cross-project
14:22:12 <johnthetubaguy> cdent: my current bet is on the resource claim logic basically doing the same thing
14:22:21 <jroll> whether that turns into a library or "best practices" or a service is to be seen
14:22:26 <alaski> I have an interest and would like to at least eavesdrop on the conversations, but I can't guarantee enough bandwidth to be useful there
14:22:28 <cdent> Is there anyone in nova who wants to be a part of those discussions so that they proceed with effective inclusion of nova concerns?
14:22:51 <johnthetubaguy> yeah, I am interested, but my bandwidth is was over full
14:22:58 <jroll> here's the meeting logs if you want to catch up http://eavesdrop.openstack.org/meetings/crossproject/2016/crossproject.2016-02-09-21.01.log.html
14:23:04 <alaski> jroll: thanks
14:23:07 <johnthetubaguy> alaski that would be awesome, do you want to bring stuff back into this meeting I guess?
14:23:25 <alaski> sure, I can at least attempt that
14:23:37 <cdent> alaski I can keep you up to date on when/if it is on the cp agenda
14:23:54 <alaski> cdent: thanks
14:24:15 <mriedem> in the cinder meeting yesterday they were talking about 4-byte unicode for volume names in their db,
14:24:22 <mriedem> jaypipes brought that up in conversation at the midcycle
14:24:29 <mriedem> so that's another cross-project thing that might be coming up
14:24:56 <sdague> I thought we supported that for names already, I even think there are tests
14:25:13 <johnthetubaguy> are we just 2-byte or something?
14:25:28 <mriedem> sdague: i don't think so, they said today cinder api returns a 500 b/c mysql doesn't handle it
14:25:40 <sdague> mriedem: right, not by default
14:26:19 <sdague> anyway, we can take it offline
14:26:28 <johnthetubaguy> yeah, lets take that offline
14:26:35 <johnthetubaguy> it sounds like we are done now?
14:26:38 <cdent> old-ish mysql can't do 4byte wide unicode without conf changes
14:27:26 <johnthetubaguy> I think there were issues around glance migrations, if I remember, for similar things, not sure if that got fixed up
14:27:31 <johnthetubaguy> but yes, I think we are done
14:27:33 <johnthetubaguy> thanks all
14:27:41 <johnthetubaguy> you have half an hour extra for some reviews
14:27:44 <johnthetubaguy> #endmeeting