21:01:15 <johnthetubaguy> #startmeeting nova
21:01:16 <openstack> Meeting started Thu Jul 16 21:01:15 2015 UTC and is due to finish in 60 minutes.  The chair is johnthetubaguy. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:01:19 <openstack> The meeting name has been set to 'nova'
21:01:31 <jroll> ohai
21:01:41 <bauzas> o............./
21:01:43 <edleafe> o/
21:01:45 <gabriel-bezerra> Good evening!
21:01:47 <xyang2> hi
21:01:47 <dansmith> -o-
21:01:47 <earlephilhower> Howdy
21:01:48 <n0ano> o/
21:01:48 <tjones1> hi
21:01:58 <mriedem> hi
21:01:58 <johnthetubaguy> #topic Release status
21:02:02 <ctrath> \o
21:02:02 <tpatil_> Hi
21:02:04 <melwitt> o/
21:02:17 <johnthetubaguy> so I send an ML message, but today was non-priority feature proposal freeze
21:02:34 <johnthetubaguy> #info today was non-priority feature proposal freeze
21:02:54 <johnthetubaguy> #info liberty-2 is july 30th and non-priority feature freeze
21:03:03 <johnthetubaguy> #link https://etherpad.openstack.org/p/liberty-nova-non-priority-feature-proposal-freeze
21:03:13 <johnthetubaguy> thats got all the details, if people are interested in what happened
21:03:22 <johnthetubaguy> #link https://wiki.openstack.org/wiki/Nova/Liberty_Release_Schedule
21:03:40 <johnthetubaguy> ^ that describes why we are doing all this process, or it tries to
21:03:47 <johnthetubaguy> any questions on process stuff?
21:04:25 <johnthetubaguy> #action johnthetubaguy needs to go through nova-specs reviews and make sure people know about the move to the backlog
21:04:44 <johnthetubaguy> OK, either IRC has netsplit without telling me, or there are now questions, so moving on I guess...
21:04:49 <bauzas> :)
21:04:51 <johnthetubaguy> #topic Bugs
21:04:51 <mriedem> no questions
21:04:55 <mriedem> however
21:04:58 <mriedem> sec
21:04:59 <mriedem> on backlogs
21:05:03 <gabriel-bezerra> is that backlog in the links?
21:05:13 <mriedem> we keep saying to move things that aren't making it to the backlog,
21:05:17 <johnthetubaguy> ah, yes, backlogs, yes, lets do that
21:05:19 <johnthetubaguy> yeah
21:05:21 <bauzas> gabriel-bezerra: http://specs.openstack.org/openstack/nova-specs/specs/backlog/
21:05:33 <mriedem> but if you read the docs on the backlog, it's about dumping ideas for people to go work on, not a place to defer things that didn't make n and need to go to n+1
21:05:50 <mriedem> we probably need to add something to the docs explaining that if backlog is going to become a deferral limbo place
21:05:58 <dansmith> yeah,
21:06:08 <dansmith> I was not in favor of making it a missed-deadline wasteland
21:06:12 <mriedem> +1
21:06:17 <johnthetubaguy> mriedem: yeah, so I think I want to discuss the plans at the midcycle
21:06:26 <mriedem> in the past people just move their stuff when they repropose
21:06:29 <gabriel-bezerra> thanks, bauzas
21:06:33 <mriedem> alright
21:06:47 <mriedem> so maybe we should hold off on telling people to start moving specs to backlog until after the meetup?
21:06:55 <johnthetubaguy> so I had some ideas, but they are a little crazy
21:06:57 <johnthetubaguy> #link https://wiki.openstack.org/wiki/Nova/Liberty_Release_Schedule#Stop_having_to_submit_a_spec_for_each_release
21:07:06 <mriedem> oh, runways
21:07:07 <mriedem> i see
21:07:12 <mriedem> RIP jogo
21:07:20 <johnthetubaguy> yeah, heading that way at least
21:07:34 <gabriel-bezerra> so the backlog is a directory in the specs repository?
21:07:43 <johnthetubaguy> gabriel-bezerra: yes
21:07:46 <bauzas> gabriel-bezerra: yep
21:07:47 <gabriel-bezerra> ok
21:07:52 <mriedem> gabriel-bezerra: yes, it's talked about in the nova-specs readme
21:08:03 <mriedem> we can move on, i'll add a thing to the etherpad for the meetup to talk about htis
21:08:07 <johnthetubaguy> gabriel-bezerra: basically merge in the backlog, rather than a specific release
21:08:24 <johnthetubaguy> mriedem: yeah, thats cool, lets bring this up at the end if that makes sense
21:08:32 <johnthetubaguy> so I should have used the undo, there, my bad
21:08:34 <johnthetubaguy> anyways, bugs
21:08:45 <gabriel-bezerra> got it
21:08:48 <johnthetubaguy> anything people want to talk about?
21:08:56 <bauzas> one criitcal
21:09:05 <bauzas> probably not critical
21:09:20 <bauzas> https://bugs.launchpad.net/nova/+bug/1475202
21:09:20 <openstack> Launchpad bug 1475202 in OpenStack Compute (nova) "Snapshot deleting of attached volume fails with remotefs volume drivers" [Critical,In progress] - Assigned to Dmitry Guryanov (dguryanov)
21:09:29 <johnthetubaguy> yes, feels like a high is the max there
21:09:48 <johnthetubaguy> bauzas: you OK to update the priority and add an educational comment?
21:09:49 <bauzas> changing the prio unless someone yells
21:09:55 <johnthetubaguy> cool, anything else
21:09:56 <bauzas> johnthetubaguy: sure thing
21:10:07 <bauzas> that's it for bugs - none for the client
21:10:23 <johnthetubaguy> mriedem: man of the gate, hows things looking right now, I saw lots of reverts being discussed that fixed a few things, I guess?
21:10:29 <mriedem> it's fine
21:10:31 <mriedem> backed up
21:10:32 <mriedem> but fine
21:10:41 <johnthetubaguy> cools
21:10:47 <dansmith> "man of the gate" ... I'll have to remember that
21:11:11 <johnthetubaguy> heh
21:11:18 <johnthetubaguy> #topic regular reminders
21:11:49 <johnthetubaguy> so its probably a good time to review low priority specs, give people have been really quite good at getting code up to review
21:11:52 <bauzas> mriedem: 16 patches in my series, no Jenkins false positives, so yeah it's cool :p
21:11:53 <johnthetubaguy> but ...
21:11:55 <johnthetubaguy> #link https://etherpad.openstack.org/p/liberty-nova-priorities-tracking
21:12:19 <johnthetubaguy> please to try and review these things too, ideally ^
21:12:20 <johnthetubaguy> anyways
21:12:34 <johnthetubaguy> I commented on unshelf as added in the agenda
21:12:45 <johnthetubaguy> #link https://etherpad.openstack.org/p/YVR-nova-liberty-summit-action-items
21:12:55 <johnthetubaguy> please do work on post summit actions^
21:13:02 <tpatil_> johnthetubaguy: Yes, we will move the specs to backlog
21:13:06 <johnthetubaguy> #link https://etherpad.openstack.org/p/liberty-nova-midcycle
21:13:17 <tpatil_> We have simplified specs by removing complex deployments strategies (host aggregate groups) and also addressed all comments received from Alaski and Matt in PS 15
21:13:21 <tpatil_> After moving specs to the backlog, request everyone to please review the specs.
21:13:23 <johnthetubaguy> tpatil_: thanks, hopefully we can get a way forward agreed really soon
21:13:36 <johnthetubaguy> tpatil_: yeah, it feels like we are getting closer now
21:13:42 <johnthetubaguy> #link https://etherpad.openstack.org/p/liberty-nova-midcycle
21:13:53 <tpatil_> johnthetubaguy: Thanks, looking forward to it.
21:13:53 <johnthetubaguy> so ideas for next week, feel free to add them ^
21:14:06 <johnthetubaguy> #topic Open Discussion
21:14:11 <johnthetubaguy> I don't see any stuck reviews
21:14:14 <bauzas> saw a google hangout link, thanks !
21:14:15 <johnthetubaguy> so straight to open
21:14:40 <johnthetubaguy> bauzas: yeah, it might not work, but we can try a few things
21:14:44 <johnthetubaguy> so we have agenda stuff...
21:14:47 <gabriel-bezerra> I have a stuck review, but mriedem advised me to put it in Open Discussion
21:14:57 <bauzas> johnthetubaguy: sure thing
21:14:57 <gabriel-bezerra> it's the first topic there
21:15:09 <johnthetubaguy> so yeah, we have: https://blueprints.launchpad.net/nova/+spec/pass-down-instance-name-to-ironic-driver
21:15:17 <gabriel-bezerra> That one
21:15:25 <gabriel-bezerra> the code is ready, just 7 lines
21:15:34 <johnthetubaguy> now, the problem here, is the blueprint freeze was at the end of June
21:15:48 <johnthetubaguy> and the exception process ended last week
21:15:58 <mriedem> mikal said in the spec that it probably doesn't need a spec https://review.openstack.org/#/c/189850/
21:16:03 <mriedem> so i think that's why it's 'stuck'
21:16:07 <gabriel-bezerra> it just adds the instance/display_name to the message nova sends to ironic
21:16:07 <mriedem> got caught in process limbo
21:16:15 <johnthetubaguy> oh dear, I see
21:16:18 <mriedem> seems trivial enough to not require a spec
21:16:21 <johnthetubaguy> yeah
21:16:25 <mriedem> we have a couple of these
21:16:31 <johnthetubaguy> gabriel-bezerra: do you have you code up for review now?
21:16:39 <gabriel-bezerra> yes, it is in the second link
21:16:40 <mriedem> https://review.openstack.org/#/c/190675/
21:16:43 <mriedem> ^ is the code
21:16:46 <jroll> gabriel-bezerra: so the idea is to pass instance display_name to ironic node.instance_info?
21:16:48 <jroll> aha
21:17:01 <gabriel-bezerra> yes, jroll
21:17:06 <dansmith> I violently disagree with this code
21:17:14 <gabriel-bezerra> so we can improve the UX of the driver
21:17:18 <jroll> ..... that code needs a spec?
21:17:28 <johnthetubaguy> dansmith: in a block the blueprint kind of way?
21:17:35 <dansmith> johnthetubaguy: no in a completely sarcastic way
21:17:45 <johnthetubaguy> dansmith: :)
21:17:52 <mriedem> so i move to trivially approve the bp
21:17:54 <mriedem> drop the spec
21:17:56 <mriedem> merge the code
21:17:59 <johnthetubaguy> yep
21:18:02 <gabriel-bezerra> :)
21:18:04 <jroll> mriedem: +1
21:18:35 <johnthetubaguy> gabriel-bezerra: so to make this happen next time, basically just add the blueprint to the nova-meeting, attempting to document and streamline all this, we had a few fall between the gaps
21:18:54 <bauzas> oh, sooooo many co-authors :)
21:19:03 <johnthetubaguy> ah, so we have a few specs that are bug fixes
21:19:05 <dansmith> yeah, how is that possible?
21:19:07 <johnthetubaguy> they need a reveiw
21:19:11 <dansmith> that's more than one author per line I think
21:19:13 <edleafe> bauzas: they each wrote one character
21:19:13 <mriedem> must be an edu thing
21:19:17 <tonyb> bauzas: Yeah one line each?
21:19:19 <jroll> johnthetubaguy: I'm shocked this even requires a blueprint
21:19:29 <johnthetubaguy> jroll: its only for tracking
21:19:34 <gabriel-bezerra> johnthetubaguy: sure. thanks.
21:19:37 <jroll> ok
21:19:38 <mriedem> moving on?
21:19:38 <johnthetubaguy> jroll: so we can tell users we added a feature
21:19:41 <bauzas> tokyo is close, I guess
21:19:44 <gabriel-bezerra> yes, we are a university
21:19:47 <jroll> johnthetubaguy: heard
21:19:49 <johnthetubaguy> #link https://review.openstack.org/#/c/198622
21:19:54 <gabriel-bezerra> ufcg.edu.br
21:19:56 <johnthetubaguy> #link https://review.openstack.org/#/c/198184/
21:20:03 <johnthetubaguy> I think those ones are API changes
21:20:21 <johnthetubaguy> but are bug fixes that spiralled, so some eyes on those would be good, I should take a look too
21:20:33 <johnthetubaguy> there is a review request on the agenda too
21:20:37 <johnthetubaguy> look there if you fancy
21:20:55 <johnthetubaguy> ah, so the next one is some brick stuff
21:21:13 <mriedem> yeah, so this is another case of process limbo,
21:21:26 <mriedem> when those were proposed we weren't sure if they would be os-brick or old style volume drivers,
21:21:33 <mriedem> so that held them up even though the code was up,
21:21:43 <mriedem> now hemna's os-brick change has a +2 and should get in,
21:21:47 <johnthetubaguy> yeah, they feel like tiny things we can just document the blueprints for
21:21:51 <mriedem> and the hgst and scaelio changes are on top of htat
21:21:54 <mriedem> right
21:21:57 <johnthetubaguy> yeah, I hoped to do the brick review today, but it didn't happen
21:22:09 <hemna> mriedem, thanks for all the help on that
21:22:12 <mriedem> so, another case where i don't think we should block those
21:22:22 <mriedem> the nova code is just a shim layer that talks to brick
21:22:40 <johnthetubaguy> yeah, seems reasonable
21:22:44 <mriedem> we should actually probably add these kinds of things to the spec template or readme about what doesn't need a spec
21:22:51 <mriedem> which i could do
21:23:14 <johnthetubaguy> we can do those kinds of blueprints on IRC I think, rather than wait for the meeting, if that works better
21:23:22 <mriedem> sure
21:23:32 <johnthetubaguy> mriedem: yeah, we lots some of the good examples in the doc clean up, these would be good adds
21:23:33 <mriedem> just airing it out here
21:23:45 <johnthetubaguy> mriedem: yeah, good idea
21:23:58 <mriedem> #action mriedem to add volume driver examples about what doesn't need a spec
21:24:11 <johnthetubaguy> the spec vs blueprint guidelines are very poor right, now, I think we are better practiced now, so we can document that
21:24:17 <johnthetubaguy> mriedem: awesome, thank you
21:24:26 <johnthetubaguy> so.. now its open open discussion
21:24:32 <johnthetubaguy> any more for any more?
21:24:39 <earlephilhower> Just checking, for those 2 BPs
21:24:48 <earlephilhower> do the authors need to do anything (Xyang and I)?
21:24:51 <mriedem> https://blueprints.launchpad.net/nova/+spec/emc-sdc-libvirt-volume-driver
21:24:54 <mriedem> https://blueprints.launchpad.net/nova/+spec/emc-sdc-libvirt-volume-driver
21:25:05 <mriedem> https://blueprints.launchpad.net/nova/+spec/add-os-brick-volume-driver-hgst-solutions
21:25:17 <johnthetubaguy> right, I think we can just approve those, as trivial things
21:25:24 <mriedem> sounds like abandon the specs and approve the bps
21:25:26 <johnthetubaguy> mostly because they are already up for review, and agreed
21:25:32 <johnthetubaguy> yeah
21:25:35 <earlephilhower> Cool, thanks.
21:25:37 <xyang2> thanks a lot!
21:25:51 <johnthetubaguy> I will do the approve and abandon in the morning
21:25:57 <johnthetubaguy> unless someone beats me to it
21:26:03 <mriedem> i can do it
21:26:42 <johnthetubaguy> mriedem: cool
21:26:48 <johnthetubaguy> anyways, any more for any more?
21:27:21 <melwitt> https://blueprints.launchpad.net/nova/+spec/service-version-number spec merged and can be approved I noticed
21:27:52 <johnthetubaguy> melwitt: ah, I missed that, oops, yeah
21:28:12 <melwitt> it wasn't there before this afternoon, I noticed it when I clicked the link in a patch about it
21:28:14 * johnthetubaguy should really automate that...
21:28:16 <dansmith> melwitt: the check is in the mail, thanks
21:28:25 <melwitt> :)
21:29:15 <johnthetubaguy> any more for any more?
21:29:25 <mriedem> nope
21:29:27 <mriedem> end it
21:29:30 <dansmith> +1
21:29:46 <johnthetubaguy> cool, so I am busy approving blueprints
21:29:53 <johnthetubaguy> see some of you on tuesday
21:30:01 <mriedem> o/
21:30:02 <johnthetubaguy> see some of you on IRC tomorrow
21:30:04 <johnthetubaguy> thanks all
21:30:07 <johnthetubaguy> #endmeeting