14:02:05 <johnthetubaguy> #startmeeting nova
14:02:06 <openstack> Meeting started Thu May 28 14:02:05 2015 UTC and is due to finish in 60 minutes.  The chair is johnthetubaguy. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:09 <openstack> The meeting name has been set to 'nova'
14:02:18 <bauzas> \o
14:02:21 <edleafe> o/
14:02:23 <alex_xu> o/
14:02:24 <markus_z> o/
14:02:29 <jlvillal> o/
14:02:30 <beagles> o/
14:02:30 <mnestratov> o/
14:02:32 <abhishekk> o/
14:02:32 <lxsli> o/
14:02:32 <dguryanov> o/
14:02:34 <rgerganov> o/
14:02:35 <eantyshev> o/
14:02:35 <dansmith> o/
14:02:36 <johnthetubaguy> #link https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting
14:02:40 <garyk> o\
14:02:42 <johnthetubaguy> hello all
14:02:42 <pczesno> o/
14:02:52 <johnthetubaguy> #topic Release Status
14:02:52 <dims_> o/
14:03:11 <johnthetubaguy> so there are lots of proposed deadline we discussed at the summit in the process session
14:03:15 * mriedem joins late
14:03:20 <johnthetubaguy> basically same as kilo, is the rough summary of that
14:03:30 <johnthetubaguy> they are in the agenda I liked above
14:03:47 <johnthetubaguy> liberty-1 being spec freeze, but we keep the backlog open
14:03:54 <johnthetubaguy> thats the one thats coming close
14:04:07 <johnthetubaguy> rather than wasting time, I will get a proposal sent to the ML
14:04:20 <garyk> johnthetubaguy: cool, that answer my question
14:04:23 <johnthetubaguy> but does anything in the list in the agenda wiki look totally off to people?
14:04:33 <johnthetubaguy> garyk: :)
14:04:45 <johnthetubaguy> so moving on then
14:04:46 <johnthetubaguy> #link https://etherpad.openstack.org/p/liberty-nova-priorities-tracking
14:04:57 <johnthetubaguy> we have an etherpad of doom for liberty
14:05:13 <johnthetubaguy> we are trying out the idea of subteams suggesting their top 3 or top 5 patches
14:05:26 <bauzas> coolness
14:05:31 <johnthetubaguy> again, there will be more details on whats happening on the ML soon, but thats the net net
14:05:41 <johnthetubaguy> its mostly all written down in the above etherpad
14:06:07 <johnthetubaguy> in future meetings, we can raise any stuck items listed in the etherpad I guess, but lets keep moving for now
14:06:36 <johnthetubaguy> there is a stuck spec review, but its not actually got a -1, so I am ignoring that: https://review.openstack.org/135387
14:06:44 <johnthetubaguy> there is one non-spec blueprint to discuss
14:06:49 <johnthetubaguy> #link https://blueprints.launchpad.net/nova/+spec/config-drive-support-for-virtuozzo
14:07:13 <johnthetubaguy> basically add config drive support to parallels, its almost a bug fix
14:07:22 <johnthetubaguy> any objections to approving that one?
14:07:36 <mnestratov> thanks for bringing this up
14:07:53 <dansmith> it's not a bug fix, let's be clear :)
14:07:58 <johnthetubaguy> mnestratov: no worries, it got on the agenda, I think mikal put it there during the summit
14:08:01 <dansmith> but yes seems like an obvious thing to do
14:08:26 <johnthetubaguy> dansmith: yes, very true, its a "me too" feature that got left out in the initial run of parallels support patches
14:08:34 <dansmith> yes
14:08:42 <dansmith> are you wondering if we can do it without a spec?
14:08:52 <johnthetubaguy> oh, sorry, yes, thats the thing here
14:09:09 <johnthetubaguy> do we approve this without a spec, as proposed in the meeting agenda by mikal
14:09:15 <dansmith> if it doesn't impact anything other than just driver support then I think that's fine
14:09:29 <johnthetubaguy> dansmith: cool, I am thinking the same thing, it looks that way
14:09:38 <dansmith> there was another proposal for a feature parity thing affecting ceph that was similar, but it affected glance usage and ceph setup,
14:09:40 <mnestratov> but we had a general spec for the previous release cycle
14:09:53 <dansmith> and thus I opined in favor of a spec because of the cross-service impact
14:09:55 <johnthetubaguy> mnestratov: you mean for the parallels support in general?
14:10:05 <johnthetubaguy> dansmith: good call out, +1 on that
14:10:12 <mnestratov> johnthetubaguy: yes
14:10:14 <dansmith> so if this is all driver-contained, then it seems reasonable to just use a BP for tracking to me
14:10:19 <johnthetubaguy> +1
14:10:23 <johnthetubaguy> any objections?
14:10:47 <dims_> +1
14:10:56 <johnthetubaguy> #info https://blueprints.launchpad.net/nova/+spec/config-drive-support-for-virtuozzo is approved for liberty without the need for a spec
14:11:05 <johnthetubaguy> I think thats all updated now
14:11:06 <mnestratov> thanks
14:11:21 <johnthetubaguy> mnestratov: please mark it as "NeedsCodeReview" once all the code is up for review
14:11:29 <johnthetubaguy> mnestratov: I guess you can do that right now?
14:11:36 <mnestratov> johnthetubaguy: sure
14:11:43 <johnthetubaguy> thanks
14:11:46 <johnthetubaguy> so moving on
14:11:56 <johnthetubaguy> #topic Events: design summit and midcycle
14:12:10 <johnthetubaguy> so I am going through all the etherpads looking for actions
14:12:16 <johnthetubaguy> #link https://etherpad.openstack.org/p/YVR-nova-liberty-summit-action-items
14:12:23 <garyk> one action item should be a mid cycle in europe
14:12:37 * bauzas should think about renaming himself :)
14:12:53 <claudiub> +1
14:12:54 <markus_z> mid cycle in europe +1
14:12:59 <johnthetubaguy> but its been delayed as we are attempting to deploy new code in our SYD region, and that being quite rough going…
14:13:02 <bauzas> honestly +1 to it
14:13:28 <mnestratov> +1
14:13:36 <mnestratov> for europe
14:13:43 <johnthetubaguy> so for a european midcycle, I worry about diluting the US based one we already agreed would happen now
14:13:53 <dansmith> yep
14:13:55 <johnthetubaguy> what about doing it during the M release?
14:14:04 <johnthetubaguy> well, pencilling one in for then
14:14:12 <garyk> sounds good to me
14:14:20 <bauzas> fair point
14:14:20 <sahid> makes sense to ask about a blueprint approval here?
14:14:26 <johnthetubaguy> if someone has office space for that, do get in touch, so we can try sort that sound
14:14:27 <mriedem> sahid: open discussion
14:14:50 <johnthetubaguy> sahid: we did that bit already, stuff needs to go on here: https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting but yeah, we can do that in Open now
14:15:12 <sahid> mriedem, johnthetubaguy ah ok thanks i was litle bit late
14:15:15 <johnthetubaguy> #action johnthetubaguy to document the idea of a european midcycle next time
14:15:18 <sahid> https://blueprints.launchpad.net/nova/+spec/libvirt-set-admin-password
14:15:25 <sahid> a really small one
14:15:28 <johnthetubaguy> sahid: no worries, lets get back to that in a bit
14:15:32 <sahid> ok
14:15:46 <johnthetubaguy> Ok, so lets keep moving
14:15:48 <edleafe> warm Europe for M midcycle, please :)
14:16:08 <cfriesen> not northern finland in winter?
14:16:09 <johnthetubaguy> edleafe: depends who gives us office space
14:16:12 <lxsli> but Bristol is beautiful on June 2nd-3rd!
14:16:27 <johnthetubaguy> anyways, lets move on
14:16:28 <bauzas> Grenoble has quite lots of snow on the slopes by January... :D
14:16:43 <johnthetubaguy> feel free to start an ML thread on that, ideally with real offers of space
14:16:58 <johnthetubaguy> #topic Community Building
14:17:15 <johnthetubaguy> so this is partly a place holder to track these efforts
14:17:28 <johnthetubaguy> mentoring being a big part of what was discussed around scaling out the nova team
14:17:35 <johnthetubaguy> #link https://etherpad.openstack.org/p/YVR-nova-liberty-process
14:17:47 <johnthetubaguy> but little updates for this week
14:18:02 <johnthetubaguy> except, I wanted to do a survey to see if people are still happy with these meeting times
14:18:20 <johnthetubaguy> the survey will close the next time we have a meeting at this time
14:18:23 <johnthetubaguy> #link http://doodle.com/eyzvnawzv86ubtaw
14:18:49 <johnthetubaguy> OK, so moving on
14:18:53 <johnthetubaguy> #topic Bugs
14:19:10 <johnthetubaguy> I notice our bug tag owners is getting stale : https://wiki.openstack.org/wiki/Nova/BugTriage
14:19:22 <johnthetubaguy> it would be good to fix that, get folks to step up
14:19:27 <bauzas> agreed
14:19:29 * johnthetubaguy wink wink, nudge nudge
14:19:38 <johnthetubaguy> mriedem: hows the gate these days?
14:19:47 <mriedem> fine for nova on master
14:20:08 <johnthetubaguy> https://bugs.launchpad.net/nova/+bug/1457527
14:20:08 <openstack> Launchpad bug 1457527 in OpenStack Compute (nova) "Image-cache deleting active swap backing images" [Critical,In progress] - Assigned to Michael Still (mikalstill)
14:20:19 <johnthetubaguy> https://bugs.launchpad.net/nova/+bug/1447380
14:20:19 <openstack> Launchpad bug 1447380 in OpenStack Compute (nova) "wrong cinder.conf.sample generation: missing directives for keystone_authtoken (at least)" [Critical,In progress] - Assigned to John Griffith (john-griffith)
14:20:34 <johnthetubaguy> so they are both critial bugs right now
14:20:46 <dansmith> how is that second one critical?
14:20:49 <mriedem> ndipanov was talking about the first yesterday, there is a patch https://review.openstack.org/#/c/83516/
14:21:01 <mriedem> the second is not crticial
14:21:02 <johnthetubaguy> dansmith: I don't think it is really, its just marked that way
14:21:20 <mriedem> i moved it to medium
14:21:29 <dansmith> cool
14:21:32 <ndipanov> mriedem, but that will not fix it for existing instances
14:21:42 <ndipanov> I started looking into that but it's not sooo easy
14:21:54 <ndipanov> if we want to cover all cases (migration etc)
14:21:55 <dansmith> can we fix it in the list object?
14:21:56 <markus_z> Is the openstack bootstrapping hour still a thing? I liked those. Could they do a session about bug triaging?
14:22:04 <johnthetubaguy> mriedem: oh me too, but thats cool
14:22:25 <bauzas> markus_z: feel free to help, we have 40 open bugs even when triaging once per week
14:22:25 <mriedem> markus_z: need topics and presenters
14:22:44 <bauzas> Nova is generating app. 20 new bugs per week
14:22:46 <mriedem> markus_z: sdague generally runs those so try to find him later
14:23:05 <johnthetubaguy> cools, I think sdague will be back online next week
14:23:07 <bauzas> half of them are invalid from my perspective
14:23:30 <markus_z> bauzas: It like to, but I had issues to understand the process the last time I read the wiki
14:23:33 <johnthetubaguy> #action markus_z and mriedem to talk to sdague about bug triage and the bootstrapping hour
14:23:42 <mriedem> oh i see what you did there
14:23:47 <bauzas> markus_z: ping me and I'll be glad to help
14:23:54 <markus_z> bauzas: thanks
14:24:02 <markus_z> johnthetubaguy: thanks, I guess ;)
14:24:18 <johnthetubaguy> anything more on that critical bug?
14:24:39 <johnthetubaguy> probably best to take that into #openstack-nova after we are done at this point
14:25:02 <johnthetubaguy> #topic Open Discussion
14:25:12 <johnthetubaguy> so we have a stuck review listed, but its not got a -1 on it
14:25:18 <bauzas> just about bugs, the trivial bugs list is up-to-date
14:25:21 <johnthetubaguy> feel free to read the agenda for the link
14:25:31 <dansmith> we need to define stuck reviews on that page, apparently
14:25:52 <johnthetubaguy> #action johnthetubaguy to define "stuck reviews" on the agenda page
14:25:54 <dansmith> i.e. "stuck != unreviewed for N days"
14:25:56 <johnthetubaguy> yeah
14:26:10 <johnthetubaguy> unless N > 180 or something
14:26:14 <johnthetubaguy> but anyways
14:26:26 <johnthetubaguy> mriedem: min libvirt version
14:26:29 <bauzas> could we rename that to 'conflicting reviews' ?
14:26:30 <dansmith> that's different
14:26:32 <dansmith> yeah
14:26:38 <mriedem> johnthetubaguy: the min libvirt version thing was old, removed it
14:26:39 <dansmith> it was supposed to be to break ties
14:26:56 <lxsli> "Reviews requiring mediation"
14:26:57 <johnthetubaguy> mriedem: gotcha, probably my bad, I thought we sorted that already
14:27:18 <mriedem> i did add this https://blueprints.launchpad.net/nova/+spec/aggregate-network-filter
14:27:22 <johnthetubaguy> lxsli: I quite like "mediation" actually
14:27:24 <mriedem> does that require a spec? it's a new scheduler filter
14:27:33 <mriedem> bauzas: ^
14:27:56 <bauzas> mriedem: the problem is that it needs to provide more to the scheduler than what's already in HostState
14:28:30 <bauzas> mriedem: here the proposal is to use filter_props, but since I'm working on RequestSpec, I'm a little worried by any impact it would cause
14:28:36 <johnthetubaguy> bauzas: oh, like it sends not just a list on instance uuids, but also networks?
14:29:01 <bauzas> johnthetubaguy: yup, it adds the networks list as part of the big filt_props blob
14:29:43 <bauzas> johnthetubaguy: so that's not technically bounded to what the Scheduler proposes
14:29:58 <bauzas> and that opens room for discussion
14:30:05 <johnthetubaguy> bauzas: are you happy to write up a dev ref on how this is happening (or spec) in general?
14:30:19 <johnthetubaguy> bauzas: and maybe describe what sorts of features are blocked because of that work?
14:30:21 <bauzas> johnthetubaguy: yeah, that's an action I have to do (and you marked it as well :)
14:30:59 <bauzas> johnthetubaguy: yeah, put my name on that
14:31:06 <johnthetubaguy> bauzas: I think we need to just do this one first, explain why we can't do this right away, and what effort to help with to get there quicker
14:31:16 <bauzas> johnthetubaguy: totally agreed
14:31:28 <bauzas> johnthetubaguy: or find a mitigation plan
14:31:30 <johnthetubaguy> #action bauzas to describe what is blocking https://blueprints.launchpad.net/nova/+spec/aggregate-network-filter and how to help
14:31:45 <johnthetubaguy> bauzas: do we want a spec for the above blueprint, because of this?
14:32:16 <bauzas> johnthetubaguy: that's harsh to say, but I would at least be able to discuss on the format of that, since it needs to be backported to the RequestSpec object
14:32:44 <bauzas> johnthetubaguy: so I really would like to avoid non-typed, unformal dicts added to the already non-typed, unversioned dict that we have
14:33:01 <lxsli> sounds like a spec to me
14:33:16 <edleafe> +1 on a spec
14:33:46 <johnthetubaguy> OK, needs a spec as it needs new info
14:33:54 <bauzas> well, at least we need to make sure that any change to filter_properties or request_spec is enough documented
14:34:02 <bauzas> so yeah for a specc
14:34:04 <bauzas> spec
14:34:05 <johnthetubaguy> #info https://blueprints.launchpad.net/nova/+spec/aggregate-network-filter needs a spec because of the extra information that needs to be passed around
14:34:17 <johnthetubaguy> sahid: you had a spec as well right?
14:34:22 <johnthetubaguy> I mean, blueprint
14:34:47 <sahid> johnthetubaguy: you mean the one i told before ?
14:34:51 <johnthetubaguy> yep
14:35:06 <sahid> johnthetubaguy: https://blueprints.launchpad.net/nova/+spec/libvirt-set-admin-password
14:35:28 <sahid> the last relase of libvirt provide the super to configure user password
14:35:45 <johnthetubaguy> sahid: so this is libvirt implementing the API xenapi already has?
14:35:50 <sahid> and so the aim of the blueprint is to use it to implement the set_admin_password PAI
14:36:02 <johnthetubaguy> I guess this will require an in guest agent?
14:36:48 <mriedem> i see danpb has +2ed all of the changes w/o the blueprint being approved
14:36:56 <sahid> hum...
14:37:00 <sahid> what do you mean ?
14:37:22 <mriedem> https://review.openstack.org/#/c/185910/
14:37:25 <dansmith> johnthetubaguy: yeah, I would think it would, if it's going to work online like the xenapi one does (right?)
14:37:55 <cfriesen> sahid: the two patches listed in the whiteboard already have +2 reviews from Daniel Berrange
14:38:11 <johnthetubaguy> so… sahid its not clear to me from the blueprint how it works
14:38:13 <sahid> cfriesen: yes but we need to bp approval no?
14:38:20 <johnthetubaguy> which seems problematic
14:38:43 <sahid> ok so you need specific detail about how it works internally on libvirt?
14:39:03 <johnthetubaguy> sahid: I need to be able to tell if it will appear the same to users as the xenapi support
14:39:03 <mriedem> sahid: are the dependent patches in that series for the guest object tied to that blueprint as well?
14:39:15 <dansmith> sahid: is this supposed to work live, or only if the guest is off (or rebooted as part of this process) ?
14:40:32 <johnthetubaguy> OK… so given there are questions
14:40:35 <johnthetubaguy> we need a spec for this
14:41:09 <johnthetubaguy> at least its the only other way we have of agreeing
14:41:18 <sahid> johnthetubaguy: hum so the support is only for qemu
14:41:22 <johnthetubaguy> I have -2ed the patches since the blueprint is not agreed
14:41:47 <cfriesen> sahid: this is using the existing set_admin_password() call?
14:41:51 <johnthetubaguy> sahid: yeah, we need a spec to talk about all the details, it seems very unclear about what is going on I am afraid, like what image properties you need to make sure the API works, etc, etc
14:41:54 <sahid> mriedem: well i have considered it was yes
14:42:44 <sahid> cfriesen: yes
14:42:57 <johnthetubaguy> #action sahid to submit a spec for the blueprint https://blueprints.launchpad.net/nova/+spec/libvirt-set-admin-password as its not clear how a user can use the feature from the spec, and it not clear its the same as the existing xenapi feature
14:43:15 <sahid> johnthetubaguy: there is no need of image property actually this use a nova API already present
14:43:21 <sahid> johnthetubaguy: ack
14:43:32 <markus_z> Is there a libvirt subteam? I see there are a lot of refactorings ongoing. It's not listed in the etherpad "liberty-nova-priorities-tracking"
14:43:36 <johnthetubaguy> sahid: so does this API work with all images that currently exist?
14:43:57 <mriedem> markus_z: there used to be and had meetings but attendance dropped so danpb disbanded
14:44:05 <sahid> the API (nova)is actually not really useful since we do not pass the user
14:44:11 <sahid> we consider we are using linux
14:44:13 <sahid> so root
14:44:26 <sahid> but we can have image with Windows
14:44:31 <dansmith> well, it is setting the admin password,
14:44:32 <markus_z> mriedem: OK
14:44:37 <sahid> so that is why i have added the thing with image property
14:44:40 <dansmith> which would be root on linux or administrator on windows
14:44:48 <johnthetubaguy> sahid: the API resets root on linux, and administrator on linux, using an in guest agent, right now, anyways
14:44:58 <johnthetubaguy> oops
14:45:02 <johnthetubaguy> administrator on windows
14:45:05 <dansmith> johnthetubaguy: and live without a reboot, right?
14:45:10 <johnthetubaguy> dansmith: yes
14:45:14 <sahid> dansmith: yes
14:45:36 <dansmith> sahid: so this will require a qemu agent to be running in the guest to provide the same functionality, right?
14:45:36 <johnthetubaguy> sahid: so how does it do it live? using an in guest agent right?
14:45:46 <sahid> the image property things was for image with an other user than Administrator
14:45:53 <sahid> johnthetubaguy: yes
14:46:00 <sahid> i'm looking at the patch rieh now
14:46:06 <johnthetubaguy> sahid: so the API should return not implemented, or similar if there is no guest agent installed, like the xenapi one does?
14:46:33 <sahid> johnthetubaguy: yep i did not add the condition, this change is only for semu
14:46:36 <sahid> qemu
14:46:59 <johnthetubaguy> sahid: so thats inconsistent, feels like we need these details discussed in the spec
14:47:18 <sahid> johnthetubaguy: do you think i can just try to enhance the blueprint?
14:47:27 <mriedem> no
14:47:29 <mriedem> this needs a spec
14:47:33 <sahid> then if that looks not good i will do the spec
14:47:41 <johnthetubaguy> right, there is too much discussion here for the blueprint to work
14:47:42 <dansmith> +1 for spec
14:47:52 <sahid> ok so go for the spec
14:47:57 <sahid> thank you guys
14:47:58 <mriedem> i also want to know about testing since we have a newer libvirt in the fc21 job but i don't think it's this new
14:48:02 <johnthetubaguy> #info agreed this really needs a spec https://blueprints.launchpad.net/nova/+spec/libvirt-set-admin-password
14:48:06 <johnthetubaguy> mriedem: +1
14:48:29 <dansmith> mriedem: yeah
14:48:37 <johnthetubaguy> OK, cools
14:48:41 <johnthetubaguy> any more for any more?
14:48:42 <dansmith> mriedem: this seems to add another moving part, so would really like to see it *actually* tested for sure
14:48:45 <mnestratov> we would like to make our pcs6 CI system comment on kilo/stable https://wiki.openstack.org/wiki/ThirdPartySystems/Parallels_PCS6_CI
14:48:46 <abhishekk> johnthetubaguy and community members please provide your valuable feedback on nova-specs, https://review.openstack.org/135387
14:49:20 <johnthetubaguy> abhishekk: its in the review queue, its going to take a little while to get through the backlog post summit
14:49:26 <mriedem> mnestratov: why stable?
14:49:29 <mriedem> why not master?
14:49:45 <abhishekk> johnthetubaguy: thank you for the update
14:50:11 <mriedem> let's just agree that we'll never do anything about the performance of the unshelve API :)
14:50:28 <mriedem> early mark?
14:50:38 <mnestratov> actually we are in the process to building next version of our product for master
14:50:59 <mriedem> mnestratov: let's talk about it in -nova
14:51:00 <mnestratov> so master a bit later with a next version
14:51:05 <mnestratov> ok
14:51:14 <johnthetubaguy> cool, so we are done then
14:51:15 <johnthetubaguy> thanks all
14:51:25 <johnthetubaguy> #endmeeting