14:01:10 <johnthetubaguy> #startmeeting nova
14:01:11 <openstack> Meeting started Thu Mar 19 14:01:10 2015 UTC and is due to finish in 60 minutes.  The chair is johnthetubaguy. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:14 <openstack> The meeting name has been set to 'nova'
14:01:17 <edleafe> o/
14:01:19 <mriedem> hi
14:01:19 <n0ano> o/
14:01:24 <alex_xu> \o
14:01:26 <alaski> o/
14:01:31 <johnthetubaguy> #topic Kilo release status
14:01:35 <johnthetubaguy> hello all
14:01:52 <johnthetubaguy> so kilo-3 gets cut today
14:02:03 <johnthetubaguy> #info https://wiki.openstack.org/wiki/Kilo_Release_Schedule
14:02:17 <johnthetubaguy> and from the above wiki, it also describes the many freezes we hit
14:02:26 <johnthetubaguy> FeatureFreeze, DepFreeze, StringFreeze
14:02:48 <johnthetubaguy> Basically only bug fixes to be merged, and low risk tidy ups
14:03:04 <johnthetubaguy> certainly no string changes, or new dependencies, etc
14:03:15 <johnthetubaguy> any questions on that stuff?
14:03:28 <edleafe> you suggested a small tune-up to my last patch
14:03:29 <mriedem> there was one string change proposed,
14:03:39 <edleafe> should stuff like that be included, or wait to L?
14:03:48 <dims> o/
14:03:56 <johnthetubaguy> edleafe: we can probably merge that
14:04:00 <n0ano> so any patches that are being reviewed now are deferred to L?
14:04:02 <johnthetubaguy> edleafe: treat it as a bug
14:04:08 <edleafe> johnthetubaguy: gotcha
14:04:27 <johnthetubaguy> n0ano: well, any that violate one of the freeze should not be merged until L
14:04:52 <n0ano> so if there's no string changes & no dependencies there's still time
14:04:53 <johnthetubaguy> mriedem: I think there is a process of exceptions in the wiki, but we are still good till the end of the day I think
14:05:15 <johnthetubaguy> n0ano: and no features, and no doc impact, yes, should be OK, assuming its also low ish risk
14:05:24 <johnthetubaguy> dims: you had your hand up?
14:05:46 <mriedem> johnthetubaguy: nevermind, it has 2 -1s now so ignorining
14:05:58 <johnthetubaguy> mriedem: ah, no worries
14:06:23 <johnthetubaguy> so… does anyone have strong feelings on FFEs and the process?
14:06:41 <johnthetubaguy> this is purely for patches that are a near miss for kilo-3
14:06:42 <flip214> yes. but not productive ones. ;/
14:07:05 <johnthetubaguy> #link policy changes: https://review.openstack.org/#/c/150267/
14:07:07 <dims> johnthetubaguy: arrived late ;)
14:07:24 <mriedem> i'm happy with actually sticking to FFE for k-3
14:07:32 <mriedem> and not making a bunch of exceptions
14:07:38 <mriedem> *FF
14:07:41 <johnthetubaguy> #link low risk migration feature: https://review.openstack.org/#/c/154521/
14:08:02 <johnthetubaguy> so those are the only two big ones that seem like we might want to give them till Monday to merge
14:08:16 <johnthetubaguy> but wondering if there are any others?
14:08:31 <mriedem> dansmith: any kilo-objects things left?
14:08:37 <mriedem> the context removal stuff all got in
14:08:50 <dansmith> mriedem: nope, not really
14:08:57 <bauzas> \o
14:08:58 <dansmith> I was hoping to bump object versions in kilo,
14:09:02 * bauzas waves late
14:09:03 <dansmith> but we have to do that right before rc1 anyway
14:09:10 <dansmith> and not sure it will make it since it's had no review
14:09:18 <johnthetubaguy> dansmith: does giving time for those two patches above seem like the right thing to do?
14:09:18 <mriedem> link?
14:09:47 <mriedem> oh to like instance object version 2.0?
14:09:54 <johnthetubaguy> dansmith: could you attach it to an RC1 bug, so we track it?
14:10:03 <dansmith> mriedem: riht
14:10:15 <johnthetubaguy> we can always drop it
14:10:22 <lxsli> dansmith: I was hoping "use migration object in RT" would merge today
14:10:27 <dansmith> johnthetubaguy: on the migration one, is jerdfeldt going to respind with a fix for jaypipes' comment?
14:10:37 <bauzas> something still unclear, what if a bugfix requires a String change ?
14:10:50 <johnthetubaguy> dansmith: not sure he is awake yet to answer the question, and I have pinged him
14:11:01 <mriedem> bauzas: that's described in the string freeze wiki
14:11:01 <dansmith> johnthetubaguy: okay
14:11:12 <dansmith> johnthetubaguy: would be awesome if he could just fix it today so we can merge today
14:11:13 <bauzas> mriedem: mmm, RTFD ok :)
14:11:14 <mriedem> bauzas: https://wiki.openstack.org/wiki/StringFreeze
14:11:19 <johnthetubaguy> dansmith: I am thinking we give those two patches till monday, assuming ttx is OK with that, and we go for zero other exceptions
14:11:20 <mriedem> there is an exception process
14:11:27 <dansmith> johnthetubaguy: but yeah, that's the only one I'd want to slip
14:11:39 <bauzas> mriedem: thanks
14:11:43 <johnthetubaguy> dansmith: there was one other patch I noticed...
14:11:50 <johnthetubaguy> https://review.openstack.org/#/c/150267/
14:11:55 <mriedem> the api policy one has a lot of changes let
14:11:57 <mriedem> *left
14:12:02 <mriedem> https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:master+topic:bp/v3-api-policy,n,z
14:12:15 <johnthetubaguy> mriedem: so given most of those are backwards compatible I think we can defer it
14:12:31 <dansmith> I dunno, how important is that?
14:12:31 <mriedem> there are more than that too https://review.openstack.org/#/q/owner:%22Alex+Xu%22+status:open,n,z
14:12:43 <johnthetubaguy> mriedem: the missing policy stuff would just be additions
14:12:48 <alex_xu> mriedem: yes, the left all about db call
14:13:04 <johnthetubaguy> alex_xu: so I was thinking the only one we NEED for kilo is this one: https://review.openstack.org/#/c/150267/
14:13:14 <alex_xu> johnthetubaguy: agree
14:13:32 <bauzas> lxsli: I'm unsure we can merge PaulMurray's patches by today...
14:13:37 <johnthetubaguy> alex_xu: OK, cool, is that generally true for all the API work, it seems that way, the other bits are unit tests
14:13:44 <lxsli> bauzas: doesn't need PaulMurray's patches
14:13:45 <alex_xu> that one rename all the rule name v2.1, if we change that before someone begin to use it, it will be easy for future
14:13:58 <bauzas> lxsli: ack
14:14:06 <johnthetubaguy> lxsli: bauzas: I am about to defer that all to liberty at this point, it looks too far away right now
14:14:40 <johnthetubaguy> alex_xu: right, it saves us having to keep the old names for compatibility, etc
14:14:41 <lxsli> johnthetubaguy: My patch has been ready to go for a couple of weeks, sahid's patch I was dependent on merged last week, just need some reviewer attention I think
14:14:59 <ndipanov> johnthetubaguy, PaulMurray 's patches would be really good to land imho
14:15:01 <bauzas> johnthetubaguy: agreed
14:15:10 <PaulMurray> johnthetubaguy, to do a complete job of the RT objects needs some a little more work, but there is plenty that could be got through now
14:15:11 <ndipanov> but not sure they are ready
14:15:14 <ndipanov> the first one is
14:15:17 <johnthetubaguy> lxsli: agreed, just its not release critical enough to get an exception at this point
14:15:26 <ndipanov> yeah
14:15:26 <PaulMurray> would be good to minimise what is left to do rather than have a pile left for next time
14:15:37 <lxsli> johnthetubaguy: sure I'll see how bribeable jaypipes is when he wakes up
14:15:54 <bauzas> johnthetubaguy: that said, I think we can quickly move forward and merge https://review.openstack.org/#/c/148904/
14:15:56 <johnthetubaguy> problem is, the plan is cutting kilo-3 not long after this meeting
14:16:30 <johnthetubaguy> now we could wait a little bit for a few patches, but those ones that are bugs, we can merge after the freeze anyway
14:17:05 <bauzas> ndipanov: jaypipes: happy with reviewing https://review.openstack.org/#/c/148904/
14:17:06 <PaulMurray> johnthetubaguy, note - the follow on patches from https://review.openstack.org/#/c/148904/ are ready
14:17:06 <bauzas> ?
14:17:13 <johnthetubaguy> anyways, if you folks can get me a list of what is good to merge, and how that its in the gate soon, we can see what can be done
14:17:16 <anteaya> if it isnt' in the gate now, realisticly it won't make it into k-3
14:17:28 <PaulMurray> johnthetubaguy, the "apparent" rebase issue is not real - they just need to go through CI again
14:17:29 <johnthetubaguy> please add updates to here: https://etherpad.openstack.org/p/kilo-nova-priorities-tracking
14:17:38 <bauzas> anteaya: I know that's not yet time to ask for, but how's the gate atm ?
14:17:45 <dansmith> anteaya: why do you say that? it's early in the day and there are only 12 things in the queue
14:17:46 <anteaya> bauzas: the gate, not bad
14:17:46 <johnthetubaguy> anteaya: right, thats my thinking here
14:17:52 <ndipanov> PaulMurray, please add your patches
14:17:52 <anteaya> check is in bad shape
14:18:00 <johnthetubaguy> ah
14:18:03 <ndipanov> or not
14:18:08 <ndipanov> not sure tbh
14:18:09 <anteaya> we are cleaning jenkins's now
14:18:17 <bauzas> anteaya: so patches could be merged in the next couple of hours if quick +W
14:18:21 <johnthetubaguy> anyways, lets move on..
14:18:41 <bauzas> anteaya: oh ok, ack
14:18:46 <sdague> what's the impact on backports if the policy permissions changes aren't merged for release?
14:18:48 <johnthetubaguy> I am thinking people want to get that in, but we can't call it release critical right?
14:19:03 <johnthetubaguy> sdague: you mean the DB ones?
14:19:08 <sdague> yeh
14:19:14 <ndipanov> johnthetubaguy, the gates seems quite empty
14:19:32 <ndipanov> so it is not unrealistic to merge sutff if we can wait for tomorrow to cut -3
14:19:33 <sdague> ndipanov: right, but the check queue is massively backlogged
14:19:54 <dansmith> it's less than yesterday
14:19:59 <ndipanov> sdague, lol - yeah didn't scroll down
14:20:01 <dansmith> it was over 200 almost all day yesterday and we merged things
14:20:14 <ndipanov> 14h
14:20:14 <sdague> dansmith: yeh, but the active node count is pretty low
14:20:36 <anteaya> we are working on it
14:20:39 <dansmith> and that has changed?
14:20:39 <sdague> also, the openssl bug drops today, so I expect a lot of things might go offline when that is fixed
14:20:52 <johnthetubaguy> sdague: OK, the db stuff is a good question, I just worry about trying to loosen the DB checks quickly at the end of a release
14:21:24 <ndipanov> I mean - if it were up to me I'd say - whatever is merged by monday morning gets a pass but not sure if that is reasonable johnthetubaguy ?
14:21:50 <sdague> johnthetubaguy: yeh, that's a good question
14:21:51 <ndipanov> because 14h means if we let anything in it will merge by friday
14:22:08 <ndipanov> and at that point why not wait until monday?
14:22:15 <mriedem> k-3 is today though...
14:22:35 <dansmith> right
14:22:38 <johnthetubaguy> ndipanov: right we release kilo-3 today, and the freeze activates, so the translation folks, etc get to work
14:23:04 <bauzas> johnthetubaguy: any idea when the packaging is done ?
14:23:08 <ndipanov> well in that case I guess what's in is in...
14:23:26 <mriedem> bauzas: shouldn't matter
14:23:32 <johnthetubaguy> bauzas: in a few hours, we will tag and create the package, once I say yes to ttx, basically
14:23:34 <mriedem> that's up to the packagers
14:23:49 <johnthetubaguy> we have lots of time for bug fixes
14:23:51 <bauzas> mriedem: I was speaking about tagging and wheeling it
14:24:14 <johnthetubaguy> I just all the co-ordination stuff starts now ish, and I don't want to derail those folks
14:24:18 <johnthetubaguy> like tranlations, etc
14:24:19 <bauzas> mriedem: of course, not what downsteam packagers do
14:24:20 <johnthetubaguy> anyways
14:24:28 <johnthetubaguy> #topic kilo priorities
14:24:30 <sdague> yep, fair
14:24:34 <johnthetubaguy> I think we covered all this really
14:24:44 <johnthetubaguy> #topic gate status
14:24:58 <mriedem> i'm not aware of any major gate blockers atm, at least from nova
14:25:00 <johnthetubaguy> mriedem: nothing major here I guess?
14:25:01 <johnthetubaguy> cools
14:25:10 <mriedem> neutron loves it some dbdeadlock though
14:25:18 <johnthetubaguy> #topic Open discussion
14:25:21 <sdague> so... https://review.openstack.org/#/c/150929/ is probably a thing we should actually push into the gate right?
14:25:26 <sdague> we seem all agreed
14:25:30 <ttx> ndipanov: the jobs at 14hours wait are actually jobs that got stuck on the wrong jenkins node
14:25:42 <sdague> and being in k3 seems to be better than not being in k3
14:25:49 <dansmith> sdague: +1
14:25:49 <ttx> current delay is more 1h45
14:25:53 <johnthetubaguy> sdague: +1
14:26:01 <johnthetubaguy> should I wombat it?
14:26:17 <sdague> yes please
14:26:24 <sdague> it has a ton of +2s, and ttx is +1 on it
14:26:42 <dansmith> and mikal
14:26:46 <sdague> yep
14:26:47 <dansmith> and everyone else :)
14:26:53 <dansmith> let it be so
14:27:05 <sdague> mikal in ton_of_plus_2s == True
14:27:18 <johnthetubaguy> (barring the -2 fast revert, which I will ignore)
14:27:32 <johnthetubaguy> thats the highest level of consensus we can get really
14:27:44 <johnthetubaguy> and it support what the ec2 folks want to do, it seems
14:27:50 <johnthetubaguy> cool,
14:27:55 <johnthetubaguy> so anything more people have?
14:28:09 <flip214> when will the blueprint repo be open for L? I'd like to move my not-K-driver to L as soon as possible.
14:28:11 <dims> could use some help with bugs :)
14:28:15 <johnthetubaguy> the wiki was left old from the last meeting, which didn't help things
14:28:26 <bauzas> flip214: it's already open IIUC
14:28:28 <johnthetubaguy> flip214: its open as of a few weeks back I think
14:28:46 <n0ano> are we going to setup an etherpad for session topics at Vancouver?
14:28:51 <johnthetubaguy> there was an ML message from mikal on that
14:29:03 <johnthetubaguy> n0ano: yes we should start that soon
14:29:24 <johnthetubaguy> #action mikal to kick start etherpad for vancouver
14:29:28 <bauzas> johnthetubaguy: I was thinking that mikal was waiting the new PTL election ?
14:29:37 <flip214> johnthetubaguy: so, is it a good idea to push the blueprint right now?
14:30:02 <flip214> with the same ID as the one for K? I believe that one's abandoned, so generating a new one might be better.
14:30:06 <edleafe> when is the PTL election?
14:30:17 <dansmith> soonish
14:30:31 <johnthetubaguy> oh, true
14:30:47 <johnthetubaguy> April 10 - April 16: PTL elections
14:30:50 <bauzas> edleafe: https://wiki.openstack.org/wiki/PTL_Elections_April_2015
14:30:54 <johnthetubaguy> #link https://wiki.openstack.org/wiki/PTL_Elections_April_2015
14:30:55 <anteaya> flip214: http://lists.openstack.org/pipermail/openstack-dev/2015-March/058107.html
14:30:59 <bauzas> eh
14:31:03 <johnthetubaguy> lol, thats covered then
14:31:05 <mriedem> mikal doesn't need to be PTL to create an etherpad for summit topics...
14:31:12 <sahid> johnthetubaguy: yes ahaha
14:31:23 <flip214> anteaya: thank you.
14:31:24 <n0ano> mriedem, +1, that's awfully late to start the discussion
14:31:26 <anteaya> flip214: welcome
14:31:30 <johnthetubaguy> mriedem: +1 but I know he doesn't like to overstep his mark
14:31:38 <flip214> is there a "previously-approved-in-paris" tag, too?
14:31:40 <mriedem> jogo can start it then :)
14:31:42 <johnthetubaguy> OK… seems like we are done for today
14:31:50 <johnthetubaguy> happy bug fixing time to all
14:32:03 <johnthetubaguy> #info please look out for RC1 critical bugs
14:32:08 <johnthetubaguy> one thing I forgot...
14:32:16 <johnthetubaguy> we need to find bugs that will stop us release kilo
14:32:25 <johnthetubaguy> and ideally target them for RC1, etc
14:32:28 <bauzas> johnthetubaguy: are we beginning to tag bugs for RC1 ?
14:32:29 <bauzas> meh
14:32:32 <mriedem> https://launchpad.net/nova/+milestone/kilo-3
14:32:49 <mriedem> https://launchpad.net/nova/+milestone/kilo-rc1
14:33:06 <mriedem> there are 3 bugs in rc1 tag already
14:33:13 <bauzas> mriedem: good point, we should defer those unimplemented bugs to rc1
14:33:33 <mriedem> well, or see if they are really stopship bugs
14:33:35 <johnthetubaguy> mriedem: yeah, just looking at kilo-3 bugs, we have some critical i didn't notice befrore :S
14:33:51 <johnthetubaguy> can folks just check if any should block kilo-3
14:33:59 <bauzas> mriedem: well, that's bug fixing time, not yet RC dance right ?
14:34:20 <bauzas> mriedem: I was thinking that only criticals were acceptable for RC2+
14:34:26 <bauzas> but RC1 is pretty free, nope
14:34:28 <bauzas> ?
14:34:37 <johnthetubaguy> bauzas: still need to spot the release critical ones, and target them for RC1
14:34:40 <mriedem> right
14:34:45 <mriedem> you shouldn't go into rc expecting rc2
14:34:55 <mriedem> if you hvae known critical bugs, they should be targeted for rc1
14:34:59 <johnthetubaguy> technically, we just rc1 when there are no bugs targeted for rc1
14:34:59 <mriedem> assuming rc1 is the final
14:35:06 <johnthetubaguy> mriedem: +100
14:35:09 <bauzas> what about low bugs ?
14:35:15 <mriedem> i've had this fun conversation internally many times
14:35:18 <johnthetubaguy> bauzas: don't target them
14:35:41 <bauzas> johnthetubaguy: ok, then we drop the target of those if they were k3
14:36:21 <johnthetubaguy> bauzas: thats my next task, untarget stuff people have targeted to k3, but didn't have to
14:36:32 <bauzas> okay
14:37:08 <johnthetubaguy> OK, so are we done now?
14:37:24 <johnthetubaguy> as always, any release-y questions, feel free to ping my and ask
14:37:28 <johnthetubaguy> thanks all
14:37:33 <johnthetubaguy> happy bug fixing
14:37:37 <johnthetubaguy> #endmeeting