21:00:47 <vishy> #startmeeting nova
21:00:48 <openstack> Meeting started Thu Sep 20 21:00:47 2012 UTC.  The chair is vishy. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:49 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:50 <openstack> The meeting name has been set to 'nova'
21:00:51 <markmc> yo
21:01:10 <vishy> #link http://wiki.openstack.org/Meetings/Nova
21:01:29 <vishy> anyone else here?
21:01:41 <eglynn> o/
21:01:42 <vishy> ttx, markmc: looks like it is just us :)
21:01:48 <vishy> oh and eglynn
21:01:48 <jog0> o/
21:01:55 <annegentle> o/
21:01:59 <mikal> Hi
21:02:00 <vishy> hi y'all
21:02:03 <russellb> hi
21:02:05 <annegentle> yo yo
21:02:14 <markmc> that's more like it :)
21:02:17 <vishy> #topic folsom-rc-potential buglist
21:02:23 <ewindisch> hi
21:02:45 <vishy> #link https://bugs.launchpad.net/nova/+bugs?field.tag=folsom-rc-potential
21:02:54 <ttx> anything in there that must absolutely be in folsom ?
21:03:00 <vishy> so a few of these are kinda nasty
21:03:25 <vishy> the 4 high ones especially
21:03:37 <vishy> IMO, they are important enough to justify rc-2
21:03:44 <ttx> vishy: I think it's safe to do a RC2 at this point... just need to start being more picky about safe fixes / high impact
21:04:18 <ttx> also, I would like to see some coordination around bug 1050359 and bug 1053364: either fix them everywhere or nowhere in Folsom
21:04:19 <uvirtbot> Launchpad bug 1050359 in cinder "Tests fail on 32bit machines (_get_hash_str is platform dependent)" [Medium,In progress] https://launchpad.net/bugs/1050359
21:04:21 <uvirtbot> Launchpad bug 1053364 in quantum "Add SIGPIPE handler to subprocess execution in rootwrap and utils.execute" [Medium,Fix committed] https://launchpad.net/bugs/1053364
21:04:35 <vishy> going to untarget the first one
21:04:38 <vishy> not worth it
21:04:53 <vishy> going to untarget bug 1052252 as well
21:04:53 <uvirtbot> Launchpad bug 1052252 in nova "Migration 90 removes foreign keys but does not re-add them" [Medium,In progress] https://launchpad.net/bugs/1052252
21:05:26 <ttx> vishy: this last one sounds nasty by its description, but you downgraded its importance ?
21:05:40 <ttx> I suppose it's not as deadly as it sounds
21:05:46 <vishy> no it is just one foreign key
21:05:50 <vishy> and things run fine without it
21:05:56 <ttx> ohai
21:05:59 <vishy> no reason to add a new db migration for it right now
21:06:00 <mikal> And John is working on it now IIRC
21:06:15 <ttx> yes, I'd like to avoid new db migrations now if we can :)
21:06:31 <ttx> what about the SIGPIPE stuff ?
21:06:44 <vishy> i think the sigpipe stuff is a nice to have
21:06:54 <vishy> since we don't know any specific issues it is causing yet
21:07:01 <markmc> the LibvirtHybridOVSBridgeDriver  and the auto-assigned floating IPs ones don't look crazy risky
21:07:08 <vishy> if we do rc2 it should go in
21:07:18 <vishy> imo
21:08:47 <markmc> the SIGPIPE thing would make me fairly nervous this late
21:09:00 <markmc> especially if we don't know of a specific serious issue it causes?
21:09:06 <vishy> markmc: I'm ok pushing sigpipe into grizzly + stable backport later
21:09:12 <ttx> markmc: sounds like something we can backport later
21:09:13 <vishy> that is probably the safe way to do it
21:09:23 <markmc> cool
21:09:30 <vishy> i will untarget
21:09:38 <ttx> lets remove folsom-rc-potential there as well
21:10:00 <vishy> removed
21:10:09 <vishy> anyone know any other bugs that have been missed?
21:10:18 <vishy> I just picked up the only one that didn't have a patch in
21:10:20 <jog0> bug  1053041
21:10:22 <uvirtbot> Launchpad bug 1053041 in cinder "SolarisISCSIDriver does not work" [Medium,In progress] https://launchpad.net/bugs/1053041
21:11:01 <ttx> vishy: want me to open a folsom-rc2 window ? I think some of your Highs should be there
21:11:15 <vishy> that is the next topic
21:11:52 <ttx> ok, lets see if we can remove more from the rc-potential list
21:12:08 <vishy> jog0: that fix looks harmless, is it going into cinder?
21:12:24 <vishy> ttx: refresh i just pulled 3
21:12:45 <jog0> vishy: not sure, you will have to sync with John on that
21:13:16 <markmc> O'm not sure I understand bug 1053441
21:13:16 <uvirtbot> Launchpad bug 1053441 in nova "Instances in vm state DELETED are preventing compute restart" [High,Fix committed] https://launchpad.net/bugs/1053441
21:13:21 <markmc> is it as serious as it sounds?
21:13:46 <vishy> jog0: ok I added to the list for now
21:13:53 <ttx> markmc: does bug 1053427 only affect nova, not cinder ?
21:13:54 <uvirtbot> Launchpad bug 1053427 in nova "solidfire volume driver's sf_allow_tenant_qos option is a boolean" [Medium,Fix committed] https://launchpad.net/bugs/1053427
21:14:15 <markmc> ttx, yes, fixed in cinder already
21:14:22 <ttx> oh, ok
21:14:33 <markmc> ttx, it's not worth rc2 for or anything
21:14:44 <markmc> ttx, just noticed when regenerating the sample config file
21:14:57 <markmc> which itself would be nice to have in folsom final, but  ...
21:15:07 <vishy> markmc: it looks like a case where the db and the host got out of sync
21:15:24 <vishy> markmc: because the compute host crashed during delete
21:15:44 <markmc> vishy, any reason to think it's a regression vs essex?
21:15:48 <ttx> heh, we should really be discussing folsom-rc2 first. We have fixes that are not worth respinning, but are safe enough to be included if we did respin
21:16:01 <vishy> markmc: it makes sense to skip attempting to sync states for instances if they are in deleting state
21:16:09 <markmc> given that it's a HP bug, it's probably an issue in essex too
21:16:29 <vishy> markmc: true do you think that means we should push it to grizzly
21:17:00 <vishy> ttx: I wanted to look at the bugs first, since we need to be familiar with the bugs to decide if we need a folsom-rc2
21:17:08 <markmc> vishy, right, issues that existed in essex aren't worth breaking folsom for at this late stage
21:17:17 <vishy> markmc: fair enough
21:17:25 <vishy> lets decide then
21:17:32 <ttx> yes, and we'll need to go back to it to target the ones that are appropriate :)
21:17:56 <markmc> well, we certainly don't have any release blockers IMHO
21:17:56 <vishy> #topic go/no-go on RC2
21:18:27 <ttx> well, I would be very surprised if that RC1 survived long... so better start a RC2 window early
21:18:30 <vishy> markmc: what about broken live migration with volumes
21:18:43 <vishy> markmc: that one seems pretty important to me
21:19:01 <markmc> this is check_for_export_parameter() thing?
21:19:17 <markmc> sorry, I must have misunderstood - thought you said "not worth it" earlier
21:19:19 * markmc looks again
21:20:24 <vishy> that is the only one that i would be upset shipping without
21:20:30 <ttx> markmc: in my mind, I'd like to go into "no more RCs unless a kitten gets killed" early next week. We still have one/two days to push extra fixes
21:21:10 <markmc> well, if there's even one "we really should fix this" and we have time, then we should go for it
21:21:20 <vishy> and i would prefer to get the other high's in
21:21:25 * markmc would like to see an uptodate nova.conf.sample shipped :)
21:21:31 <ttx> so if it's mostly things that already have fixes, I'm fine
21:21:37 <vishy> markmc yeah :)
21:22:01 <ttx> ok, let's do it, but be conservative in what we put in ?
21:22:11 <vishy> good by me
21:22:24 <vishy> markmc: I will untarget the deleted volumes fix
21:22:25 <sdague> yeh, it seems there should be time to do some in tree doc things. It wouldn't hurt to take a run at the man pages starts that were added as well.
21:22:32 <vishy> markmc: any way to mark it for backport yet?
21:22:41 <ttx> i.e. things htat already have fixes...
21:22:57 <vishy> doc fixes should be fair game until we actually ship rc2 imo
21:23:12 <markmc> vishy, I guess we don't have a folsom series to target it at, just tag with folsom-backport-potential
21:23:17 * markmc adds that to official tags
21:24:15 <ttx> vishy: adding to rc2 bugs that are already fixed in master, there is little risk of overflowing
21:24:36 <jog0> sdague: the version in the man pages should be bumped up
21:25:11 <ttx> vishy: if you ack I'll create the milestone so we can start playing targeting
21:25:30 <vishy> ack
21:26:19 <vishy> ok next topic
21:26:32 <vishy> #action ttx to open RC-2
21:26:40 <ttx> https://launchpad.net/nova/+milestone/folsom-rc2
21:26:41 <vishy> #topic sample testing path
21:26:57 <ttx> go wild
21:26:57 <vishy> so we got a lot of the sample tests in but there are a bunch more to go
21:27:13 <vishy> I want to discuss where they should go.
21:27:38 <vishy> The issue is that we may be adding new extensions during the grizzly release and potentially be improving/adding to existing extensions
21:28:11 <vishy> but i think api.openstack.org should be for the current release
21:28:16 <vishy> as opposed to trunk
21:28:28 <russellb> so api.openstack.org could just pull from stable/folsom then?
21:28:33 <vishy> so in that sense it makes sense to generate them from stable/folsom
21:28:38 <russellb> and just backport additions that are applicable
21:28:43 <vishy> but then we have to backport stuff into stable/folsom
21:28:56 <sdague> is there a way to version api.openstack.org? so you could see stable as well as head?
21:28:57 <vishy> the question is is that ok? they are just tests and docs
21:29:13 <russellb> sdague: yeah, that'd be even better
21:29:14 <annegentle> sdague: hm. thinking.
21:29:25 <markmc> question is whether backporting api tests to folsom is ok?
21:29:30 <vishy> sdague: I think we could do that. The question is more about whether it is ok to backport api_sample_tests to folsom
21:29:33 <vishy> markmc: right
21:29:37 <sdague> api.openstack.org/folsom api.openstack.org/grizzly, and a redirect from the default
21:29:41 <russellb> just tests, seems fine to me
21:29:47 <annegentle> honestly originally api.openstack.org always tracked try stack, unfortunately that's not panning out :)
21:29:49 <russellb> that shouldn't risk breaking the code :-)
21:29:51 <markmc> we're doing it for a good reason, I don't see why not
21:30:14 <vishy> markmc: ok I just wasn't sure it fit perfectly with the definition of stable-maint
21:30:25 <markmc> vishy, it doesn't exactly :)
21:30:33 <markmc> vishy, but updating the docs is a good reason
21:30:39 <sdague> there shouldn't be any impact, they are also helpful in nailing down behavior, to figure out if things actually changed in the way they worked from folsom to grizzly
21:30:47 <vishy> in that case I will merge any of those are completed by rc2 in as well
21:30:59 <vishy> and port all of them over to api.openstack.org
21:31:14 <vishy> btw if anyone wants to help with the porting I would love it :)
21:31:14 <markmc> sounds good
21:31:30 <annegentle> This patches api.openstack.org with the tested samples: https://review.openstack.org/#/c/13201/
21:31:31 <sdague> vishy: I thought annegentle push a big chunk the other day
21:31:34 <vishy> basically copying files over and updating the wadl's with any broken params
21:31:50 <annegentle> however in the actual bringing them over I'm finding there are far more samples than api.openstack.org actually presents to users
21:31:50 <vishy> annegentle: you are a superstar!
21:32:05 <annegentle> why thank you. But but but… not sure what to do with all the awesome samples.
21:32:11 <vishy> annegentle: yes we need to add more sections to the wadls
21:32:25 <vishy> annegentle: I don't think there are any for xml stuff in the extensions for example
21:32:33 <annegentle> I do get a drop down list, I wonder if something like the "create server" section could just have a bunch in the drop down?
21:32:44 <annegentle> yeah that patch only does core also, doesn't touch extensions yet
21:33:15 <sdague> vishy: so one thing I was always confused about on api.openstack.org, there really isn't any documentation on error returns for api calls. And samples doesn't really address that. How do we get that added in in the future
21:33:41 <vishy> sdague: I'm not sure about that, I think there is data in some of the wadl's about that
21:33:57 <sdague> ok
21:34:14 <vishy> just getting the happy path stuff in first will be a huge + but there is a lot of room to continue to improve
21:34:26 <vishy> sdague: we really need someone to drive this from a tech side
21:34:32 <annegentle> sdague: yeah I've been tracking that omission in this bug https://bugs.launchpad.net/openstack-manuals/+bug/975232
21:34:33 <uvirtbot> Launchpad bug 975232 in openstack-manuals "Need response codes displayed on api.openstack.org" [Medium,Triaged]
21:34:35 <annegentle> but no one has picked it up
21:34:48 <ttx> vishy, off-topic, but for bug 1053041 you should coordinate with jgriffith: either in both or in none ?
21:34:52 <uvirtbot> Launchpad bug 1053041 in cinder "SolarisISCSIDriver does not work" [Medium,In progress] https://launchpad.net/bugs/1053041
21:34:55 <vishy> sdague: so if you want to come up with a plan and recruit help at the summit
21:35:01 <annegentle> sdague: also would like navigation for these LONG lists tracked with
21:35:02 <annegentle> https://bugs.launchpad.net/openstack-manuals/+bug/1039163
21:35:03 <sdague> vishy: yeh, that might be an option
21:35:03 <annegentle> and
21:35:03 <uvirtbot> Launchpad bug 1039163 in openstack-manuals "api.openstack.org needs permalinks to individual items" [Wishlist,Confirmed]
21:35:08 <annegentle> https://bugs.launchpad.net/openstack-manuals/+bug/980228
21:35:09 <vishy> ttx: yes I put rc-potential so I wouldn't lose it
21:35:09 <uvirtbot> Launchpad bug 980228 in openstack-manuals "Need anchor tags for headings built on api.openstack.org so pointers can be more exact" [Low,Confirmed]
21:35:14 <vishy> was going to ping him after
21:35:17 <sdague> I won't sign up quite yet, but don't let me forget about it :)
21:35:20 <annegentle> if you know people who'd like to work on it I can certainly connect
21:35:22 <jgriffith> ttx: I was planning it for RC2
21:35:40 <ttx> jgriffith: ok, then should also be in nova rc2
21:35:45 <vishy> the anchor tags thing looks pretty simple
21:36:00 <vishy> and it would definitely help
21:36:04 <annegentle> vishy: for sure
21:36:14 <vishy> we are getting a little off topic though
21:36:18 <vishy> lets move on
21:36:38 <vishy> #action api samples to be backported to stable to improve documentation
21:36:55 <vishy> #topic release notes
21:37:55 <ttx> http://wiki.openstack.org/ReleaseNotes/Folsom
21:38:20 <vishy> thanks i was looking for that
21:38:24 <vishy> #link http://wiki.openstack.org/ReleaseNotes/Folsom
21:38:36 <vishy> so I would love some help writing this
21:38:54 <vishy> I think we should put it in an etherpad so we can all work on it
21:39:14 <jgriffith> +1 on etherpad
21:39:37 <vishy> #link http://etherpad.openstack.org/nova-folsom
21:40:00 <vishy> I will add all relevent data I have today and tomorrow
21:40:14 <vishy> but anyone who has input please help so we can make them as complete as possible
21:40:29 <vishy> #topic open discussion
21:40:37 <vishy> anyone have anything else?
21:40:52 <ttx> vishy: targeted bug 1053041 to rc2
21:40:53 <uvirtbot> Launchpad bug 1053041 in nova "SolarisISCSIDriver does not work" [Medium,In progress] https://launchpad.net/bugs/1053041
21:40:55 <sdague> vishy: I'll pop over tomorrow and take a look
21:41:04 <ttx> vishy: since jgriffith added to to his
21:41:13 <vishy> ttx: great thanks
21:41:24 <ttx> vishy: wil let you pick the other ones
21:41:38 <ttx> and will help with the backporting tomorrow
21:41:52 * ttx goes to sleep
21:42:19 <vishy> ttx: thanks
21:42:25 <vishy> ok sounds like we are done
21:42:38 <vishy> thanks everyone!
21:42:42 <vishy> #endmeeting nova