21:00:47 <vishy> #startmeeting nova
21:00:48 <openstack> Meeting started Thu Aug 23 21:00:47 2012 UTC.  The chair is vishy. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:49 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:50 <openstack> The meeting name has been set to 'nova'
21:01:06 <maoy> helo
21:01:14 <vishy> #topic http://wiki.openstack.org/Meetings/Nova
21:01:30 <markmc> yo
21:01:34 <vishy> #topic Role Call
21:01:43 <ttx> ~o
21:01:55 <vishy> #link Agenda: http://wiki.openstack.org/Meetings/Nova
21:02:07 <dansmith> here
21:02:11 <markmc> o~~~>
21:02:18 <vishy> the topic setting seems to be broken :(
21:02:32 <markmc> wow, someone can't spell cinder :)
21:02:46 <vishy> #info Attendeees: maoy, dansmith, markmc, ttx
21:03:00 <jk0> o/
21:03:03 <dprince> hello
21:03:22 <vishy> #info Atendees: jk0, dprince
21:03:35 <vishy> lol i can't spell attendees
21:03:38 <vishy> lets try that again
21:04:01 <vishy> #info Attendees: vishy, maoy, dansmith, markmc, ttx, jk0, dprince
21:04:11 <vishy> #topic FFE for Entry Points
21:04:21 <vishy> I think this was mostly hashed out on the list
21:04:28 <ttx> vishy: the meeting report will mention everyone that spoke at least a line... so rollcall is not that useful :)
21:04:29 <vishy> looks like everyone is ok deferring to grizzly
21:04:43 <markmc> yeah
21:04:46 <vishy> ttx: good to know, I will skip it in the future :)
21:04:49 <ttx> yes, looks like everyone agrees it could wait
21:04:58 <vishy> I do like to know who is here.
21:05:09 <markmc> I'm actually really looking forward to digging into it more
21:05:17 <vishy> #info Entry Points will be deferred to Grizzly
21:05:25 <markmc> but I think it would benefit from a good big of discussion/thought
21:05:32 <ttx> vishy: I think someone mentioned it could use a summit discussion
21:05:36 <markmc> s/big/bit/
21:05:48 <vishy> #action summit discussion needed for entry points
21:05:53 <ttx> around general usage of entry point vs. config for some things
21:06:06 <vishy> mtaylor: you ok proposing that session?
21:06:27 <ttx> I think Monty is out of town
21:06:38 <vishy> well he can do the action anyway :p
21:06:46 <ttx> action him!
21:07:05 <vishy> #action mtaylor to schedule summit discussion for entry points
21:07:21 <vishy> #topic Feature Freeze Progress
21:07:29 * vishy is scared that the bot is broken
21:07:36 <dansmith> yeah, it should be replying I think
21:07:41 <ttx> clarkb: ^
21:07:44 <vishy> #link https://blueprints.launchpad.net/nova/+spec/os-api-network-create
21:08:07 <vishy> #help need review on https://review.openstack.org/#/c/9847/
21:08:10 <markmc> so, I got the API issue sorted on that
21:08:15 <markmc> but never got around to final review
21:08:25 <markmc> will definitely do it tomorrow unless someone else gets in there
21:08:45 <vishy> #link https://blueprints.launchpad.net/nova/+spec/project-specific-flavors
21:09:02 <vishy> #help need review on https://review.openstack.org/#/c/11270/
21:09:10 <vishy> both of those just need another reviewer
21:09:10 <ttx> vishy: we should probably communicate about nova-manage once that merges
21:09:25 <vishy> ttx: agreed, lets discuss nova-manage next week
21:09:43 <vishy> #topic Bug Triage Plan
21:10:00 <vishy> so we are supposed to come up with a plan to get the untriaged bugs down to 0
21:10:09 <markmc> ttx and I did 20 each :)
21:10:10 <ttx> markmc proposed 5 people take 20
21:10:14 <ttx> I did too :)
21:10:20 <vishy> there aren't really enough nova-core members here
21:10:29 <vishy> #action vishy to triage 20 new bugs
21:10:36 <vishy> who else can volunteer
21:10:37 <markmc> we're down to ~60 or so
21:10:39 <ttx> we are at 67
21:10:49 <lifeless> How triaged do they need to be?
21:10:49 <markmc> I'll do another 20 sometime next week
21:10:58 <dprince> I'll take some
21:11:01 <vishy> #link https://bugs.launchpad.net/nova/+bugs?search=Search&field.status=New
21:11:12 <vishy> #action dprince to triage 20 new bugs
21:11:16 <dansmith> I can try, I'm just always worried about properly representing the core team's feelings on things :)
21:11:16 <dprince> 20 seems abit ambitious for a slacker like myself though
21:11:21 <markmc> lifeless, moved from new -> confirmed/incomplete/invalid and priority assigned
21:11:23 <ttx> lifeless: step 1 and 2 from http://wiki.openstack.org/BugTriage
21:11:41 <vishy> #action markmc to triage 20 (more) new bugs
21:11:50 <vishy> that should get us almost empty
21:12:01 <vishy> we still have lots of bug fixing to do
21:12:15 <dprince> So just to be clear triage means assign the status, confirmed, etc.
21:12:25 <markmc> yep
21:12:27 <vishy> dprince: correct
21:12:28 <lifeless> ok cool; thats much saner than other triage processes I've seen; thanks.
21:12:33 * dprince does lots of fixing... not so much triaging though.
21:12:43 <dprince> Ah. Cool. That'll be quick then.
21:12:47 <vishy> usually i find 2 or 3 to fix while I'm triaging
21:12:51 <vishy> which slows me down :(
21:13:02 * markmc tried to avoid that
21:13:14 <markmc> just stuck things on rc1 target so I could come back to them later
21:13:21 <vishy> markmc: that is probably wise. In the future I will just assign myself or something
21:13:21 <dprince> ditto. Hard to keep focus where there is so much good stuff in there.
21:13:29 <markmc> probably overzealous with targeting a bit, but easy to untarget
21:13:33 <vishy> #topic Critical Bugs
21:13:47 <ttx> dprince: it's mostly about separating things that are obviously not ready to be fixed, from things that certainly look like a valid bug
21:14:10 <ttx> dprince: and notice what looks like a crtitical/High issue
21:14:12 <dprince> ttx: thanks. That helps
21:14:22 <ttx> so that we can put it on release radar
21:14:32 <vishy> so i think we should all be targetting bugs to rc1 if they are really important
21:15:13 <markmc> is this not merged? https://bugs.launchpad.net/nova/+bug/1011852
21:15:14 <uvirtbot> Launchpad bug 1011852 in nova "Scheduler race condition" [High,In progress]
21:15:46 <dprince> It is.
21:15:53 <markmc> vishy, well, or low hanging fruit that would be nice to knock off before release
21:15:53 <ttx> setting to fixco
21:16:21 <vishy> #info target bugs to rc1 if they should be fixed for rc1
21:16:24 <vishy> #link https://launchpad.net/nova/+milestone/folsom-rc1
21:16:52 <vishy> markmc: right, low hanging fruit can have a lower importance.
21:17:10 <vishy> it looks like there are a few there that are high but have no one assigned
21:17:14 <dprince> So I found a couple tickets related to dns_domains. Kind of a niche feature... but our default 'driver' is confusing people I think. I'd like to get that in if you guys buy it.
21:18:52 <markmc> dprince, just target them at rc1 IMHO, it'll get untargetted later if it's not getting done and we decide it's not critical
21:19:15 <vishy> dprince: links to bugs
21:19:19 <dprince> markmc: soundgs good.
21:19:32 <ttx> yes, the RC1 buglist is a worklist, we'll add more and remove some in the next week(s)
21:19:32 <vishy> markmc: I do have thing i'd like to discuss in this section
21:20:05 <vishy> #link https://review.openstack.org/#/c/10936/
21:20:27 <vishy> it got approved but i notice smokestack hasn't commented on the patchsets
21:20:47 <vishy> dprince: just want to make sure the patch works with postgres
21:20:58 <dprince> vishy: ack. action me
21:21:01 <markmc> wow, that's a whole lot of +2s
21:21:02 <maoy> seems there are duplicated version numbers
21:21:10 <vishy> yes it needs a rebase
21:21:15 <vishy> and fix of version numbers
21:21:16 * ttx disappears
21:21:25 <vishy> #action dprince to verify https://review.openstack.org/#/c/10936/ works on postgres
21:21:36 <dprince> vishy: cool. will look at it.
21:22:03 <vishy> there is one other mysql related change
21:22:35 <vishy> ah nm, it is going to wait until grizzly: https://review.openstack.org/#/c/10797/
21:22:54 <vishy> any other critical bugs that people need to discuss?
21:23:17 <dprince> Nothing specific. Last week I ran the full suite of Tempest and lots of tests are failing.
21:23:22 <dansmith> heh
21:23:24 <markmc> this one - https://bugs.launchpad.net/bugs/1039665
21:23:25 <uvirtbot> Launchpad bug 1039665 in nova "Creating quantum L2 networks (without subnets) doesn't work as expected" [High,Confirmed]
21:23:37 <vishy> dprince: yes it looks like tempest could use some serious help.
21:23:41 <markmc> seems there's some confusion about how to use quantum with nova in folsom
21:23:44 <dprince> I'm pretty sure there are some valid issues in there... just haven't had a change to file them all.
21:23:51 <markmc> am I missing docs, or ... ?
21:24:10 <dprince> I'm going to try to look into some of them this week. Or weekend maybe.
21:24:13 <markmc> strikes me that since quantum is becoming core in folsom, we should be all over it
21:24:30 <dansmith> markmc: docs are for lightweights, didn't you know?
21:24:51 <vishy> markmc: yes that is interesting, didn't know that we still used legacy nw info in libvirt
21:25:02 <markmc> dansmith, absolutely :)
21:25:34 <dansmith> heh
21:26:02 <markmc> vishy, I guess I'm saying that it feels like we expect the quantum folks to worry about the integration
21:26:07 <devananda> vishy: re: 10797, there are a few folks who would like it in Folsom, but unless I figure out why it's not working in the next day, it'll be a few weeks before I can do any more on it.
21:26:09 <markmc> rather than nova-core folks generally poking at it
21:26:17 * markmc admits he hasn't played with it much
21:26:21 <vishy> markmc: I think that has been true
21:26:36 <vishy> i was just going to suggest making an email to the list asking for quantum people to verify
21:27:15 <vishy> devananda: I would love it for performance, but it sounds like it is too slow/late so we might have to consider backporting it from g once we can verify it for a while
21:27:40 <markmc> dprince, quantum's on your todo list for smokestack, right? think I remember you saying that
21:28:02 <dprince> markmc: Yessir. It is one of the things up next.
21:28:10 <markmc> dprince, awesome
21:28:20 <vishy> markmc: short term can you email danwendlandt about that bug so they can help us solve it?
21:28:22 <dprince> markmc: To really make use of it I need full linux net support.
21:29:01 <markmc> vishy, will do, although dan's a bit busy right now :)
21:29:09 * markmc will include garyk
21:29:27 <vishy> i'm sure, i just want to make sure someone can look at it who has a chance of a quick fix
21:29:46 <vishy> #action markmc to send an email about https://bugs.launchpad.net/bugs/1039665
21:29:47 <uvirtbot> Launchpad bug 1039665 in nova "Creating quantum L2 networks (without subnets) doesn't work as expected" [High,Confirmed]
21:30:09 <vishy> #topic XML Support in Nova
21:30:22 * dansmith gulps
21:30:25 <vishy> this seems to be moving kind of slowly
21:30:28 <vishy> dansmith: go
21:30:39 <dansmith> so, we have 17 changes queued against tempest right now
21:30:47 <dansmith> as identified, tempest has been a bit sick lately
21:30:58 <dansmith> david added some skips that helped free it up for the most part
21:31:09 <dansmith> however, I think with jaypipes out, we're lacking a lot of review muscle
21:31:15 <dansmith> Daryl tentatively approved the approach,
21:31:27 <dansmith> then realized we were proposing running the JSON and XML tests on every run
21:31:31 <dansmith> which is what jaypipes wanted
21:31:36 <dansmith> and isn't in favor of that
21:31:53 <dansmith> so, hopefully we can satisfy that concern with some strategically-placed skips and a flag or something
21:32:11 <dansmith> but I'm certainly in favor of testing the stuff we claim to be testing as often as possible
21:32:24 <dansmith> so anyway, we're getting pretty close to coverage on stuff that can be tested in nova I think
21:32:31 <dansmith> and have found three legit xml bugs I think,
21:32:41 <vishy> so IMO both api testing and api docs are really important for release
21:32:41 <dansmith> one filed and closed, two more almost ready for that
21:33:09 <vishy> markmc: has been cleaning up config samples which is also really helpful
21:33:25 <dansmith> also thing we found an issue in nova-volume that wasn't cropping up with regular tempest but that we see when we run both because of a fast create/delete/create thing with similar names/ids
21:33:31 <vishy> but we need openstack to be easier to install and easier to build stuff on.
21:34:10 <vishy> it seems like this tempest stuff is useful
21:34:14 <annegentle> yeah appreciate that markmc and the DocImpact flags, super helpful
21:34:22 <vishy> but I don't know how to unblock dansmith with jaypipes out of town
21:34:28 <vishy> thoughts?
21:34:40 <markmc> annegentle, np :)
21:34:42 <dansmith> find jaypipes, make him come home? :)
21:34:54 <dprince> someone else on core Tempest should just push them in.
21:35:03 <dprince> dansmith: who else is Tempest core?
21:35:12 <markmc> that's what I'm trying to figure out :)
21:35:19 <dansmith> mtaylor, jeblair, davidkranz, ...
21:35:37 <dansmith> https://launchpad.net/~openstack-qa-core
21:35:44 <dprince> dansmith: I think if you explain it to Daryl he'll rubber stamp approve them.
21:35:47 <dansmith> blamar, bcwaldon
21:35:59 <dansmith> dprince: well, I did, and he said he didn't agree with jaypipes
21:36:12 <dansmith> https://review.openstack.org/#/c/11411/
21:36:18 <dansmith> I understand his concern, of course,
21:36:22 <dprince> dansmith: we can get blamar and bcwaldon to jump in.
21:36:36 <dansmith> and if you really don't care about XML, hiding them in a corner is legit :)
21:36:36 <vishy> are they in core also?
21:36:39 * blamar jumps
21:36:40 <dansmith> dprince: okay, sweet
21:37:04 <dansmith> dprince: they may need more review, we've had very little, but we need *something*
21:37:10 <dansmith> 17 patches is a deep queue :)
21:37:34 <markmc> dansmith, meh, testing is for lightweights :)
21:37:41 <dansmith> haha
21:37:43 <vishy> #action blamar to unblock tempest queue!
21:37:50 <dprince> blamar: We need your help to review some Tempest branches sir.
21:37:57 <dansmith> well, I never add bugs, but I hear markmc  does, so.. testing is important
21:38:12 <dprince> blamar: also sounds like its time to recruite more Tempest core members too ;)
21:38:18 <vishy> dansmith: have you filed the xml bugs you've found?
21:38:41 <dansmith> vishy: the one that was obvious we have, I'll kick (gently) my team members that are holding the others to get them filed ASAP
21:38:41 <vishy> ok the other prong of our approach for xml testing is the api sample testing i'm doing in nova
21:38:53 <dansmith> they want to know the fix before filing, of course, but I'll push 'em
21:38:56 <vishy> I really need another approve here: https://review.openstack.org/#/c/11263/
21:39:13 <vishy> dansmith: if they just report the bug and assign themselves that is awesome
21:39:16 <dprince> vishy: I'm ready to approve that.. just one little question.
21:39:26 <vishy> dprince: what is it?
21:39:31 <markmc> dprince ... always with the questions
21:39:31 <maoy> vishy: I had the same question as dprice..
21:39:43 <dprince> vishy: Would it be nicer to have an environment variable for that global to turn it on/off.
21:39:45 <markmc> actually, an env variable is a good idea
21:39:47 <dansmith> vishy: yep, just timid, but we'll do it
21:39:59 <dprince> vishy: If you pop that in I think its a go.
21:40:01 <vishy> dprince: interesting thought on the env variable
21:40:09 <vishy> dprince: ok i will do that today
21:40:33 <markmc> vishy, will you also add a simple "how to re-generate" README to the api_samples dir?
21:40:34 <vishy> do env variables pass all the way through tox/run_tests? i guess we will find out
21:40:40 <markmc> should do, yeah
21:40:42 <vishy> markmc: sure
21:41:15 <vishy> #action vishy to switch the api sample testing to an env variable so it can get approved
21:41:28 <vishy> ok so once that is in, there are a bunch more api samples that need to be generated
21:41:56 <vishy> we need to hit the resto of the core apis and all of the extensions, and that is where I expect we will run into a bunch of xml bugs
21:42:03 <vishy> would anyone else like to help?
21:42:09 <markmc> vishy, will the docs folks pull these api samples into the docs?
21:42:22 <dansmith> vishy: I don't want to, no, but we'll start looking at those once we're done or completely blocked on the tempest stuff
21:42:39 <markmc> vishy, if you did up a todo list, might be easier to snarf some volunteers
21:42:48 <vishy> markmc: the plan is to pull them into manuals
21:42:53 <markmc> coolness
21:43:03 <vishy> markmc: and modify the wadls slightly so that they are used for api.openstack.org
21:43:39 <vishy> #action vishy to create an etherpad for work around api samples testing
21:43:42 * markmc refrains from snarking about wadls
21:44:07 <vishy> #topic Open Discussion
21:44:11 <vishy> anything else?
21:44:27 <maoy> i'd like get some help on lintstack!
21:44:28 <markmc> yes, I've just noticed it's easy to typo your name as virsh
21:44:33 <markmc> too confusing, please rename
21:44:38 <maoy> I mean reviews..
21:44:48 <dansmith> markmc: I typed "vishy list" at a prompt the other day
21:44:55 <maoy> https://review.openstack.org/#/c/11444/
21:44:56 * markmc sorry for distracting from maoy with silliness
21:45:06 <vishy> markmc: :)
21:45:11 <maoy> haha
21:45:25 <maoy> the ci team has been super helpful and efficient
21:45:32 <dprince> markmc: You can fix that you know. Just alias vishy='virsh' in your environment.
21:45:32 <maoy> the silent pipeline is already running
21:45:36 <vishy> maoy: so the lintstack stuff is just silently running atm?
21:45:41 <maoy> yes
21:46:00 <vishy> maoy: and your proposal turns it into a gate?
21:46:04 <maoy> but since the patch is not in, the silent test is always failing..
21:46:11 <maoy> not in a few months
21:46:25 <maoy> i propose to make it a FYI for checking
21:46:32 <maoy> and see how it goes..
21:46:36 <vishy> so this is just to enable the silent test?
21:46:40 <maoy> yes
21:46:59 <markmc> maoy, hmm, this HEAD~1 vs HEAD thing - how does that work out if a developer with uncommitted changes runs it?
21:47:22 <maoy> markmc: the checkout will abort
21:47:38 <markmc> and this runs if you just run 'tox' ?
21:47:51 <dansmith> vishy: https://bugs.launchpad.net/nova/+bug/1040891
21:47:52 <uvirtbot> Launchpad bug 1040891 in nova "XML formatting for volume metadata incorrect" [Undecided,New]
21:48:00 <vishy> maoy: should we add it to run_tests.py as well?
21:48:00 <dansmith> vishy: I was wrong, at least one of the other two is already filed
21:48:06 <maoy> that i'm not sure... i only use run_tests.sh and tox -e pylint
21:48:27 <dprince> Yes. run_tests.sh would be nice.
21:48:52 <maoy> vishy: now I prefer not to, because it actually checks out code so it might confuse people
21:48:53 <vishy> dansmith: nice, if that is being fixed, can you assign it to someone
21:48:59 <vishy> dansmith: also target it to cinder as well
21:49:11 <dansmith> vishy: okie
21:49:15 <vishy> maoy: why is it necessary to checkout code?
21:49:19 <maoy> because it first: git checkout HEAD~1, then git checkout $HEAD_COMMIT
21:49:42 <maoy> so it's no longer on any branch.
21:50:01 <vishy> maoy: is it comparing errors from current branch to previous commit?
21:50:02 <maoy> vishy: because I think maintaining an exception file is a bad idea for silent mode..
21:50:07 <maoy> vishy: exactly
21:50:28 <vishy> maoy: interesting. Well I don't have a problem with it going in for silent testing
21:50:33 <maoy> vishy: this way there is no need to maintain the exception file
21:51:29 <vishy> maoy: so it only runs with tox -epylint
21:51:36 <vishy> or a full run of tox
21:51:37 <vishy> yes?
21:51:38 <maoy> yes
21:51:44 <vishy> seems fine to me
21:51:56 <vishy> might as well try it out and see if it helps us find bugs
21:52:05 <maoy> good.
21:52:22 <vishy> ok anything else?
21:52:28 <dprince> not here.
21:52:36 <vishy> coolness
21:52:41 <vishy> #endmeeting nova