19:00:23 <shamail> #startmeeting nonatc
19:00:24 <openstack> Meeting started Thu May 26 19:00:23 2016 UTC and is due to finish in 60 minutes.  The chair is shamail. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:27 <openstack> The meeting name has been set to 'nonatc'
19:00:32 <shamail> Hi everyone
19:00:37 <dabukalam> hui
19:00:47 <MeganR> Hi
19:00:52 <maishsk> o/
19:00:58 <shamail> hi dabukalam, MeganR, and maishsk!
19:01:05 <shamail> #chair maishsk
19:01:05 <openstack> Current chairs: maishsk shamail
19:01:06 <maishsk> Sorry about last week - I was on a plane
19:01:13 * dabukalam was also on a plane
19:01:21 <shamail> today’s agenda:
19:01:23 <shamail> #link https://wiki.openstack.org/wiki/NonATCRecognition#Meeting_Information
19:01:40 <dc_mattj> hello
19:01:45 <shamail> np maishsk and dabukalam
19:01:46 <dabukalam> dc_mattj: hi!
19:01:48 <dc_mattj> sorry was lurking elsewhere
19:01:49 <shamail> hi dc_mattj
19:02:08 <shamail> #topic UC Charter Progress
19:02:41 <shamail> Edgar presented a draft charter for the User Committee earlier this week in the user-committee meeting.
19:02:44 <shamail> #link https://docs.google.com/document/d/1QmLOeseAkjBWM_TXsUeKBErNaSHnuZp81II0T71ARfo/edit?usp=sharing
19:02:44 <dc_mattj> shamail, slightly better turnout than last time
19:02:47 <dc_mattj> ;)
19:02:58 <shamail> a bit dc_mattj!
19:03:25 <shamail> The UC is still looking for feedback so please add comments in the doc as you see fit.
19:03:54 <dc_mattj> looks great
19:04:00 <shamail> Specifically related to this WG, they have included the roles/activities from our milestone-2 read-out
19:04:07 <maishsk> shamail: leave feedback here / or on the doc?
19:04:20 <shamail> maishsk: on the doc
19:04:50 <shamail> I agree dc_mattj, it’s coming together well.
19:05:46 <shamail> One of the items they will revisit in the near-term future are AUC benefits/rights but they have already included how to become a consitituent which is a great starting point.
19:06:19 <shamail> Any questions on this topic?  I wanted to share with everyone in case you missed it earlier in the week
19:06:37 <shamail> #topic WG name change
19:07:10 <maishsk> none from me
19:07:16 <shamail> On a related note, I wanted to propose changing the WG name to “AUC Recognition WG” from “Non-ATC Recognition WG” since we have the designation identified in the charter
19:07:38 <dabukalam> shamail: that would make me very happy
19:07:46 <dc_mattj> shamail, +1
19:07:50 <MeganR> +1
19:07:54 <maishsk> I for one am really for this - at the time the only thing we had was non-ATC (which has a negative sound to it)
19:08:02 <maishsk> so a +1 from me
19:08:39 <shamail> #agree WG will be renamed to AUC (Active User Contributor) Recognition WG
19:08:55 <shamail> It feels good to get rid of the negative sounding name :)
19:09:06 <maishsk> And so the AUC is born !! :)
19:09:23 <maishsk> Mazel Tov!
19:09:24 <shamail> #action shamail will update wiki, eavesdrop, etc. to rename WG from Non-ATC to AUC
19:09:36 * shamail cheers
19:09:50 <shamail> #topic Review milestone-3 action item status
19:10:32 <shamail> The next item is to review progress on identifying metrics (and capturing them) for various consitituency roles
19:10:49 <shamail> We will just go in order based on the agenda
19:10:54 * maishsk goes and hides in a corner
19:10:58 <shamail> lol
19:11:00 <shamail> Metrics for user group organizers (shamail)
19:11:09 <maishsk> (I have not followed up on any of my AI’s)
19:11:23 <dc_mattj> so for user groups this is now a solved problem right ?
19:11:39 <dc_mattj> since things have moved forward with the 'official' groups ?
19:12:28 <shamail> I spoke with fifieldT and he said the the user group oragnizers and contributors can not be queried via API at this point in time
19:12:42 <dabukalam> right, are we doing just official groups, or official groups that have been active in the last 6 months. ISTR discussion of activity as well?
19:12:44 <shamail> therefore I will get a list from him (for this cycle) once we are ready
19:12:57 <shamail> dc_mattj: I did not know that, can you please tell us more?
19:13:08 <shamail> They have defined the “official” ones now?
19:13:38 <dabukalam> the foundation has designated a few of the 100 or so groups as official based on various metrics and goals meetups should strive to deliver on
19:13:49 <dc_mattj> what he said ^
19:13:57 <dabukalam> https://groups.openstack.org/groups in that list all the groups highlighted red
19:14:16 <maishsk> dabukalam: how was that designation decided?
19:14:16 <dabukalam> you can also select using the filters on the left
19:14:24 * dabukalam finds link
19:14:25 <shamail> thanks dabukalam and dc_mattj
19:14:54 <shamail> Based on that, we would only recognize 12 user groups?
19:14:56 <dabukalam> maishsk: https://groups.openstack.org/official-group-process is the current criteria I believe
19:15:07 <dc_mattj> again what he said ^
19:15:37 <dabukalam> shamail: It depends, many groups just have little niggly bits they have to fix to become official, so I expect more and more to become official this cycle now that it's been announced
19:15:38 <shamail> I think for this cycle we should stay with including all groups since the criteria for official groups was just defined
19:15:41 <dc_mattj> I think basically this was supposed to be driven by the ambassadors, and it's taken a while
19:15:46 <maishsk> shamail: so how do get to 12 users groups?
19:15:53 <shamail> and then we can define it as official group in the next few cycles?
19:16:03 <dc_mattj> more and more of them will hopefully sort it out now
19:16:10 <shamail> go to groups.openstack.org, click on groups at the top, and then filter on “official groups”
19:16:22 <dabukalam> shamail: I don't think that will help with encouraging usergroups to follow official process
19:16:44 <shamail> For example, I didn’t see Manchester on there :[
19:16:49 <dabukalam> part of the reason for this announcement was to try to force the community to follow official openstack guidelines rather than doing a bunch of random stuff and calling it "an openstack meetup"
19:16:52 <dabukalam> shamail: it is there!
19:16:57 <dc_mattj> we are one of them
19:16:59 <shamail> hmm
19:17:01 <dc_mattj> one of the first ones
19:17:01 <shamail> under official?
19:17:01 <maishsk> And I dont see the Israel one there either
19:17:07 <shamail> I must be sorting incorrectly
19:17:18 <dc_mattj> tick the official box
19:17:24 <dc_mattj> then you get the list
19:17:24 <shamail> #link https://groups.openstack.org/groups?status[]=official
19:17:41 <dc_mattj> indeed
19:17:48 <shamail> Oh, interesting..
19:17:55 <shamail> Manchester did not show up for me
19:18:02 <shamail> When I ran the search for Europe + Official
19:18:04 <shamail> then it did
19:18:21 <shamail> Now its refreshed
19:18:28 <shamail> and shows up properly on the main page for me
19:18:51 <shamail> I guess I will ensure that I validate the list I see with Tom for official WGs
19:19:03 <shamail> maishsk: I don’t see Israel there either
19:19:13 <maishsk> It is not an official
19:19:39 <shamail> Anyway, so do we believe that now that we have criteria for official that we should start supporting official starting with this cycle?
19:19:45 <dc_mattj> +1
19:19:54 <dabukalam> yes
19:19:56 <dc_mattj> there is clear guidance and process on how to do that
19:20:01 <MeganR> yes
19:20:22 <maishsk> The criteria are there - I just hope there are enough ambassadors around to cope with all the groups
19:20:23 <shamail> #agree Change criteria to “official user groups”
19:20:31 <maishsk> +1
19:20:46 <shamail> Okay, next one:
19:20:49 <shamail> Metrics for WG participants (MeganR)
19:21:08 <MeganR> Sorry, I don't have an update - will for next week.
19:21:15 <shamail> Okay, thanks
19:21:19 <shamail> Metrics for Ops meetup moderators (maishsk)
19:21:24 <dc_mattj> didn't we talk about using IRC stats ?
19:21:28 <dc_mattj> for WG
19:21:46 <MeganR> not all WGs use IRC
19:21:51 <shamail> We did dc_mattj along with finding which WGs dont use IRC or how to account for them
19:21:58 <maishsk> no update on my AI’s - sorry
19:22:04 <shamail> MeganR: You can also use https://github.com/openstack/uc-recognition/blob/master/tools/get_active_wg_members.py as a starting point for the ones that do use IRC.
19:22:18 <shamail> Thanks maishsk
19:22:33 <shamail> Metrics for repository commits under UC governance (dabukalam)
19:22:40 <dc_mattj> Ops meetup moderators is fairly easy given there aren't many of them, it's currently difficult to do this automagically but we could easily do it manually
19:22:47 <MeganR> shamail: thank you!
19:22:48 <shamail> dc_mattj: +1
19:22:50 <maishsk> dc_mattj: +1
19:23:19 <dc_mattj> I'm in the WG for Ops Meetups and we can talk about how to make that data available
19:23:22 <dabukalam> shamail: so I think that one is relatively easy - base it off queried git commits, and decide whether one commit is enough or a certain x commits is required similar to the decision the TC made recently about ATC
19:23:26 <dc_mattj> currently it's a spreadsheet ;)
19:23:50 <shamail> That spreadsheet has lived on for generations of ops meetups, don’t change it!! (JK)
19:24:06 <dabukalam> I can't see many people submitting typos for recognition to the uc gov repo similar to how people get ATC currently, but who knows
19:24:09 <shamail> dabukalam: +1 that is reasonable
19:24:41 <maishsk> dabukalam: What decision was that?
19:24:46 <dc_mattj> shamail, :)
19:25:18 <shamail> I think you are right on the lower volume too dabukalam… therefore we might need to consider a lower required commit count
19:25:32 <shamail> lower than what ATC uses
19:25:40 <dc_mattj> shamail, +1
19:26:03 <dc_mattj> we want operators to contribute, and often it's far too easy to write stuff for you own env
19:26:11 <shamail> Also dabukalam, check this script out: https://github.com/openstack/uc-recognition/blob/master/tools/get_active_commiters.py
19:26:28 <dabukalam> maishsk: I think a typo patch into openstack no longer gets you a free summit pass
19:26:30 <shamail> dc_mattj: +1
19:26:56 <maishsk> dabukalam: when was that decided?
19:27:00 <shamail> I think the criteria is commits in two consecutive cycles will give you ATC
19:27:09 <shamail> ATC does not automatically qualify you for a free ticket
19:27:16 <shamail> I think that is the direction
19:27:44 <maishsk> shamail: that I knew was coming - but when was the ATC criteria changed?
19:27:54 <dabukalam> maishsk: the discussion at the board meeting was along the lines of, "we currently have 1200 active developers, but 2000 ATCs
19:28:11 <shamail> maishsk: not sure exactly when it was changed
19:28:19 <dabukalam> maishsk: I fail to remember if an action was taken there and then or was deferred
19:29:05 <shamail> dabukalam: the UC repo commits will be more than typos… it will be people contributing to OSOps, submitting user stories to the Product WG, etc.
19:29:08 <dc_mattj> can I suggest we don't rathole on this too much
19:29:11 <shamail> I am hopeful we will see a good count
19:29:14 <shamail> dc_mattj: +1
19:29:18 <dc_mattj> the criteria for AUC is different
19:29:25 <dc_mattj> we want ops to contribute code
19:29:42 <dc_mattj> and since the code base is currently so small it would be hard to get away with a typo fix
19:29:47 <dc_mattj> so slightly irrelevant
19:30:09 <shamail> Anythign else on this one dabukalam?
19:30:17 <dc_mattj> even a tiny bash script is a precious jewel at the minute ;)
19:30:17 <dabukalam> nope, relatively simple
19:30:27 <shamail> dc_mattj: :]
19:30:31 <shamail> next one...
19:30:32 <shamail> Metrics for summit track chairs (dabukalam)
19:30:42 <dc_mattj> ooh interesting
19:30:48 <dc_mattj> I missed the last meeting
19:31:02 <dc_mattj> so what's the metric here dabukalam ?
19:31:13 <dabukalam> so that's easy. anyone that's a track chair should be AUC - the summit before last they were listed on the track-chairs mailing list, last summit it was in an etherpad
19:31:34 <dabukalam> so we need to consolidate that info and get it to be in a central location that can be grepped
19:31:52 <shamail> dabukalam: I am not opposed to the criteria but should we specify all or certain tracks (not just operators only but a list)?
19:31:54 <dc_mattj> there's a track chair app, so we already have access to that info
19:31:59 <dc_mattj> from a metric perspective
19:32:06 <dabukalam> dc_mattj: ah yes, forgot about that
19:32:09 <shamail> dc_mattj: +1
19:32:20 <dabukalam> dc_mattj: unfair, you've been a track chair before :P
19:32:24 <dc_mattj> shamail, all track chairs should get this automatically, although almost all of them are probably ATC anyway
19:32:25 <dc_mattj> ;)
19:32:26 <shamail> dabukalam and dc_mattj: The foundation also creates a mailing list for track chairs
19:32:32 <dc_mattj> shamail, indeed
19:32:34 <shamail> so we could also just ask them for member list for the mailing list
19:32:40 <maishsk> shamail -  would we limit to certain tracks
19:32:56 <maishsk> *why would
19:33:08 <dabukalam> I don't see why we would limit to certain tracks, anyone that's taking the time to be a track chair is contributing positively in my view
19:33:12 <shamail> ah ok, I was curious
19:33:39 <dc_mattj> track chairs need to have a massively wide understanding of the commercial and technical landscape to be able to make judgements on presentations
19:33:48 <shamail> there are certain tracks that usually have more WG/users as track chairs (case studies, enterprise tracks, operators, community)
19:33:57 <dc_mattj> this is a no-brainer, and there's much smarter track chairs than I am
19:34:17 <shamail> I am perfectly fine with doing all track chairs, the workload is rather insane!
19:34:35 <shamail> I just wanted to bring up the option for discussion (in case we are asked by anyone else)
19:34:39 <MeganR> will we compare our list with the ATC list and then remove those that have an ATC designation?
19:34:45 <shamail> MeganR: Nope
19:34:53 <dc_mattj> shamail, and not just the workload, it's also more about understanding the field, it's not a box ticking exercise
19:34:58 <shamail> A person could be both AUC and ATC
19:35:12 <maishsk> shamail: +1
19:35:21 <MeganR> shamail: just what I was about to ask - thank you!
19:35:28 <shamail> MeganR: np!
19:35:36 <dc_mattj> MeganR, I thought it was quite nice at this Summit that people could have Ops and ATC for example
19:35:40 <shamail> dc_mattj: Agreed!
19:35:46 <MeganR> totally agree!
19:36:02 <carolbarrett> +1
19:36:05 <MeganR> I like the all around recognition
19:36:30 <shamail> So, yeah, the possible sources of this data could be going through track chair app or mailing list membership
19:36:37 <shamail> anything else on this one dabukalam?
19:36:41 <dabukalam> nope!
19:36:45 <shamail> Thanks!
19:36:54 <shamail> Metrics for Superuser/SuperuserTV contributors (maishsk)
19:37:07 <maishsk> and again - no update :(
19:37:16 <shamail> maishsk: for this one, I would recommend contacting Nicole and Allison from the OpenStack Foundation
19:37:30 <dabukalam> specifically Nicole
19:37:38 <shamail> Allison runs SuperuserTV
19:37:43 <shamail> so both would be ideal
19:37:46 <maishsk> shamail: if someone would please send their email addresses over - I would be happy to follow up
19:37:51 <dabukalam> shamail: ah ok
19:38:07 <shamail> maishsk: sounds good
19:38:32 <dc_mattj> tbd it is a difficult one because it puts Nicole/Allison in a position of making a value judgement
19:38:39 <dc_mattj> which kind of isn't their job
19:38:41 <shamail> I had spoken with them briefly about this in Austin and it might be a list they have to provide you (so automation might not be possible)
19:38:50 <dc_mattj> I did also a little bit
19:39:10 <shamail> dc_mattj: good point.. We should define the criteria and ask them for those who meet it
19:39:43 <dc_mattj> as I said before though, I think that's one of those things where actually folks will have likely fallen into multiple other categories before they reach this one
19:39:48 <shamail> Unfortunately, there is no optimal way externally to get this data… API or even a list… on their end, they have a database
19:39:57 <dc_mattj> and I suspect we'll end up removing that from the list
19:40:02 <dc_mattj> in the long run
19:40:30 <dc_mattj> I added to the doc that I don't believe being interviewed is the same as creating content
19:40:38 <shamail> maybe so but we probably should define criteria and get data for this round to validate the hypothesis
19:40:53 <dc_mattj> and if I look back on content there I see a bunch of people who would already be recognised through other mean
19:40:55 <dc_mattj> means
19:41:06 <dc_mattj> shamail, +1
19:41:23 <shamail> I agree though, it might be the list if similar
19:41:40 <shamail> and the effort question is an interesting one too (it’s why we dropped user survey)
19:42:07 <shamail> Thanks maishsk and dc_mattj
19:42:18 <shamail> Next one is “Discuss "extra-AUC" (dabukalam)”
19:42:26 <shamail> I think I had dropped off when we discussed this one in the meeting
19:42:40 <dabukalam> right, so I have en example patch for extra-ATC, we could do it the same way
19:42:42 <shamail> but I would like to propose differing this criteria discussion fo rnow
19:42:59 <shamail> dabukalam: +1
19:43:05 <dc_mattj> I think you mean deferring
19:43:12 * dabukalam wondered that
19:43:18 <shamail> The reason I was asking if it is okay to differing is that milestone-4 is all about this topic
19:43:21 <dc_mattj> which potentially has a different meaning than differing for most of us ;)
19:43:23 <shamail> Milestone 4: Establish/identify review board for self-nominated members
19:43:30 <shamail> postponed*
19:43:31 <shamail> sorry
19:43:33 <dc_mattj> although differing is an interest new verb
19:43:48 <maishsk> shamail: +1 for deferring
19:43:55 <shamail> Essentially, this topic will come up in milestone-4
19:44:03 <dabukalam> right
19:44:24 <shamail> because I think we agree that we need “extra-AUC” but we would need to define a process around it (who can nominate, who reviews, etc.)
19:44:30 <dc_mattj> +1 for differing which must somehow relate to diffs, but also +1 for deferrring
19:44:38 <shamail> rofl
19:44:39 <dabukalam> lol
19:44:47 <shamail> dc_mattj will not let me live down that typo!
19:44:52 <shamail> haha
19:45:00 <dc_mattj> shamail, you also missed my extra r typo
19:45:09 <dc_mattj> I'm equally guilty ;)
19:45:11 <shamail> lol
19:45:50 <maishsk> :)
19:45:53 <shamail> So are you okay with this dabukalam?  We originally decided to dedicate an entire milestone to this conversation in case we have DIFFERING opinions and topics that take us down rat-holes
19:46:13 <dc_mattj> joking aside, I absolutely agree - out of all this stuff, probably that process is the one that needs a bit more definition around it
19:46:22 <dabukalam> yup, agreed
19:46:25 <shamail> dc_mattj: +1
19:46:36 <dc_mattj> shamail, liking the CAPITALISATION
19:46:45 * dabukalam will brb, arch linux has crashed and the only thing I can do is type into this window
19:46:48 <dabukalam> need to restart
19:46:50 <shamail> Alrighty, next one (last one)
19:46:50 <dc_mattj> note the deliberate use of the S ;)
19:46:55 <shamail> sounds good dabukalam
19:47:05 <dc_mattj> good meeting guys
19:47:07 <shamail> I did take note dc_mattj
19:47:08 <shamail> Metrics for active moderators on Ask OpenStack (shamail)
19:47:09 <maishsk> ;)
19:47:18 <dc_mattj> sorry - folks
19:47:24 <maishsk> Every single one of this WG has been a good meeting
19:47:40 <shamail> So Tom F has built an awesome script
19:47:46 <shamail> #link https://github.com/openstack/uc-recognition
19:47:47 <dc_mattj> Anita has been teaching me about not using 'guys' ;)
19:48:01 <shamail> This repo is our friend!
19:48:20 <maishsk> especially with MeganR and carolbarrett around :)
19:48:24 <shamail> #link https://github.com/openstack/uc-recognition/blob/master/tools/get_active_moderator.py
19:48:26 <dc_mattj> indeed ;)
19:48:34 <carolbarrett> :)
19:48:38 <shamail> There is a script already there to look at Ask OpenStack moderator activity
19:48:46 <MeganR> didn't notice till you said something  :)
19:48:57 <shamail> I don’t think we need to change much in it unless we want to increase or decrease the required karma level
19:48:58 <maishsk> So I was thinking, since some of the info that we want to collect will be manual
19:49:07 <maishsk> and through email and spreadhsheets
19:49:29 <dc_mattj> shamail, I think this group could do with understanding how we extract the track chairs from the track chairs app - one for the UC to ask the devs ?
19:49:47 <maishsk> would this WG (or anyone who that care about the subject) prefer to have that info committed to this repo?
19:49:56 <shamail> Right now, he AskOpenStack requires 200 karma and active for over 6 months
19:50:25 <shamail> That’s all I have on Ask OpenStack Moderators for now… switching topics to open since we are arleady there :P
19:50:28 <shamail> #topic opens
19:50:36 <maishsk> it would be a semi manual process - but at least once committed - the info can be pulled out and used
19:50:38 <shamail> dc_mattj: I think that is a great idea
19:50:53 <shamail> if we can scrap it from a public source then we can automate it eventually
19:51:34 <shamail> maishsk: we should discuss where we compile the list… I have mixed feelings about the AUC members contact info being publicly available as a list
19:51:56 <maishsk> shamail: point taken +1
19:52:00 <shamail> The criteria and automation tools are fine but, for example, the ATC list is not published either
19:52:21 <dabukalam> it doesn't have to be contact info. It's quite common in open source projects to have a contributor list somewhere
19:52:39 <dabukalam> in a git repo. I'm not suggesting that's the way to go, but it's not a bad thing to do if necessary
19:52:50 <dabukalam> as long as it's just names
19:52:57 <shamail> dabukalam: yep, we should figure out how ATC handles this
19:53:08 <maishsk> shamail: I think the ATC is published
19:53:20 <shamail> I’ll be glad to talk to the foundation to figure it out
19:53:28 <shamail> maishsk: I’ll double-check and report back to our WG
19:54:11 <shamail> #action shamail: determine if ATC membership information is published anywhere (and, if so, what is published about them)
19:54:29 <shamail> by the way, welcome back dabukalam :)
19:54:36 <dabukalam> thanks
19:54:37 <shamail> That is all we had for today!
19:54:53 <dabukalam> great
19:54:56 <maishsk> thanks!
19:54:58 <shamail> The meetings have been amazingly productive!
19:55:00 <dabukalam> shamail: thanks for running this
19:55:03 <maishsk> +100
19:55:44 <shamail> Thanks for joining dabukalam!
19:55:51 <shamail> Have a great day/evening
19:55:56 <shamail> #endmeeting