16:02:24 <bauzas> #startmeeting nfv
16:02:24 <openstack> Meeting started Thu Oct  2 16:02:24 2014 UTC and is due to finish in 60 minutes.  The chair is bauzas. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:29 <openstack> The meeting name has been set to 'nfv'
16:02:30 <bauzas> #chair imendel
16:02:31 <openstack> Current chairs: bauzas imendel
16:02:33 <imendel> i think i did..
16:02:36 <imendel> tnx
16:02:43 <bauzas> nope, the "#" was missing :)
16:02:49 <bauzas> I leave you drive the meeting
16:02:52 <imendel> ..:)
16:03:15 <imendel> who is here for nfv?
16:03:19 <bauzas> so \o
16:03:20 <colintd> colintd from Metaswitch, standing in for cloudon1 who can't make the meeting
16:03:50 <imendel> #info agenda for today https://etherpad.openstack.org/p/nfv-meeting-agenda
16:03:59 <imendel> let's start?
16:04:24 <imendel> first topic in the agenda is action items
16:04:53 <imendel> colindt, can you update on the vlan trunking?
16:05:11 <imendel> cloudon1 has an ai on it
16:05:11 <colintd> Calum sent a note to the list yesterday detailing the usage case
16:05:44 <colintd> Essentially vlan trunking provides a clean means of getting customer traffic into an NFV app with separation
16:06:52 <imendel> I guess we shall review and discuss. Anyone has a comment or want to discuss it today?
16:06:52 <colintd> Customer traffic comes into the service provider network over a range of access means, and the SP then dumps each customer's traffic into its own VLAN
16:07:38 <imendel> this is for public networks or tenants ones?
16:08:41 <colintd> It will depend on the application, but typically each VLAN will connect to a customer net
16:09:18 <colintd> So the trunk allows all the customer nets to be presented to a VNF over a single interface, with no reconfig required as nets added and removed
16:10:36 <imendel> ok, so this would be the main use case for it i guess.
16:11:18 <colintd> Yes, a very typical use.  Similar uses exist between SPs carrying end-to-end customer traffic.
16:12:12 <imendel> ok, tnx. I suggest we read the use case send and discuss further if needed in the ml
16:12:33 <colintd> makes sense
16:12:49 <imendel> next topic in the agenda is review the design summit plans
16:12:52 <imendel> •	#topic ALL please review relevant project design summit plans (Nova, Neutron, Heat, Glance, etc.)
16:12:59 <imendel> #topic ALL please review relevant project design summit plans (Nova, Neutron, Heat, Glance, etc.)
16:13:14 <bauzas> #undo
16:13:15 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0x27fda90>
16:13:37 <imendel> tnx bauzas... still learning :)
16:13:41 <bauzas> imendel: sorry this is part of the topic action items yet :)
16:13:47 <bauzas> imendel: no worries
16:14:25 <imendel> anyone review the plans for the summit?
16:14:34 <bauzas> so, I guess it's hard to see a commitment on that action :)
16:14:45 <imendel> yep...
16:14:56 <imendel> we cn move to the next so
16:15:03 <bauzas> sure
16:15:10 <imendel> keshava here?
16:16:12 <bauzas> imendel: I don't think so
16:16:25 <imendel> i guess no. so will follow up next week on service insertion
16:16:29 <bauzas> let's put him again an action item
16:16:38 <bauzas> I leave you doing that ... :)
16:17:02 <bauzas> # action owner to do sth
16:17:07 <imendel> #action for keshava to follow up on last week action (service insertion and chaining use case)
16:17:30 <imendel> I guess we can move to next topic...
16:17:33 <bauzas> sure
16:17:40 <imendel> #topic Juno status
16:18:00 <bauzas> imendel: tbp, this is #action someone to do sth
16:18:10 <bauzas> but that works too
16:18:24 <bauzas> so, Nova RC1 is landed
16:18:54 <bauzas> haven't seen any communaction from ttx about Neutron RC1
16:19:37 <bauzas> #link http://lists.openstack.org/pipermail/openstack-dev/2014-October/047539.html
16:19:44 <ttx> bauzas: open-kulo change  still gating
16:20:01 <bauzas> #info Nova RC1 is tarballed
16:20:11 <bauzas> #info no status about Neutron RC1
16:20:28 <bauzas> ttx: you mean about Neutron ?
16:20:47 <bauzas> #undo
16:20:48 <openstack> Removing item from minutes: <ircmeeting.items.Info object at 0x26a7ed0>
16:21:41 <bauzas> #info Neutron Kilo trunk not yet open (on gate atm)
16:22:19 <imendel> other updates on Juno?
16:22:32 <bauzas> imendel: I haven't followed that much, but it seems all necessary patches landed for RC1
16:22:59 <bauzas> I was seeing some ndipanov's bugfixes, dunno the exact status about it
16:23:03 <bauzas> ndipanov: ^?
16:23:18 <bauzas> talking about NUMA blueprints
16:23:32 <ndipanov> bauzas, what? it works like a charm
16:23:38 <bauzas> ndipanov: oh cool
16:23:41 <ndipanov> 12 embarrassing bugs later
16:23:43 <ndipanov> :)
16:23:53 <bauzas> nice so RC1 is NUMA happy
16:24:02 <ndipanov> it should be yeah
16:24:07 <bauzas> cool
16:24:24 <bauzas> imendel: that's it for me then
16:24:33 <imendel> ok, I guess it's the current status. Do we want to follow up next week too?
16:25:00 <bauzas> imendel: don't think so, RC2 is on its way but not including patches from our side
16:25:09 <imendel> ok
16:25:24 <imendel> btw sriov is also happy in RC1?
16:25:48 <bauzas> baoli: you there ?
16:26:06 <baoli> bauzas: Hi
16:26:28 <bauzas> baoli: hi, imendel was querying about SRIOV status for RC1
16:26:42 <bauzas> baoli: do you have anything missing from RC1 ?
16:27:48 <bauzas> #info potential Nova RC status is here https://bugs.launchpad.net/nova/+bugs?field.tag=juno-rc-potential
16:28:15 <baoli> bauzas, I think that we are in good shape in RC1.
16:28:24 <imendel> cool
16:28:27 <bauzas> baoli: cool
16:28:35 <baoli> bauzas, there is bug https://bugs.launchpad.net/nova/+bug/1370348, which I'm thinking to make it RC2 if possible
16:28:36 <uvirtbot> Launchpad bug 1370348 in nova "Using macvtap vnic_type is not working with vif_type=hw_veb" [Undecided,Confirmed]
16:29:03 <baoli> bauzas, what's the deadline for RC2?
16:29:14 <bauzas> baoli: good question
16:29:21 <bauzas> baoli: I don't know yet
16:29:38 <bauzas> that's the rolling ballet for releases candidates
16:30:10 <imendel> i guess we can move to next topic?
16:30:27 <bauzas> https://wiki.openstack.org/wiki/Release_Cycle#Pre-release_.28Release_Candidates_dance.29
16:31:21 <imendel> #topic Kilo planning
16:31:43 <bauzas> baoli: if you want to ship the bugfix into RC2, I would suggest you to discuss that with johnthetubaguy and mikal
16:32:02 <bauzas> baoli: it depends if it's a really regression bug
16:32:13 <johnthetubaguy> baoli: makre sure it gets the tag anyways
16:32:15 <bauzas> baoli: or it will be shipped into the Kilo trunk
16:32:52 <bauzas> imendel: now, dates have been confirmed for Kilo
16:33:00 <baoli> bauzas, it's not a regression.
16:33:01 <bauzas> imendel: let me find the email
16:33:18 <imendel> tnx
16:33:31 <baoli> johnthetubaguy: what tag should it get?
16:34:08 <johnthetubaguy> baoli: juno-rc-potential
16:34:36 <imendel> meanwhile see link to the active bp list
16:34:38 <imendel> #link https://wiki.openstack.org/wiki/Teams/NFV#Active_Blueprints
16:34:50 <bauzas> #link http://lists.openstack.org/pipermail/openstack-dev/2014-September/047128.html
16:35:03 <bauzas> #undo
16:35:03 <openstack> Removing item from minutes: <ircmeeting.items.Link object at 0x265b3d0>
16:35:09 <baoli> johnthetubaguy: thanks.
16:35:16 <bauzas> #link http://lists.openstack.org/pipermail/openstack-dev/2014-September/047128.html Kilo release schedule
16:36:26 <bauzas> imendel: now, we need to figure out which bps are good candidates for Kilo
16:36:38 <imendel> any inputs on bp for Kilo...
16:38:10 <imendel> We discuss in the past the scheduling bps. any insights from the team?
16:38:13 <bauzas> imendel: well, at least some specs have already been approved
16:38:31 <bauzas> imendel: those are good candidates for being worked on first
16:38:53 <bauzas> imendel: what do you mean by "scheduling bps" ?
16:38:58 <imendel> bauzas: we have them listed?
16:39:42 <imendel> bauzas: all the related to scheduling decisions. like NIC state aware scheduling
16:40:39 <bauzas> imendel: well, if the spec has been rejected, it will take more time than other efforts
16:40:51 <bauzas> imendel: because it needs to be approved first
16:41:13 <bauzas> imendel: unless it's something quite handy to work on, like a new filter
16:41:50 <imendel> right. it was just an example. we have also Solver Scheduler - complex constraints scheduler with NFV use cases
16:41:56 <bauzas> anyway, some triaging/prioritization has to be done for NFV, I leave sgordon and others identify the main efforts
16:42:20 <bauzas> imendel: both the examples you mention are not having a good consensus yet
16:43:05 <imendel> right. I was asking as I thought we discuss in the past it's an interesting idea. but if status is that still no consensus we can drop
16:43:09 <imendel> for now
16:43:13 <bauzas> anyway, I think that's it we can do for today re: priorities
16:43:32 <imendel> ok
16:44:16 <imendel> we want to discuss cross-projects session proposal
16:44:42 <bauzas> right
16:46:07 <imendel> any specific suggestions? I think ahoban had one last meeting
16:46:48 <imendel> but I don't see him around today
16:47:21 <imendel> bauzas: you recall?
16:47:35 <bauzas> not that much
16:47:42 <imendel> ok...:)
16:47:57 <bauzas> #link https://etherpad.openstack.org/p/kilo-crossproject-summit-topics
16:48:39 <bauzas> let's discuss that maybe next week
16:49:29 <imendel> seems so...  yes
16:49:55 <imendel> so last one for today is the ETSI gap analysis publication
16:50:23 <imendel> #topic: ETSI gap analysis publication
16:50:32 <bauzas> #undo
16:50:33 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0x28efb50>
16:50:37 <bauzas> redo it
16:50:53 <imendel> #topic ETSI gap analysis publication
16:51:05 <bauzas> is this something public ?
16:51:28 <imendel> Does anyone has an update on it?
16:51:45 <imendel> I can try and check for next week if no one here has
16:52:05 <bauzas> sure, I leave you take an action then
16:52:14 <bauzas> I'm interested in the analysis :)
16:52:32 <imendel> #action imendel to check on ETSI gap analysis publication
16:52:40 <imendel> sure..:)
16:53:00 <imendel> any other items for discussion ?
16:53:14 <imendel> #topic other discussion
16:53:24 <bauzas> nice timing, 5 mins for opens
16:53:34 <imendel> ...:)
16:54:52 <bauzas> hearing crickets...
16:54:56 <imendel> I guess no other items...
16:55:07 <imendel> so bauzas, tnx for your help today, i needed it :)
16:55:19 <bauzas> no worries, you're in a good shape :)
16:55:25 <imendel> tnx everyone
16:55:31 <bauzas> thanks
16:55:41 <imendel> #endmeeting