16:01:32 <sgordon> #startmeeting nfv
16:01:37 <openstack> Meeting started Thu Aug 21 16:01:32 2014 UTC and is due to finish in 60 minutes.  The chair is sgordon. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:37 <bauzas> tic tac
16:01:37 <ijw> o/
16:01:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:40 <openstack> The meeting name has been set to 'nfv'
16:01:44 <sgordon> #topic roll call
16:01:50 <sgordon> who is here for the nfv meeting :)
16:01:51 * bauzas needs to be faster next time
16:01:56 <bauzas> \o
16:02:11 <lukego> Howdy
16:02:25 <kuba1> o/
16:02:29 <sgordon> i see an ijw, bauzas, vjardin_, lukego, kuba1
16:03:04 <sgordon> #info plan is to try the alternating times for a few weeks and see what attendance is like
16:03:30 <sgordon> #info sgordon, bauzas, ijw, lukego, kuba1, vjardin_, cloudon1
16:03:34 <sgordon> no doubt others
16:03:36 <sgordon> ok
16:03:44 <sgordon> #topic review actions from last week
16:03:46 <vjardin_> Steve> I almost missed that session, thanks Luke to notifying me
16:04:04 <lukego> welcome :)
16:04:06 <ijw> Yeah, earlier warnings might help (though I think I'd probably still have missed it)
16:04:19 <sgordon> sooo
16:04:21 <sgordon> we're here
16:04:26 <sgordon> which means i did action item # 1
16:04:31 <sgordon> set up the alternating schedule
16:04:37 <adrian-hoban> Hi Folks
16:04:47 <sgordon> i removed the extensible resource tracker from the wiki as not nfv-specific
16:05:03 <sgordon> and tried to update the wiki to track status for juno
16:05:11 <sgordon> still plenty of catch up to do there though....
16:05:25 <sgordon> #action sgordon to continue trying to bring the wiki up to date with current status
16:05:38 <bauzas> just wondering if the dashboard might help...
16:05:48 <sgordon> bauzas, "sort of"
16:05:56 <sgordon> bauzas, it's good for reviewing what is in flight
16:06:06 <bauzas> sgordon: yeah, I understand
16:06:11 <sgordon> bauzas, not so good for "that spec was never approved or no work has been summitted"
16:06:25 <bauzas> sgordon: I'm just thinking about other webpage for tracking this
16:06:25 <sgordon> which brings me to
16:06:37 <sgordon> #info Feature Proposal Freeze is August 21 (today)
16:06:42 <sgordon> sooo
16:06:56 <sgordon> does anyone have a proposal that was tagged on the wiki and approved but does not have code up yet?
16:07:17 <sgordon> my understanding is for nova an exception will require *three* cores to approve this time around
16:07:24 <sgordon> not sure about neutron and other projects
16:07:43 <bauzas> sgordon: johnthetubaguy confirmed he tied up Launchpad with NeedCodeReview states for Nova if it was missing
16:08:01 <sgordon> great that helps
16:08:11 <bauzas> sgordon: so we can reasonably count on Launchpad for Nova
16:08:32 <johnthetubaguy> bauzas: I plan to sort out launchpad, its not been done yet, only done the medium and high stuff so far
16:08:34 <sgordon> #info Nova requires three core reviewers to sign up for feature proposal freeze exceptions this time around
16:08:52 <bauzas> johnthetubaguy: thanks for that
16:08:57 <jchapman_> #sgrordon Some of my code is up but not all.          https://blueprints.launchpad.net/nova/+spec/input-output-based-numa-scheduling
16:09:22 <sgordon> #info johnthetubaguy in the progress of updating nova BP entries to match reality
16:09:33 <jchapman_> #sgordon, i have a dependency on some work from Daniel and Nikola
16:09:33 <johnthetubaguy> bauzas: but tomorrow morning, blueprints will get −2ed if they don't have all their code up, or its not clear if they have all their code up for review
16:09:49 <sgordon> jchapman_, ok
16:09:52 <johnthetubaguy> sgordon: awesome, that really helps me out when thats done
16:10:03 <sgordon> jchapman_, are the patches you are reliant on in flight?
16:10:15 <johnthetubaguy> oops, read that the wrong way around, running away
16:10:28 <bauzas> johnthetubaguy: thanks again
16:10:29 <sgordon> johnthetubaguy, haha
16:10:32 <sgordon> johnthetubaguy, i wish i could
16:10:43 <sgordon> johnthetubaguy, i dont have access to fix up bp stuff for ones i dont own
16:10:53 <jchapman_> sgordon, they were uploaded yesterday
16:10:54 <bauzas> jchapman_: lemme check
16:11:08 <sgordon> jchapman_, ok
16:11:13 <johnthetubaguy> sgordon: feel free to leave a note in the whiteboard, if you see something obvious, that would help when I come along
16:11:25 <sgordon> jchapman_, if there is any possibility of getting yours up today that would be easier than an exception
16:11:33 <sgordon> jchapman_, recognize that might be a challenge though
16:11:54 <jchapman_> sgordon, we will try :(
16:12:01 <bauzas> jchapman_: do your work require another patch, or everything is OK with https://review.openstack.org/#/c/108634/ ?
16:12:35 <bauzas> jchapman_: FPF is for specs that haven't code submitted and yours has
16:12:51 <jchapman_> sgordon, we will upload another patch soon. This will be to extend the NUMA sched stuff from Daniel and Nikola
16:12:53 <sgordon> #topic FPF
16:13:07 <bauzas> jchapman_: then you have to do it today
16:13:16 <sgordon> #info jchapman_ working on additional I/O scheduling patch based on danpb and ndipanov's NUMA work
16:13:39 <jchapman_> bauzas, gulp
16:14:13 <bauzas> jchapman_: yeah I know, life sucks
16:14:18 <bauzas> :)
16:14:23 <ndipanov> jchapman_, heads up - I am changing some of the stuff due to review comments - although not fundamentally - just removing data from the instance
16:14:43 <sgordon> ok
16:14:53 <jchapman_> ndipanov, thanks
16:14:55 <sgordon> so we need to keep the dialog going on that
16:14:57 <bauzas> jchapman_: I would suggest you to rebase your next patch on the whole ndipanov's patch series
16:15:17 <ndipanov> coming tomorow europe time to a gerrit near you
16:15:36 <sgordon> i wanted to highlight a few that do have patches up w/o negative feedback
16:15:37 <jchapman_> bauzas Ye im in the process of rebasing now
16:15:47 <sgordon> #topic BP code w/o negative feedback
16:15:58 <sgordon> #info SR-IOV https://review.openstack.org/#/q/98828,n,z
16:16:14 <sgordon> #info VIF_VHOSTUSER https://review.openstack.org/#/q/96140,n,z
16:16:23 <sgordon> lukego, you had some comments about the latter?
16:16:28 <sgordon> comments/updates?
16:16:31 <lukego> Right
16:16:43 <lukego> The code is getting good reviews and all seems well on that front. but,
16:17:10 <lukego> the only Neutron code that depends on it is the Snabb NFV mech driver, and I have had an unexpected request from Neutron core to develop that out-of-tree for a while, because they are overloaded with new drivers and still working on new policies to accomodate them
16:17:39 <lukego> and while I want to be helpful and accomodating to the overloaded Neutron core, I hope this does not impact the vhost-user getting merged, because that’s useful to a bunch of people.
16:17:50 <sgordon> right
16:17:58 <sgordon> that is a question i can't really answer
16:18:07 <sgordon> anyone here from the nova team have an opinion?
16:18:29 * bauzas passes...
16:19:36 <lukego> well...
16:19:46 <sgordon> taking that as a no
16:19:57 <sgordon> lukego, is there a m/l thread tagged [nova] to raise this?
16:20:03 <bauzas> sgordon: +1
16:20:28 <sgordon> #info some concern about impacts of neutron out of tree driver proposal on vhost-user merge
16:20:31 <bauzas> lukego: IIUC, your nova patch is making use of a Neutron driver that is not yet merged ?
16:20:36 <lukego> sgordon: no. I am trying to get the Neutron core feedback made in a public space that I can reference, e.g. with a patch to untarget the mech driver from juno with a rationale
16:21:03 <lukego> bauzas: no. the nova patch is stand-alone. it’s just that there is no code in neutron that will use it immediately if the mech driver doesn’t merge
16:21:09 <bauzas> lukego: from my understanding, Neutron API is not driver-dependent
16:21:29 <bauzas> lukego: do you make use of new features in Neutron ?
16:21:47 <lukego> bauzas: in the nova patch? no, it is really small and stand-alone and has no dependencies on Neutron.
16:21:53 <bauzas> lukego: I mean, does your Nova patch make use of something tested by Tempest for Neutron or something totally new ?
16:22:22 <bauzas> lukego: then I can't see the dependency with Neutron :)
16:22:31 <ijw> His Nova patch is a new plugging model - this is not going to have a Tempest test without Neutron working, and that won't be in
16:22:45 <lukego> bauzas: ok :). my fear was it would be “why add this to Nova before it’s needed by Neutron?” objection
16:22:50 <vjardin_> bauzas: but it would help to break the eggs to start getting VHOSTUSER even if not used yet. I think it reaches a consensus that it'll be needed.
16:23:32 <lukego> I think it would be valuable within the NFV group to all know that we can use VHOSTUSER going forward, and easier to do this if it’s in tree and we don’t all have to backport it out of Gerrit..
16:23:50 <vjardin_> lukego: +1
16:23:59 <bauzas> lukego: well, please send an email to -dev then, because I'm really not sure that you won't get objections
16:24:02 <cloudon1> +1
16:24:06 <lukego> bauzas: ack
16:24:22 <sgordon> lukego, sure - challenge is proving it in the gate w/o an implementation
16:24:29 <bauzas> lukego: that said, I haven't reviewed your patch, so I'm unable to see the impacts
16:24:40 <bauzas> sgordon: +1
16:25:00 <ijw> sgordon: at least this is dead code for people who aren't using it - the testing will be poor but there will be no bugs that affect others
16:25:06 <sgordon> #action lukego to highlight vhost-user current state on -dev
16:25:09 <sgordon> ijw, yeah i agree
16:25:25 <bauzas> ijw: the problem is that dead code can be alive for many people wanting to contribute on it or use it
16:25:26 <adrian-hoban> lukego: Agree it will be useful and would like to see this work merged.
16:25:34 <sgordon> ijw, i also am onboard with the fact it's going to be needed sooner or later
16:25:55 <ijw> Yup, it's true and for the minute we'll have to watch reviews like a hawk
16:26:19 <lukego> thanks for the support all :)
16:26:28 <sgordon> np
16:26:37 <sgordon> so i had two other minor tweaks that are on the dash
16:26:46 <sgordon> just client support for find and evacuate host bp
16:26:57 <sgordon> #link https://review.openstack.org/#/q/75025,n,z
16:27:05 <sgordon> #link https://review.openstack.org/#/q/76859,n,z
16:27:27 <sgordon> other than that
16:27:38 <sgordon> #link http://nfv.russellbryant.net/
16:27:43 <bauzas> sgordon: https://review.openstack.org/#/c/76859/ can be debated
16:27:54 <bauzas> sgordon: because that's impacting V3
16:27:54 <ijw> Not sure I see the relevance of host evacuation to NFV
16:27:55 <sgordon> bauzas, that is the v3 one right?
16:28:02 <bauzas> sgordon: correct
16:28:03 <sgordon> whether it's important or not is also debatable
16:28:12 <bauzas> sgordon: I have to assume this one probably won't get merged
16:28:31 <sgordon> yeah not sure that is really a problem given where the v3 api discussion is at anyway
16:28:34 <bauzas> sgordon: but the V2 one sounds good to me
16:29:04 <sgordon> ijw, my loose understanding is typically this type of function is being performed from a higher level orchestrator for nfv atm
16:29:07 <bauzas> sgordon: +1
16:29:11 <sgordon> ijw, so it's a nice to have rather than crucial
16:29:36 <ijw> I can see it's done by an orchestrator but I can't see how it affects NFV even so
16:30:48 <sgordon> desire to re-schedule using the same logic that was used when originally placing the VNF
16:31:02 <sgordon> problem here of course is persistent scheduler hints was not approved
16:31:08 <sgordon> so not sure how useful it is in isolation
16:31:49 <bauzas> sgordon: that whole discussion will probably be raised during next summit
16:32:09 <sgordon> yeah
16:32:09 <bauzas> sgordon: we need to figure out what is the best API/contract in between computes and scheduler
16:32:13 <sgordon> almost without a doubt
16:32:51 <sgordon> #info Long list of Work In Progress Or Unverified patches progressing
16:32:58 <sgordon> so we have a long list of work in progress
16:33:06 <sgordon> bt most appears to have pretty recent updates
16:33:12 <sgordon> (as in, today)
16:33:20 <sgordon> so not sure that is too concerning
16:33:33 <sgordon> other than the inevitable upcoming review crunch...
16:34:18 <bauzas> sgordon: if you look at these, that's because of a whole patch series failed mainly
16:34:42 <ijw> I think we should be looking at ahead at some of the patches we've not succeeded with and will want to get in in Kilo
16:34:52 <ijw> ... early in Kilo, whenit's quiet
16:34:54 <sgordon> ijw, i 100% agree
16:35:00 <sgordon> 110 even
16:35:14 <ijw> All the ones that cause me problems failed, which is disappointing
16:35:25 <sgordon> i am trying to get the wiki up to date so we have a clear picture of what is in juno and what is outstanding
16:35:29 <sgordon> and then focus on outstanding
16:35:34 <sgordon> ijw, understood
16:35:42 <ijw> At this point it's basically nag people to review and think ahead
16:36:07 <sgordon> yes
16:36:21 <sgordon> also need to work out how to do a better job of highlighting on the neutron side
16:36:29 <adrian-hoban> I'm sure we'll have a new set of potential work items to be added between now and Kilo too...
16:36:32 <sgordon> which seems to be where we have been really stuck on a lot of things
16:36:40 <ijw> I think we need to nominate marun as our delgate to the core team
16:37:15 <sgordon> if he is game...
16:38:23 <sgordon> anyway
16:38:30 <sgordon> i dont actually have anything else on my list for this week
16:38:58 <sgordon> as ijw said at this point for juno it is really keep iterating what did get approved, be persistent about following up on reviews
16:39:05 <ijw> The complaints I got were that we weren't engaging with them. My assumption was that we went to them when we had something; their argument was that we shoudl involve them at the start to work out whether we were in sync
16:39:06 <sgordon> and start looking forward on what we could do better for kilo
16:39:20 <sgordon> ijw, yes that is the feedback i got as well
16:39:46 <sgordon> ijw, so i think having a roadmap of what we want to try achieve earlier will be important
16:39:58 <sgordon> ijw, as this time we really only got it together post summit
16:40:08 <sgordon> though we all had ideas of what we wanted to achieve before that no doubt
16:40:14 <sgordon> #topic open discussion
16:41:54 <sgordon> ok
16:41:59 <sgordon> i am going to close this out
16:42:08 <ijw> Ok, mail hte roadmap out to the list ;)
16:42:22 <sgordon> i would appreciate any  help / thoughts on better breaking up the wiki to make it clearer what is going to remain outstanding
16:42:25 <sgordon> and needs to go on that roadmap
16:42:52 <sgordon> #action sgordon formulate nfv roadmap/goals *before* summit and send to list
16:43:00 <sgordon> will probably do co-ordination for the above on list as well
16:43:35 <sgordon> #endmeeting