20:01:51 <sdague> #startmeeting newton-cross-project-session-scheduling
20:01:52 <openstack> Meeting started Thu Apr  7 20:01:51 2016 UTC and is due to finish in 60 minutes.  The chair is sdague. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:54 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:01:56 <openstack> The meeting name has been set to 'newton_cross_project_session_scheduling'
20:02:10 <sdague> ok, potentially useful for logging
20:02:10 * mtreinish lurks
20:02:19 * harlowja sorta lurks
20:02:20 <sdague> #link https://etherpad.openstack.org/p/newton-cross-project-sessions
20:02:44 <dims> hmm, won't add my nick at the top :)
20:02:58 <sdague> I added up all the scores earlier, and the results of the top 21 sessions were sent out to the tc ML
20:03:13 <sdague> #link http://lists.openstack.org/pipermail/openstack-tc/2016-April/001159.html
20:03:32 <sdague> first order of business, do we think any sessions should be 2x ?
20:03:46 <sdague> #topic any 2x sessions
20:03:49 <ttx> I don't think there is a session that really needs everyone and therefore would justify a more complex setup than 3x7
20:04:04 <sdague> ttx: oh, sorry, different question
20:04:09 <sdague> though that's a good one
20:04:10 <ttx> let me see if there is anything really too short
20:04:12 <dtroyer_zz> o/
20:04:14 <sdague> should any session be a double block
20:04:25 <sdague> as in run long
20:04:25 <ttx> yeah, I started typing before you topiced
20:04:56 <sdague> but I agree we should look to do a 3 track by default and only do something diffferent if we have to
20:05:21 <ttx> sdague: not sure any of the big topics is advanced enough that a double session would make it make progress a lot more than a single-session
20:05:23 <dims> sdague : does not seem so
20:05:32 <dims> i mean don't see anything running too long
20:05:35 <sdague> ok, fair enough, I'm fine with that
20:05:39 <ttx> Co-installability is a long topic, but we are just breaking the subject
20:05:49 <sdague> the deployment tools one was the only thing I was wondering about
20:06:02 <ttx> single CLI maybe
20:06:05 <sdague> but maybe if we stick that early in the day it will let those folks continue to discuss later
20:06:14 <ttx> deployment, they can decide to continue it on Friday
20:06:24 <ttx> or even Tuesday yes
20:06:51 <sdague> ok, so I also thought there were a few natural pairings like deployment & coinstall
20:07:04 <sdague> I stuck those in there
20:07:06 <ttx> sdague: Maybe we should be clear that those are long topics that will surely not be solved in 40min and encourage people to meet afterwards
20:07:12 <sdague> yep
20:07:48 <dtroyer_zz> the continue on Friday is good, with some time inbetween to dig in small groups maybe
20:07:51 <sdague> ok, should we start proposing things into slots and see where we get to?
20:07:58 <ttx> Room sizes will be roughly equivalent so no need to prioritize by popularity
20:08:18 <ttx> Let me see if we group them by themes
20:08:43 <harlowja> def some kind of 'tech tebt theme'
20:08:54 <dtroyer_zz> 23 might follow the 13 then 6 chain well
20:09:24 <dims> "API/CLI" is probably a theme
20:10:36 <dims> 9 and 23 are non-technical (community)
20:11:55 <ttx> I think there are three big themes
20:12:12 <ttx> General policy/community decisions, like the EOL
20:12:26 <ttx> Implementation of things that are already there or in progress, like CLI
20:12:42 <ttx> And more... long-term technical design discussion
20:13:04 <dtroyer_zz> I like 9 and 24 being together, there is some connection between them
20:13:22 <ttx> That makes 3x7
20:13:24 <dtroyer_zz> I think 9 should be ahead of 24, it might inform it somewhat
20:13:35 <ttx> Though I did have to shoehorn 4 into the first category
20:13:38 <sdague> right 9 & 24 pair
20:13:53 <dims> sorry i typoed before. yes 9/24
20:14:01 <sdague> so, I want to tweak this a little because I think we have audience overlap as well, let me propose a thing
20:14:04 <ttx> sdague: saw my categorization on the etherpad ? makes sense for room split ?
20:14:56 <sdague> well, except I think deploy & coinstall should go back to back
20:15:05 <ttx> ok
20:15:09 <sdague> because coinstallability is basically held back by the deploy folks
20:15:12 <dims> ttx : 4 is borderline between practical and astroturf :)
20:15:17 <sdague> they are the stake holders
20:15:19 <ttx> Let's move Quto to room C then
20:15:22 <ttx> Quota
20:15:27 <sdague> sure
20:15:35 <ttx> and/or policy
20:15:37 <sdague> the 2 policy should go back to back
20:16:03 <ttx> 4/20 is a bit in-between room B and C
20:16:59 <dims> 13 and 6, which one do we want to talk about first?
20:17:14 <dtroyer_zz> 13 I think?
20:17:25 <sdague> yeh, I'd rather make sure the pairings land together, and not across a break
20:17:27 <dims> sure
20:17:31 <ttx> maybe swapping 22 and 23 ?
20:17:59 <sdague> sure, I'd be fine with that
20:18:00 <dtroyer_zz> those two may have a similar audience
20:18:05 <ttx> 22 sounds more practical/immediate than 23
20:18:23 <dims> agree
20:18:28 <ttx> I like the split
20:18:43 <sdague> ok, let me stare at this for a second and make sure I'm not screwed in my time blocks
20:19:11 <dtroyer_zz> We should swap 9 and 24
20:19:12 * ttx adds too
20:19:39 <dims> 26 and 11 probably should be back to back
20:19:55 <dims> good
20:20:36 <ttx> I think I'm not screwed
20:20:42 <sdague> ok, so we ruined dtroyer_zz
20:21:09 <dtroyer_zz> swap the devstack pair with the policy pair?
20:21:12 <ttx> ideally we'd put the design summit split discussion at the end of the day, to limit bikeshedding
20:21:32 <sdague> yeh
20:21:35 <ttx> and move the CLI discussion earlier
20:21:41 <sdague> dtroyer_zz: what about move CLI early?
20:21:41 <ttx> so that we unscrew dtroyer
20:21:51 <dtroyer_zz> I think the split discussion that has consequences for 24
20:22:02 <dtroyer_zz> CLi early is good
20:22:04 <ttx> like swap with discovery
20:22:28 <sdague> ttx I pushed it 2 blocks earlier
20:22:32 <sdague> before the coffee break
20:22:56 <ttx> let me see if we spread out the popular ones enough
20:23:26 <dtroyer_zz> can we swap (14,20) with (26,11)?
20:23:59 <ttx> good for me
20:24:22 <ttx> but maybe sdague wanted to be at the cross-project one
20:24:27 <sdague> ok, that completely eliminates me from the room A meta discussions
20:24:44 <sdague> which might be fine
20:24:57 <dims> ttx is all day in room A except for one
20:25:15 <sdague> yeh, that's fine
20:25:30 <dims> we don't let him out :)
20:25:35 <sdague> so, I would invert 26,11 if we keep them there anyway
20:26:18 <ttx> sdague: ok move them and let's see how it works
20:26:23 <sdague> but, yeh, I can live with the jump
20:26:33 <dtroyer_zz> so B: 22, 1 11, 26, 16, 14, 20
20:27:02 <dtroyer_zz> howzzat?
20:27:13 <sdague> actually can we stick policy in C
20:27:18 <sdague> in the midblock
20:27:32 <ttx> sdague: we could swap 24 and 9 (or 14 with 20) depending on which discussion from room A you prefer to be around for
20:28:12 <sdague> how about that?
20:28:26 <dtroyer_zz> works for me
20:28:33 <sdague> it moves policy to the C room, and I inverted the order on the devstack ones so I can be in the service one
20:28:44 <sdague> the v3 one I'm still not a huge fan of
20:29:03 <dims> lgtm
20:29:04 <dtroyer_zz> maybe that's the one you need to be in then?
20:29:29 <ttx> let's check moderators quickly
20:29:51 <sdague> dtroyer_zz: I'm not a huge fan of it on the schedule, because I don't see what is going to happen there that wouldn't happen in an email :)
20:30:08 <sdague> it's not like anything is controversial there, it just needs to be written down
20:30:09 <dtroyer_zz> ah, gotcha.
20:31:43 <sdague> right, there is definitely a mordred conflict
20:32:09 <sdague> 23 <-> 25?
20:32:53 <sdague> dtroyer_zz: that would put CLI in the first block
20:33:11 <ttx> 19/25 ?
20:33:51 <ttx> hmm, or 12<->25
20:34:08 <sdague> sure, I think 19 <-> 25, 23 <-> 25, or 12 <-> 25 would all be fine
20:34:34 <ttx> arh no
20:34:46 <sdague> what does 12 - 25 break?
20:34:49 <ttx> we need thingee in that cross-project one
20:34:54 <sdague> oh, right
20:34:58 <ttx> conflict with 24
20:35:01 <ttx> revert
20:35:08 <sdague> yep
20:35:18 <dtroyer_zz> 19<->25?
20:35:30 <ttx> I think mordred would want to be in co-installability
20:35:38 <sdague> sure, or 23 <-> 25?
20:35:50 <ttx> works for me
20:36:04 <dtroyer_zz> I can live with it, but those two probably have some audience overlap
20:36:18 <dtroyer_zz> er, 23 and 22
20:36:42 <sdague> dtroyer_zz: possibly
20:36:43 <ttx> dtroyer_zz: how about we swap 19 and 23 now then
20:37:02 <dtroyer_zz> sure
20:37:09 <sdague> ok, ttx you c/p
20:37:13 <sdague> so we don't collide again
20:37:25 <sdague> the joys of bubble sort on schedule
20:37:33 <dims> y
20:37:38 <dims> :)
20:37:41 <ttx> been off the wheel for the last 5 min, so taht was not me :)
20:37:46 <sdague> ah, ok
20:37:55 <sdague> ok, done
20:38:10 <sdague> that looks about as sane a first pass as I can imagine
20:38:29 <ttx> I think I preferred 19/23 the other way, but that may be a bit selfish
20:38:40 <sdague> I can take that and propose it to the dev list, and ask for feedback
20:38:42 <ttx> (I would rather attend CLI on my last free slot)
20:39:05 <sdague> so, we could
20:39:15 <dtroyer_zz> I'd prefer to be in 10 over 17, so ya, it can go back
20:39:26 <sdague> 19<->23 and 1<->22
20:39:26 <ttx> sdague: that is a risky recipe, note that there is no way to please everyone
20:39:44 <sdague> ttx: well, not so much feedback as hard conflicts at this point
20:39:55 <sdague> because who knows who is on the conf schedule
20:39:57 <ttx> sdague: 19<->23 and 1<->22 +1
20:40:05 <sdague> dtroyer_zz: ?
20:40:10 <dtroyer_zz> +1
20:40:29 <thingee> o/
20:40:34 <sdague> ok
20:40:54 <sdague> people generally good with this as a draft?
20:41:20 <ttx> sdague: it's fine posting it as a strawman and ask for conflicts, just say that it is already the result of an optimization, so we won't likely be able to accommodate every request
20:41:23 <dims> sdague : LGTM
20:41:27 <ttx> LGTM
20:41:35 <dtroyer_zz> LGTM2
20:41:52 <sdague> ttx: yeh, I will word it correctly to only ask for resolution if you have a hard conflict
20:42:02 <sdague> ok, I'll send that out in the morning
20:42:05 <ttx> hmm, let me check something else quickly
20:42:10 <sdague> oh no
20:42:19 <ttx> conference talks
20:42:31 <ttx> I have the list of conflicts there pre-canned for DS planning
20:43:01 <ttx> Monty has talks at 11:15 and 4:40
20:43:34 <ttx> + robclark at 4:40
20:43:40 <dims> he looks clear for those 2 slots
20:43:44 <dtroyer_zz> that may be ok, modulo distance?
20:43:52 <ttx> I don't care about distance. Run
20:43:57 <dims> haha
20:44:05 * dtroyer_zz makes note to bring roller blades
20:44:10 <dims> this is texas :)
20:44:14 <ttx> yes, looks good
20:44:45 <sdague> whew
20:44:53 <sdague> ok, thanks all.
20:45:08 <ttx> fun uh
20:45:09 <sdague> #action sdague to send email with schedule to list
20:45:12 <dtroyer_zz> cool
20:45:27 <dims> nice
20:45:28 <sdague> #action ttx to carve out 3x7 schedule block
20:45:44 <sdague> I can fill out details once you put the blocks there
20:45:46 <ttx> mind you, that talk conflict data was lifted off the schedule a few weeks ago so likely to be corrupt by now
20:45:52 <sdague> sure
20:46:02 <dtroyer_zz> gotta start somewhere
20:46:05 <ttx> sdague: alright, will create that tomorrow morning
20:46:09 <sdague> sounds good
20:46:11 <sdague> thanks all
20:46:13 <ttx> It's pretty solid I think
20:46:18 <sdague> yeh, me too
20:46:19 <ttx> sdague: thx a lot for driving
20:46:22 <sdague> no prob
20:46:28 <sdague> #endmeeting