14:00:45 <njohnston> #startmeeting neutron_upgrades
14:00:45 <openstack> Meeting started Thu Jun 21 14:00:45 2018 UTC and is due to finish in 60 minutes.  The chair is njohnston. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:47 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:49 <openstack> The meeting name has been set to 'neutron_upgrades'
14:01:15 <njohnston> Hello all
14:01:32 <TuanVu> Hi Nate
14:01:58 <njohnston> #topic Action Items
14:02:09 <njohnston> #info njohnston review https://review.openstack.org/#/c/507772/
14:02:30 <njohnston> I did not have much time to take a look at https://review.openstack.org/#/c/507772/, but it looks like there has been a quickening pace of reviews and some good feedback.
14:02:46 <TuanVu> yes
14:03:03 <njohnston> I think there is a good amount of interest in it.
14:03:35 <njohnston> So I think the prospects for that change are good.
14:03:35 <TuanVu> yeah, I'm trying to solve all the concerns from reviewers
14:04:00 <njohnston> Let me know if you need any assistance.
14:04:23 <TuanVu> thank you, Nate. Please feel free to add your opinion on that patch if you have any
14:04:34 <njohnston> Will do, thanks. :-)
14:04:41 <njohnston> #info Update meeting agenda https://wiki.openstack.org/wiki/Meetings/Neutron-Upgrades-Subteam
14:04:42 <TuanVu> thank you in advance :)
14:04:50 <njohnston> I don't have edit privileges on the wiki.  I will check with lujinluo when she gets back to see how she wants to approach this.
14:04:58 <njohnston> #action njohnston to check with lujinluo on upgrades meeting wiki
14:05:14 <njohnston> I think that concludes the action items from last time
14:05:24 <njohnston> and so on to the main show
14:05:26 <njohnston> #topic OVO
14:05:35 <njohnston> #link https://review.openstack.org/#/q/topic:bp/adopt-oslo-versioned-objects-for-db+(status:open+) List of outstanding changes
14:06:01 <njohnston> We just discussed https://review.openstack.org/#/c/507772/ so we can skip it
14:06:08 <njohnston> #link https://review.openstack.org/#/c/565358/ objects: don't refetch a non-list object field if it's None - Ihar Hrachyshka
14:06:23 <njohnston> This still looks solid.  It needs some core attention.  I will reach out directly to additional reviewers.
14:06:32 <TuanVu> that's great
14:06:53 <njohnston> #action njohnston to reach out to core reviewers for https://review.openstack.org/#/c/565358/
14:07:04 <njohnston> #link https://review.openstack.org/#/c/549168/ Use Router OVO in l3_db.py - Van Hung Pham
14:07:16 <njohnston> This one is seeing major problems with tests.
14:08:38 <njohnston> OK, no update from the author on that
14:08:48 <njohnston> #link https://review.openstack.org/#/c/562489 ipam_backend_mixin: Service Type model to OVO - Vu Cong Tuan
14:08:56 <njohnston> This one has been sitting since April, I think it is ripe for revival but some comments need to be addressed.
14:09:14 <njohnston> I don't know if the author is still attending to it.  Do you know, TuanVu?
14:09:16 <TuanVu> yeah, I'm trying to apply your suggestion
14:09:30 <njohnston> Ah, never mind, I just realized you are the author :-)
14:09:49 <TuanVu> hopefully you've received my email
14:10:08 <njohnston> Yes I did!  Let me talk about that in a later section.
14:10:17 <TuanVu> it would be great if there's example about mentioned implementation
14:10:23 <TuanVu> awesome!
14:10:27 <TuanVu> thank you very much!
14:10:35 <njohnston> #link https://review.openstack.org/#/c/561834 ipam_backend_mixin: Segments model to OVO - Vu Cong Tuan
14:11:34 <njohnston> Any thoughts on that one, TuanVu?
14:11:45 <TuanVu> this one is the same
14:12:00 <TuanVu> I'll work on it after Service Type OVO patch
14:12:07 <njohnston> sounds good
14:12:25 <njohnston> #topic OVO Joins
14:12:40 <njohnston> OK, so I have had discussions with a number of people in the community.
14:12:54 <njohnston> The problem is that a SQL join performs multiple functions
14:13:54 <njohnston> It can join an element in one table with an element in another table based on a common field
14:14:18 <njohnston> Or it can locate N elements that exist only in both of 2 tables (inner join)
14:14:44 <TuanVu> ok
14:14:46 <njohnston> Or it can elements in table 1, and then optionally enrich them with data from table 2 if it exists (outer join)
14:15:48 <njohnston> What I noticed is that in the existing OVO code there are places where it looks like complex SQL Alchemy including joins has just been forklifted into the object
14:16:37 <TuanVu> yeah
14:16:52 <njohnston> #link https://git.openstack.org/cgit/openstack/neutron/tree/neutron/objects/ports.py#n472 Example query with join and filter in an OVO
14:17:24 <njohnston> So is that the pattern we should be following, so that we retain the assumptions inherent in what a 'join' is?
14:18:03 <njohnston> I will keep investigating, and hope to return a recommendation, including an example implementation change, next week.
14:18:08 <njohnston> It's a complex question :-)
14:18:28 <TuanVu> awesome explanation :)
14:18:32 <TuanVu> thank you very much
14:18:37 <TuanVu> it sounds great!
14:18:48 <njohnston> I appreciate your vote of confidence :-)
14:19:20 <njohnston> #topic Open Discussion
14:19:29 <njohnston> Anything else to talk about?
14:19:58 <TuanVu> nothing else from me
14:20:13 <njohnston> OK.  Thanks very much TuanVu!
14:20:31 <njohnston> lujinluo will be back next week, so it will be a return to normal order :-)
14:21:03 <TuanVu> I hope so
14:21:17 <TuanVu> btw, Luo is leaving Fujitsu
14:21:21 <njohnston> Oh, also the position of Neutron liaison to the Oslo team was vacated, and I volunteered to take it on.
14:21:45 <njohnston> Oh?  I wish her the best with her new endeavor!
14:21:59 <TuanVu> yeah, me too
14:22:06 <njohnston> The important question: do you know if she will be continuing in the OpenStack community?
14:22:27 <TuanVu> regarding to your volunteer, it's great!
14:22:35 <TuanVu> I'm not sure
14:22:47 <TuanVu> we can talk about that next week, I think
14:22:51 <njohnston> We'll have to ask her all the questions next week, indeed.
14:22:56 <TuanVu> yeah
14:23:15 <njohnston> OK, I think that is everything for today.  More than half an hour back to you!  Have a lovely day.
14:23:17 <njohnston> #endmeeting