14:09:09 <mlavalle> #startmeeting neutron_routed_networks
14:09:10 <openstack> Meeting started Tue Aug  9 14:09:09 2016 UTC and is due to finish in 60 minutes.  The chair is mlavalle. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:09:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:09:14 <openstack> The meeting name has been set to 'neutron_routed_networks'
14:09:20 <mlavalle> #chair jonh-d
14:09:21 <openstack> Warning: Nick not in channel: jonh-d
14:09:22 <openstack> Current chairs: jonh-d mlavalle
14:09:35 <mlavalle> #chair john-davidge
14:09:37 <openstack> Current chairs: john-davidge jonh-d mlavalle
14:09:50 <mlavalle> #chair carl_baldwin
14:09:51 <openstack> Current chairs: carl_baldwin john-davidge jonh-d mlavalle
14:10:13 <mlavalle> in case carl_baldwin jojns later :-)
14:10:13 <john-davidge> mlavalle: Thanks
14:10:24 <mlavalle> Agenda is here:
14:10:27 <john-davidge> #topic Announcements
14:10:31 <mlavalle> #link https://etherpad.openstack.org/p/routed-provider-networks-notes
14:10:40 <carl_baldwin> Sorry. /me totally late.
14:10:55 <john-davidge> Mid-cycle is next week!
14:10:57 <john-davidge> #link https://etherpad.openstack.org/p/newton-neutron-midcycle
14:10:58 <mlavalle> carl_baldwin: I started the meeting already
14:11:00 <carl_baldwin> Thanks for starting mlavalle
14:11:12 <john-davidge> carl_baldwin: Hi Carl, it's all yours :)
14:11:15 <carl_baldwin> I was thinking 9am
14:11:35 <carl_baldwin> mlavalle, could you drive for a bit?
14:11:58 <mlavalle> carl_baldwin: john-davidge is driving. this is the day I have an audio meeting at the same time
14:12:12 <john-davidge> carl_baldwin: I'm happy to keep driving
14:12:12 <mlavalle> john-davidge: carry on please
14:12:29 <john-davidge> okie dokie, any other announcements?
14:12:46 <john-davidge> #topic Reviews
14:12:55 <john-davidge> #link https://review.openstack.org/#/q/status:open+topic:bp/routed-networks
14:13:06 <john-davidge> #link https://review.openstack.org/#/q/status:open+topic:bp/service-subnets
14:13:21 <john-davidge> #link https://review.openstack.org/#/q/status:open+topic:bp/neutron-routed-networks
14:14:15 <john-davidge> Any reviews anybody would like to highlight?
14:14:40 <mlavalle> Earlier this week I pushed https://review.openstack.org/#/c/350665/
14:14:58 <mlavalle> This patchset adds the segment_id to the ports dictionary
14:15:13 * john-davidge looks
14:15:27 <mlavalle> it will be used by Nova when scheduling instances
14:15:36 <blogan> o/
14:16:29 <john-davidge> mlavalle: Looks like it's had some review attention in the last couple days. Do you have everything you need to roll another patchset?
14:16:38 * carl_baldwin 's laptop not connecting to net
14:16:47 <mlavalle> john-davidge: no. I just wanted the team to be aware of it
14:17:02 <john-davidge> mlavalle: Ok, thanks
14:17:07 <mlavalle> carl_baldwin: don't worry. we are managing well
14:17:28 <carl_baldwin> The one I wish to highlight as a top priority is https://review.openstack.org/#/c/317358
14:17:50 <john-davidge> There are a lot of patches in the review queue with jenkins failures and merge conflicts, so if you own any of those please make sure they're up to date
14:18:29 <mlavalle> carl_baldwin: if that helps, I'll take a look later
14:18:36 <mlavalle> today
14:19:08 <john-davidge> I pushed a new patch for service subnets CRUD today - https://review.openstack.org/#/c/337851/
14:19:25 <john-davidge> It addresses armax's concerns
14:19:53 <john-davidge> I'll have a new patchset for port creation soon - https://review.openstack.org/#/c/350613/
14:20:12 <carl_baldwin> john-davidge: Thanks for the quick attention on that.
14:20:36 <john-davidge> carl_baldwin: Thanks for the plentiful reviews!
14:21:34 <carl_baldwin> john-davidge: keep them coming
14:21:35 <john-davidge> The python-neutronclient change is ready to merge as soon as the CRUD patch does https://review.openstack.org/#/c/342976/
14:21:40 <john-davidge> Thanks haleyb!
14:22:09 <john-davidge> Any other reviews to highlight?
14:22:45 <haleyb> np, i never saw this meeting reminder, getting old or something
14:22:56 <haleyb> thank you for getting the other patches in shape
14:23:12 <john-davidge> haleyb: np :)
14:23:16 <mlavalle> haleyb: or maybe looking forward to vacation week :-)
14:23:26 <john-davidge> #topic Docs
14:23:40 * mlavalle will miss his DEC buddy in Ireland
14:23:42 <john-davidge> carl_baldwin: Any doc updates?
14:24:12 <carl_baldwin> Not like I wanted to. I didn't get as much done on docs.
14:24:17 <carl_baldwin> Still working...
14:24:36 <mlavalle> Maybe something we want to tackle next week in Cork?
14:24:37 <carl_baldwin> I might just have to acknowledge that docs will come after N-3
14:24:55 <carl_baldwin> mlavalle: We could. Sometimes docs writing is a good on-plane activity.
14:25:04 <carl_baldwin> ... unless I'm wiped
14:25:05 <john-davidge> mlavalle carl_baldwin: Yeah, I'm sure we could find some time to sit down together on docs next week
14:25:33 <mlavalle> carl_baldwin: I am willing to help with that, if you need help
14:25:39 <carl_baldwin> I'll keep trying to get a rough draft, or at least an outline ready for then.
14:26:21 <carl_baldwin> If not, we'll have to start from very little.
14:26:21 <john-davidge> carl_baldwin: happy to take a look whenever you need reviews etc
14:26:51 <john-davidge> #topic Testing
14:26:59 <mlavalle> Hi
14:27:11 <mlavalle> so we made good progress this past week
14:27:24 <mlavalle> I'll let yb update the team
14:28:32 <mlavalle> maybe yb left the meeting
14:28:39 <yb> Hi, I think I need write the test cases to test the instances in two different segmentations
14:28:53 <mlavalle> we have scenario test up for review https://review.openstack.org/#/c/347188/
14:29:10 <carl_baldwin> mlavalle: I'll review it.
14:29:16 <mlavalle> we are getting reviews
14:29:17 <yb> I have almost finish testing the pre-port creation and insufficient ip addresses scenarios
14:30:22 <mlavalle> john-davidge: that's probably it on this subject this week
14:30:29 <john-davidge> yb: mlavalle: Sounds good, thank you
14:30:36 <john-davidge> #topic Integration with Nova Scheduler
14:30:38 <mlavalle> yb: thanks for your hard work!
14:30:50 <yb> Thanks:)
14:30:52 <mlavalle> Hi again
14:30:56 <carl_baldwin> yb ++
14:31:08 <yb> carl_baldwin::)
14:31:30 <mlavalle> On this topic, as I mentioned earlier I worked on publishing the segment id on ports reesponses
14:32:04 <mlavalle> This is important for the Nova scheduler to select hosts where an instance will be schduled
14:32:31 <mlavalle> I have also been playing with the Generic Resource Pools API in Nova
14:33:01 <mlavalle> That is the API that we will use to inform Nova scheduler of our routed networks / segment topology
14:33:28 <john-davidge> mlavalle: Anything you'd like to get some eyes on?
14:33:52 <mlavalle> The key idea I want to share with the team is that I want to use is the association of subnets with a segment
14:34:17 <mlavalle> #link https://github.com/openstack/neutron/blob/master/neutron/plugins/ml2/plugin.py#L972
14:34:53 <mlavalle> In my opinion we want only to send segments data to Nova when it is indeed a segment associated with a routed network
14:35:27 <carl_baldwin> mlavalle: ++
14:35:39 <mlavalle> Therefore I want to use the notification of subnet create (when segments are associated to subnets) to trigger the update of Nova
14:36:12 <mlavalle> And that got me thinking also about segment host mapping
14:36:43 <mlavalle> Maybe we want to simplify it and only add segments to the host mapping when they are associated to subnets
14:36:56 <mlavalle> that may be a follow up port N-3
14:37:11 <mlavalle> we can discuss in Cork
14:37:37 <mlavalle> that's it on this topic
14:37:51 <john-davidge> mlavalle: Sounds like good progress, thanks!
14:37:58 <carl_baldwin> Let's talk about it next week.
14:38:04 <john-davidge> #topic Service Subnets
14:38:22 <john-davidge> We touched on this already, but I'll highlight the review topic again:
14:38:36 <john-davidge> #link https://review.openstack.org/#/q/status:open+topic:bp/service-subnets
14:39:12 <john-davidge> Progress has been very good I think. Everything will start falling into place once https://review.openstack.org/#/c/337851/ merges
14:39:18 <carl_baldwin> I'll have another look today.
14:39:23 <john-davidge> haleyb: Anything to add?
14:40:54 <haleyb> john-davidge: no, i think it's in good shape.  There will probably be some l3-agent work once we get the ipam changes in, hopefully not too bad
14:41:46 <carl_baldwin> haleyb: what needs to change in the agent?
14:41:58 <john-davidge> haleyb: I hadn't anticipated any, what did you have in mind?
14:42:52 <haleyb> carl_baldwin: i'm thinking there might be a small tweak when the router IP is in a different subnet than the floating IP, might be wrong but it gets to the email sent to the list from Hui (?)
14:43:39 * carl_baldwin behind on ML again
14:44:31 <john-davidge> haleyb: Yeah I remember the email, will see if I can dig it up again. Thanks
14:44:48 <john-davidge> haleyb: Let's follow up next week
14:45:03 <haleyb> it was from last week, but relates to having an existing subnet route when adding the floating IP
14:45:25 <carl_baldwin> Anyone have a link?
14:45:54 <haleyb> carl_baldwin: i could be completely wrong too, looking for the link
14:46:38 <haleyb> http://lists.openstack.org/pipermail/openstack-dev/2016-July/100494.html
14:47:22 <carl_baldwin> Right, I do remember that one (even responded at one point).
14:48:09 <carl_baldwin> I might have to reread to see if there is still any issue. Also, we'll need to do some full testing in a multi-node system.
14:48:24 <carl_baldwin> So, there might yet be some work to do.
14:48:34 <john-davidge> carl_baldwin: ++
14:48:34 <carl_baldwin> Thanks for pointing that out, haleyb
14:48:42 <haleyb> right, it's more of a concern until we get some testing in, didn't want us to think it was clear sailing from here
14:48:55 <carl_baldwin> haleyb: ++
14:49:39 <john-davidge> haleyb: Thanks for raising that, let's move on to the next topic
14:49:42 <john-davidge> #topic Client
14:50:00 <john-davidge> rtheis: Hi
14:50:04 <rtheis> hi
14:50:23 <john-davidge> rtheis: Any client work you'd like to highlight?
14:50:42 <rtheis> no, just waiting for create and delete segment to merge
14:51:07 <rtheis> https://review.openstack.org/#/c/317358
14:51:50 <john-davidge> rtheis: Thanks
14:51:58 <rtheis> yw
14:51:59 * john-davidge reminds himself to go and review that patch
14:52:15 <john-davidge> #topic Open Discussion
14:52:22 <john-davidge> That's it, anything we've missed?
14:52:26 <carl_baldwin> rtheis: thanks
14:52:58 <carl_baldwin> Now that we have a good start on service subnets, I'm starting to think about how to do floating ips on a routed network.
14:53:32 <carl_baldwin> We need to be able to associate a fip with a port on the routed network instead of through a neutron router.
14:53:43 <carl_baldwin> And, it will require routing.
14:54:02 <mlavalle> is this something we want to do in Newton?
14:54:09 <carl_baldwin> No.
14:54:14 <mlavalle> ok
14:54:23 <carl_baldwin> Just thinking about it.
14:54:40 <carl_baldwin> Something to keep my mind busy while running, biking, swimming, etc.
14:55:00 <mlavalle> or doing yoga
14:55:03 <mlavalle> :-)
14:55:11 <carl_baldwin> mlavalle: I should do that too.
14:55:53 <john-davidge> I can't usually think about anything other than the TRON Legacy soundtrack while doing those things
14:56:09 <mlavalle> john-davidge: lol
14:56:10 <carl_baldwin> BTW, I was running blissfully this morning at 8am thinking that our meeting was an hour later. Apologies again for that.
14:56:11 <john-davidge> neutron thinking comes just as im trying to fall asleep :)
14:56:35 <carl_baldwin> john-davidge: you mean it puts you to sleep.
14:56:54 <john-davidge> carl_baldwin: Quite the opposite!
14:56:58 <mlavalle> john-davidge: that happens to me as well some times. and no, it wakes me up
14:57:05 <mlavalle> carl_baldwin: ^^^
14:57:11 * john-davidge hasn't slept since learning what a Neutron was
14:57:25 <carl_baldwin> john-davidge: I see, neutron induced insomnia .  I get that too.
14:57:37 <carl_baldwin> nii
14:57:41 <john-davidge> #action carl_baldwin to take his morning run an hour earlier next week
14:58:13 <john-davidge> And speaking of next week, I imagine many of us will be travelling for the midcycle on tuesday
14:58:19 <john-davidge> will we cancel the meeting?
14:58:47 <carl_baldwin> john-davidge: I will be in HPE's Galway office. So, I could go either way.
14:59:13 <john-davidge> I'll be on a plane I believe
14:59:27 <mlavalle> I will be already in Cork, so I can attend if needed
14:59:50 <john-davidge> Ok, we're out of time so lets discuss on the ML if neccessary
14:59:54 <john-davidge> thanks everyone!
15:00:06 <john-davidge> #endmeeting