14:02:05 <carl_baldwin> #startmeeting neutron_routed_networks
14:02:06 <openstack> Meeting started Tue May 31 14:02:05 2016 UTC and is due to finish in 60 minutes.  The chair is carl_baldwin. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:10 <openstack> The meeting name has been set to 'neutron_routed_networks'
14:02:22 <carl_baldwin> #topic Announcements
14:02:29 <carl_baldwin> #link https://etherpad.openstack.org/p/routed-provider-networks-notes
14:02:38 <carl_baldwin> N-1 is going to be any time now.
14:03:38 <carl_baldwin> Any other announcements?
14:04:13 <mlavalle> TThe Neutron mid-cycle will be in Cork Ireland, August 15-17
14:04:26 <blogan> mlavalle: 17-19 now
14:04:36 <carl_baldwin> mlavalle: Thanks.
14:04:46 <carl_baldwin> That date change will make it harder for me.
14:05:09 <carl_baldwin> But, there is the holiday on the 15th.
14:05:16 <carl_baldwin> So, that didn't make much sense.
14:05:32 <blogan> yeah
14:05:42 <blogan> neither works for me
14:06:01 <carl_baldwin> I might have to make the last day a travel day.
14:06:06 <mlavalle> Both are fine with me
14:06:27 <carl_baldwin> Any others?
14:07:09 <carl_baldwin> ok
14:07:13 <carl_baldwin> #topic Progress
14:07:58 <carl_baldwin> We've made great progress.  The first three topics, segment crud, subnets to segments, and host to segment are in pretty good shape.
14:08:13 <mlavalle> yeah!
14:08:23 <carl_baldwin> There are a couple of cleanup patches in there that could use some review as your time permits.
14:08:41 <carl_baldwin> #link https://review.openstack.org/#/c/312688/
14:08:49 <carl_baldwin> #link https://review.openstack.org/#/c/295173
14:09:11 <carl_baldwin> #topic Segment Aware IP Allocation
14:09:23 <carl_baldwin> I think this is in pretty good shape and patches are up.
14:09:45 <carl_baldwin> #link https://review.openstack.org/#/c/314815
14:10:02 <carl_baldwin> #link https://review.openstack.org/320631
14:10:18 <carl_baldwin> ^ I think these are the new priority patches to review / merge.
14:10:43 <carl_baldwin> Thanks, blogan for the reviews.
14:11:33 <blogan> no problem
14:11:42 <carl_baldwin> We also have an ML2 bug to fix.
14:11:46 <carl_baldwin> #link https://review.openstack.org/#/c/320657
14:11:54 <carl_baldwin> #link https://review.openstack.org/#/c/321152
14:12:02 <carl_baldwin> I'll take this to the ML2 meeting tomorrow.
14:12:31 <carl_baldwin> It prevents deferred IP allocations from being returned with the port update response.  Nova will need it.
14:13:05 <carl_baldwin> #action carl_baldwin will discuss these in the ML2 meeting (tomorrow, I think)
14:13:43 <blogan> progress oh dhcp scheduler: https://review.openstack.org/#/c/311931/
14:14:06 <blogan> carl_baldwin: changed it to use a segment_id column on the networkdhcpagentbindings table
14:14:06 <carl_baldwin> #topic DHCP scheduler
14:15:04 <carl_baldwin> blogan: I was weighing the pros / cons of that approach.
14:15:07 <blogan> obviously tests broke but that did clean the code up and I do believe that segment_id column will be fine for now
14:15:43 <carl_baldwin> blogan: What about when an agent wants to connect to multiple segments on the same network?  Will that prevent it?
14:15:59 <blogan> well since we have to assume a dhcp agent can only communicate with one segment, it works
14:16:21 <carl_baldwin> Do we?
14:16:50 <blogan> carl_baldwin: wasn't that the result of the ML discussion about adding the API calls for segments?
14:16:52 <blogan> to reschedule them?
14:17:21 <carl_baldwin> I'll have to re-read that thread to refresh my memory.
14:17:58 <blogan> i probably should too just to confirm
14:18:39 <carl_baldwin> blogan: If that is the case, I do like that model a little bit better.
14:18:56 <blogan> yeah i do too
14:19:16 <blogan> i do not like what i had to do with the scheduler inheritance though, in the dhcp_agent_scheduler.py file
14:19:37 <blogan> but that's unrelated to the column vs separate table debate
14:20:36 <carl_baldwin> The mro can be kind of pain.
14:20:50 <blogan> carl_baldwin: thanks for the review on it
14:21:03 <carl_baldwin> I'll review it again soon.
14:21:29 <blogan> carl_baldwin: let me get the tests passing so you're not wasting time on the review, unless you're like really really bored and have nothing to do
14:21:34 <blogan> but what are the chances of that?
14:21:45 <mlavalle> lol
14:21:49 <carl_baldwin> blogan: lol
14:21:56 <carl_baldwin> Okay, let me know when it is ready.
14:22:02 <blogan> will do
14:22:21 <carl_baldwin> blogan: anything else?
14:22:42 <blogan> nope thats all for me
14:23:09 <carl_baldwin> #topic Integration with Nova Scheduler
14:23:33 <carl_baldwin> mlavalle: hi
14:23:34 <mlavalle> good progress here as far as specs
14:24:07 <mlavalle> Add prep-for-network-aware-scheduling spec got a +2: https://review.openstack.org/#/c/313001/
14:24:29 <mlavalle> I reviewed it last week and added the DNS perspective
14:24:39 <mlavalle> it should merge soon
14:24:42 <carl_baldwin> Cool.
14:24:58 <mlavalle> That work is important because we will code routed networks stuff on top of it
14:25:44 <carl_baldwin> I need to address feedback on mine, speaking of stuff on top of it.
14:25:47 <carl_baldwin> #link https://review.openstack.org/#/c/263898/
14:25:47 <mlavalle> The routed networks spec for Nova is maming good progress, despite it got a couple of -1s: https://review.openstack.org/#/c/263898/
14:26:05 <carl_baldwin> #action carl_baldwin will review feedback.
14:26:08 <mlavalle> The feedback from johnthetubaguy was really a soft -1
14:26:19 <mlavalle> we just need to solve a few TODO's left
14:26:54 <johnthetubaguy> yeah, just needs a few more details filling out to push it over the line
14:26:56 <mlavalle> So it seems I am being able to walk the fine line of pushing for reviews without being annoying
14:27:04 <johnthetubaguy> by the way, the deadline is this thursday
14:27:05 <carl_baldwin> mlavalle: johnthetubaguy:  I'll update it today.
14:27:15 <carl_baldwin> johnthetubaguy: Thanks for the heads up.
14:27:39 <carl_baldwin> This long week-end made all the deadlines suddenly seem much closer.
14:27:54 <carl_baldwin> I'll update it first thing after this meeting.
14:28:24 <mlavalle> as soon as johnthetubaguy starts implementing https://review.openstack.org/#/c/313001/
14:28:34 <mlavalle> I'll help in any way needed
14:28:58 <carl_baldwin> mlavalle: Great.
14:29:01 <mlavalle> Reviewing code
14:29:05 <johnthetubaguy> yeah, at this point, thats after the spec deadline, but hope to get to that soonish
14:29:28 <mlavalle> That's all I have this week
14:30:41 <carl_baldwin> I'm going to start working on something related to this this week.  I'm going to start working on the attribute Nova can use to tell when a port will have deferred IP allocation.
14:31:00 <mlavalle> ++
14:31:11 <carl_baldwin> That's all.
14:31:41 <carl_baldwin> #topic L2 Adjacency Extension
14:31:54 <carl_baldwin> reedip: Are you around?
14:32:10 <carl_baldwin> #link https://review.openstack.org/304647
14:32:44 <carl_baldwin> ^ Looks like this needs an update.  That's all.
14:32:49 <mlavalle> carl_baldwin: he commented last week that he recently moved back to India from Japan
14:33:23 <mlavalle> so he's been having trouble working on this. But commited to follow up as soon as possible
14:33:34 <carl_baldwin> mlavalle: Yes, that's right.  Thanks.
14:33:50 <carl_baldwin> #topic Enable Create / Delete of Segments on Existing Network
14:34:09 <carl_baldwin> xiaohhui mentioned he would not be able to make the meeting.
14:34:18 <carl_baldwin> However, he's made some great progress on this.
14:34:49 <carl_baldwin> Looks the the review could use reviews.
14:35:01 <carl_baldwin> #link https://review.openstack.org/#/c/317358
14:36:11 <carl_baldwin> #topic Client
14:36:17 <carl_baldwin> Anyone here to discuss the client?
14:36:21 <rtheis> hi
14:36:38 <rtheis> https://review.openstack.org/#/c/290138/
14:36:47 <rtheis> merged so we now have a couple OSC commands
14:36:54 <carl_baldwin> rtheis: hi
14:37:20 <carl_baldwin> rtheis: That is great progress.
14:37:47 <rtheis> I'll start preparing the next couple commands based on create and delete segment work by xiaohhui
14:38:38 <carl_baldwin> rtheis: Thanks.  Anything else?
14:39:04 <rtheis> I'll also look into OSC command updates for https://review.openstack.org/#/c/288774/
14:39:11 <rtheis> that's it from me for now
14:39:35 <carl_baldwin> rtheis: Thanks.
14:39:43 <carl_baldwin> #topic OVN plugin
14:39:44 <rtheis> carl_baldwin: yw
14:40:02 <carl_baldwin> Anyone around to discuss this?
14:40:13 <rtheis> we are getting close on conversion to ML2
14:40:48 <rtheis> I have several remaining patch sets out that need to merge and then can work on final conversion patch set
14:40:53 <carl_baldwin> I did notice this merged:  https://review.openstack.org/#/c/312705/
14:41:39 <carl_baldwin> rtheis: That is cool.  I imagine with OVN being an ML2 plugin, a lot of this becomes easier.
14:41:45 <rtheis> I think so
14:41:52 <carl_baldwin> It is just a matter of getting host / segment mapping to work.
14:41:55 <carl_baldwin> ... I think.
14:42:13 <rtheis> yeah, I need to review xiaohhui's patch sets as well
14:42:57 * mlavalle panicked for a second. But carl_baldwin means on the OVN side lol
14:42:57 <carl_baldwin> rtheis: Good progress.
14:43:21 <carl_baldwin> mlavalle: Right.  Sorry to cause you panick.  lol
14:43:31 <carl_baldwin> *panic
14:43:41 <carl_baldwin> #topic Open Discussion
14:43:56 <carl_baldwin> Great progress.
14:44:05 <carl_baldwin> I think there are two main areas that need the most attention.
14:44:24 <carl_baldwin> Those are DHCP scheduling and Nova scheduling integration.
14:44:48 <carl_baldwin> But, things are looking really good.
14:45:17 <carl_baldwin> Anything else?
14:45:45 <mlavalle> I want to share with the team my conversation with Matt Musllow about creating a test environment
14:46:00 <mlavalle> Matt Mulsow^^^
14:46:34 <mlavalle> He is with Softlayer and is creating a new cloud with several hundred hypervisors
14:47:00 <mlavalle> He is willing to loan us some of that gear to let us start testing routed networks at some scale
14:47:21 <mlavalle> So there is an email conversation going on with him and carl_baldwin
14:47:31 <mlavalle> I'll keep the team updated on this
14:47:54 <mlavalle> The other thing I am doing on the testing front is to create a Vagrant multinode test environment
14:48:06 <carl_baldwin> mlavalle: Sorry I didn't respond to that email.  Will do soon.
14:48:27 <mlavalle> so everybody can start playing with the feature in a more reallistic way
14:48:50 <mlavalle> carl_baldwin: I am thinking to add a Vagrant folder to the Neutron repo. What do you think?
14:49:01 <mlavalle> Just like the OVN guys do
14:49:41 <mlavalle> That way this work can be re-used beyond the routed networks effort
14:49:42 <carl_baldwin> mlavalle: Interesting.  I think we'll want to ask a much broader group about that.
14:50:04 <mlavalle> In that case, I'll send a message to the ML
14:50:13 <carl_baldwin> I wouldn't object but I imagine that' the kind of thing that people will want to chime in on.
14:50:46 <mlavalle> In the meantime, I'll just create a repo in github.com
14:51:14 <mlavalle> that's all I have
14:51:15 <carl_baldwin> I think sharing a vagrant environment is a great idea.
14:51:29 <carl_baldwin> mlavalle: Thanks.
14:51:58 <carl_baldwin> Anything else?
14:52:21 * mlavalle is shamelessly re-using as much as possible the OVN Vagrant stuff
14:52:58 <carl_baldwin> mlavalle: s/shamelessly/opportunistically/
14:53:18 <carl_baldwin> mlavalle: ^ Your spelling was way off on that one.
14:53:24 <mlavalle> LOL
14:53:26 <carl_baldwin> :)
14:53:31 <carl_baldwin> Going once...
14:53:37 <carl_baldwin> going twice...
14:54:00 <carl_baldwin> Thanks everyone!
14:54:04 <mlavalle> Bye
14:54:07 <carl_baldwin> #endmeeting