14:01:02 <carl_baldwin> #startmeeting neutron_routed_networks
14:01:10 <carl_baldwin> #topic Announcements
14:01:11 <openstack> Meeting started Tue May 17 14:01:02 2016 UTC and is due to finish in 60 minutes.  The chair is carl_baldwin. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:15 <openstack> The meeting name has been set to 'neutron_routed_networks'
14:01:31 <carl_baldwin> #link https://etherpad.openstack.org/p/routed-provider-networks-notes
14:01:48 <carl_baldwin> First, like the L3 meeting agenda, I'm now using the etherpad instead of the wiki.
14:02:06 <carl_baldwin> Second, Newton-1 is just two short weeks away.
14:02:34 <carl_baldwin> Any other announcements?
14:03:04 <carl_baldwin> #topic Progress
14:03:15 <carl_baldwin> The subnet / segment association is now merged.
14:03:26 <mlavalle> ++
14:04:06 <carl_baldwin> I also got one IPAM patch merged which should allow someone to enhance the allocation algorithm to consider multiple subnets at once.
14:05:02 <carl_baldwin> mlavalle: were you or James going to take that?  I forget.
14:05:22 <carl_baldwin> mlavalle: Could you remind of James's nick?
14:05:42 <mlavalle> carl_baldwin: I haven't offered but if you think I can help, I'll take it
14:06:09 <carl_baldwin> It might have been something else I'm thinking of.
14:06:29 <carl_baldwin> mlavalle: Let's make sure we progress on some other things before taking that on.
14:06:39 <mlavalle> ok
14:06:56 <carl_baldwin> #topic Segment / Host Mapping
14:07:09 <carl_baldwin> mlavalle: I've seen that you have an update but I haven't reviewed it yet.
14:07:26 <mlavalle> yeah, I refactored https://review.openstack.org/#/c/285548/ into a class
14:07:45 <carl_baldwin> mlavalle: Ready for review?
14:07:50 <mlavalle> yes
14:08:13 <carl_baldwin> Ok, let's put our review priority on this one.
14:08:31 <carl_baldwin> I'll review it today.
14:08:40 <carl_baldwin> mlavalle: Anything else?
14:08:43 <xiaohhui> I will review it tomorrow :)
14:08:50 <mlavalle> I am still getting a failure with migration script
14:09:06 <carl_baldwin> That same functional test one?
14:09:15 <mlavalle> I will follow up with HenryG about it
14:09:21 <mlavalle> yeah, it is the same one
14:09:38 <mlavalle> hopefully either they fix the test or remove it
14:09:42 <carl_baldwin> Any resolution on what should be done with it?
14:10:00 <carl_baldwin> Oh, so probably no resolution.
14:10:14 <mlavalle> I pinged HenryG yesterday but he didn't respond. I'll follow up today again
14:10:30 <carl_baldwin> mlavalle: Thanks, I'll look for him too.
14:10:48 <HenryG> mlavalle: sorry I missed your ping yesterday
14:10:48 <mlavalle> that's for today
14:11:02 <carl_baldwin> That's the next patch we need to go in.  We've all kind of piled on that one as a dependency.
14:11:06 <mlavalle> HenryG: any news on that functional test failing?
14:11:39 <HenryG> mlavalle: can you refresh my memory?
14:12:13 <mlavalle> HenryG: the test migration test that is failing with my contract script
14:12:29 <mlavalle> it gets angry becasuse I have a create table there
14:13:01 <HenryG> mlavalle: ah yes, I wanted to talk to Ihar about that
14:13:02 <mlavalle> this is the patchset:  https://review.openstack.org/#/c/285548/
14:13:25 <mlavalle> yeah, I think he is back from vacation since yesterday
14:14:25 <carl_baldwin> HenryG: Hopefully we can come to a resolution soon.  Thanks for your help.
14:14:26 <mlavalle> carl_baldwin: we can move on for the purpose of this meeting. I'll follow up with HenryG today
14:14:32 <carl_baldwin> mlavalle: thanks.
14:14:41 <carl_baldwin> #topic Segment Aware IP Allocation
14:14:56 <carl_baldwin> I've made some progress on this.
14:15:17 <carl_baldwin> I have a patch up which uses segment / host mapping to allocate IP addresses from the right segment on port create.
14:15:27 <carl_baldwin> #link https://review.openstack.org/#/c/314815
14:15:36 <carl_baldwin> This one is ready for review.
14:16:07 <carl_baldwin> Basically, if subnets are on segments then IPAM needes binding information to allocate IP addresses.  If no binding information, then it doesn't allocate any.
14:16:56 <carl_baldwin> I am currently working on a patch to follow up and do IP allocation on port update.
14:17:08 <carl_baldwin> That one isn't up yet but I'll be sure to put it on the etherpad when it is.
14:17:19 <xiaohhui> What is the binding information? port bind to segment?
14:17:48 <carl_baldwin> xiaohhui: All that is needed is the binding:host parameter.
14:18:06 <xiaohhui> OK, thanks
14:18:26 <mlavalle> and that is where the host segments mappings get in the picture, right? :-)
14:18:40 <carl_baldwin> xiaohhui: I raise an exception if there are multiple segments on the network connected to the host.
14:18:56 <carl_baldwin> xiaohhui: ... until we can discuss the issue that you brought up in the etherpad.
14:19:03 <carl_baldwin> mlavalle: right
14:19:23 <xiaohhui> So, this is a TODO, instead of a limitation, right?
14:19:58 <carl_baldwin> xiaohhui: Yes.
14:20:49 <carl_baldwin> xiaohhui: However, I would like to think about the use cases for multiple segments connected to a single host.
14:21:07 <carl_baldwin> xiaohhui: I'm not sure it is very compelling.  Do you have use cases for this in mind?
14:21:38 <xiaohhui> All I can think about now is mutiple-nic at host
14:22:03 <xiaohhui> each nic connect to a physical network
14:23:06 <carl_baldwin> xiaohhui: that is more an implementation than a use case.  I want to know why an operator wants to do it.
14:23:28 <carl_baldwin> I'm adding a note to the etherpad.  We can continue the discussion out of band.
14:23:51 <xiaohhui> Yeah, I can think some details off the meeting
14:24:07 <carl_baldwin> xiaohhui: thanks.
14:24:16 <xiaohhui> :)
14:25:01 <carl_baldwin> My next step will be to start discussions with Nova about how to do the deferred IP allocation (and unaddressed ports) thing.
14:25:19 <carl_baldwin> There is an old spec in Nova about this that I'll respin as soon as I can get to it.
14:26:25 <carl_baldwin> I'm finding the link, almost there.
14:26:37 <carl_baldwin> #link https://blueprints.launchpad.net/nova/+spec/vm-boot-with-unaddressed-port
14:26:48 <carl_baldwin> Anyway, that's all on this topic.
14:27:22 <carl_baldwin> #topic DHCP scheduler
14:27:23 <carl_baldwin> blogan let me know he wouldn't be able to make it today.
14:28:01 <carl_baldwin> There is a patch up.
14:28:14 <carl_baldwin> #link https://review.openstack.org/#/c/311931
14:29:04 <carl_baldwin> ... and there is a discussion to be had about how the APIs should look for managing DHCP scheduling for segments
14:29:28 <carl_baldwin> Basically, the segment analog to the APIs we have for managing it for networks.
14:29:46 <mlavalle> right
14:30:01 <carl_baldwin> I'm wondering what the best way to move that discussion along will be.
14:30:05 <carl_baldwin> Should it go to the ML?
14:30:51 <mlavalle> yeah, let's do that
14:31:11 <mlavalle> worst case we end up discusssing among ourselves anyway
14:31:35 <carl_baldwin> ok, I'll work with blogan to do that.
14:31:48 <carl_baldwin> #action carl_baldwin to work with blogan to get discussion going.
14:32:10 <carl_baldwin> I see that blogan added some notes to the etherpad.
14:32:22 <carl_baldwin> #topic Integration with Nova Scheduler
14:32:29 <carl_baldwin> mlavalle: still around?
14:32:36 <mlavalle> yes
14:33:03 <mlavalle> good news regarding the generic resource pools specs
14:33:12 <mlavalle> it merged last night
14:33:27 <carl_baldwin> mlavalle: Nice.  So, ours is up next?
14:33:31 <mlavalle> https://review.openstack.org/#/c/300176/
14:33:43 <mlavalle> yeah, that is what mriedem said
14:34:01 <mlavalle> I just started bugging him this morning
14:34:21 <mlavalle> right now he is a meeting. He will get back to me today
14:34:37 <carl_baldwin> mlavalle: Thanks.
14:34:53 <carl_baldwin> Anything else?
14:35:14 <mlavalle> also, I would like to see if johnthetubaguy made any progress with the refactoring of allocate for instance
14:35:54 <johnthetubaguy> so tiny bit of progress
14:36:02 <johnthetubaguy> got some positive noises on the spec: https://review.openstack.org/#/c/313001/
14:36:17 <johnthetubaguy> currently tied up doing spec reviews, with that deadline looming large, for Nova at least
14:36:44 <johnthetubaguy> it would be great to get more eyes on that spec
14:36:44 <carl_baldwin> johnthetubaguy: when is that deadline?
14:37:01 <mlavalle> johnthetubaguy: I'll review it today
14:37:13 <johnthetubaguy> http://releases.openstack.org/newton/schedule.html
14:37:16 <johnthetubaguy> 2nd june
14:37:25 <johnthetubaguy> http://releases.openstack.org/newton/schedule.html#nova-non-priority-spec-approval-freeze
14:37:37 <carl_baldwin> johnthetubaguy: Thanks.
14:37:41 <mlavalle> johnthetubaguy: anything we can do to help?
14:37:46 <carl_baldwin> I'll go read that spec.
14:37:49 <mlavalle> besides reviewing
14:37:52 <johnthetubaguy> I think thats the main things right now
14:38:06 <mlavalle> will do :-) Thanks for your help!
14:38:19 <johnthetubaguy> we should look into the routed networks nova spec again I guess, how is that looking?
14:38:37 <mlavalle> Today I am following up with mriedem
14:38:37 <carl_baldwin> johnthetubaguy: lonely.
14:38:54 <johnthetubaguy> whats the link again, so it gets to the top of my queue more quickly :)
14:39:14 <carl_baldwin> #link https://review.openstack.org/#/c/263898/
14:39:27 <carl_baldwin> johnthetubaguy: ^ that's it.  Thanks.
14:39:45 <mlavalle> johnthetubaguy: last time we talked about it with mriedem about it, we were going to merge genrric resource pools and the routed networks was next
14:39:46 <johnthetubaguy> cool, its in a tab again :)
14:39:57 <mlavalle> grp merged last night
14:40:05 <johnthetubaguy> yeah, that sounds right
14:40:24 <mlavalle> so I am followup with mrioedem today to make sure that happens :-)
14:41:06 <johnthetubaguy> all sounds good
14:41:20 <mlavalle> carl_baldwin: that's all I have today
14:41:28 <carl_baldwin> mlavalle: johnthetubaguy:  thank you.
14:41:35 <carl_baldwin> keep up the good work.
14:41:38 <carl_baldwin> #topic Enable Create / Delete of Segments on Existing Network
14:41:44 <carl_baldwin> xiaohhui: You still around?
14:41:50 <xiaohhui> yeah
14:41:59 <xiaohhui> I posted a patch today
14:42:02 <carl_baldwin> I sent a message to the mailing list toward the end of the week last week about this.
14:42:24 <carl_baldwin> #link http://lists.openstack.org/pipermail/openstack-dev/2016-May/094833.html
14:42:51 <xiaohhui> Although I tagged WIP, I think it is ready for review. I will reply that mail to point out some thing to discuss
14:42:58 <carl_baldwin> I'm hoping for a response for Sukhdev and rkukura
14:43:08 <carl_baldwin> xiaohhui: Do you have a link?
14:43:21 <carl_baldwin> I see a link on the etherpad
14:43:27 <xiaohhui> https://review.openstack.org/#/c/317358
14:43:40 <xiaohhui> yeah, I update the etherpad right before the meeting
14:45:10 <carl_baldwin> xiaohhui: Thanks.
14:45:43 <xiaohhui> Thank you for the advice ealier today
14:45:50 <carl_baldwin> xiaohhui: At first glance, it looks like a good start.
14:46:11 <xiaohhui> That is great.
14:46:44 <carl_baldwin> xiaohhui: Would you mind replying to my ML thread with some of the points that you have on the etherpad?
14:47:02 <carl_baldwin> I'm hoping to keep that thread alive and start getting attention from ml2 guys.
14:47:03 <xiaohhui> Sure, I plan to do it before I end my today.
14:47:33 <carl_baldwin> xiaohhui: I know its late, tomorrow would be fine.
14:47:48 <xiaohhui> :)
14:47:54 <mlavalle> xiaohhui: yeah, way too late for you
14:48:00 <carl_baldwin> xiaohhui: Thanks.
14:48:19 <xiaohhui> I have some draft mail written, just need to click the send button.
14:48:31 <mlavalle> xiaohhui: ~10:50 pm?
14:48:46 <xiaohhui> yes, mlavalle
14:49:16 <mlavalle> kudos for your dedication
14:49:21 <carl_baldwin> xiaohhui: We appreciate your time very much.
14:49:40 <xiaohhui> Thanks, guys
14:49:44 <blogan> sorry im extremely late
14:50:05 <carl_baldwin> #topic Open Discussion
14:50:22 <carl_baldwin> I think we've hit all of the hot topics.  What do others have to discuss?
14:50:49 <rtheis> carl_baldwin: a couple client patches are ready for your review
14:50:50 <xiaohhui> I think this patch needs more love https://review.openstack.org/#/c/295173/6
14:50:57 <mlavalle> carl_baldwin: I just want to mention that for host segments mapping I am going to add unit tests today. But the patchset is good for review
14:50:58 <rtheis> SDK: https://review.openstack.org/#/c/290054/
14:51:22 <rtheis> which is needed by OSC: https://review.openstack.org/#/c/290138/
14:52:07 <carl_baldwin> xiaohhui: thanks.  blogan, could you review his?
14:52:33 <carl_baldwin> rtheis: I'll review these today.
14:52:34 <blogan> carl_baldwin, xiaohhui: will do
14:52:45 <rtheis> carl_baldwin: thank you
14:53:09 <xiaohhui> carl_baldwin, blogan: thanks
14:53:59 <carl_baldwin> Anything else?
14:54:18 <carl_baldwin> Going once...
14:54:25 <rtheis> nothing else from me
14:54:38 <carl_baldwin> twice...
14:54:59 <carl_baldwin> #endmeeting