15:00:50 <mlavalle> #startmeeting neutron_l3
15:00:50 <openstack> Meeting started Thu Aug 25 15:00:50 2016 UTC and is due to finish in 60 minutes.  The chair is mlavalle. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:52 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:55 <openstack> The meeting name has been set to 'neutron_l3'
15:01:00 <john-davidge> hi o/
15:01:10 <njohnston> o/
15:01:15 <jschwarz> \o/
15:01:17 <mlavalle> #chair carl_baldwin
15:01:19 <openstack> Current chairs: carl_baldwin mlavalle
15:02:01 <njohnston> carl_baldwin just said that he's off this morning on #openstack-neutron
15:02:09 <mlavalle> Agenda for today is here:
15:02:16 <mlavalle> #https://etherpad.openstack.org/p/neutron-l3-subteam
15:02:28 <mlavalle> njohnston: yeah, I saw that, thanks :-)
15:02:39 <carl_baldwin> I'm mobile and won't be able to participate in general
15:03:08 <mlavalle> carl_baldwin: np, we will try not to wreck the place without your supervision :_)
15:03:29 * john-davidge will try no such thing
15:03:41 <mlavalle> #topic Annoucements
15:03:57 <carl_baldwin> mlavalle: it is in good hands
15:04:27 <mlavalle> So we are getting to the end of Newton.... Next week is L3
15:04:52 <mlavalle> #link https://releases.openstack.org/newton/schedule.html
15:05:37 <mlavalle> any other announcements, reminders from the team?
15:07:00 <mlavalle> ok, moving on
15:07:07 <mlavalle> #topic Bugs
15:07:57 <mlavalle> We don't have any critical bugs this week. The one we had hasn't shown up over a good period of time
15:08:33 <mlavalle> So first High priority one is https://bugs.launchpad.net/neutron/+bug/1583759
15:08:33 <openstack> Launchpad bug 1583759 in neutron "Invalid input for operation: IP allocation requires subnets for network" [High,New] - Assigned to Bharat Kumar (bharatkumar)
15:09:30 <mlavalle> So it is being worked on
15:09:39 <mlavalle> any comments from anyone?
15:10:34 <mlavalle> ok, moving on
15:10:46 <mlavalle> Next one is https://bugs.launchpad.net/neutron/+bug/1609540
15:10:46 <openstack> Launchpad bug 1609540 in neutron "Deleting csnat port fails due to no fixed ips" [High,In progress] - Assigned to Carl Baldwin (carl-baldwin)
15:11:47 <mlavalle> We haven't seen any ocurrences of this one lately either. carl_baldwin added a debug level message to track this one
15:12:28 <mlavalle> I have to check with infra if we get debug level messages in logstash. I will follow up with this
15:13:03 <mlavalle> #action mlavalle to follow up with infra about debug level messages
15:13:22 <mlavalle> any other comments?
15:14:07 <mlavalle> Next one is https://bugs.launchpad.net/neutron/+bug/1562878
15:14:07 <openstack> Launchpad bug 1562878 in neutron "L3 HA: Unable to complete operation on subnet" [High,Confirmed] - Assigned to Ann Taraday (akamyshnikova)
15:14:31 <mlavalle> jschwarz: do you have any comments on this one?
15:14:42 <jschwarz> mlavalle, nopes.
15:14:58 <jschwarz> I haven't had much time to work on this and neither has Ann I think
15:15:14 <mlavalle> jschwarz: you planning to follow up?
15:15:45 <jschwarz> mlavalle, last I tried, I couldn't get this to reproduce
15:15:59 <jschwarz> mlavalle, so until there's a reproduction setup I don't see much value in hunting down ghosts
15:16:05 <jschwarz> also it's not appearing in the gate so..
15:16:38 <mlavalle> jschwarz: ok, do us a favor, since you are closer to Ann's time zone, would you check with her if she is being able to reproduce?
15:16:51 <jschwarz> mlavalle, I'll put a reminder to ask her
15:17:10 <mlavalle> If the answer is no, let's update it and demote it, since it is not showing up in the gate
15:17:19 <jschwarz> sounds good to me
15:17:28 <mlavalle> jschwarz: thanks :-)
15:19:22 <mlavalle> Next one is https://bugs.launchpad.net/neutron/+bug/1610483
15:19:22 <openstack> Launchpad bug 1610483 in neutron "Pluggable IPAM rollback mechanism is not robust" [High,Confirmed]
15:20:08 <mlavalle> Last time we talked about this, john-belamaric was going to check if they could take care of it
15:20:57 <mlavalle> pavel_bondar: do you know anything about following up with this bug ^^^^
15:21:19 <pavel_bondar> mlavalle: I don't have any news about it
15:21:34 <mlavalle> better to follow up with John, right?
15:21:38 <pavel_bondar> But I can ping John about it later today
15:21:59 <mlavalle> pavel_bondar: yeah, please do that and leave us anote in the bug, please
15:22:04 <pavel_bondar> mlavalle: it would be even better, to check directly with John
15:22:20 <mlavalle> pavel_bondar: ok, I'll follow up with John directly
15:22:45 <mlavalle> #action mlavalle to follow up with John Belamaric about https://bugs.launchpad.net/neutron/+bug/1610483
15:22:45 <openstack> Launchpad bug 1610483 in neutron "Pluggable IPAM rollback mechanism is not robust" [High,Confirmed]
15:23:41 <mlavalle> Last one in the list is https://bugs.launchpad.net/neutron/+bug/1612186
15:23:41 <openstack> Launchpad bug 1612186 in neutron "failed to create flavor router" [High,In progress] - Assigned to yong sheng gong (gongysh)
15:24:27 <mlavalle> This is a new one that njohnston helped us recently to triage
15:24:33 <mlavalle> Thanks
15:24:40 <njohnston> happy to help
15:24:48 <mlavalle> And it is being worked on
15:24:58 <mlavalle> any additional comments?
15:25:51 <mlavalle> Any other bugs from the team that I might have missed?
15:26:51 <mlavalle> ok, moving on
15:27:29 <mlavalle> #topic Routed Networks
15:27:59 <mlavalle> Here, in the absence of carl_baldwin I just want to highlight a few patchsets
15:28:28 <mlavalle> Number 1 is https://review.openstack.org/#/c/350613/ by john-davidge
15:28:39 <mlavalle> it merged last night
15:28:57 <john-davidge> Woohoo! \o/
15:29:21 <mlavalle> Great job! And I personally found it very educational with the discussion of joins vs filters :-)
15:29:34 <john-davidge> No critical gate-breakers reported yet. I'll continue to keep my fingers crossed
15:30:32 <mlavalle> The other patchset worth mentioning is the enablement of segments creation and deletion in ml2
15:30:38 <mlavalle> #link https://review.openstack.org/#/c/317358
15:31:12 <mlavalle> We need ML2 expert eyes to review it. hoping kevinbenton have time to take a look soon
15:31:45 <mlavalle> anything ele I might be missing john-davidge ?
15:32:15 <john-davidge> mlavalle: Nothing else that carl_baldwin mentioned as high priority iirc
15:32:37 <john-davidge> mlavalle: I have a documentation WIP for the networking guide for service subnets #link https://review.openstack.org/#/c/360526/
15:32:54 <mlavalle> ok, will take a look
15:33:46 <mlavalle> and that reminds me also of carl_baldwin's documentation:
15:33:52 <mlavalle> #link https://review.openstack.org/#/c/356013/
15:34:07 <mlavalle> This is the routed networks doc. Please take time to review it
15:34:24 <mlavalle> Moving on
15:34:45 <john-davidge> mlavalle: will do, thanks
15:34:47 <mlavalle> #chair tidwellr
15:34:48 <openstack> Current chairs: carl_baldwin mlavalle tidwellr
15:35:06 * tidwellr is sorry for joining late
15:35:07 * mlavalle adding some fault tolerance to the meeting :-)
15:35:20 <mlavalle> #topic BGP Dynamic Routing
15:35:32 <mlavalle> tidwellr, steve_ruan: you are on
15:35:42 <steve_ruan> yes
15:35:59 <steve_ruan> I submit a new spec for bgp evpn advertisement
15:36:12 <steve_ruan> totally in depend on networking-bgpvpn
15:36:28 <steve_ruan> please help review
15:36:47 <steve_ruan> https://review.openstack.org/#/c/360620
15:37:01 <tidwellr> steve_ruan: I'm trying to make time for it, I've got other things I'm trying to get in to Newton, sorry for the silence
15:37:31 <tidwellr> steve_ruan: I'll try to catch carl_baldwin today to chat about it and get this lined up for the drivers meeting
15:37:43 <steve_ruan> <tidwellr> thanks,
15:38:10 <tidwellr> btw we finally have the all voting jobs up and running against neutron-dynamic-routing, spinout is complete
15:38:24 <mlavalle> \o/
15:38:34 <tidwellr> that's all I had
15:38:54 <mlavalle> tidwellr, steve_ruan: thanks for the updates
15:39:05 <mlavalle> #topic FWaaS
15:39:11 <mlavalle> njohnston: your turn
15:39:36 <njohnston> Hi!  So almost all of the L3 agent extension patches are merged, thanks for everyone's help, support, and reviews.
15:39:42 <njohnston> The one that is left is https://review.openstack.org/#/c/357503/
15:40:05 <njohnston> carl_baldwin had some review comments on that, and I am going to sync with him later when he is in.
15:40:33 <njohnston> We're also working on the FWaaS side for the FWaaS L3 agent extension, it looks like things are going all right
15:41:04 <njohnston> I think that covers the current state of things.
15:41:36 <mlavalle> njohnston: thanks for the update
15:42:28 <mlavalle> #topic Conversion to Pluggable IPAM
15:43:00 <mlavalle> Here the update is that we switched to pluggable IPAM since 2 weeks ago:
15:43:07 <mlavalle> #link https://review.openstack.org/#/c/181023
15:43:28 <mlavalle> So far so good.... \o/
15:43:51 <pavel_bondar> great :)
15:44:42 <mlavalle> #topic Open Discussion
15:44:56 <jschwarz> Hi
15:45:02 <mlavalle> hey
15:45:20 <jschwarz> So I brought this up during yesterday's DVR meeting - there were talks in the midcycle regarding adding a new DVR+HA job to the gate
15:45:58 <jschwarz> it's unclear in what setting this will come to light (a new experimental job? re-using the existing multinode-dvr?)
15:46:28 <jschwarz> and it's unclear how many nodes each job will require, but it looks like 3 (2 dvr_snat+ha, 1 dvr)
15:46:56 <jschwarz> Looking for the best approach to not piss off #openstack-infra as much :)
15:47:03 <mlavalle> lol
15:47:09 <jschwarz> the thinking is that legacy routers should be deprecated eventually and DVR+HA is the way forward.
15:47:36 <jschwarz> I will ask around people with gate experience during next week and we'll see how best to approach this
15:47:46 <jschwarz> any comments/advices in this matter? :)
15:48:06 <mlavalle> As I said in Cork, let's do it
15:48:32 <mlavalle> let us know if you need any help
15:48:56 <jschwarz> will do
15:49:15 <mlavalle> Thanks for doing this and the update
15:49:21 <jschwarz> :)
15:49:26 <mlavalle> Any other topics?
15:49:45 <jschwarz> Ah yes,
15:50:13 <jschwarz> https://review.openstack.org/#/c/255237/ is a very appreciated effort by anilvenakata_afk
15:50:36 <jschwarz> it's all about allowing L3+L2pop to co-exist without wanting to kill eachother, and about unblocking a lot of efforts
15:50:59 <jschwarz> comments on that were a bit sparse lately but now it's been picking up - any comments you guys can throw on that patch are welcomed :)
15:51:24 <mlavalle> ok
15:51:48 <mlavalle> Any other topics?
15:51:50 <jschwarz> that's it from me, I think ;-)
15:52:19 <steve_ruan> hi
15:52:24 <mlavalle> hi
15:52:30 <steve_ruan> I have spec https://review.openstack.org/#/c/282180
15:52:47 <steve_ruan> it has been reviewer for long time, got some +1
15:52:57 <steve_ruan> it need +2 :)
15:53:28 <steve_ruan> could anyone help?
15:54:50 <mlavalle> steve_ruan: will try to help
15:55:17 <steve_ruan> <mlavalle> thanks
15:55:19 <mlavalle> steve_ruan: has it been discussed in the drivers meeting?
15:55:42 <steve_ruan> yes, it's long time ago
15:55:50 <steve_ruan> in M release
15:56:21 <mlavalle> ok, maybe it is an issue of following up with the core reviewers
15:56:50 <mlavalle> Any other topics?
15:57:35 <mlavalle> Ok team, thanks for attending and your updates
15:57:39 <mlavalle> #endmeeting