15:04:09 <mlavalle> #startmeeting neutron_l3
15:04:09 <openstack> Meeting started Thu Aug 20 15:04:09 2015 UTC and is due to finish in 60 minutes.  The chair is mlavalle. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:04:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:04:13 <openstack> The meeting name has been set to 'neutron_l3'
15:04:46 <regXboi> #link https://wiki.openstack.org/wiki/Meetings/Neutron-L3-Subteam Agenda in the usual place
15:04:51 <mlavalle> #topic announcements
15:05:02 <mlavalle> the agenda is here https://wiki.openstack.org/wiki/Meetings/Neutron-L3-Subteam#Agenda
15:05:21 <mlavalle> so, Liberty 3 is August 31st. Almost over
15:05:40 * regXboi would like to see a couple more bug patches land before then ... more on that later
15:05:44 <mlavalle> if you have patchsets that ned to be approved, the sooner the better
15:05:58 <mlavalle> I am myself in that situation
15:06:05 <Medberry2> On board a plane won't be able to help today
15:06:21 <mlavalle> Medberry2: np, have a nice flight
15:06:36 <mlavalle> any other annoucements?
15:06:59 <regXboi> Folks should look at the operator midcycle etherpads for comments about L3 and networking in general
15:07:14 <regXboi> #link https://etherpad.openstack.org/p/PAO-ops-meetup root etherpad link
15:07:26 <mlavalle> great point regXboi !
15:07:43 <regXboi> mlavalle: it was .... ****very**** interesting
15:08:02 <mlavalle> I know..... we have a lot to contribute to that group
15:08:10 <tidwellr> +1, very enlightening
15:08:20 <regXboi> ... and a fair amount to learn ....
15:08:28 <mlavalle> I really encourag people to peruse the etherpads
15:08:32 <amuller> there's a mailing list thread about that
15:08:42 * john-davidge is perusing
15:08:44 <regXboi> amuller: link?
15:09:11 * regXboi mutters "I know I contributed to it, but don't have the link handy... ugh..."
15:09:43 <amuller> [openstack-dev] [Neutron] Etherpad from the Ops Meetup
15:09:53 <tidwellr> https://etherpad.openstack.org/p/PAO-ops-meetup
15:10:04 <regXboi> #link http://lists.openstack.org/pipermail/openstack-dev/2015-August/072462.html start of email thread
15:10:06 <regXboi> found it
15:10:24 <mlavalle> thanks for the links guys!
15:11:03 <mlavalle> ok, moving on.......
15:11:06 <regXboi> I encourage folks to look at all of the etherpads, because networking came up in muliple places
15:11:23 <mlavalle> #topic Bugs
15:11:39 <mlavalle> regXboi: I think you've been hard working with https://bugs.launchpad.net/neutron/+bug/1404743
15:11:39 <openstack> Launchpad bug 1404743 in neutron "sporadic test failures due to VMs not getting a DHCP lease" [Critical,In progress] - Assigned to Ryan Moats (rmoats)
15:12:07 <regXboi> yes, I owe an update to that today
15:12:12 <regXboi> so be on the lookout
15:12:43 <mlavalle> how close are we to resolution?
15:12:53 <regXboi> If this query goes 0, very
15:12:58 * regXboi checking now
15:13:19 <regXboi> in the meantime, let's move on :)
15:13:41 <regXboi> ok, I've got 1 hit in logstash in the last 7 days on one of the two queries
15:13:50 <regXboi> I think we can mark it closed
15:14:05 <regXboi> er ... hold on... browser being difficult
15:15:15 <regXboi> added comment to bug, but I don't have perms to close it
15:15:23 <regXboi> will leave that for somebody that does
15:15:25 <regXboi> next?
15:15:38 <mlavalle> since you have floor, let's do DVR.....
15:15:53 <mlavalle> regXboi: ^^^^
15:15:59 <regXboi> there are three high bugs that I want to cover - all needing review of patch sets
15:16:05 <regXboi> https://bugs.launchpad.net/neutron/+bug/1486627
15:16:05 <openstack> Launchpad bug 1486627 in neutron "DVR doesn't always schedule SNAT routers" [High,In progress] - Assigned to Oleg Bondarev (obondarev)
15:16:11 <regXboi> the patch set is https://review.openstack.org/#/c/215055/
15:16:21 <regXboi> the second bug is https://bugs.launchpad.net/neutron/+bug/1369721
15:16:21 <openstack> Launchpad bug 1369721 in neutron "manually moving dvr-snat router fails" [High,In progress] - Assigned to Oleg Bondarev (obondarev)
15:16:27 <regXboi> patch set is https://review.openstack.org/#/c/122024/
15:16:35 <regXboi> ^^^^^ has 2 +2s already, just needs a W+1
15:16:44 <regXboi> the last bug is https://bugs.launchpad.net/neutron/+bug/1405910
15:16:44 <openstack> Launchpad bug 1405910 in neutron "distributed router can not add routes" [High,In progress] - Assigned to Brian Haley (brian-haley)
15:16:52 <regXboi> it's patch set is https://review.openstack.org/#/c/144205/
15:17:03 <regXboi> all the other High items are in Fix committed state :)
15:17:39 <regXboi> mlavalle: that's my update and ask of folks
15:17:48 <mlavalle> regXboi: thanks for the update
15:17:58 <mlavalle> I have been working with https://bugs.launchpad.net/neutron/+bug/1461172
15:17:58 <openstack> Launchpad bug 1461172 in neutron "neutron.tests.functional.agent.test_l3_agent.MetadataL3AgentTestCase.test_access_to_metadata_proxy times out intermittently" [High,Confirmed] - Assigned to Miguel Lavalle (minsel)
15:18:35 <mlavalle> I am finding difiicult to replicate it in my system...... So I will have to dig deeper in lostash. I'll updsate as I learn more
15:18:44 <haleyb> regXboi: swami also sent out a revert for a recent DVR change which broke things, but i think oleg knows of it now
15:19:00 <regXboi> haleyb: ack - that is in process
15:19:14 <regXboi> haleyb: it's not clear that the revert doesn't break things in its own right
15:19:16 <regXboi> :(
15:20:02 <mlavalle> any other bugs that we might be missing?
15:20:40 <mlavalle> ok, moving on......
15:20:44 <regXboi> mlavalle: I'm planning a re-prioritization after L3 for the next milestone
15:20:52 <regXboi> (as an FYI)
15:21:04 <mlavalle> that's cool, thanks for doing it
15:21:26 <mlavalle> #topic Routed network segments
15:21:41 <mlavalle> so carl_baldwin is not here.....
15:21:53 <mlavalle> does anyone have anything to report on this topic?
15:21:54 <haleyb> he's at linuxcon
15:22:27 <regXboi> this was discussed at the PAO LDT breakout Tuesday - mestery and carl_baldwin were telecommed in
15:22:37 <regXboi> #link https://etherpad.openstack.org/p/PAO-ops-large-deployments etherpad
15:23:06 <mlavalle> regXboi: thanks for the info
15:23:17 <regXboi> the tl;dr; of that etherpad is to create a new L3 first class citizen in the model, to land in Mitaka
15:23:56 <regXboi> that's fairly consistent with where the ML threads appear to be coming out (at least based on my reading)
15:24:14 <mlavalle> #topic BGP dynamic routing
15:24:22 * tidwellr runs for cover
15:24:45 <mlavalle> tidwellr: don't please, we know you are working hard
15:24:55 <tidwellr> BGP this is in serious danger of not making it into liberty
15:25:22 <tidwellr> at this point, I don't have the confidence we can test it thoroughly enough
15:25:40 <mlavalle> would an exception to FF help?
15:25:48 <tidwellr> perhaps
15:26:01 <tidwellr> that gives us an extra 2 weeks?
15:26:15 <mlavalle> I'm not familiar with the process, so I'll let other comment on it
15:26:21 <tidwellr> even then, I want to be up front that this is on shaky ground for Liberty
15:26:28 <vikram_choudhary> we need extra time
15:27:08 <mlavalle> tidwellr: yeah, that is why I was asking.... if even with FF exception we don't feel we can make it, then I don't think we should initiate it
15:27:32 <vikram_choudhary> tidwellr: why we can't make it ?
15:27:38 <tidwellr> mlavalle: agreed, I want the FFE since I'm not ready to throw in the towel
15:28:16 <tidwellr> vikram_choudhary: address scope awareness and testing with and without DVR are huge hurdles
15:28:17 <mlavalle> tidwellr: I would advice to send and email to carl_baldwin and mestery, so they are aware
15:28:38 <tidwellr> mlavalle: will do
15:28:38 <mlavalle> tidwellr: they seem to be very busy at Linuxcon
15:28:44 <yamamoto> is there any bgp patch ready for review?
15:28:47 <tidwellr> yes, Carl is traveling today
15:28:50 <vikram_choudhary> tidwellr: can't we finish rest?
15:28:56 <mlavalle> so the sooner they are aware, the better
15:29:20 <tidwellr> yamamoto: we have a review chain that starts here https://review.openstack.org/#/c/201621/
15:29:24 <mlavalle> also bring it up in the neutron meeting early next week, Tuesday
15:29:42 <tidwellr> carl_baldwin is aware, but we need to loop in mestery
15:29:53 <mlavalle> :-)
15:30:18 <mlavalle> any other specific help worth asking in this meeting?
15:30:40 <vikram_choudhary> mlavalle: reviews will be helpful
15:31:00 <mlavalle> vikram_choudhary: url's please, so we make it easier for folks....
15:31:05 <tidwellr> reviews, api tests, devstack integration
15:31:16 <tidwellr> https://review.openstack.org/#/c/201621/
15:31:25 <yamamoto> tidwellr: i asked ryu team to take a look at ryu-using patch at least.
15:31:28 <vikram_choudhary> https://review.openstack.org/#/q/+project:openstack/neutron+branch:master+topic:bp/bgp-dynamic-routing,n,z
15:31:50 <mlavalle> vikram_choudhary: THANKS FOR THE TOPIC LINK, THAT IS MOST USEFUL
15:31:55 <tidwellr> vikram_choudhary: thanks for digging that up
15:31:57 <mlavalle> sorry for the caps
15:32:05 <vikram_choudhary> :)
15:32:07 <mlavalle> slippery finger
15:32:23 <regXboi> moar yelling?
15:32:49 <tidwellr> I think worst-case this lands in Mitaka-1
15:33:10 <mlavalle> tidwellr: you mentioned api tests and devstack integration. do you have patchsets for that to be reviewed or you need help from devstack and tempest folks?
15:33:29 <tidwellr> haven't started with devstack integration yet
15:33:56 <tidwellr> I have API tests in https://review.openstack.org/#/c/201621/, but they need to be expanded
15:34:03 <mlavalle> would it help if we have someone from that team advicing / helping?
15:34:20 <tidwellr> no, we just need to write the tests
15:34:27 <mlavalle> I meant devstack
15:34:32 <tidwellr> oh
15:34:55 <tidwellr> that would be helpful
15:35:08 <tidwellr> we can't run the API tests in the gate right now
15:35:30 <mlavalle> I assume you don't have anythin in mind...... I can try to find someone, if you are too busy for that
15:35:39 <mlavalle> anyboody I menat
15:36:07 <tidwellr> yeah, that would be helpful
15:36:28 <mlavalle> #action mlavalle will find devstack help for the BGP effort
15:36:57 <mlavalle> anything else on this topic
15:37:28 <tidwellr> not from me, vikram_choudhary?
15:37:42 <vikram_choudhary> nothing.. you mentioned all
15:37:44 <vikram_choudhary> :)
15:38:10 <mlavalle> great work guys! this are the normal pains of open source development
15:38:22 <mlavalle> #topic IPAM
15:38:35 <pavel_bondar> hi
15:38:44 <mlavalle> hi pavel_bondar
15:39:01 <pavel_bondar> IPAM is merged, so I and John Belamaric are working on Infoblox driver
15:39:12 <pavel_bondar> I guess it is all updates for IPAM:)
15:39:17 <mlavalle> yeah, I assumed so....
15:39:26 <mlavalle> anything the team should know?
15:39:34 <mlavalle> or might help with?
15:39:45 <pavel_bondar> I think no
15:40:09 <mlavalle> ok, moving on
15:40:26 <mlavalle> #topic ML3 router plugin
15:40:39 <mlavalle> I don't think there is much to report here
15:40:56 <mlavalle> I bring it up just in case....
15:41:14 <mlavalle> ok, moving on......
15:41:20 <mlavalle> #topic DNS
15:41:41 <mlavalle> on this topic, https://review.openstack.org/#/c/200952/ has had a lot of progress this past week
15:42:05 <mlavalle> since yesterday, we are a little bogeed with a controversy on dns labels validation in the api
15:42:38 <mlavalle> but I don't expect this to be a major hurddle to merge this in Liberty
15:43:12 <mlavalle> as far as the external side https://review.openstack.org/#/c/212213/, it is not going to merge in Liberty
15:43:25 <mlavalle> all the rework on the internal side slowed me down
15:43:38 <mlavalle> \but we are making solid progres......
15:43:57 <mlavalle> thanks to pavel_bondar and john-belamaric for their comments
15:44:17 <mlavalle> please keep an eye on this. I appreciate your guidance
15:44:57 * pavel_bondar will review new version
15:44:58 <mlavalle> #topic Address scopes
15:45:12 <mlavalle> any one to report on this topic?
15:46:03 <mlavalle> ok moving on
15:46:14 <mlavalle> #topic IPv6
15:46:28 <mlavalle> amuller: the lurker.... anything on ipv6?
15:46:34 <amuller> nope!
15:46:39 <mlavalle> ^^^HenryG
15:47:32 <john-davidge> #link https://review.openstack.org/#/c/185977/ is in great shape and has some positive reviews. Just need some core attention and I’m confident we can get this merged for Liberty.
15:47:32 <mlavalle> #topic Open discussion
15:47:41 <mlavalle> #undo
15:47:42 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0xa4c2c50>
15:48:02 <mlavalle> john-davidge: any help you might need?
15:48:22 <john-davidge> I also have a patch for adding compatibility to the pluggable IPAM reference driver
15:48:26 <john-davidge> #link https://review.openstack.org/#/c/212688/
15:48:56 <john-davidge> Would be great to get some feedback from pavel_bondar and john-belamaric
15:49:22 <john-davidge> mlavalle: Just some +1’ and 2’s :)
15:49:36 <mlavalle> john-davidge: will give it a try :-)
15:49:49 <pavel_bondar> john-davidge: I'll take a look, but John is on vacation this week
15:50:03 <haleyb> john-davidge: i think the first one is down to nits, will take a look later
15:50:07 <mlavalle> yeah, that slacker :-)
15:50:16 <john-davidge> Thanks everyone
15:50:33 <mlavalle> #topic Open discussion
15:50:51 <mlavalle> I have a couple of quations....
15:51:13 <mlavalle> have folks received their ATC passes for Tokyo? I fear I lost it in my email
15:51:24 <mlavalle> queue
15:51:29 <regXboi> mlavalle: I think I saw mine
15:52:00 <regXboi> yes.... back on 8/11
15:52:07 <john-davidge> mlavalle: Yes I got mine weeks ago
15:52:14 <mlavalle> regXboi: thanks... that is helpful
15:52:37 <mlavalle> I forgot the other question
15:52:42 <mlavalle> any other topics
15:52:44 <mlavalle> ?
15:53:03 <regXboi> the PAO had an interesting ask for Mitaka
15:53:08 <regXboi> DVR with LB
15:53:34 <regXboi> well not an ask, more a "if you want us to use this, make it work with LB" statement
15:53:52 <mlavalle> pretty eloquent....
15:54:20 <regXboi> dougwig and I sat down at lunch on Wed and thought through a paper napkin design
15:54:45 <mlavalle> will that be translate to a BP?
15:54:45 <regXboi> which *might* let us simplify ovs/dvr and get rid of some of the nasty side-effects
15:54:52 <amuller> regXboi: carl baldwin and I also had conversations about that
15:55:08 <regXboi> mlavalle, amuller: I need to talk to carl_baldwin and mestery first
15:55:10 <Swami> amuller: regXboi: there was separate email thread on this topic
15:55:16 <regXboi> Swami: link?
15:55:44 <Swami> regXboi: I don't have it handy but I will forward the email thread to you
15:55:50 <regXboi> Swami: ack
15:56:04 * regXboi expects if it is an old thread, it will be time to wake it up again
15:56:39 <mlavalle> anything else today?
15:56:43 <regXboi> that's all I had (other than general grousing about neutron logging needing a good rationalization)
15:57:18 <mlavalle> ok, we are retuing 3 full minutes to your day
15:57:32 <mlavalle> thanks you very much for attending and all the great work!
15:57:45 <mlavalle> #endmeeting