15:00:55 <carl_baldwin> #startmeeting neutron_l3
15:00:56 <openstack> Meeting started Thu Feb 12 15:00:55 2015 UTC and is due to finish in 60 minutes.  The chair is carl_baldwin. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:57 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:59 <openstack> The meeting name has been set to 'neutron_l3'
15:01:03 <carl_baldwin> #topic Announcements
15:01:11 <carl_baldwin> #link https://wiki.openstack.org/wiki/Meetings/Neutron-L3-Subteam
15:01:33 <carl_baldwin> Any announcements for today?  I don’t think I have any.
15:01:49 <carl_baldwin> Looking at the meeting page, I need to update it.
15:02:12 <carl_baldwin> I’ve heard the name of the L release will be Liberty.  Is that right?
15:02:29 <carl_baldwin> Also, keep a close eye on the kilo release schedule.
15:02:31 <carl_baldwin> #link https://wiki.openstack.org/wiki/Kilo_Release_Schedule
15:03:06 <carl_baldwin> March 19th will come very soon.  If history is a good indicator, the gate will get crazy and it will be difficult to get stuff in the last week or son.
15:03:09 <pc_m> carl_baldwin: Yes Liberty
15:03:10 <carl_baldwin> s/son/so/
15:03:20 <carl_baldwin> Any other announcements?
15:03:44 <carl_baldwin> #topic Bugs
15:04:05 <carl_baldwin> Any bugs that we should be aware of?
15:04:34 <carl_baldwin> I’m not aware of any new ones.
15:04:45 <carl_baldwin> Any discussion needed here?
15:05:16 <carl_baldwin> #topic L3 Agent Restructuring
15:05:51 <carl_baldwin> This is going well.  Once I can finish my latest patch, I think pretty much all of the router logic will be moved to the router classes.
15:06:09 <carl_baldwin> #link https://review.openstack.org/#/c/154513/
15:07:01 <carl_baldwin> Thanks to all of you who have pitched in with patches and reviews.
15:07:44 <carl_baldwin> Anything else to discuss about restructuring?
15:08:27 <carl_baldwin> #topic neutron-ipam
15:08:40 <carl_baldwin> johnbelamaric: pavel_bondar: salv-orlando: ping
15:08:49 <pavel_bondar> pong
15:08:50 <johnbelamaric> carl_baldwin: pong
15:09:06 <carl_baldwin> tidwellr too
15:09:17 <tidwellr> carl_baldwin: pong
15:09:39 <carl_baldwin> I think we’ve got one open issue with the interface.
15:09:44 <carl_baldwin> #link https://review.openstack.org/#/c/134339/
15:10:21 <carl_baldwin> That is how to update IPAM with changes in the subnet.
15:10:55 <johnbelamaric> yes - also i want to verify that the subnet request will contain a pre-generated subnet_id, even though it has not yet been allocated
15:11:04 <johnbelamaric> at least, that's what the interface is implying now
15:11:54 <carl_baldwin> johnbelamaric: That is what I was thinking.  Do you think that will work?
15:12:42 <johnbelamaric> carl_baldwin: sure, that should be fine. one sec let me go back and read the comments
15:14:25 <johnbelamaric> carl_baldwin: ok, so the discussion on PS 18 line 221
15:15:25 <carl_baldwin> johnbelamaric: What about a SubnetUpdateRequest.  Very much like SpecificSubnetRequest.
15:15:27 <carl_baldwin> ?
15:16:09 * carl_baldwin just thinking out loud here.
15:16:09 <johnbelamaric> carl_baldwin: the subnet_id resolves the issue from line 85. but line 221 is talking about the sequencing and where/when the DB object is created and saved and who has that responsibility
15:16:29 <johnbelamaric> carl_baldwin: sure, that's possible. but why not just pass the subnet object to the driver and let it decide what to do with it?
15:17:22 <johnbelamaric> carl_baldwin: to me, the idea of the request was that we would be allocating based on various criteria. The update isn't to the CIDR, it's just to the name or other meta-data, isn't it?
15:17:52 <carl_baldwin> johnbelamaric: Right.
15:18:04 <johnbelamaric> carl_baldwin: i guess allocation pools - can the driver reject a change to allocation pool? i would think it would need to be able to
15:18:50 <carl_baldwin> johnbelamaric: I think the driver could reject such a change.  The current implementation doesn’t but I think it should be able to.
15:19:23 <carl_baldwin> johnbelamaric: I’ll look at it today.  Will you be around in case I want to ping you in openstack-neutron?
15:19:59 <johnbelamaric> carl_baldwin: yes, i should be unless i am in a meeting or something. i do have to leave for a memorial service at 5pm eastern today, though :(
15:20:37 <carl_baldwin> johnbelamaric: I’ll plan to get to it well before that then.
15:20:49 <carl_baldwin> tidwellr: How is the subnet allocation coming?
15:20:51 <johnbelamaric> carl_baldwin: ok. I am not sure for the need of a special "update request" object - do you see just passing the subnet object as enough?
15:21:34 <tidwellr> looking to post a review that is not WIP tonight
15:22:10 <carl_baldwin> johnbelamaric: It might be.  I’m going to give it some thought and get back with you.
15:22:18 <carl_baldwin> tidwellr: Great.
15:22:20 <johnbelamaric> ok
15:22:31 <tidwellr> just working through some unit tests
15:22:33 <carl_baldwin> tidwellr: What parts will this patch cover in all?
15:23:37 <carl_baldwin> tidwellr: I guess all of the CRUD on the pool resource, right?  Probably doesn’t touch on allocation of subnets yet.
15:23:40 <tidwellr> carl_baldwin: it will cover CRUD on subnet pools and everything that goes with that
15:23:54 <tidwellr> carl_baldwin: no allocation yet
15:24:16 <carl_baldwin> tidwellr: Do we need to get tempest tests going for this?
15:24:55 <tidwellr> carl_baldwin: for the allocation component? I would say yes, this is where the rubber meets the road
15:25:04 <johnbelamaric> tidwellr, carl_baldwin: actual allocation will be part of the driver, no? so creation of the pools would be enough, then the driver uses the pool info to do allocations
15:26:17 <tidwellr> johnbelamaric: when a subnet is requested, the driver still needs to be invoked
15:26:33 <carl_baldwin> johnbelamaric: Yes, I believe so.  We may need to be a bit creative since this and the drivers are being developed simultaneously.
15:27:00 <johnbelamaric> tidwellr: sure. ok - i will go look at the code and see how it will fit together
15:27:09 <carl_baldwin> tidwellr: I think even the subnet pool CRUD should be covered by tempest.  I’ll admit I’ve not written a full tempest test before.
15:27:43 <carl_baldwin> tidwellr: I wonder if we can find someone who would be willing to help us get started with the tempest tests.
15:28:10 <carl_baldwin> Does anyone here have any suggestions for who we might go to for help?
15:29:25 <carl_baldwin> #action carl_baldwin will look in to getting tempest tests started.
15:29:37 <mlavalle> carl_baldwin: talk to mtreinish
15:29:50 <carl_baldwin> mlavalle: Thanks.  That is a good idea.
15:30:30 <mlavalle> carl_baldwin: I might be of some small help. I just don't want to over commit. As you know, I am quite busy with the l3 agent restructuring
15:30:54 <carl_baldwin> mlavalle: Thanks, we’ll take that in to consideration.
15:31:00 <carl_baldwin> I feel the same way.
15:31:15 <tidwellr> carl_baldwin: once I get a review up tonight and I could start looking into it
15:31:43 <tidwellr> tempest sounds like a ramp for most of us here anyway
15:32:03 <carl_baldwin> tidwellr: I think there are some things that others could pitch in on so that you can start looking to allocation.
15:32:25 <tidwellr> ok, I'm fine with that, offer still stands though......
15:32:32 <carl_baldwin> tidwellr: great, thanks.
15:32:49 <carl_baldwin> Anything else to discuss regarding ipam?
15:33:22 <pavel_bondar> I will upload new version of re-factoring db_base patch for review aftr meeting
15:33:44 <carl_baldwin> pavel_bondar: Great.  ping me when you do.
15:33:59 <pavel_bondar> it will be still WIP, but the approach can be reviewed
15:34:08 <pavel_bondar> carl_baldwin: ok, sure
15:34:20 <carl_baldwin> #topic neutron-ovs-dvr
15:34:35 <carl_baldwin> Any dvr folks around today?
15:34:48 <carl_baldwin> I couldn’t make the dvr meeting yesterday but will read through the notes.
15:34:56 <carl_baldwin> #action carl_baldwin will catch up on dvr meeting.
15:35:39 <carl_baldwin> I found that the dvr check job (non-voting) had been failing on the stable branch.  I uploaded a backport to fix it.
15:35:42 <carl_baldwin> #link https://review.openstack.org/#/c/154576/
15:36:42 <carl_baldwin> That is all I have.
15:36:56 <carl_baldwin> #topic Open Discussion
15:37:00 <carl_baldwin> Anything else to discuss?
15:38:26 <amuller> https://review.openstack.org/#/c/149647/ is generally ready for review
15:39:06 <carl_baldwin> amuller: Thanks, I’ve actually been watching for an update on that one.
15:39:53 <carl_baldwin> We’ll make it a short meeting then.  Thanks everyone.  I’ve seen great progress.  Keep up the great work.
15:40:19 <carl_baldwin> I’ve got to be offline to ride in to the office but then I plan to be around the rest of the day.
15:40:37 <johnbelamaric> ok, bye all
15:40:38 <carl_baldwin> #endmeeting