15:10:38 <pc_m> #startmeeting neutron_l3
15:10:38 <openstack> Meeting started Thu Jan 29 15:10:38 2015 UTC and is due to finish in 60 minutes.  The chair is pc_m. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:10:39 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:10:41 <openstack> The meeting name has been set to 'neutron_l3'
15:10:56 <pc_m> #topic Announcements
15:11:12 <pc_m> K2 is on Feb 5th.
15:11:24 <pc_m> Anyone have announcements?
15:12:10 <pc_m> ok... onto bugs...
15:12:15 <pc_m> #topic Bugs
15:12:38 <pc_m> Here the list:  #link https://bugs.launchpad.net/neutron/+bugs?field.searchtext=&orderby=-importance&search=Search&field.status%3Alist=NEW&field.status%3Alist=CONFIRMED&field.status%3Alist=TRIAGED&field.status%3Alist=INPROGRESS&field.status%3Alist=INCOMPLETE_WITH_RESPONSE&field.importance%3Alist=UNKNOWN&field.importance%3Alist=UNDECIDED&field.importance%3Alist=CRITICAL&field.importance%3Alist=HIGH&assignee_option=any&field.assignee=&field.
15:12:38 <pc_m> bug_reporter=&field.bug_commenter=&field.subscriber=&field.structural_subscriber=&field.tag=l3-ipam-dhcp+&field.tags_combinator=ANY&field.has_cve.used=&field.omit_dupes.used=&field.omit_dupes=on&field.affects_me.used=&field.has_patch.used=&field.has_branches.used=&field.has_branches=on&field.has_no_branches.used=&field.has_no_branches=on&field.has_blueprints.used=&field.has_blueprints=on&field.has_no_blueprints.used=&field.has_no_blueprint
15:12:39 <pc_m> s=on
15:12:56 * pc_m wow, that didn't paste well.
15:13:14 <ihrachyshka> use link shortener Luke
15:13:30 <pc_m> #link http://goo.gl/7O8AKS
15:14:32 <pc_m> Any updates on these?
15:15:21 * pc_m patiently hoping someone will speak up :)
15:15:32 * ihrachyshka notes that some of those just need core reviewers to merge
15:16:24 <pc_m> ihrachyshka: OK.... #action Cores to review high priority bugs so they can merge
15:16:29 <pc_m> :)
15:16:39 <ihrachyshka> :)
15:17:18 <pc_m> Carl also has a list of L3 IPAM DHCP bugs... #link https://bugs.launchpad.net/neutron/+bugs?field.tag=l3-ipam-dhcp
15:17:58 <pc_m> Any comments/concerns/questions on these?
15:18:24 <pc_m> OK. Will move on...
15:18:35 <pc_m> #topic L3 Agent Restructuring
15:18:54 <pc_m> Anyone care to give an update?
15:19:46 <pc_m> I don't see amuller online
15:20:20 <pc_m> #topic BGP Dynamic Routing
15:20:36 <pc_m> devvesa: ping
15:21:21 <pc_m> Is there anything on this?
15:21:42 <pc_m> Hmm...
15:22:08 <pc_m> Rather than going through the agenda... Let's try something different.
15:22:20 <pc_m> Anyone have an item that they want to discuss?
15:22:57 <Swami> pc_m: we are seeing more failures on the dvr tests lately.
15:22:57 <pc_m> or want to provide an update on?
15:23:12 <pc_m> #topic DVR
15:23:12 <Swami> Yesterday we saw most of the test failing with "No host found".
15:23:59 <Swami> Do you know is there a way to figure out why do we get "No host found" errors only with DVR tests and not with the neutron full tests.
15:24:57 <Swami> Error message seen: Details: {u'message': u'No valid host was found. There are not enough hosts available.', u'created': u'2015-01-28T23:11:29Z', u'code': 500}
15:25:45 <pc_m> Swami: Can you post a link to one of the failure test runs, so folks can look at it?
15:25:56 <Swami> The DVR team is currently working on sorting out the differences between the neutron-full test and neutron-dvr test.
15:26:05 <Swami> sure.
15:27:00 <Swami> #link http://logs.openstack.org/68/143568/10/check/check-tempest-dsvm-neutron-dvr/e0f5bd8/logs/testr_results.html.gz
15:27:43 <pc_m> Swami: thanks
15:28:10 <Swami> I was consistently seeing these errors last night in most of the builds.
15:28:19 <pc_m> :(
15:28:33 <pc_m> So not creating the server for the test?
15:28:43 <Swami> Any help from the Infra team to sort of such issues will be great.
15:29:05 <pc_m> anteaya: ping
15:29:07 <Swami> pc_m: Yes it seems that what it says.
15:30:03 <Swami> The dvr team will be working on making the dvr test voting. That would be our high priority as of now. Any help from the community and infra will be appreciated.
15:30:21 <Swami> That would be our high priority for this week.
15:30:33 <pc_m> Swami: Thanks for the info.
15:30:35 <Swami> That's all I had from the DVR side.
15:31:00 <pc_m> Swami: Maybe we can reach out to Maru to see if he knows of people that can help from infra.
15:31:26 <ihrachyshka> have you tried #openstack-infra?
15:31:34 <Swami> pc_m: ok thanks will do
15:31:44 <pc_m> ihrachyshka: +1
15:31:53 <Swami> I will try that IRC channel as well.
15:32:23 <pc_m> It'll be a good start.
15:32:58 <pc_m> Any other topic people want to discuss or have questions on?
15:33:28 <ihrachyshka> I have smth. I want to kindly ask people to check my test_l3_agent refactoring series at: https://review.openstack.org/#/q/status:open+project:openstack/neutron+branch:master+topic:split_ra_unit_tests,n,z It's a start to later add more coverage for ra.py.
15:33:48 <pc_m> #topic L3 Refactoring
15:33:56 <ihrachyshka> it's currently in conflict with trunk reality :) but I'd like to hear if direction is ok before proceeding
15:35:15 <pc_m> ihrachyshka: Thanks. Please help Ihar out with reviewing this.
15:35:29 <ihrachyshka> for now a brief review on direction is enough
15:35:34 <ihrachyshka> thanks :)
15:36:07 <pc_m> Anything more on L3 refactoring?
15:36:41 <pc_m> Anything on IPAM?
15:36:56 <ihrachyshka> pavel_bondar, ?
15:37:47 <pavel_bondar> Yeah, it would be nice if somebody took a look on current version of #link https://review.openstack.org/#/c/147479/
15:37:48 * pc_m Thanks for helping with calling out people ihrachyshka!
15:37:56 <pc_m> #topic IPAM
15:38:01 <pavel_bondar> it is IPAM Driver Loader
15:38:44 <johnbelamaric> ok, i will take a look today
15:38:54 <pc_m> johnbelamaric: Thanks for helping!
15:38:56 <tidwellr> I'll take a look as well
15:39:04 <pc_m> tidwellr: ditto!
15:39:15 <tidwellr> https://review.openstack.org/#/c/148698/
15:39:15 <ihrachyshka> the last time I checked the interface definition was not mature. have you heard from carl on whether he'll update it in near future?
15:39:17 <johnbelamaric> have we seen a reference driver from salv-orlando ? I know he has done a lot on it so far
15:39:53 <pc_m> salv-orlando: ping
15:40:01 <pavel_bondar> Also I got WIP code from Salvatore(Reference IPAM Driver)
15:40:26 <pavel_bondar> #link https://review.openstack.org/#/c/150485/ It is in WIP status, investigating deeper with it
15:40:35 <tidwellr> I saw this as well
15:41:05 <johnbelamaric> ok, good
15:42:13 <pavel_bondar> I'll plan to provide next week some WIP version of re-factored db_base_plugin based on it
15:42:31 <pc_m> pavel_bondar: great
15:43:01 <pc_m> #action pavel_bondar to provide WIP version of re-factored db_base_plugin next week
15:43:52 <pc_m> pavel_bondar: Anything else on IPAM you care to bring up?
15:43:55 <tidwellr> basic subnetpool CRUD is taking shape, still WIP but some more eyes on it would be great https://review.openstack.org/#/c/148698/
15:44:05 <pavel_bondar> that's it for now
15:44:16 <pc_m> thanks for the update.
15:44:43 <pc_m> Anything else from the agenda that people want to discuss, before we go to open discussion?
15:45:25 <pc_m> #topic Open Discussion
15:46:08 <pc_m> amuller: hi
15:46:16 <amuller> pc_m: Good morning
15:46:30 <pc_m> We're almost done. Did you have anything you wanted to discuss for L3?
15:46:49 <amuller> Nope!
15:46:55 * pc_m Carl's not around today, so I'm feebly trying to fill in
15:47:35 <pc_m> Anyone have any other items to discuss? Otherwise we'll give back a few mins :)
15:48:48 <pc_m> OK. thanks for joining in everyone. If you have any other items, please use the IRC or ML and let Carl know.
15:49:08 <pc_m> #endmeeting