15:01:06 <carl_baldwin> #startmeeting neutron_l3
15:01:07 <openstack> Meeting started Thu May 29 15:01:06 2014 UTC and is due to finish in 60 minutes.  The chair is carl_baldwin. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:12 <openstack> The meeting name has been set to 'neutron_l3'
15:01:22 <carl_baldwin> #topic Announcements
15:01:41 <carl_baldwin> Juno-1 is in about two weeks.
15:02:04 <carl_baldwin> I’m not sure exactly what the date is.
15:02:33 <carl_baldwin> June 12th.
15:02:44 <carl_baldwin> #link https://wiki.openstack.org/wiki/Juno_Release_Schedule
15:03:30 <carl_baldwin> Also, there will be two mid-cycle meetings.  One focused on nova/neutron parity and the other on LBaaS.
15:03:38 <carl_baldwin> #link https://etherpad.openstack.org/p/neutron-juno-mid-cycle-meeting
15:03:58 <carl_baldwin> #link https://etherpad.openstack.org/p/neutron-juno-lbaas-mid-cycle
15:04:21 <carl_baldwin> #topic Bugs
15:04:53 <carl_baldwin> As you may have seen, there is a bug czar appointed for the neutron team.
15:05:08 <carl_baldwin> #link https://wiki.openstack.org/wiki/NeutronBugs
15:05:27 <carl_baldwin> I don’t see any new bugs for this subteam now but we’ll be going through them.
15:05:54 <carl_baldwin> #topic l3-svcs-vendor-*
15:06:08 <carl_baldwin> I don’t see pcm on.
15:06:15 <carl_baldwin> #undo
15:06:17 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0x1f2eb10>
15:06:28 <carl_baldwin> #topic bgp-dynamic-routing
15:06:32 <carl_baldwin> nextone92: Hi
15:06:37 <nextone92> Hi Carl
15:06:42 <keshava-hp> Hi
15:06:51 <nextone92> Jaume has updated the latest version of the document and will provide feedback
15:06:53 <devvesa> There is just a new patch of the blueprint
15:07:23 <devvesa> we have made several changes from the previous one
15:07:40 <carl_baldwin> nextone92: Could you edit the topic in gerrit to bp/bgp-dynamic-routing
15:08:06 <carl_baldwin> I look forward to seeing the changes.  Thanks for getting that up there.
15:08:25 <gangadhar> if we have some comments.. can we update in the doc?
15:08:36 <nextone92> Sorry about that - topic will be updated correctly
15:08:46 <carl_baldwin> gangadhar: Yes, please do add comments to the doc in gerrit.
15:08:59 <gangadhar> ok
15:09:11 <carl_baldwin> gangadhar: If you mean the google doc, nextone92 has closed comments on that so that the comments will be in the gerrit review.
15:09:18 <devvesa> i'll be aware of any comment, so I hope to give you quick feedback
15:09:34 <keshava-hp> I have added some comments and submitted for BGP use case and BGP-VPN documents
15:09:55 <carl_baldwin> devvesa: thanks for staying on top of it.
15:10:09 <carl_baldwin> keshava-hp: great
15:10:35 <carl_baldwin> Have you guys had a chance to begin getting your hands dirty with a proof of concept yet?
15:10:57 <carl_baldwin> I’m curious to see a comparison of the various BGP speakers that have been suggested.
15:11:10 <devvesa> basic changes from the previous one is to add the idea of a new agent, as we talked in the summit and try to avoid protocol names (as BGP in table names and entities)
15:12:11 * pcm_ sorry, I'm late
15:12:19 <devvesa> carl_baldwin: i can begin the development, yes
15:12:37 <carl_baldwin> #action carl_baldwin to review blueprint
15:12:48 <devvesa> but I haven't had the opportunity until now
15:12:53 <carl_baldwin> devvesa: where do you think is a good place to begin?
15:13:47 <devvesa> I think I have to start with the agent that implements the BGP functionality
15:14:41 <devvesa> and that would be a good chance to try BGP speakers
15:14:59 <devvesa> (understanding BGP speaker as an implementation of the API that the agent will expose)
15:15:13 <carl_baldwin> devvesa: Sounds reasonable.  Could you add a few items to the “Work Items” section in the bp?
15:15:19 <devvesa> ok
15:15:36 <devvesa> #action devvesa to ad work items at bp
15:15:42 <keshava-hp> Hi, when we do BGP we are thinking these CN Nodes = CE ( BGP-VPN Scenario) ? or only adding BGP routing ?
15:15:55 <carl_baldwin> Please review the blueprint
15:16:03 <carl_baldwin> #link https://review.openstack.org/#/c/90833
15:16:11 <carl_baldwin> nextone92: devvesa: anything else to discuss?
15:16:28 <nextone92> Looking forward to the team feedback
15:16:35 <carl_baldwin> #topic l3-svcs-vendor-*
15:16:37 <carl_baldwin> pcm_: hi
15:16:47 <pcm_> hi!
15:17:44 <pcm_> Been trying to split out validation for VPNaaS. Hit some problems with initial approach. Trying another approach now, that is working better.
15:17:47 <carl_baldwin> I see your blueprint is marked WIP.  So, I haven’t spent much time looking at it.
15:18:08 <carl_baldwin> pcm_: did you get what you need out of the ML discussion?
15:18:47 <pcm_> carl_baldwin: I think so... some is moot point as cannot really do validation before persistence
15:19:30 <pcm_> carl_baldwin: Need to do from within persistence (to handle case of multiple clients changing same config)
15:19:56 <pcm_> so, no issue of pre/post commit vs validate/apply.
15:20:32 <pcm_> I've got validation separated for one API and am trying to modify vendor code to see if I can override.
15:20:38 <pcm_> looks promising.
15:20:54 <carl_baldwin> Sounds good.  Let us know when you have something to look over.
15:20:59 <pcm_> Once I get one API done, I can put out as WIP.
15:21:13 <pcm_> For some early feedback.
15:21:39 <carl_baldwin> pcm_: That’ll be good.  Anything else?
15:22:17 <pcm_> carl_baldwin: Made a bug for the client side validation removal, but no action on it yet.
15:22:23 <pcm_> carl_baldwin: That's all for me.
15:22:44 <carl_baldwin> pcm_: Could you paste a link here for the bug just for reference?
15:23:25 <pcm_> sure. I'll look it up...
15:23:45 <carl_baldwin> roaet_: ping
15:25:32 <carl_baldwin> Sorry I’m kind of rushing through the topics this morning and leaving a few off.  I want to have time to discuss DVR when Swami joins.
15:25:35 <keshava-hp> BGP summarlization also we have plan to add ?
15:25:42 <pcm_> #link https://bugs.launchpad.net/python-neutronclient/+bug/1322659
15:26:10 <carl_baldwin> pcm_: Right, I was looking in the neutron bugs even knowing it was a client bug.
15:26:29 <carl_baldwin> #topic Open Discussion
15:26:36 <pcm_> carl_baldwin: Yeah, took me a bit to get to the right queue
15:26:40 <carl_baldwin> We’ll move to DVR when Swami is on.
15:27:24 <carl_baldwin> keshava-hp: I don’t understand the question, could you elaborate?
15:28:32 <yamamoto> how about creating a bgp speakers comparison chart somewhere eg. on wiki?
15:29:53 <nextone92> Sounds good - maybe we could reuse the etherpad?
15:29:54 <nextone92> https://etherpad.openstack.org/p/juno-dynamic-routing
15:29:54 <devvesa> yamamoto: that would be good. I think is the best moment to do it
15:29:57 <carl_baldwin> yamamoto: I would like to see that.  Would you mind getting a wiki page started?  Add a link to it in the bp?
15:30:04 <keshava-hp> when there are many prefix from multiple Nodes, then it possible to aggregates routes and advertize to peer speaker. This will help to reduce number of route entries in the upstream BGP. This will also help to reduce route flapping when a particular VM prefix is withdraw
15:30:12 <carl_baldwin> I’m okay with wiki or etherpad.
15:30:40 <devvesa> carl_baldwin: btw, we think we can have the development ready for j
15:30:40 <yamamoto> i can create a wiki.  any suggested url?
15:30:43 <devvesa> juno-3
15:31:10 <yamamoto> wiki is easier for a table than etherpad
15:31:46 <devvesa> agree
15:32:19 <carl_baldwin> #action yamamoto will create bgp speaker comparison table on wiki and link from bp.
15:32:21 <carl_baldwin> Swami: hi
15:32:22 <Swami> hi
15:32:46 <carl_baldwin> #topic neutron-ovs-dvr
15:33:09 <Swami> DVR progress update
15:33:21 <Swami> The DVR spec was approved this week
15:33:32 <Swami> DVR is targetted for Juno Milestone 1.
15:33:39 <carl_baldwin> Yes, thank you for addressing comments very quickly.
15:33:59 <Swami> We are still working on the SNAT part.
15:34:15 <Swami> It seems that it might take another 5 working days to complete the SNAT portion.
15:34:42 <carl_baldwin> Swami: does that come as a patch separate from the east/west and floating ip north/south?
15:35:02 <Swami> So I was thinking about pushing just east-west first.
15:35:14 <Swami> And then later the FIP and SNAT together will be another patch.
15:35:19 <carl_baldwin> If so, I’d be thrilled to see the other stuff land for Juno-1 even before default SNAT lands.
15:35:37 <Swami> That way we can target for reviewing and pushing the code for Juno Milestone 1
15:36:04 <Swami> Also to address any unit test issues and add any unit tests it would be easy to handle one at a time rather than all together.
15:36:11 <carl_baldwin> Could fip and snat be separated in order to review the distributed north south earlier?
15:36:13 <Swami> But this would be the worst case.
15:36:42 <Swami> No right now we are not planning to split the fip and snat. They will go together.
15:37:28 <Swami> If we have everything working for the North-South by next week, then we can push everything for Juno 1 milestone, otherwise we should have a back up plan.
15:37:40 <Swami> So just targetting East-West will be the back up plan.
15:37:50 <Swami> Does that sound reasonable.
15:38:16 <carl_baldwin> Swami: when can you push the east / west code?
15:39:22 <Swami> Yes I have already pushed the plugin code, Vivek is also addressing the comments on the ML2/OVS work for East-West.
15:39:30 <armax> it's my understanding that reviews here:
15:39:30 <armax> https://review.openstack.org/#/q/topic:bp/neutron-ovs-dvr,n,z
15:39:41 <armax> are addressing the east/west case
15:39:56 <armax> and they also introduce the api/model changes
15:39:58 <Swami> Then I will ask Mike and Murali to push in just the East-West for the L3 Agent and Scheduler part.
15:40:17 <armax> is there any review missing to the lot?
15:40:23 <carl_baldwin> Swami: That will be great.
15:40:36 <Swami> armax: No all the reviews should be in the same page.
15:40:44 <Swami> We starting pushing everything earlier.
15:40:48 <carl_baldwin> armax: that link contains all of them.
15:41:09 <armax> cool
15:41:12 <Swami> But to be safe and to have something to be merged for Juno 1 I am proposing that we might only push the East-West .
15:41:18 <armax> so if at least we get all of them by J1
15:41:20 <armax> it's a good start
15:41:47 <Swami> Yes that is my plan. Hopefully everything should fall in at the right time.
15:42:09 <Swami> Carl: For the next month I will be working in different time zone. I am on FTO, so will be working from India.
15:42:10 <carl_baldwin> Swami: In your email to me yesterday you mentioned some patches that should be reviewed first.  I plan to add that to the how to wiki page that you created.  Are you okay with that?
15:42:31 <carl_baldwin> Swami: Good to know.
15:42:41 <armax> swami: I can help you with https://review.openstack.org/#/c/84223/ if you like
15:42:47 <Swami> Yes I wanted the "Base L3 Plugin Extension" code to be reviewed first since all other patches have dependency on it.
15:43:25 <Swami> armax: Thanks
15:43:30 <armax> Swami: unless you have it almost ready
15:44:06 <carl_baldwin> Swami: Is that the link that armax pasted ^
15:44:14 <armax> carl_baldwin: I think it is
15:44:16 <Swami> armax: The current patch that I uploaded last night has everything that is required for East-West, I still need to add unit test for the code that I added.
15:44:27 <Swami> carl: yes
15:44:46 <armax> Swami: feel free to poke me individually to coordinate efforts
15:44:51 <Swami> vivek has also posted the L2 code.
15:44:55 <carl_baldwin> Great.  armax and Swami let me know if I can help.  I’ll stick to that review like glue.
15:44:59 <Swami> armax: sure will do.
15:45:08 <armax> carl_baldwin: I am sure you're not the only one ;)
15:45:24 <carl_baldwin> #action carl_baldwin will document patch dependencies on the wiki for other reviewers.
15:45:47 <Swami> carl: Also the ML2 / OVS code is also posted for review. Vivek is addressing the review comments, that should also be addressed.
15:46:01 <carl_baldwin> It is very encouraging to see that Jenkins gave it a +1.
15:46:06 <Swami> the other patches can follow these two patches.
15:46:29 <Swami> Yes I was working last night to make sure everything works. I have not broken any unit test as of now.
15:46:39 <carl_baldwin> Swami: Great work.
15:46:42 <carl_baldwin> #link https://review.openstack.org/#/c/87730/
15:46:48 <Swami> I will start to work on adding new test cases for handling the distributed one.
15:46:49 <carl_baldwin> This is Vivek’s ^
15:47:13 <Swami> carl: Yes that is vivek's patch.
15:48:15 <carl_baldwin> It needs a rebase.  Jenkins couldn’t merge it.
15:48:52 <Swami> I will speak to Murali and also ask him to push his scheduler code with my code as a dependency, so that everything for East-West will come through.
15:49:14 <carl_baldwin> Swami: Sounds good.
15:50:53 <carl_baldwin> Swami: Is there anything more that you need from me or the subteam?
15:51:08 <Swami> carl: I will let you know if I need any help.
15:51:21 <Swami> For now we might have to focus on these two reviews and try to finalize it.
15:51:30 <carl_baldwin> I’m still trying to set up my multi-node test bed.  Our datacenter guys took my machines out from under me.  So, I had a little set back.
15:52:13 <Swami> By monday I will ask Mike and murali to push their updated code for review.
15:52:54 <carl_baldwin> Swami: Sounds like a plan.  I may mark the other patches as WIP to keep them from drawing focus away from these two.
15:53:08 <Swami> Ok, sounds good to me.
15:53:11 <armax> Swami: it's good to do it sooner rather than later so that in the process they can incorporate feedback while the patch shapes up
15:53:38 <carl_baldwin> armax: +1
15:54:02 <Swami> armax: Are you talking about the other two patches or the North/South.
15:54:43 <armax> Swami: mine it's more like a general comment, if the patches are really early stages then it's worth waiting a little more
15:55:09 <armax> but I am assuming that's not the case
15:55:20 <carl_baldwin> Swami: I have a question about https://review.openstack.org/#/c/96389
15:55:37 <carl_baldwin> I have the feeling that this ^ should be squashed in to another patch.
15:55:45 <Swami> Yes, that is the reason we had all our patches out there for a while now.
15:56:23 <Swami> carl: I have fixing a merge conflict issue with the HEAD. And unfortunately it ended up as a separate patch.
15:56:26 <armax> carl_baldwin: I am taking this one over, I'll take care of it
15:56:42 <carl_baldwin> Swami: It has been helpful for me to see the early patches up there.  I have had a head start in understanding the code/patch structure.
15:56:43 <armax> carl_baldwin: this one actually: https://review.openstack.org/#/c/84223/
15:57:13 <carl_baldwin> armax: Great.
15:58:24 <Swami> armax: carl: thanks for your help.
15:58:51 <carl_baldwin> Swami: yw.  Glad to help.  It is fun!
15:58:52 <armax> carl_baldwin: I abandoned patch 96389 fyi
15:59:14 <carl_baldwin> armax: good
15:59:20 <carl_baldwin> Swami: Anything else?
16:00:08 <carl_baldwin> That’s a wrap.  Thanks everyone!
16:00:09 <armax> none from me
16:00:16 <carl_baldwin> #endmeeting