15:00:48 <carl_baldwin> #startmeeting neutron_l3
15:00:49 <openstack> Meeting started Thu May 22 15:00:48 2014 UTC and is due to finish in 60 minutes.  The chair is carl_baldwin. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:50 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:52 <openstack> The meeting name has been set to 'neutron_l3'
15:01:00 <carl_baldwin> #topic Announcements
15:01:10 <carl_baldwin> #link https://wiki.openstack.org/wiki/Meetings/Neutron-L3-Subteam
15:01:25 <carl_baldwin> Summit was great! Lot's of energy and a lot of good work to come.
15:01:59 <armax> yup!
15:02:06 <carl_baldwin> Neutron mid-cycle meeting for Juno is set for July 9-11. I've got my travel arrangements already. Do you?
15:02:13 <carl_baldwin> #link https://etherpad.openstack.org/p/neutron-juno-mid-cycle-meeting
15:02:21 <roaet> presents
15:02:29 <armax> not yet ony my end
15:02:46 <roaet> I do not have plans set up either.
15:03:03 <carl_baldwin> I hope to see many of you there.
15:03:17 <carl_baldwin> #topic Bugs
15:03:30 <carl_baldwin> #link https://bugs.launchpad.net/neutron/+bugs?field.tag=l3-ipam-dhcp
15:03:55 <carl_baldwin> I’ll be adding this section to the meeting each week as I’ll be working more on bug triage, especially where this tag is applied.
15:04:10 <carl_baldwin> None of the bugs stick out to me today as urgent but I haven’t been through them all.
15:04:40 <carl_baldwin> #topic l3-svcs-vendor-*
15:04:44 <carl_baldwin> pcm__: ping
15:05:05 <carl_baldwin> Your session at the summit was very informative.  It got me up to speed.
15:05:35 <pcm__> thanks!
15:05:43 <amuller> Have to get going guys, just stopped by to say hi and that it was great meeting everyone at the summit
15:05:53 * pcm__ trying to engage in two meetings at once :(
15:05:59 <carl_baldwin> amuller: Thanks.  We’ll be in touch.
15:06:16 <roaet> I'm not sure who I met, but whoever I did it was nice to meet you.
15:06:23 <carl_baldwin> pcm__: I know the feeling.  Have you filed a bug for that third item?
15:07:05 <pcm__> carl_baldwin: sorry, which item?
15:07:12 <carl_baldwin> We could use reviews on the spec here:  https://review.openstack.org/88406
15:07:27 <carl_baldwin> pcm__: There was the problem where the client validates over aggressively.
15:07:51 <pcm__> ah, that one. No. Not yet. Plan to do that.
15:08:20 <pcm__> Thought is to remove validation of enum fields from client (already no validation of integer fields)
15:08:26 <carl_baldwin> #action pcm__ will file a bug for client validation problem.
15:08:46 <carl_baldwin> #action carl_baldwin will review https://review.openstack.org/88406
15:08:55 <carl_baldwin> ^ I encourage others to review the blueprints as well.
15:09:01 <carl_baldwin> pcm__: Anything else?
15:09:21 <pcm__> For validation... I was thinking about separating the validation from the persistence.
15:09:42 <carl_baldwin> That sounds like a good thing.
15:09:51 <pcm__> This way, if/when we go to TaskFlow, we'll have discrete tasks. In the meantime, I can try to
15:10:07 <carl_baldwin> Is that spelled out in your blueprint?
15:10:08 <pcm__> allow provider to override the validation (since it will be separate)
15:10:26 <pcm__> BP needs to be updated to reflect summit items.
15:10:45 <pcm__> will work that too.
15:10:49 <carl_baldwin> #action pcm__ To update blueprint from summit discussion.
15:11:00 <carl_baldwin> pcm__: Thanks.  Keep up the good work.
15:11:09 <pcm__> sure. np.
15:11:11 <carl_baldwin> #topic bgp-dynamic-routing
15:11:25 <roaet> carl_baldwin: btw grats on the nomination for core, quite deserved
15:11:31 <carl_baldwin> nextone92: I thought the session went well.  I heard a lot of support in the room.
15:11:45 <carl_baldwin> roaet: Thanks.
15:11:46 <nextone92> Thank you
15:12:06 <nextone92> It was a great opportunity to learn requirements and use cases for dynamic routing :)
15:12:07 <carl_baldwin> I’ve heard good things since summit as well from a few people who did not speak up in the room.
15:12:27 * pcm__ clapping
15:12:30 <carl_baldwin> Do you have any action items out of it?
15:12:45 <nextone92> Jaume and I are working to incorporate the comments and to work through the use cases of the new agent
15:13:08 <nextone92> We have collected feedback from the in-person discussion, the session, and over the email
15:13:42 <carl_baldwin> Great, ping the ML when you’ve posted a new draft of the blueprint.  I’d like to see the improved blueprint.
15:14:03 <nextone92> Great! Looking forward to more feedback after that
15:14:12 <carl_baldwin> Do you have any idea what milestone you are looking to target with the implementation?
15:14:42 <nextone92> I will take an action item to create the schedule estimate for next meeting
15:15:06 <carl_baldwin> nextone92: Great.
15:15:35 <nextone92> #action nextone92 Provide BGP dynamic routing schedule
15:15:48 <carl_baldwin> #topic *-dns-resolution
15:16:37 <carl_baldwin> I’m still working on the blueprints for this.  There are a few points to work out.  I’ll be addressing feedback but otherwise this topic is going to have to wait until DVR is merged.
15:17:04 <carl_baldwin> #topic IPAM
15:17:17 * roaet salutes
15:17:23 <carl_baldwin> roaet: hi
15:17:41 <roaet> I have put up a very simple implementation that I believe most people can agree with on https://etherpad.openstack.org/p/ipam_pod in the Implementation Details
15:17:43 <carl_baldwin> I was pleased to see the grass roots energy around this topic at the summit and recently in IRC and on ML.
15:18:36 <roaet> Indeed, a lot of people showed up to the pod
15:18:51 <roaet> I'm wondering any of those people are here so they can comment on the implementation.
15:19:06 <roaet> carl_baldwin: did you find any blueprints that you wished to use as the spearhead of this, or are we just going to use them all?
15:19:30 <carl_baldwin> I took a look through them.  They were varied.
15:20:01 <carl_baldwin> We should try to consolidate.
15:20:05 <roaet> agree.
15:20:31 <carl_baldwin> I think that Sumit’s blueprint is the closest to where we want to start.  But, it doesn’t have much detail.
15:20:55 <roaet> As far as direction goes henceforth, I guess it's a matter of gathering more input on that very simple implementation and reviewing people's current implementation proposals?
15:21:56 <carl_baldwin> Yes.  We should probably submit a design specification to Neutron specs.
15:22:10 <carl_baldwin> I’ll work on consolidating the existing blueprints.
15:22:14 <roaet> I am not familiar with that step.
15:22:26 <roaet> I assume it's documented somewhere, I"ll look around, but if you have it avail...
15:22:42 <carl_baldwin> #action carl_baldwin to work with blueprint owners to consolidate.
15:23:06 <carl_baldwin> There is a wiki page.  Does anyone have the neutron-specs wiki page link on hand?
15:23:16 <salv-orlando> car;_baldwin: happy to help in defining design and or reviewing it
15:23:26 <carl_baldwin> roaet: The whole process is very new.
15:23:27 <salv-orlando> carl_baldwin: ^^
15:23:38 <roaet> salv-orlando: i'd appreciate your input
15:23:39 <salv-orlando> As with anything, two core-devs is better than one ;)
15:23:48 <carl_baldwin> salv-orlando: Great
15:24:13 <carl_baldwin> #link https://wiki.openstack.org/wiki/Blueprints#Neutron
15:24:14 <roaet> i found https://github.com/openstack/neutron-specs
15:25:05 <roaet> oh, this is that thing voss was talking about. I'll need to ping people on the right way to do this.
15:25:05 <carl_baldwin> roaet: Admittedly, there is a learning curve if you haven’t written RST but the whole process is a huge improvement over what we had before.
15:25:21 <carl_baldwin> roaet: There is a very good sample document to start with.
15:25:31 <roaet> I am a fan of rst, so I'll have that going for me.
15:26:00 <roaet> carl_baldwin: ok. I'll work on making that so it can be reviewed properly.
15:26:10 <carl_baldwin> #action roaet to propose specification.
15:26:24 <carl_baldwin> Anything else?
15:26:32 <roaet> that is it, thank you.
15:27:15 <carl_baldwin> roaet: thank you.
15:28:08 <carl_baldwin> #topic rootwrap
15:28:16 <carl_baldwin> I’ll give a quick update on this.
15:28:35 <carl_baldwin> There was a meeting in the oslo track about the rootwrap daemon mode.
15:29:18 <carl_baldwin> They did not have any reason not to go forward with the daemon mode implementation by YorikSar.
15:29:52 <carl_baldwin> A few of them will review the blueprints and provide feedback on the implementation.
15:31:32 <carl_baldwin> I probably won’t have this subject on the agenda past today.  Bookmark the topic in gerrit and review it.
15:31:34 <carl_baldwin> #link https://review.openstack.org/#/q/topic:bp/rootwrap-daemon-mode,n,z
15:31:39 <salv-orlando> can we then integrate it smoothly in neutron or do you think we will need to adapt some modules?
15:32:05 <carl_baldwin> salv-orlando: Good question.  That was a point of discussion at the summit.
15:32:16 <carl_baldwin> Yuriy has proposed some code that integrates it.
15:32:50 <carl_baldwin> salv-orlando: You’ll find the proposal in the topic linked ^
15:33:28 <salv-orlando> ok great. thatconcludes the discussion then, I think
15:34:02 <carl_baldwin> salv-orlando: It may be a little behind the discussion.
15:34:36 <salv-orlando> carl_baldwin: that's ok, I meant the discussion here, in this meeting
15:34:37 <carl_baldwin> The general sentiment was that probably more of the integration could be implemented in oslo than neutron.
15:34:46 <carl_baldwin> Oh, I see.
15:35:11 <salv-orlando> being the point of contact between oslo and neutron I should probably look at that :/
15:35:34 <carl_baldwin> Please do.  It will be greatly appreciated.
15:36:09 <carl_baldwin> Swami: ping
15:36:35 <carl_baldwin> #topic neutron-ovs-dvr
15:36:49 <carl_baldwin> I don’t see Swami around.
15:37:28 <carl_baldwin> I do know that work on DVR is moving along and picking up.  I grabbed a few nodes in our development environment and I’m currently in the process of building up my own little DVR deployment.
15:38:03 <nextone92> Is there a way to run DVR on devstack?
15:38:26 <carl_baldwin> nextone92: I plan to start with devstack.
15:39:09 <carl_baldwin> I don’t see any reason why it shouldn’t and it needs to.
15:39:58 <carl_baldwin> I’ll admit I haven’t run a multi-node devstack yet.
15:40:12 <nextone92> Great!
15:40:18 <carl_baldwin> A colleague sitting next to me has and is willing to share his experience with me.
15:40:59 <carl_baldwin> The setup will help with DVR and with VRRP which I’ve been meaning to test out as well.
15:41:20 <carl_baldwin> I will document what I learn through the process for the next meeting.
15:41:26 <carl_baldwin> Swami: hi
15:42:03 <Swami> hi
15:42:52 <Swami> carl: Am I too late for the dvr update
15:42:59 <carl_baldwin> We were just discussing running DVR in devstack.
15:43:08 <Swami> good topic
15:43:17 <carl_baldwin> You’re not too late.  I’ve been saving DVR until the end because I know you can’t join early.
15:43:22 <Swami> we need to have a multinode setup to run the DVR in devstack
15:43:39 <carl_baldwin> Swami: I have carved out time to try this out and document it for the community.
15:43:46 <Swami> I am planning to put together a Wiki to run multinode setup with the DVR
15:44:11 <carl_baldwin> #action carl_baldwin to document experience getting DVR going with devstack in a multi-node configuration.
15:44:12 <Swami> carl: Do you have a workable config that runs devstack in multinode setup right now.
15:44:24 <carl_baldwin> Swami: I will be glad to help out.
15:44:32 <Swami> carl: thanks
15:44:59 <carl_baldwin> Swami: I’m part way through.  I’ve just identified some nodes in our dev environment to do it on and I’ve installed the base OS.
15:45:09 <Swami> who ever first attempts it can provide information
15:45:38 <carl_baldwin> Swami: Will you create a wiki page stub so that we can have a URL to collaborate on?
15:45:45 <Swami> I got a config file from Kyle for mulitnode setup I will forward it to you
15:45:57 <Swami> Yes I do have a Wiki already. I will post the link
15:46:01 <carl_baldwin> Great.
15:46:20 <Swami> #link https://wiki.openstack.org/wiki/Neutron/DVR/HowTo
15:46:45 <Swami> You can use this place to update your findings
15:46:54 <carl_baldwin> I will, thanks.
15:47:55 <carl_baldwin> Swami: How was the DVR meeting yesterday?
15:48:03 <Swami> it went well.
15:48:16 <Swami> I think you left during the services discussion
15:48:42 <Swami> We had some discussion about where to handle the FWaaS for the DVR scenario.
15:48:53 <carl_baldwin> Yes.  Sorry to bug out.
15:49:13 <Swami> I have asked Yiun to come up with his ideas to apply the FWaaS for the DVR. Vivek and Rajeev also provided some ideas.
15:49:34 <Swami> We will be capturing those ideas in the coming week and will probably walk through.
15:49:51 <Swami> We also discussed about the VPNaaS and its impact.
15:50:31 <Swami> Right now there might not be too much impact for the VPN, just some code refactoring to schedule the VPN Service in the Service Node when associated with the DVR router.
15:50:59 <Swami> This week our main focus is to fix all the broken Unit tests by the introduction of the DVR
15:51:15 <Swami> it affects many plugins out there and we are cherry picking and fixing it.
15:51:22 <carl_baldwin> Swami: I did get your email about that.
15:51:49 <carl_baldwin> It can be labor intensive to fix unit tests.
15:52:08 <Swami> Yes, you are right.
15:52:26 <SumitNaiksatam> Swami: regarding fwaas, we also have DVR as a standing item on our FWaaS meeting
15:52:54 <Swami> SumitNaiksatam: Yes Yiun mentioned that he will take it up to the FWaaS team.
15:52:55 <carl_baldwin> SumitNaiksatam: what are your thoughts overall?
15:52:57 <SumitNaiksatam> Swami: if you get a chance, you can chime in that discussion as well, just to reinforce the discussion here
15:53:24 <Swami> SumitNaiksatam: Sorry I missed yesterday's meeting since I was busy with other work. I will chime in
15:53:29 <SumitNaiksatam> carl_baldwin: we dont have a clear solution yet
15:53:38 <SumitNaiksatam> carl_baldwin: we are sifting through the options
15:53:47 <SumitNaiksatam> Swami: no worries at all, just a suggestion
15:54:40 <Swami> SumitNaiksatam: Thanks for accomodating the DVR/FWaaS requirements
15:54:42 <carl_baldwin> SumitNaiksatam: Is the major concern that routing for each direction of east/west traffic is done on a different node and therefore cannot share state?
15:54:54 <SumitNaiksatam> carl_baldwin: yes
15:55:02 <carl_baldwin> Are there other concerns?
15:55:21 <SumitNaiksatam> not that i am aware of at this point
15:55:42 <carl_baldwin> SumitNaiksatam: Thank you.
15:55:50 <SumitNaiksatam> i have also requested Yi to start an email thread on this
15:55:53 <SumitNaiksatam> on the dev mailer
15:56:11 <carl_baldwin> SumitNaiksatam: Great.
15:56:19 <SumitNaiksatam> carl_baldwin: sure
15:56:23 <Swami> SumitNaiksatam: Thanks sumit
15:56:40 <SumitNaiksatam> Swami: np
15:56:44 <carl_baldwin> FYI, FWaaS meetings are on Wednesdays at 1830 UTC in this meeting room.
15:56:51 <carl_baldwin> #link https://wiki.openstack.org/wiki/Meetings/FWaaS
15:56:58 <carl_baldwin> I will put it on my calendar.
15:57:44 <carl_baldwin> Swami: anything else?
15:57:51 <Swami> That's all I had carl.
15:58:55 <carl_baldwin> Swami: thanks
15:58:57 <carl_baldwin> #topic General Discussion
15:59:06 <carl_baldwin> One minute left.  ;)
16:00:04 <carl_baldwin> Thanks everyone!  Have a great week.
16:00:10 <carl_baldwin> #endmeeting