15:00:52 <carl_baldwin> #startmeeting neutron_l3
15:00:56 <openstack> Meeting started Thu May  8 15:00:52 2014 UTC and is due to finish in 60 minutes.  The chair is carl_baldwin. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:57 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:59 <openstack> The meeting name has been set to 'neutron_l3'
15:01:08 <carl_baldwin> #topic Announcements
15:01:21 <carl_baldwin> Summit is next week. We will not hold this meeting on the 15th. It will continue on the 22nd.
15:01:54 <carl_baldwin> I have updated the team meeting page with summit information partaining to design sessions from this team.  There are a number of them.
15:02:02 <carl_baldwin> #link https://wiki.openstack.org/wiki/Meetings/Neutron-L3-Subteam
15:02:29 <carl_baldwin> If you have a session, please create an etherpad and post it.
15:02:38 <carl_baldwin> #link https://wiki.openstack.org/wiki/Summit/Juno/Etherpads#Neutron
15:03:47 <carl_baldwin> Also, there will be a Neutron mid-cycle meeting in July.  There is an etherpad but I’m unable to reach it.
15:03:55 <carl_baldwin> #link https://etherpad.openstack.org/p/neutron-juno-mid-cycle-meeting
15:03:55 <Swami> hi
15:04:00 <carl_baldwin> Swami: hi
15:04:50 <carl_baldwin> Okay, etherpad came up for me now.
15:05:11 <carl_baldwin> Looks like it is still between the weeks of the 7th and 14th.
15:05:29 <carl_baldwin> Location is between Minneapolis and San Jose.
15:05:42 <carl_baldwin> I expect decisions will be made soon.
15:06:04 <carl_baldwin> Any other announcements?
15:06:38 <carl_baldwin> #topic Bugs
15:07:13 <carl_baldwin> I’ll start discussing bugs in the team meeting.  Our bugs will be tagged with l3-ipam-dhcp.
15:07:28 <carl_baldwin> #link https://bugs.launchpad.net/neutron/+bugs?field.tag=l3-ipam-dhcp
15:08:26 <carl_baldwin> Looks like there are a few High priority but all have owners.  I’ll go through the Undecided and try to get them triaged the remainder of this week.
15:08:40 <carl_baldwin> #action carl_baldwin to triage undecided bugs
15:09:09 <carl_baldwin> #topic l3-svcs-vendor-*
15:09:14 <carl_baldwin> pcm_: hi
15:09:35 <carl_baldwin> I added information about your summit session on the page for a little extra visibility.
15:09:35 <pcm_> hi
15:09:49 <pcm_> thanks!
15:09:54 <carl_baldwin> Anything to report?
15:10:25 <carl_baldwin> If you’re like me, you’re just busy preparing for the discussion.
15:10:37 <pcm_> no. just need to know more about Mark McClain's TaskFlow and how it impacts.
15:10:51 * pcm_ very busy
15:11:21 <carl_baldwin> Ah, right.  That will be good to explore before the discussion a bit.
15:11:34 <pcm_> Please look at the etherpad and and anything...
15:11:40 <pcm_> and add
15:11:44 <carl_baldwin> Last I knew, there was no blueprint available for Mark’s.  Has be posted something?
15:11:56 <pcm_> Didn't check today,
15:12:02 <pcm_> but nothing yesterday.
15:12:17 <Swami> what is this task flow?
15:12:26 <carl_baldwin> I’m checking to see if he has an etherpad.
15:12:41 <pcm_> #link https://wiki.openstack.org/wiki/TaskFlow
15:13:00 <carl_baldwin> pcm_: I see your etherpad and I will have a look.
15:13:16 <carl_baldwin> It is linked from our subpage for others to find it too.
15:13:16 <pcm_> Swami: Allows you to create tasks for actions, flows (collection of tasks), and engine (how to apply the flow)
15:13:28 <pcm_> carl_baldwin: nice
15:13:56 <pcm_> Question is whether we'll consider using TaskFlow at a low and/or high level.
15:14:11 <carl_baldwin> I will also read through this task flow page.  I think this will touch everyone’s work in some way.
15:14:49 <pcm_> IOW: to do the flow for one command (validation, persistence, appy), or for one action (create VPN policy, create PSK, and create conneciton)
15:15:22 <pcm_> carl_baldwin: yes. need to understand more, have some examples, and discuss how to apply.
15:15:26 <carl_baldwin> pcm_: That is a good question.  We should keep that in mind as we review the two subjects.
15:15:56 <pcm_> I'm not sure (yet) how TaskFlow can be used with vendors (conditional tasks)
15:16:19 <pcm_> where we want to do a vendor validation, based on some flavor.
15:17:12 <pcm_> anyhow, add thoughts/comments/questions.etc on the Etherpad. Will really help.
15:17:33 <pcm_> Could use some eyes on the client capabilities BP, as I'm not sure how feasible that is.
15:17:36 <carl_baldwin> We’ll use the next week to review and think about it.  We can use etherpad and ML to discuss over the next week before the discussion.
15:17:50 <pcm_> roger that
15:18:02 <pcm_> that's if for me
15:18:05 <pcm_> it
15:18:10 <carl_baldwin> What is the link for the BP?
15:18:37 <pcm_> #link https://review.openstack.org/#/c/89366/1/specs/juno/l3-svcs-vendor-client-cap.rst
15:19:05 <carl_baldwin> Thanks, I see you have three BPs up now.  I had only seen the validation one.
15:19:17 <carl_baldwin> I’ll be sure the subteam links to them all.
15:19:40 <pcm_> Yeah, 3 BP and 3 specs, all interrelatted.
15:20:15 <carl_baldwin> pcm_: Thanks for your update.  You’ve done a lot of work to get that all posted.
15:20:45 <carl_baldwin> #action carl_baldwin will update subteam page to show all BP and specs.
15:20:49 <pcm_> welcome
15:20:58 <carl_baldwin> #topic l3-high-availability
15:21:22 <carl_baldwin> I don’t see safchain
15:22:00 <carl_baldwin> The activity I’ve seen on this is with dvr so we can discuss later.
15:22:17 <carl_baldwin> #topic bgp-dynamic-routing
15:22:20 <carl_baldwin> nextone92: hi
15:22:30 <nextone92> Hi!
15:22:48 <nextone92> Thank you everyone for providing comments
15:23:02 <carl_baldwin> I see you’ve posted a new revision of the bp.
15:23:23 <nextone92> I have responded to code review feedback and took down some action items for changes I haven't yet made
15:23:39 <carl_baldwin> Great.
15:24:10 <nextone92> There was a recommendation from Pedro Marques to consider merging this with VPN blueprint
15:24:36 <carl_baldwin> I didn’t see that.
15:24:54 <nextone92> It's the first comment BGP L3VPN
15:25:01 <carl_baldwin> To me, the two topics are distinct.
15:25:11 <nextone92> I believe we have discussed this early in L3 subteam meetings
15:25:33 <nextone92> I don't have a strong opposition for more BGP use cases, but think it would be prudent to start slow
15:25:40 <nextone92> start *small
15:25:47 <nextone92> and then expand to more use cases
15:26:12 <carl_baldwin> Yes.  I don’t think BGP L3VPN will be the first use case.
15:26:36 <carl_baldwin> I guess I had seen his comments on L3VPN.
15:27:05 <nextone92> Okay - the next action item are improvement comments from Mark Mcclain - I have responded on the code review and sent him an email from launchpad
15:27:16 <nextone92> I haven't heard back and will send him another emaik
15:27:45 <nextone92> The last action item is quagga HA question asked by you
15:28:12 <carl_baldwin> I recall some discussion in Hong Kong about BGP and L3 VPN.  I think there are some who get stuck on L3VPN whenever BGP comes up.
15:28:25 <carl_baldwin> We may have to be prepared for that in the discussion.
15:29:04 <carl_baldwin> nextone92:  You and I are sharing the session on Friday at 4pm.  We should probably have a discussion about how we’re going to use that time.
15:29:11 <nextone92> Okay, and I will try to see if I can meet Pedro in person and ask more questions
15:29:53 <carl_baldwin> That would be great.
15:29:57 <nextone92> Yes, my schedule is very open so any time that works for you would work for me. I will private message you.
15:30:06 <carl_baldwin> Would you like to talk before Atlanta or in Atlanta?
15:30:33 <carl_baldwin> Okay, we’ll discuss privately.
15:30:35 <carl_baldwin> Anything else?
15:31:06 <nextone92> I think we can talk about Quagga HA quicklt
15:31:29 <nextone92> One approach would be not to HA quagga, but to have multiple servers running quagga with their own uplinks
15:31:49 <nextone92> so when one quagga dies, there is a duplicate uplink with corresponding routes
15:31:53 <carl_baldwin> nextone92: I totally agree.  That is how I envisioned it.
15:32:10 <nextone92> Thank you for the clarification
15:32:16 <carl_baldwin> BGP kindof has that HA built in to the protocol.
15:32:38 <nextone92> Yes, and that seems the easiest approach
15:32:42 <carl_baldwin> Just run multiple BGP speakers to the same set of upstream routers.
15:32:48 <carl_baldwin> nextone92: Agreed
15:33:02 <carl_baldwin> Anything else?
15:33:03 <nextone92> The final question that I had is whether there is a routing daemon preference
15:33:21 <nextone92> Mark Mcclain has recommended to look into Bird vs Quagga
15:33:35 <carl_baldwin> Ah, my only reason for a preference is because I’ve only had experience with Quagga.  I’m open to suggestions.
15:34:14 <nextone92> Same here, if there are no other recommendations I will follow up with Mark
15:34:15 <carl_baldwin> The solution should be pluggable but we’ll need to discuss the options for a reference implementation.
15:34:23 <carl_baldwin> nextone92: great.
15:34:45 <carl_baldwin> #action nextone92 will follow up with markmcclain about comments and routing daemon.
15:34:58 <carl_baldwin> #topic rootwrap-daemon-mode
15:35:07 <carl_baldwin> YorikSar: ajo: hi
15:35:14 <YorikSar> o/
15:35:20 <carl_baldwin> I posted information about the summit session.
15:35:33 <carl_baldwin> YorikSar: you will not be at summit, right?
15:36:13 <YorikSar> carl_baldwin: Right. Roman Popolyaka agreed to represent me there
15:36:25 <YorikSar> *Podolyaka
15:36:55 <carl_baldwin> Great.  I also plan to attend.  I’ll introduce myself.  It will be good to have someone there who is up to date on your work.
15:37:28 <YorikSar> carl_baldwin: I also haven't came around to post the blueprint yet. I've been wrapped up in Nova scheduler specs...
15:37:42 <YorikSar> I hope to put together one soon.
15:37:52 <carl_baldwin> Okay.  Will you have one before the design session?
15:37:55 <YorikSar> I've also finally made my patch work with Neutron.
15:38:04 <YorikSar> carl_baldwin: Sure.
15:38:23 <carl_baldwin> YorikSar: Great.  I’d like to test it out.
15:38:37 <carl_baldwin> I’m sure others will too.
15:39:07 <carl_baldwin> I’ll grab the patches and give it a go.
15:39:16 <YorikSar> And I've found weird behavior in DHCP agent. It creates an instance of driver for every action needed to be done which makes it hard to link with rootwrap daemon's client - one daemon instance ends up running for each request.
15:39:29 <carl_baldwin> #action YorikSar will post blueprint before summit design talk.
15:39:38 <YorikSar> I'll file a bug on this topic and put together a fix
15:40:23 <YorikSar> Oh, my patch is there:
15:40:27 <YorikSar> #link https://review.openstack.org/84667
15:40:41 <carl_baldwin> Thanks for the link.
15:41:50 <YorikSar> You can see example of weird behavior here: (traceback for every creation of new Client is there)
15:41:56 <YorikSar> #link http://logs.openstack.org/67/84667/20/check/check-tempest-dsvm-neutron/3a7768e/logs/screen-q-dhcp.txt.gz?level=INFO
15:42:48 <carl_baldwin> Ah, yeah.  Send me the bug number when you’ve filed it.
15:43:01 <YorikSar> carl_baldwin: Ok.
15:43:04 <carl_baldwin> One last thing.  Thierry will drive this as part of the Oslo track.  As long as they keep sufficient traction in it then we won’t have this on this subteam agenda any more.
15:43:43 <carl_baldwin> I’ll watch from the background and try to fan the flames if it starts to die out.
15:43:51 <YorikSar> Huh... Ok. I guess I'll attend their meetings then
15:44:23 <carl_baldwin> I guess we’ll see how the transition goes at the summit discussion.
15:44:24 <YorikSar> carl_baldwin: It won't. Current overhead of rootwrap actually troubles me :)
15:44:35 <carl_baldwin> YorikSar: Me too.  :)
15:44:39 <carl_baldwin> Anything else?
15:44:41 <YorikSar> carl_baldwin: Sure.
15:44:58 <YorikSar> carl_baldwin: I'll also try to put together a patch for Nova next week.
15:45:18 <YorikSar> carl_baldwin: Nope. That's it.
15:45:43 <carl_baldwin> YorikSar: Great work.  I’m excited to see this improve rootwrap.
15:45:54 <carl_baldwin> #topic neutron-ovs-dvr
15:45:57 <carl_baldwin> Swami: hi
15:46:17 <Swami> hi
15:46:31 <Swami> Yes DVR work is progressing in fast pace.
15:46:48 <Swami> We are currently working on the SNAT for the North-South
15:47:15 <Swami> Hopefully we will complete this work with a couple of weeks.
15:47:47 <Swami> I will also update the Wiki with the Howto on configuring and running the DVR
15:47:51 <carl_baldwin> How close are we to having something the community can test?
15:48:06 <carl_baldwin> Ah, great timing for that comment.  Exactly what I was after.  :)
15:48:52 <Swami> Some parts of the code was not yet merged with the Master, so will be merging it in the next week or so and should be able to run with the Wiki's help
15:49:29 <carl_baldwin> That would be a great thing to have prepared before your summit session.
15:49:53 <carl_baldwin> Let’s see.  Wednesday at 5:20pm.
15:50:10 <Swami> Yes our plan was to have all the code as WIP before the summit and then start working on pushing the non-WIP code to upstream by the Juno milestone1
15:50:22 <carl_baldwin> If you have workable code published I might just skip whatever party is that night and go try it out.  ;)
15:50:42 <Swami> That's all I had from my end.
15:51:11 <carl_baldwin> Swami: Thanks for your report.
15:51:30 <carl_baldwin> Swami: It is great to see it coming together.
15:51:47 <carl_baldwin> #topic pluggable-ext-net
15:51:48 <Swami> carl: It is a great team effort
15:52:04 <carl_baldwin> #link http://junodesignsummit.sched.org/event/562393582543b1a0da0db766a5c4a7b3#.U2fC2K1dVcM
15:52:13 <carl_baldwin> #link https://etherpad.openstack.org/p/juno-neutron-pluggable-external-network
15:52:28 <carl_baldwin> #action carl_baldwin will start fleshing out the etherpad by the end of the week.
15:52:46 <carl_baldwin> This is the sharing I’m sharing with nextone92
15:52:54 <carl_baldwin> That’s all I have.
15:53:04 <carl_baldwin> #topic *-dns-resolution
15:53:35 <carl_baldwin> My design topic got bumped at the last minute before the schedule came out.
15:54:03 <carl_baldwin> However, there is a lot of interest in having a discussion.  Looks like we’ll try to get together late afternoon on Monday.
15:54:28 <carl_baldwin> #link https://etherpad.openstack.org/p/juno-dns-neutron-nova-designate
15:55:12 <carl_baldwin> #topic Open Discussion
15:56:31 <carl_baldwin> We got through it all.
15:57:30 <Swami> I think you covered a lot of items today
15:57:45 <Swami> I don't have any open items at this time.
15:58:13 <pcm_> See you all at the summit!
15:58:35 <carl_baldwin> I look forward to meeting most of you at the summit.  We have some good discussions coming up.
15:58:56 <carl_baldwin> Thanks for all your work.  Things are progressing well.
15:58:58 <Swami> See you , bye
15:59:07 <carl_baldwin> #endmeeting