15:02:06 <carl_baldwin> #startmeeting neutron_l3
15:02:07 <openstack> Meeting started Thu Apr 24 15:02:06 2014 UTC and is due to finish in 60 minutes.  The chair is carl_baldwin. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:11 <openstack> The meeting name has been set to 'neutron_l3'
15:02:11 <carl_baldwin> xuhanp: hi
15:02:18 <carl_baldwin> #topic Announcements
15:02:26 <carl_baldwin> #link https://wiki.openstack.org/wiki/Meetings/Neutron-L3-Subteam
15:03:01 <carl_baldwin> Sounds like the selection process for summit sessions is moving right along.  The deadline for submitting topics has passed.
15:03:27 <carl_baldwin> Any other announcements?
15:04:19 <carl_baldwin> #topic l3-svcs-vendor-*
15:04:26 <carl_baldwin> pcm_: hi, any updates since last week?
15:04:44 <pcm_> just to have people review the specs that are out.
15:05:23 <pcm_> I'm trying to create a simple prototype of validation calling sequence. Will put it out in gerrit to get thoughts
15:06:00 <carl_baldwin> Great.  I encourage working through as much as possible before summit.  I think the discussion will be more productive that way.
15:06:11 <pcm_> There are a bunch of ways to handle, so will want to get something that everyone likes.
15:06:34 <pcm_> Yeah, plan is to get something on Gerrit, just to discuss.
15:06:36 <carl_baldwin> I’m trying to pull up the blueprints page but I’m having trouble with launchpad.  Is it just me?
15:07:14 <carl_baldwin> It must be launchpad.  I can hit gerrit without a problem.
15:07:14 <pcm_> For the spec, is OK: https://review.openstack.org/#/c/88406/
15:07:40 <pcm_> Right, BP page is not coming up
15:07:42 <Sudhakar> yep..launchpad not loading for me too..
15:08:12 <pcm_> carl_baldwin: Well, just imagine this really great BP :)
15:08:12 <carl_baldwin> pcm_: Do you have all three specs up or just the one?
15:08:18 <pcm_> all three
15:08:28 <carl_baldwin> #link https://review.openstack.org/#/c/88406/
15:08:30 <pcm_> https://review.openstack.org/#/c/88482/
15:08:40 <pcm_> https://review.openstack.org/#/c/89366/
15:08:53 <pcm_> Been mostly thinking about the validation one.
15:08:55 <carl_baldwin> Feel free to use the (#)link syntax to get the links in to the meeting minutes.
15:09:37 <carl_baldwin> Okay, I will read through them.  I encourage others to do the same.  It will be good preparation for the summit discussion.
15:09:38 <pcm_> Not much though on how to do the client caps one (89366) other than broad strokes.
15:10:11 <carl_baldwin> #link https://review.openstack.org/#/c/88482/
15:10:30 <carl_baldwin> #link https://review.openstack.org/#/c/89366/
15:10:38 <carl_baldwin> ^ Just to get them in to the minutes.
15:10:44 <carl_baldwin> pcm_: Anything else?
15:10:45 <pcm_> ah, thanks. Will try to remember that!
15:10:50 <pcm_> no. thanks!
15:11:11 <carl_baldwin> #topic l3-high-availability
15:11:14 <Sudhakar> pcm_:good work...
15:11:36 <pcm_> Sudhakar: thanks!
15:11:48 <carl_baldwin> ^ pcm_ I echo that too.  Thanks for getting those specs up so quickly.
15:12:00 <carl_baldwin> safchain: Are you around?
15:12:10 * pcm_ someone had to be the guinea pig for Kyle :)
15:12:55 <carl_baldwin> #link https://review.openstack.org/#/q/topic:bp/l3-high-availability,n,z
15:13:40 <carl_baldwin> These review have been neglected during the push to Icehouse.
15:13:57 <carl_baldwin> I’m not sure if there is a spec written and posted to gerrit yet.
15:14:13 <carl_baldwin> #action carl_baldwin will follow up with Sylvain about the spec.
15:14:39 <carl_baldwin> #topic bgp-dynamic-routing
15:14:42 <Sudhakar> carl l3 HA is now targeted for Juno1?
15:15:03 <nextone92> I have an action item to check in the spec into gerrit
15:15:15 <carl_baldwin> Sudhakar: I believe so.
15:15:29 <Sudhakar> ok..
15:15:32 <carl_baldwin> nextone92: Do you have a timeline yet?
15:15:57 <nextone92> I'll get that done this week
15:16:09 <carl_baldwin> BTW, great job nextone92 on getting your session accepted for summit.
15:16:33 <nextone92> Thank you, I'm excited to have this opportunity to discuss dynamic routing :)
15:16:50 <Sudhakar> nextone92 Congrats :)
15:16:55 <carl_baldwin> There are a lot of sessions being combined.  Let’s find a time to chat about how to best utilize the time for a good discussion.
15:17:29 <nextone92> That sounds good
15:17:36 <carl_baldwin> nextone92: Could you send an email to the ML when the spec is posted?
15:17:46 <carl_baldwin> nextone92: Maybe tag me as a reviewer as well.
15:17:57 <nextone92> Okay, I'll do that
15:18:02 <carl_baldwin> … and any other team members as well.
15:18:27 <nextone92> #action nextone92 submit dynamic routing blueprint spec on gerrit
15:18:45 <carl_baldwin> nextone92: great!
15:19:04 <carl_baldwin> Anything else this week?
15:19:22 <nextone92> I received and responded to comments from Igor - thank you!
15:19:30 <nextone92> And that's it
15:19:47 <carl_baldwin> nextone92: Thanks
15:20:02 <carl_baldwin> #topic rootwrap-daemon-mode
15:20:08 <carl_baldwin> ajo: YorikSar: hi
15:20:15 <YorikSar> o/
15:20:42 <carl_baldwin> Anything to report?
15:20:43 <YorikSar> I didn't spend too much time on rootwrap this week.
15:20:59 <YorikSar> I've managed to provide more low-level workaround for that problem though.
15:21:04 <YorikSar> And it actually worked :)
15:21:19 <YorikSar> So now I have to see what fails in tempest.
15:21:29 <carl_baldwin> That is great!  So, does that take care of the big blocker?
15:22:03 <YorikSar> I haven't provided more info to that Ubuntu bug yet though...
15:22:15 <YorikSar> It looks very much like it.
15:22:32 <YorikSar> But I think it'd be good to push that backport at least to Ubuntu.
15:22:58 <YorikSar> And I still haven't got around to testing on CentOS or just Python 2.6.
15:23:17 <carl_baldwin> Okay. Good progress though.
15:23:21 <carl_baldwin> Unfortunately, there is another blocker.  :(  The new process will require a blueprint merged in to the neutron-specs repository.
15:23:55 <YorikSar> Yes, I've seen someone (was it you?) -1ing my change because of that.
15:24:31 <YorikSar> I think my bp in neutron will be rather small, so I think I'll do it today or tomorrow.
15:24:51 <carl_baldwin> I don’t recall doing that but I probably would have.  -1 isn’t so bad.  ;)  Some changes are -2’d because of that.
15:25:13 <pcm_> FYI #link https://wiki.openstack.org/wiki/Blueprints#Neutron
15:25:46 <YorikSar> That was Sean M. Collins (don't know his nick)
15:26:06 <carl_baldwin> pcm_: Thank you for the link.  There is a bit of a learning curve with the new process.  A nice template is provided though.
15:26:25 <carl_baldwin> YorikSar: Anything else?
15:26:39 <pcm_> Yeah, lot of items to fill out, but makes you think about design.
15:26:40 <YorikSar> Nope. That's it on this topic.
15:27:10 <carl_baldwin> Great work on that work-around and thanks for the update.
15:27:19 <carl_baldwin> #topic neutron-ovs-dvr
15:27:54 <carl_baldwin> #undo
15:27:55 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0x3808e50>
15:28:26 <carl_baldwin> #topic *-dns-resolution
15:28:27 <YorikSar> <ircmeeting.items.Topic object at 0x3808e50> - how cool is that! :)
15:29:06 * carl_baldwin is not exactly sure what that means
15:29:11 <Sudhakar> YorikSar good catch ;)
15:29:48 <YorikSar> carl_baldwin: That means that bot tried to write some Python object without converting it to string :)
15:30:05 <carl_baldwin> YorikSar: thanks.  :)
15:30:33 <carl_baldwin> I got a couple of blueprints up on the topic of DNS resolution and got a session topic accepted.
15:30:52 <carl_baldwin> #link https://blueprints.launchpad.net/neutron/+spec/internal-dns-resolution
15:31:01 <carl_baldwin> #link https://blueprints.launchpad.net/neutron/+spec/external-dns-resolution
15:31:21 <Sudhakar> carl Congrats!
15:31:30 <carl_baldwin> Sudhakar: thanks.
15:31:55 <carl_baldwin> That is all I have to report.  Just that the blueprints are up for review.  I look forward to discussing them in gerrit and at the summit.
15:33:12 <carl_baldwin> I don’t see Swami on yet.
15:33:40 <carl_baldwin> #topic pluggable-ext-net
15:33:53 <carl_baldwin> This is another blueprint I’ve filed.
15:33:56 <carl_baldwin> #link https://blueprints.launchpad.net/neutron/+spec/pluggable-ext-net
15:34:18 <carl_baldwin> I had hoped Swami would be on to discuss this along with DVR.
15:35:24 <carl_baldwin> The idea started with addressing and eliminating the need to consume public IP addresses for the compute nodes when DVR is in use.
15:35:53 <carl_baldwin> This was a loose end in the original DVR plan that needed some more thought while allowing DVR to progress without it.
15:36:49 <carl_baldwin> It will also allow the flexibility to use introduce dynamic routing on ext-net per nextone92 ’s blueprint.
15:37:37 <carl_baldwin> #topic neutron-ovs-dvr
15:38:28 <carl_baldwin> I’ll try to report what I know.  Feel free to jump in if you have anything to report.
15:38:55 <carl_baldwin> #topic https://review.openstack.org/#/q/topic:bp/neutron-ovs-dvr,n,z
15:39:02 <carl_baldwin> #undo
15:39:02 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0x398ec90>
15:39:08 <carl_baldwin> #link https://review.openstack.org/#/q/topic:bp/neutron-ovs-dvr,n,z
15:39:19 <carl_baldwin> Oops.
15:39:40 <carl_baldwin> The team continues to post patches as they are able to get them merged to master.
15:40:42 <carl_baldwin> The patches as they appear in gerrit are not quite sufficient to test the whole solution yet.
15:41:14 <carl_baldwin> Target is still Juno-1
15:41:38 <carl_baldwin> I believe that they have still have an action item to post the blueprint specification to gerrit.
15:42:05 <carl_baldwin> #action Swami post blueprint specification to gerrit
15:42:45 <xuhanp> https://review.openstack.org/#/c/89934/  there is one on gerrit
15:43:21 <carl_baldwin> xuhanp: Great, I did not see that post yesterday.  Thank you for the link.
15:43:26 <carl_baldwin> #undo
15:43:27 <openstack> Removing item from minutes: <ircmeeting.items.Link object at 0x3800e10>
15:44:07 <carl_baldwin> #link https://review.openstack.org/#/c/89934/
15:44:45 <carl_baldwin> DVR is a top priority for Juno.  It would be great to get eyes on this review soo.
15:45:39 <carl_baldwin> *soon
15:45:58 <carl_baldwin> That is all that I can think of for DVR.
15:47:20 <carl_baldwin> Is there any topic that I’ve missed?
15:47:47 <Sudhakar> nope
15:48:05 <carl_baldwin> #topic Open Discussion
15:49:41 <Sudhakar> carl good thought of linking the DNS hostnames to the dnsmasq ...
15:50:39 <carl_baldwin> Sudhakar: thanks.  The thought has been out there in one form or another.  Just wasn’t getting any traction and there were a lot of loose ends that hopefully the blueprint addresses.
15:51:44 <Sudhakar> true.. all these days I happy enough to see IP addresses pinging after the deployment...  ;)
15:52:09 <carl_baldwin> Also, that needed to be address before we could start thinking about integrated DNS externally.
15:52:34 <Sudhakar> agreed...
15:54:13 <carl_baldwin> Well, if there is nothing else.  We can end.
15:54:46 <carl_baldwin> Great work in a lot of areas.  We have a handful of summit sessions.  Great job on that as well.
15:55:02 <carl_baldwin> #endmeeting