15:01:52 <carl_baldwin> #startmeeting neutron_l3
15:01:53 <openstack> Meeting started Thu Mar  6 15:01:52 2014 UTC and is due to finish in 60 minutes.  The chair is carl_baldwin. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:55 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:57 <openstack> The meeting name has been set to 'neutron_l3'
15:02:14 <carl_baldwin> #topic Announcements
15:02:28 <carl_baldwin> #link https://wiki.openstack.org/wiki/Meetings/Neutron-L3-Subteam
15:02:58 <carl_baldwin> #info Daylight savings time for US starts this weekend.  Next week’s team meeting will shift by an hour in the US.
15:03:31 <carl_baldwin> Watch for your local daylight savings time for when the meeting will shift in your geography.
15:04:08 <carl_baldwin> #topic l3-high-availability
15:04:37 <carl_baldwin> Is safchain around?
15:05:17 <carl_baldwin> Review of the code is still in progress.  safchain has posted recent updates to the patches.
15:05:41 <Swami> hi carl
15:05:55 <carl_baldwin> Hi Swami.  Thanks for joining.
15:06:50 <Swami> sorry I was a bit late
15:07:11 <carl_baldwin> #info We've added some guides to reviewing and testing the l3-high-availability code.  Available from the sub team page.
15:07:59 <carl_baldwin> #topic neuron-ovs-dvr
15:08:09 <Swami> Hi carl
15:08:18 <Swami> Yes we have uploaded the L2 design doc
15:08:31 <Swami> Thanks Carl for bringing it to the ML2 teams attention
15:08:44 <Swami> We will be providing feedback on any comments on the doc
15:09:04 <Swami> I saw your comments and I will address all your comments
15:09:07 <carl_baldwin> Happy to help.  There were a few questions brought up in the meeting.
15:09:22 <Swami> We are working on the L3 agent doc and will share with the team when it is ready
15:09:31 <carl_baldwin> Great, looking forward to it.
15:09:49 <Swami> In our meeting yesterday we also discussed about the utilizing the L3 VRRP HA for the DVR
15:09:58 <Swami> Safchain mentioned that it should work.
15:10:23 <Swami> By next week we might be able to split the tasks and start adding tasks to the Launchpad
15:10:35 <Swami> That's all from my end.
15:10:42 <carl_baldwin> Great to see the progress.  Thank you.
15:11:32 <carl_baldwin> #topic bgp-dynamic-routing
15:12:05 <carl_baldwin> Is Artem around?  I'm not sure what your IRC nickname is.
15:12:14 <nextone92> Good morning!
15:12:42 <nextone92> It's just 'nextone92'
15:12:52 <carl_baldwin> Hi.  Great.  Now I know.
15:13:07 <carl_baldwin> There has been some interesting discussion on the blueprint this week.
15:13:31 <carl_baldwin> Is there anything that you would like to highlight or discuss?
15:13:33 <Swami> carl: is there a separate meeting on this. if so can you include me on that
15:13:53 <carl_baldwin> Swami: No, but I should provide a link to the document.
15:14:02 <Swami> carl: thanks
15:14:03 <carl_baldwin> #link https://docs.google.com/a/ecbaldwin.net/document/d/1wUcgL6ZTqB14DsiNvGaA1Ao2Try5i5E7_VAzcavzTbY/edit#heading=h.l8nz0xz5ct46
15:14:14 <nextone92> The basic use case for the dynamic routing is to automatically negotiate routes to/from OpenStack
15:14:38 <Swami> I had one suggestion because the "BGP" is also used by the VPN service, can this be abstracted and then either used by the L3 service or by the VPN service
15:14:48 <nextone92> But it's written not to limit other use cases within OpenStack
15:15:53 <carl_baldwin> Swami: I do recall that was brought up as a use case at the summit.  My impression is that it is out of scope for this use case but I wonder what sort of abstraction can allow for that.
15:16:12 <carl_baldwin> nextone92: Any thoughts on the VPN question?
15:16:25 <Swami> There were couple of more blueprints that address the BGP support for the VPN services.
15:16:53 <Swami> If we can combine all those and that create an abstract for the BGP then it would be great and it can be used against any services.
15:17:06 <Swami> With respect to API/CLI we don't need to redo anything.
15:17:27 <nextone92> Swami, Carl - could VPN connection be abstracted as a gateway router?
15:17:41 <carl_baldwin> Swami: Do you happen to have links handy for those bps?  If not, could you add links to them to the sub team page?  I'd like to review them.
15:18:25 <Swami> ok will do
15:18:55 <carl_baldwin> #action Swami will add links to BGP bps to sub team page under dynamic routing section.
15:19:21 <carl_baldwin> I would like to review those and give it some thought.  Maybe we can continue that discussion next week.
15:19:47 <carl_baldwin> #action carl_baldwin will review BGP bps.
15:19:52 <Swami> #link https://blueprints.launchpad.net/neutron/+spec/neutron-bgp-mpls-vpn
15:19:54 <nextone92> That sounds great!
15:20:44 <carl_baldwin> nextone92: What are your thoughts on whether to peer individual neutron routers with upstream routers or to aggregate them in to fewer peers from the Neutron side?
15:21:34 <nextone92> For the purposes of connecting to the upstream networks/routers, I think the latter would be more efficient
15:22:03 <carl_baldwin> I agree.  It removes the scaling concerns that I had.
15:22:41 <carl_baldwin> If that is the direction then I think the API changes section needs some work.
15:23:06 <nextone92> Would it be to scandalous to talk about a concept of "provider" routers?
15:23:45 <nextone92> For example, a tenant router using a bgp enabled "provider" router for communication outside of OpenStack network
15:24:49 <Swami> So in this case the bgp is not enable inside the openstack cloud and only enabled by the provider router.
15:24:50 <carl_baldwin> nextone92: I think that should be considered.  We would still need an open source implementation, no?
15:25:07 <nextone92> Absolutely
15:25:13 <Swami> So it is just connecting your service node to a provider router.
15:25:56 <nextone92> Maybe a "provider" router could be an instance of quagga performing dynamic route exchange but not the actual traffic forwarding
15:27:14 <carl_baldwin> nextone92: That is along the lines of what I was thinking but I wasn't thinking of it as a "provider router".  I thought of it more as just a dynamic routing process.
15:27:19 <Swami> Hi nextone92 could you please add an use case in your blueprint with a picture and a description on what you are proposing with respect to the provider router.
15:28:52 <Swami> Also there was already a provider router blueprint out there. May be we need to take a look at that also.
15:28:55 <nextone92> Swami, that sounds good. I will add a more clear description of the main use case and try not to make it too restrictive so it can't be reused with the blueprint you have posted (neutron-bgp-mpls)
15:29:36 <carl_baldwin> #action nextone92 will update bp.
15:29:41 <carl_baldwin> Anything else for this week?
15:30:44 <carl_baldwin> #topic l3-agent
15:31:36 <carl_baldwin> Does anyone have anything to discuss (e.g. l3-agent-consolidation, l3-router-service-type-framework)
15:31:54 <carl_baldwin> I did not have anything in mind...
15:32:09 <Swami> Hi carl: Yesterday I saw a message from Mark that Agent consolidation was moved to Juno and it did not make the cut through for the Icehouse
15:32:32 <carl_baldwin> Swami: Yes, he did add a note to the bp.  Thanks for the reminder.
15:33:30 <carl_baldwin> There is code to review.  It is linked to the blueprint.
15:34:37 <carl_baldwin> #topic DNS
15:35:28 <carl_baldwin> This is one that I'm working on.  I have a blueprint nearly done.  I need to have my company review and approve but hopefully I can have it ready to review next week.
15:35:57 <carl_baldwin> The basic idea is to reconcile DNS names in neutron with instance names.  Then, integrate with DNSaaS.
15:36:26 <Swami> sounds good
15:36:47 <carl_baldwin> #action carl_baldwin to finish blueprint for DNS instance lookup
15:36:53 <carl_baldwin> #topic Open Discussion
15:37:37 <carl_baldwin> markmcclain: Hi, anything for the L3 sub team?
15:38:09 <carl_baldwin> Also, anyone else bring anything to discuss?
15:38:17 <markmcclain> carl_baldwin: nothing from me
15:38:36 <Swami> carl: nothing to add
15:38:56 <carl_baldwin> markmcclain: No problem, just saw you'd joined the room.
15:41:09 <carl_baldwin> If there is nothing else, I'll run off to another meeting.
15:41:45 <carl_baldwin> Thank you to those who joined.  Until next week.
15:41:50 <nextone92> Thanks
15:41:51 <carl_baldwin> #endmeeting