22:01:48 <mestery> #startmeeting networking_third_party_testing
22:01:49 <openstack> Meeting started Thu Dec 19 22:01:48 2013 UTC and is due to finish in 60 minutes.  The chair is mestery. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:01:50 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:01:52 <openstack> The meeting name has been set to 'networking_third_party_testing'
22:01:53 <shivharis> hi all
22:02:10 <roeyc> Hi
22:02:18 <hichihara> Hi
22:02:22 <yamahata> hi
22:02:22 <mestery> #link https://etherpad.openstack.org/p/multi-node-neutron-tempest Shared Etherpad for 3rd Party Testing and Multi-Node Tempest Testing
22:02:57 <mestery> gongysh amotoki, you guys here?
22:03:36 <mestery> OK, so lets get started, myabe this will be quick this week.
22:03:51 <mestery> I guess lets just start with the obivous: Where are people at with regards to Neutron 3rd party testing?
22:04:01 <mestery> Does anyone have a full voting Tempest setup up and (partially) working yet?
22:04:16 <shivharis> partially working ...
22:04:23 <luqas> partially too
22:04:28 <roeyc> same here
22:04:42 <mestery> Great! What issues have you guys faced in this so far?
22:04:43 <shivharis> Jenkins seems not too flexible
22:04:52 <mestery> shivharis: In what way?
22:05:02 <shivharis> I have issues with patchset ID
22:05:29 <shivharis> The patchset id is the the code that need to be tested
22:05:35 <mestery> shivharis: I see you put that on the wiki. Perhaps we can collect those there and ask someone from -qa for help with an email to openstack-dev?
22:05:41 * mestery nods.
22:05:46 <shivharis> not the one at the top of the branch
22:06:25 <shivharis> I want to add the broad step there; can some take a look and see if that is what need to be done. (very broad)
22:06:31 <mestery> So you can get the top of hte branch patchset ID, but not the one from the gerrit review itself?
22:07:15 <shivharis> The event posted by the patchset Id need to be derived somehow. having toruble with that
22:07:38 <shivharis> to be precise gerrit posts and event and that event has the patchset id
22:07:45 <mestery> shivharis: Can you ping someone in -qa or email openstack-dev? Also, whatever you find out, put it in the wiki.
22:08:02 <shivharis> Ok willdo.
22:08:33 <shivharis> can folks see the etherpad and agree on the broad steps, just posted to etherpad
22:08:34 <mestery> #action shivharis to figure out patchset ID issue and report back on etherpad with fix.
22:08:49 <mestery> shivharis: At the bottom?
22:08:59 <shivharis> yes
22:09:22 <mestery> shuvharis: How much of what you've put there is covered by these instructions: http://ci.openstack.org/running-your-own.html
22:09:38 <shivharis> not much..
22:09:42 <mestery> :)
22:10:46 <mestery> So, I think the general flow of what you're trying to do is right shivharis.
22:10:57 <shivharis> Do we have to do this with Jenkins, can we do another way?
22:11:15 <jbrendel> I think you can manually read the Gerrit event stream.
22:11:17 <mestery> shivharis: You can do this anyway you want, but I was thinking using Jenkins would be easier, perhaps it's not.
22:11:30 <mestery> jbrendel: Is that what you're doing, skipping some of this infra?
22:11:49 <jbrendel> I've heard the Jenkins plugin takes care of a lot of issues (such as making test results available to upstream).
22:11:51 <shivharis> I found jenkins is not flexible enough. Had more success reading the event stream.
22:12:01 <jbrendel> Haven't implemented that yet, though, so can't be sure.
22:12:35 <mestery> jbrendel: Agreed, if it takes care of some details, I think it's the way to go quite honestly,.
22:12:37 <jbrendel> #shivharis: Interesting. Reading the event stream itself shouldn't be too difficult, but are there other benefits to using Jenkins?
22:14:22 <shivharis> without jenkins, posting results is quite easy as well
22:14:54 <luqas> shivaris: yes but you have to do it manually...
22:15:47 <shivharis> nothing can be manual.
22:16:02 <shivharis> it has to run anytime and event is posted.
22:16:08 <shivharis> s/and/an/
22:16:15 <jbrendel> Ok, what does the Jenkins plugin give you?
22:16:34 <jbrendel> Maybe "manual" here referred to "having to implement some mechanism yourself" vs. "letting the plugin do it"?
22:17:13 <luqas> the ability to run tests and post the results?
22:17:29 <mestery> luqas: Agreed, I thought that's what it got us, does it not?
22:17:32 <shivharis> I have limited Jenkins knowledge. need some pointers/folks I can talk to
22:18:24 <mestery> shivharis: The best place is to talk to folks in #openstack-qa, they can give guidance there, or on the mailing list.
22:18:43 <mestery> I suspect a lot of people listening here have minimal Jenkins experience as well.
22:19:19 <shivharis> Actually runnings tests is minor. We need the right code, from the correct branch and them applying patchset, then testing
22:19:52 <shivharis> branch is "stable/grizzly", ... "master"
22:20:59 <mestery> Can anyone verify that is  what the jenkins plugin actually helps with?
22:22:59 <mestery> OK, so if people look near hte bottom of the shared etherpad, you can see some info on how hte QA team has suggested we all sedt this up.
22:23:07 <mestery> The part about "Use Infrastructure for Testing"
22:23:32 <mestery> I suggest we take a look at that and see how far it gets us, and we can reconvene the week after next, on January 2.
22:23:42 <mestery> Unless anyone has anything else today?
22:24:03 <shivharis> I can talk to #openstack-qa and get back
22:24:23 <mestery> Thanks shivharis.
22:24:30 <mestery> OK, so lets proceed with this plan then.
22:24:32 <luqas> i got a question regarding who's responsible for the third party testing of ODP
22:24:41 <mestery> luqas: OpenDaylight?
22:25:00 <luqas> if any
22:25:11 <mestery> luqas: I am working with the Linux Foundation on that, we're stuck getting VMs for that. So I guess you could say I'm sheparding that at the moment.
22:25:29 <mestery> rosella was interested in helping there, is she still?
22:25:39 <luqas> ok, so I will talk to you offline :-)
22:25:48 <mestery> ok, thanks.
22:25:55 <luqas> yes I guess
22:26:05 <mestery> OK, well happy holidays everyone and we'll see you in the new year!
22:26:21 <luqas> merry xmas!
22:26:25 <mestery> Questions or issues before then, please ping -neutron -qa on IRC or send email to openstack-dev with "[neutron] [third-party-testing]" in the subject!
22:26:27 <mestery> #endmeeting