14:01:48 <mestery> #startmeeting networking_ml2
14:01:49 <openstack> Meeting started Wed Nov 20 14:01:48 2013 UTC and is due to finish in 60 minutes.  The chair is mestery. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:50 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:52 <openstack> The meeting name has been set to 'networking_ml2'
14:02:12 <mestery> #link https://wiki.openstack.org/wiki/Meetings/ML2 Agenda
14:02:30 <mestery> Only two things on the agenda today: Testing and TypeDriver discussion.
14:03:05 <mestery> #announcements
14:03:11 <mestery> #topic announcements
14:03:29 <mestery> Anyone have anything to share with the ML2 sub-team?
14:03:33 <mestery> Announcement wise?
14:04:03 * mestery thinks some people have forgotten about the time change in the US.
14:04:09 <mestery> #topic Testing
14:04:33 <mestery> So, as most folks are aware, the priority item for Neutron in Icehouse is improving Test coverage in Tempest.
14:04:52 <mestery> #link https://etherpad.openstack.org/p/NeutronIcehouseProjectPlan Neutron Icehouse Project Plan
14:05:36 <mestery> What I'd like to discuss for the first part of this meeting is ML2 Tempest testing, and how we can improve things there.
14:06:04 <mestery> Currently, we're testing ML2 with the OVS agent.
14:06:22 <mestery> We need some additional testing for both Linuxbridge and L2 Population as well, at a minimum.
14:07:14 <mestery> What other testing gaps with ML2 do people see exist?
14:07:24 <matrohon> hi
14:07:31 <garyk> mestery: are the gating issues with ml2 fixed
14:07:48 <mestery> garyk: I think they are currently being worked on.
14:07:59 <mestery> garyk: Although, specifically which ones are you referring to?
14:08:29 <garyk> mestery: ok, thanks. the mail that jog0 sent to the list indicated that at least 29 failures are due to this. i am trying to dig up the bug give me a sec
14:08:41 <mestery> garyk: I'm also checking ...
14:09:16 <amotoki> hi
14:09:28 <garyk> mestery: https://bugs.launchpad.net/neutron/+bug/1244255
14:09:31 <uvirtbot> Launchpad bug 1244255 in neutron "binding_failed because of l2 agent assumed down" [Undecided,Fix committed]
14:09:45 <garyk> it looks like a fix was commited :)
14:10:31 <mestery> garyk: Yes, thanks for sharing this one!
14:10:54 <mestery> Is anyone aware of other bugs for ML2 we should be tracking right now?
14:11:17 <mestery> #link https://bugs.launchpad.net/neutron/+bugs?field.tag=ml2 ML2 Bugs
14:11:30 <mestery> The current list shows 10, with 4 medium ones.
14:12:39 <mestery> OK, switching back to Tempest again.
14:12:58 <mestery> For those who joined late, we need to add Tempest tests which cover ML2+Linuxbridge and ML2+L2 Population.
14:13:04 <mestery> To ensure coverage for those MechanismDrivers.
14:13:55 <matrohon> ok, working on ml2+l2pop tempest case is in our short roadmap
14:14:20 <mestery> matrohon: Thanks! Any chance you will have something by Icehouse-2?
14:14:41 <matrohon> mestery: that's our goal!
14:15:03 <mestery> matrohon: Great!
14:15:20 <matrohon> I understood that gating could not occurs on a multi-host config?
14:15:25 <mestery> So I'm going to look at adding ML2+Linuxbridge Tempest tests to ensure coverage there as well.
14:15:44 <mestery> matrohon: I don't know that for sure, someone from QA can answer that for us I think.
14:16:03 <mestery> But it would be good if we could make that happen, as L2 Pop is more useful in multi-host.
14:16:38 <matrohon> mestery: I totally agree, and we need multi-host to test tunneling too
14:16:45 <rkukura> sorry I'm late - forgot this was scheduled on GMT
14:16:48 <mestery> matrohon: Yes.
14:17:05 <mestery> rkukura: No problem. We're discussing ML2 Tempest tests now for expanded coverage per the agenda.
14:17:13 <rkukura> ok
14:17:40 <mestery> At a high level, we need to ensure coverage of all existing Open Source MechanismDrivers.
14:19:03 <amotoki> nova also seems to have no tests with multi node.
14:19:34 <mestery> amotoki: Good data point. I wonder why that is?
14:20:03 <amotoki> i am not sure the reason now. I just checked nova jenkins results.
14:20:12 <sc68cal> Possibly because multi node nova-network acts the same across nodes?
14:20:54 <sc68cal> since it NATs all the instances running on the HV, I don't think there's any east-west side effects
14:21:04 <mestery> sc68cal: Agreed.
14:21:08 <anteaya> o/
14:21:10 <amotoki> i see.
14:21:25 <mestery> anteaya: We're wondering about multi-host Tempest tests.
14:21:33 * anteaya listens
14:21:38 <mestery> For some of the ML2 Tempest tests we want to add, multi-host Tempest tests would be a requirement.
14:21:49 <anteaya> great
14:21:54 <mestery> But we haven't seen any of these. Any idea why those don't exist?
14:21:57 <mestery> No requirement perhaps?
14:22:13 <anteaya> I have no idea what the reqirements would be but I can find out who would know and get some information flowing
14:22:28 <anteaya> it is possible there is no requirement yet
14:22:29 <mestery> anteaya: That would be great! Much appreciated! Point them my way if you can. :)
14:22:39 <anteaya> in which case, we need to make some
14:22:44 <anteaya> will do
14:22:48 <amotoki> i think it is better to have multinode tests as second step. it is good to test not only l2pop but aslo agent scheduler or other things.
14:23:04 <jp_at_hp> From the description of the devstack gate test it is deliberately single-host.  I think the lack of multi-node devstack gate is the difficulty of automating that orchestration at the tooling level. https://github.com/openstack-infra/devstack-gate
14:23:33 <mestery> jp_at_hp: Thanks for the link.
14:24:27 <mestery> OK, anything else from anyone on testing before we move to the next item on the agenda?
14:24:40 <anteaya> if we have a use case for testing multi-node we need to create the structure to support that
14:24:55 <mestery> anteaya: Agreed.
14:24:55 <jp_at_hp> Should there be an action for someone to follow up with the ci team to determine if multi-node testing can be performed uin the gate?
14:24:59 <anteaya> we are creating a whole new paradigm for testing tripleo
14:25:11 <aveiga> mestery, being new to the community I may be missing something here, but is it possible to put in preliminary non-gating tests for IPv6 to be informative?
14:25:15 <anteaya> we can do the same for multi-node now that we know about it
14:25:29 <mestery> jp_at_hp: Good idea.
14:25:45 <matrohon> anteaya : great!
14:25:47 <mestery> #action mestery to follow up with the ci team to determine if multi-node testing can be performed in the ate.
14:26:28 <mestery> aveiga: I think that's possible, but given how new I am in this area, maybe anteaya knows for sure.
14:26:33 <dkehn> another link
14:26:41 <dkehn> another linnk http://devstack.org/guides/multinode-lab.html
14:27:08 <dkehn> a long time ago this is what I used
14:27:10 <mestery> dkehn: Thanks for sharing the link.
14:27:20 <aveiga> sorry for not formally introducing myself: I'm Anthony Veiga from the Comcast OpenStack team
14:27:22 <mestery> dkehn: I routinely use multi-node devstack for testing in my lab as wel.
14:27:29 <anteaya> aveiga: I don't know the answer to that question right now, let's discuss in -neutron
14:27:31 <mestery> aveiga: Hey, welcome!
14:27:45 <anteaya> welcome aveiga
14:28:22 <mestery> OK, lets move on to the next topic on the agenda now.
14:29:05 <mestery> #topic Modular L2 TypeDriver extra port information
14:29:17 <mestery> asomya rkukura: Still with us?
14:29:24 <asomya> yup
14:29:25 <rkukura> yes
14:29:29 <mestery> Cool.
14:29:50 <mestery> Wanted to follow up on this Summit session with regards to the review here:
14:30:03 <mestery> #link https://review.openstack.org/37893 ML2 TypeDriver extra port info
14:30:23 <mestery> I think we wanted to discuss how much of that review closed the gap on asomya's Summit session
14:30:54 <asomya> I'm reviwing Zang Mingjie's patch.. seems to overlap quite a bit with what we discussed in the summit
14:31:26 <asomya> But doesn't quite cover it 100%.. i think we can build on top of his patch
14:31:34 <mestery> Yes. Perhaps reviving this one is a way to do what you're looking at, which is why rkukura suggested evaluating this.
14:31:50 <ZangMingJie> Any suggest? so I can improve my patch
14:32:28 <asomya> ZangMingJie: I'll post comments on the review itself,
14:32:32 <rkukura> I like that ZangMingJie's patch opens up TypeDrivers' attribute sets
14:32:35 <ZangMingJie> ok thanks
14:33:29 <mestery> #action asomya to provide review comments for TypeDriver patch from ZangMingJie
14:33:56 <mestery> asomya: See how much more is needed to handle what you needed in the TypeDriver infrastructure.
14:34:26 <asomya> mestery: sure
14:34:51 <mestery> Anything else on the TypeDriver agenda item?
14:34:55 <amotoki> ZangMingJie: do you have any document or wiki about your patch?
14:35:25 <ZangMingJie> not yet
14:36:14 <amotoki> mestery: in the summit, we need some new "type" for flat but virtualized networks (provided by sdn controller).
14:36:43 <mestery> amotoki: Yes, this was per asomya's discussion.
14:37:22 <asomya> amotoki: That was a proposal to modify providernet extensions to define externally managed networks
14:37:58 <rkukura> asomya, mestery: what modification is needed for this?
14:38:41 <asomya> rkukura: We haven't fleshed out the details of the BP yet, at a high level overview: Just the ability to define a few extra attributes when creating a network
14:39:48 <amotoki> asomya: do we need some new extra attrs?
14:40:06 <rkukura> asomya: So does the network type need some attributes other than phyiscal_network and segmentation_id?
14:40:40 <asomya> amotoki: If it's an externally controller managed network, then we might need to somehow expose that in neutron to differentiate between neutron and externally managed networks
14:40:56 <sc68cal> asomya: Would extra attributes include QoS attributes?
14:41:07 <asomya> rkukura: At the summit, I think Rohit proposed arbitrary attributes for networks
14:41:18 <sc68cal> looking to rework my QoS API for Ml2, may be germane to the current discussiojn
14:41:36 <rkukura> asomya: And I think ZangMingJie's patch provides that, right?
14:41:57 <asomya> sc86cal: Nope, this is just information regarding who's managing the network.
14:42:16 <asomya> rkukura: I just started looking at it a couple of hours ago, if it does then that's great :)
14:42:57 <amotoki> asomya: I think the impl of a new type driver is simple and it is similar to flat or local. neutron type driver needs to do nothing about segmentation.
14:43:04 <sc68cal> asomya: thx
14:44:08 <asomya> amotoki: yes
14:44:40 <mestery> #topic Open Discussion
14:44:48 <mestery> Anything else on ML2 this week?
14:45:32 <rcurran> quick q for rkukura
14:45:42 <rkukura> Are people paying attention to the race condition email discussion?
14:46:18 <rcurran> portbinding:vlan info available to the delete_port_postcommit() md's
14:46:19 <mestery> rkukura: Yes, I am.
14:46:21 <amotoki> yes.
14:48:32 <mestery> OK, thanks everyone!
14:48:40 <mestery> Those with action items, we'll follow up next week.
14:48:45 <mestery> #endmeeting