17:30:56 <dougwig> #startmeeting networking_lib
17:30:57 <openstack> Meeting started Wed Jul 20 17:30:56 2016 UTC and is due to finish in 60 minutes.  The chair is dougwig. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:30:58 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:31:00 <openstack> The meeting name has been set to 'networking_lib'
17:31:11 <dougwig> #topic Announcements
17:31:20 <dougwig> I'm out next Wednesday. Any volunteers to chair the meeting?
17:31:45 <boden> I’ve never done, but am happy to try
17:31:52 <dougwig> sure.
17:32:00 <dougwig> #action boden to chair next week's meeting
17:32:06 <dougwig> #topic What changes are applicable to release notes?
17:32:31 <dougwig> what do we have for release notes today?
17:33:22 <boden> I’m thinking none, but am trying to verify
17:33:25 * HenryG pops in fashionably late
17:33:43 <dougwig> do we need them for a developer library?  likely, but i'm asking anyway.
17:34:15 <HenryG> I think it would be nice for changes in the api contract
17:34:29 <HenryG> Most of them will be for additions, I guess
17:34:40 <dougwig> what do we think of the proposal for all interface changes require a reno?
17:34:42 <boden> we talked about generating a changed API summary, IMHO that would suffice
17:35:55 <HenryG> That might work. We could generate a reno from that when tagging a release.
17:36:18 <boden> I’m skipping ahead in topics, but its releated… #link http://paste.openstack.org/show/526626/
17:36:21 <dougwig> the auto-generation would be plenty for my tastes, personally.
17:36:21 <boden> is a sample
17:36:51 <HenryG> LGTM
17:37:18 <dougwig> #action need to add lib release action to add a reno with auto-generated api differences
17:37:37 <dougwig> #link http://paste.openstack.org/show/526626/
17:37:54 <dougwig> moving on
17:38:01 <dougwig> #topic Does all public code needs doc string and perhaps adding a hacking check for it?
17:38:59 <dougwig> my vote is yes, but we are adding barriers to moving code (new unit tests, new docstrings)
17:39:08 <HenryG> IMO we should encourage it but not dictate it
17:40:05 <boden> fair enough; we can dev-ref that public api “should” be documented, but no hacking check
17:40:15 <HenryG> +1
17:40:17 <boden> I guess I’ll stop -1ing for missing docs :)
17:40:29 <dougwig> can hacking checks be warnings?  cleaning up the warnings might be good ATC fodder.
17:40:49 <boden> I was thinking that too
17:41:15 <boden> I can follow-up on if a check can warn
17:41:41 <HenryG> Sounds good
17:41:45 <dougwig> #action boden to check on if hacking checks can be warnings
17:41:57 <dougwig> #topic public api report tool
17:42:02 <dougwig> boden, take it away
17:42:15 <boden> so we just saw a sample of its output
17:42:23 <HenryG> It seems to work well
17:42:27 <boden> question is; do we care how pretty/robust this ‘tool’ is?
17:42:45 <boden> e.g. should I go off and make it nice
17:42:46 <HenryG> I am inclined to approve it and we can fix issues as they arise
17:42:58 <dougwig> i think what you had looked great for our purposes.  likely don't need to spew the unchanged section.
17:43:13 <boden> dougwig: agree
17:43:25 <boden> I have a few TODOs I want to clean up in that code
17:43:27 <HenryG> It's not going to break any production code, so we can carry it with bugs and iterate
17:43:29 <boden> then I’ll submit for review
17:43:41 <dougwig> good.
17:43:45 <boden> do you think it should be run as part of pep8? or may a standalone tox target for it?
17:43:46 <dougwig> #topic Open discussion
17:43:50 <dougwig> anything else for today?
17:43:59 <boden> sorry: I had 1 more question ^
17:44:13 <HenryG> boden: I vote for standalone tox target
17:44:34 <boden> works for me
17:44:44 <HenryG> boden: I think it doesn't need to run in the gate
17:44:56 <boden> agreed
17:45:46 <boden> nothing else from me
17:45:54 <HenryG> Regarding base DB stuff, I need dougwig and kevinbenton to lay eyes on https://review.openstack.org/339875
17:46:34 <dougwig> ack
17:46:43 <boden> HenryG: disregard my doc questions as per our discussion today on docs :)
17:47:01 <HenryG> boden: ack
17:47:47 <dougwig> ok, let's blast out of here and do some reviews.
17:47:50 <dougwig> thanks all
17:47:52 <dougwig> #endmeeting