16:01:14 <emagana> #startmeeting networking-guide
16:01:15 <openstack> Meeting started Thu Dec 17 16:01:14 2015 UTC and is due to finish in 60 minutes.  The chair is emagana. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:19 <openstack> The meeting name has been set to 'networking_guide'
16:01:25 <john-davidge> Hi o/
16:01:28 <Sam-I-Am> hello
16:01:30 <emagana> Let's rock & roll
16:01:48 <Sam-I-Am> yep
16:01:48 <emagana> Sam-I-Am john-davidge good to see you both... anyone else?
16:02:03 <Sam-I-Am> looks pretty quiet
16:02:13 <emagana> well.. read you instead of seeing you..  :-)
16:02:29 <emagana> Sam-I-Am: holidays are here.. a lot of Christmas parties!
16:02:34 <Sam-I-Am> yeah, its getting slow
16:02:42 <Sam-I-Am> unless you're me... and you use this time to catch up on everything
16:02:46 <Sam-I-Am> always a new rabbit hole
16:03:04 <emagana> Let's go over the agenda #link https://wiki.openstack.org/wiki/Documentation/NetworkingGuide/Meetings
16:03:07 <Sam-I-Am> i needed to update our agenda and forgot...
16:03:19 <emagana> #topic announcements
16:03:51 <emagana> As everybody else we will not have the next IRC meeting
16:03:53 <Sam-I-Am> i'm going to guess theres no apac meeting next week
16:04:24 <emagana> which mean the next IRC meeting will be on Jan 14th 2016
16:04:51 <Sam-I-Am> isnt there one before that?
16:04:56 <Sam-I-Am> apac meeting... the week before?
16:05:25 <emagana> Sam-I-Am: Maybe the next.. give people more time to recovery  ;-)
16:06:09 <john-davidge> emagana: You must be planning a big holiday party!
16:06:13 <emagana> #action send a reminder about the next meeting
16:06:23 <emagana> john-davidge: I'm already drinking
16:06:43 <john-davidge> emagana: Me too! If coffee counts…
16:06:51 <emagana> Sam-I-Am: you will be sending the one for APAC, correct?
16:06:56 <Sam-I-Am> yeah
16:07:02 <Sam-I-Am> i'll try to hold it
16:07:07 <emagana> john-davidge: if you drink it, then it counts
16:07:23 <Sam-I-Am> coffee here too. lots of it.
16:07:35 <emagana> #topic review previous action items
16:07:46 <emagana> Let's me start here
16:08:26 <emagana> I made some changes on the wiki pages and I will continue that. The next one will be #link https://wiki.openstack.org/wiki/NetworkingGuide/TOC
16:08:54 <emagana> I sent the emails for the meeting but we obviously are not getting many responses  :-(
16:09:03 <Sam-I-Am> well, this isnt the only meeting
16:09:08 <Sam-I-Am> docs in general has few attendees :/
16:09:12 <Sam-I-Am> very frustrating
16:10:33 <emagana> Sam-I-Am: The times for the USA one is very hard for PST people
16:10:43 <Sam-I-Am> its 8am there, no?
16:10:47 <emagana> I can't be ready and functional at 6am
16:10:54 <Sam-I-Am> oh, the US docs meeting?
16:10:57 <john-davidge> Yeah, 8am :(
16:11:00 <Sam-I-Am> i'm trying to get that one moved
16:11:08 <Sam-I-Am> i might just post a patch and see what happens
16:11:11 <emagana> The meeting is at 6am
16:11:17 <Sam-I-Am> but the apac meetings are empty too
16:11:25 <emagana> I can make it at 8am for sure..
16:11:37 <emagana> anyway.. let's keep trying
16:12:32 <Sam-I-Am> yep
16:12:34 <Sam-I-Am> moving along...
16:12:34 <emagana> I prepared the etherpad with the sections that still need work #link https://etherpad.openstack.org/p/networking-guide
16:12:48 <emagana> we will review some assignments as our next topic
16:12:56 <john-davidge> emagana: Nice!
16:13:02 <Sam-I-Am> so much work to do
16:13:10 <Sam-I-Am> and we have more things to add too :/
16:13:35 <emagana> I still need to create the spec for all this changes, I will complete that before the holidays
16:14:11 <Sam-I-Am> emagana: somewhere in there we need bgpvpn and bgprouting
16:14:27 <Sam-I-Am> i razzled those folks into contributing operator-centric docs to the networking guide
16:14:36 <emagana> Sam-I-Am: Please, include them in the etherpad
16:14:45 <Sam-I-Am> i sort of think we might need a restructuring to something like "experimental services"
16:15:00 <Sam-I-Am> they're not necessarily advanced, but not necessarily production-ready either
16:15:08 <Sam-I-Am> trying to get them to contribute scenarios
16:15:15 <Sam-I-Am> basically overlay these features on an existing deployment
16:15:32 <john-davidge> IPv6 PD would probably benefit from an ‘experimental’ section as well
16:16:01 <Sam-I-Am> so here's the problem
16:16:35 <Sam-I-Am> a lot of these experimental projects need visibility to weed out bugs, but their only docs are devref "heres how you use it in a devstack all-in-one"
16:16:40 <Sam-I-Am> which is completely useless to most operators
16:16:51 <emagana> Sam-I-Am: I do agree with that
16:17:11 <Sam-I-Am> hence why an experimental section of "heres how you make this work on a real deployment" makes sense for those people
16:17:23 <Sam-I-Am> get them some visibility
16:17:30 <emagana> Sam-I-Am: I dont think we can modify the scenarios until the experimental features are stable ones
16:17:35 <sc68cal> devstack does have a multinode neutron guide.
16:17:42 <sc68cal> it may not be very good, since I wrote it :)
16:17:54 <sc68cal> but yeah AIO needs to go the way of the dodo
16:18:05 <Sam-I-Am> emagana: the existing stable scenarios stay... these experimental things can either a) add on to them b) create their own scenarios
16:18:10 <emagana> sc68cal: did not notice you were around!
16:18:26 <Sam-I-Am> sc68cal: i need to go through that guide
16:18:26 <sc68cal> emagana: gotta ping me at 3AM local time
16:18:35 <emagana> Sam-I-Am: I vote for option b) cerate their own scenarios
16:18:37 <Sam-I-Am> sc68cal: get me some multinode devstack w/ lots of neutron to break
16:18:58 <Sam-I-Am> emagana: in some cases it might be as easy as "follow scenario A or B, then do this stuff to make X work"
16:19:03 <sc68cal> Sam-I-Am: got 900 bucks? http://coreitpro.com/2015/11/11/devstack-home-lab-pt1.html
16:19:17 <Sam-I-Am> which i think applies to things like bgproute
16:19:25 <Sam-I-Am> maybe vpnaas
16:19:31 <Sam-I-Am> (which has nearly zero docs)
16:19:44 <emagana> sc68cal: nice!
16:20:07 <Sam-I-Am> sc68cal: i use cloud servars
16:20:44 <Sam-I-Am> anywho...
16:20:48 <emagana> So, do we have an agreement to cover the new features as new scenarios making references to existing ones?
16:21:07 <sc68cal> ++
16:21:11 <Sam-I-Am> +
16:21:19 <Sam-I-Am> we'll give them options of what they can do
16:21:30 <Sam-I-Am> i'd also like to add ipv6 to those scenarios
16:21:31 <john-davidge> ++
16:21:34 * Sam-I-Am looks at sc68cal
16:21:39 <Sam-I-Am> s/i'd/sean'd
16:21:53 <emagana> #info we will cover the new features as new scenarios making references to existing ones
16:22:10 <emagana> ok.. moving to the next action item
16:22:10 <sc68cal> Sam-I-Am: careful, I may just delete ipv4 from all of the guide ;)
16:22:36 <Sam-I-Am> sc68cal: i see nothing
16:22:48 <emagana> Sam-I-Am: could you make a summary of the decisions around OVN and restructuring legacy scenarios (I read your email)
16:22:56 <Sam-I-Am> emagana: sure. typing...
16:23:04 <emagana> sc68cal: Ohhhh!!!
16:23:09 <emagana> Long live IPv6
16:23:15 <Sam-I-Am> i sent an email to the ops list about how to address provider networks on existing scenarios... and mostly got nothing back
16:23:26 <Sam-I-Am> which sort of surprises me. either ops dont use the guide, or no one has an opinion
16:23:50 <emagana> Sam-I-Am: maybe we could try to be more direct  :-)
16:23:54 <Sam-I-Am> so i think i'll just add provider network support to the legacy ovs, lb, and l3ha scenarios and see what happens
16:24:05 <emagana> picking specific operators and requesting input
16:24:10 <Sam-I-Am> the only response was really about our use of the word 'legacy'
16:24:13 <Sam-I-Am> do you have anyone in mind?
16:24:21 <Sam-I-Am> neutron users... or people looking to use neutron
16:24:22 <emagana> I can provide you a list!
16:24:36 <Sam-I-Am> please send me a list... i'll send another e-mail
16:24:59 <sc68cal> Sam-I-Am: s/legacy/classic/g ?
16:25:09 <emagana> #action emagana will send a list of operators to request input on the networking guide directly
16:25:12 <Sam-I-Am> sc68cal: yeah, or conventional. something like that.
16:25:21 <sc68cal> "just like mom used to make" networking
16:25:36 <emagana> since when networking becomes classic or conventional?
16:25:39 <Sam-I-Am> the idea around legacy was that l3ha and dvr would blow the original architectures away due to excessive awesome
16:25:43 <sc68cal> john-davidge: queen's networking? ;)
16:25:44 <Sam-I-Am> but that never happened
16:25:48 <Sam-I-Am> (this was back in icehouse days)
16:26:21 <Sam-I-Am> i think we also need to develop a table that compares the scenarios
16:26:34 <Sam-I-Am> with some consistent language... like provider/external/public network are more or less the same thing
16:26:36 <emagana> Sam-I-Am: That is a great idea!
16:26:39 <Sam-I-Am> so many words
16:26:47 <Sam-I-Am> project/tenant/private/internal oh my
16:26:49 <john-davidge> sc68cal: “One must then restart One’s l3 agents forthwith…”
16:27:01 <Sam-I-Am> john-davidge: restarteth
16:27:17 <sc68cal> forsooth!
16:27:23 <emagana> Sam-I-Am: I just want to be sure that we scope the guide properly for this release, and make it stable.. I hate that stupid WIP warning
16:27:32 <Sam-I-Am> emagana: well, thats another topic here :)
16:27:37 <Sam-I-Am> in a bit
16:27:40 <Sam-I-Am> but first... OVN
16:27:47 <emagana> Sam-I-Am: Please go ahead!
16:27:54 <Sam-I-Am> so happens that politics trumped my plans to put OVN in the networking guide
16:28:21 <emagana> Sam-I-Am: why so much love for OVN? :-)
16:28:26 <Sam-I-Am> it opened the door to everyone dumping their stuff in the networking guide and we couldn't come up with a solid line that would include ovn but not everything else
16:28:36 <Sam-I-Am> emagana: ovn finally makes ovs useful
16:28:47 <sc68cal> allegedly.
16:28:49 <Sam-I-Am> rather than just a switch that overly complicates things
16:28:59 <Sam-I-Am> sc68cal: i'm feeling positive
16:29:09 <emagana> Sam-I-Am: I know.. I have my eyes on it!
16:29:18 <Sam-I-Am> replace l3 agent, includes distributed routing, no network node, will eventually do dhcp internally
16:29:25 <Sam-I-Am> all of this sounds good on paper
16:29:45 <Sam-I-Am> to me, the evolution of conventional OVS would be OVN, hence my interest in putting it in the net guide
16:30:09 <Sam-I-Am> but turns out ovn is not a ref arch and therefore considered 'third party' ... which opens the door to all sorts of bunk going into the net guide
16:30:16 <Sam-I-Am> and we want to keep the net guide as simple as possible
16:30:22 <emagana> Sam-I-Am: was the input to wait a bit more while we put any documentation in the ref section for neutron?
16:30:58 <Sam-I-Am> the idea now is to contribute docs to networking-ovn in such a fashion that we can easily port them to the openstack-manuals repo and net guide
16:31:11 <Sam-I-Am> so... same work...  different repo
16:31:25 <Sam-I-Am> of/when ovn becomes a "thing" we move it over
16:31:28 <Sam-I-Am> if
16:31:47 <Sam-I-Am> make sense?
16:32:19 <emagana> Sam-I-Am: got it.. I guess it makes sense.. we can move staff from the networking-ovn repo to the networking guide once it gets a better shape
16:32:47 <Sam-I-Am> i'm implementing our conventions in their repo, so it should be easy(er) to move
16:32:59 <Sam-I-Am> turns out devref uses a different set of characters for headers, but thats easy to fix
16:33:12 <emagana> so, there is not action item regarding OVN for us at the moment, correct?
16:33:22 <Sam-I-Am> emagana: action item is removing the spec
16:33:42 <Sam-I-Am> or just temporarily not publishing it
16:33:49 <emagana> #action remove the spec to include OVN in networking guide
16:34:25 <emagana> ok, I want to move to review the etherpad and make some possible assignments, is it ok?
16:34:49 <Sam-I-Am> emagana: sure. we also need to hit versioning.
16:34:56 <Sam-I-Am> that's sc68cal's thang
16:35:14 <emagana> #topic review etherpad ToC
16:35:16 <emagana> #link https://etherpad.openstack.org/p/networking-guide
16:35:52 * sc68cal hides
16:36:03 <Sam-I-Am> emagana: i'd like to work on most of the "introduction" stuff ... you know, if time happens.
16:36:16 <emagana> I marked the section that need work and I included a preliminary prioritization L = Low, M and H
16:36:33 <Sam-I-Am> we have some intro stuff, but a lot of it is still crap
16:36:44 <Sam-I-Am> i.e., not in a format that makes sense to people
16:37:03 <emagana> Sam-I-Am: network components and tunneling needs some love, should I add your name to those?
16:37:16 <Sam-I-Am> the configuration stuff should be easy - i more or less want to cover what each config file does, and which one is necessary on which nodes.
16:37:19 <Sam-I-Am> emagana: sure
16:37:31 <Sam-I-Am> for example, you dont need ml2 on anything but the controller node
16:37:34 <Sam-I-Am> people seem to think you do
16:37:43 <emagana> Sam-I-Am: sounds good. Please, start with the configuration part. I believe has higher priority.
16:37:48 <Sam-I-Am> all this will be much easier when we version the guide :)
16:37:52 * Sam-I-Am glares at sc68cal
16:38:23 * sc68cal throws a rock at Sam-I-Am
16:38:34 <Sam-I-Am> sc68cal: crap, i'm in a glass house
16:38:44 <sc68cal> I threw it straight through mine
16:38:52 <sc68cal> Sorry, the LB gate and some bugs chewed me up this week
16:39:11 <Sam-I-Am> me too!
16:39:19 <Sam-I-Am> squirrels and rabbit holes
16:39:28 <emagana> Do you guys prefer to go directly to the therpad and pick the section that you can/want to cover instead of going one by one and we can move to versioning?
16:39:39 <Sam-I-Am> emagana: yeah
16:39:45 <Sam-I-Am> we can review it next meeting and see whats left
16:39:50 <Sam-I-Am> then voluntold people
16:40:01 <Sam-I-Am> all of... 3-4 of us, none of whom have time :/
16:40:15 <emagana> #action all pick up a section to cover from the etherpad
16:40:17 <Sam-I-Am> waiting patiently for operator/dev contribs
16:40:54 <emagana> #topic networking guide versioning
16:41:00 <Sam-I-Am> heyyyyy
16:41:00 <emagana> sc68cal: dont run!
16:41:12 <sc68cal> haha
16:41:15 <emagana> Sam-I-Am: ?
16:41:23 <Sam-I-Am> emagana: its an exciting topic
16:41:38 <sc68cal> so I have a big ugly monster patch that I'm going to use to update the stable/kilo branch of openstack-manuals, the networking guide specifically
16:41:45 <emagana> Sam-I-Am: dude.. in my ind.. I was.. damn it... what did I break?!
16:41:54 <Sam-I-Am> lol
16:42:01 <Sam-I-Am> sc68cal: isnt that patch still wip?
16:42:03 <sc68cal> https://review.openstack.org/255376
16:42:19 <sc68cal> Sam-I-Am: yeah. I need to use a more accurate SHA of the networking guide, kilo era
16:42:23 <Sam-I-Am> andreas pushed the patches to the publishing system... and they've been approved.
16:42:32 <john-davidge> Well, that’s a monster patch all right
16:43:02 <emagana> somebody else besides me hates the new gerrit loook?
16:43:07 <Sam-I-Am> sc68cal: which sha did you use?
16:43:21 <john-davidge> emagana: It’s horrible!
16:43:24 <sc68cal> Sam-I-Am: I was lazy and used master I think, so I need to dig up the SHA we found after last week's meeting
16:44:00 <sc68cal> ah, it's 1446e9ec5450c0a3849c958b9167f1598308783d
16:44:20 <Sam-I-Am> sc68cal: yeah thats it
16:44:27 <Sam-I-Am> push button, see if it builds, go
16:44:30 <sc68cal> yup
16:44:42 <Sam-I-Am> then we can backport master to liberty
16:44:48 <Sam-I-Am> and then off to the races of content
16:45:09 <Sam-I-Am> granted we'll need to backport the "intro" content and stuff that we write, but that should be easy
16:45:14 <Sam-I-Am> its pretty static stuff
16:45:41 <Sam-I-Am> main thing is being able to contribut stuff for mitaka now, and updates for liberty, without making a mess
16:45:53 <Sam-I-Am> we'll also need to review the guide to remove "In XXX release" wording
16:45:56 <Sam-I-Am> but thats also easy
16:46:05 <emagana> Sam-I-Am: indeed
16:46:11 <Sam-I-Am> the big part is backport... does it build, does it publish?
16:46:44 <sc68cal> looks like 1446e9ec545 is a bust. SR-IOV stuff for juno is in it :(
16:46:58 <sc68cal> so, time to go a little further back in time
16:47:03 <Sam-I-Am> j... juno?
16:47:08 * sc68cal hops into his time machine
16:47:12 <emagana> same question, juno?
16:47:31 * Sam-I-Am sings the alphabet song
16:47:44 <sc68cal> yeah there's a file about using SR-IOV in juno that's part of the networking guide in 1446e9ec5450c0a3849c958b9167f1598308783d
16:47:55 <Sam-I-Am> juno is before kilo
16:47:58 <Sam-I-Am> so thats ok?
16:48:02 <sc68cal> oh. right.
16:48:03 <Sam-I-Am> its also eol
16:48:04 <sc68cal> i knew that.
16:48:10 <Sam-I-Am> there is no juno guide
16:48:25 <sc68cal> right - it was just that it said "as of Juno" blah blah blah
16:48:35 <sc68cal> sorry I never learned the alphabet properly apparently.
16:48:35 <Sam-I-Am> yeah, we'll need to fixerate that
16:48:46 <Sam-I-Am> if it worked in juno, it probably works in kilo
16:48:58 <sc68cal> right
16:48:59 <emagana> Sam-I-Am: thats a big statement
16:49:22 <Sam-I-Am> emagana: i like to think positive
16:49:50 <Sam-I-Am> right now a lot of the guide is bug-driven because we cant test everything... someday making it more proactive would be nice, but time. stpid time.
16:49:58 <Sam-I-Am> time and contributors, really
16:50:06 <Sam-I-Am> the sr-iov people should be contributing a scenario
16:50:30 <Sam-I-Am> i would really like policy in neutron of no docs no test no merge, but thats not happening today
16:50:34 <Sam-I-Am> nor retroactive
16:50:37 <emagana> Sam-I-Am: getting close to the hour!
16:50:43 * sc68cal lobs big artillery shell into gerrit
16:50:48 <Sam-I-Am> for example, bgpvpn was released with... no docs
16:50:50 <sc68cal> https://review.openstack.org/#/c/255376/
16:51:46 <Sam-I-Am> sc68cal: can you add the sha you used to the commit?
16:51:55 <Sam-I-Am> unless its somewhere i'm not seeing it
16:52:03 <Sam-I-Am> 6 cups of coffee is not enough or too much
16:52:04 <sc68cal> Sam-I-Am: yeah good point, will do
16:52:08 * Sam-I-Am rips table in two
16:52:21 <emagana> sc68cal: What kind of help do you need from us?
16:53:03 <sc68cal> I think just search for the string "Liberty" in the diff (god help you) and make sure they all make sense in context
16:53:15 <sc68cal> a couple I've seen do have "Liberty" - but it's been in the context of "the upcoming release"
16:53:18 <sc68cal> future tense
16:53:25 <Sam-I-Am> yeah we'll need to change those later
16:53:28 <Sam-I-Am> easy stuff though
16:53:47 <Sam-I-Am> also scenario4X is still there, we changed that later
16:53:50 <emagana> #action all review the patch and provide input
16:54:02 <Sam-I-Am> +2A, fire and forget!
16:54:12 <emagana> Sam-I-Am: I go for that... hit and run!
16:54:34 <Sam-I-Am> sc68cal: thanks for your work here
16:54:41 <Sam-I-Am> can you pop a liberty backport up too?
16:54:46 <Sam-I-Am> (hey thanks heres more work)
16:54:54 <sc68cal> Sam-I-Am: sounds good. just need to find a good SHA for it
16:54:56 <Sam-I-Am> i'd make a good manager
16:54:57 <emagana> sc68cal: second that... great progress and great work!
16:55:11 <Sam-I-Am> sc68cal: my guess is you can just backport master
16:55:16 <Sam-I-Am> because no work has been done for mitaka
16:55:20 <Sam-I-Am> or if there is, very little
16:55:21 <sc68cal> Sam-I-Am: ack
16:55:31 <Sam-I-Am> only thing i can think of is rbac
16:55:36 <Sam-I-Am> which went in a couple of weeks ago
16:55:47 <Sam-I-Am> mmmmmaybe some ipv6 stuff? but i think that was liberty
16:56:11 <sc68cal> just PD
16:56:13 <emagana> anything else on this topic?
16:56:21 <Sam-I-Am> so more or less not much
16:56:24 <emagana> to be chair is not fun!
16:56:26 <sc68cal> right.
16:56:30 <Sam-I-Am> might as well backport master and call it good
16:56:31 <sc68cal> think we're good on this topic
16:56:40 <emagana> #topic open agenda
16:56:47 <emagana> anything on the next four minutes?
16:56:56 <Sam-I-Am> not here. more coffee.
16:56:58 <Sam-I-Am> MOARRR
16:57:15 <john-davidge> sc68cal: PD was liberty. One small change made for mitaka though
16:57:23 <emagana> stop drinking coffee and get some spirits
16:57:30 <john-davidge> sc68cal: New config option
16:57:39 <Sam-I-Am> john-davidge: dammit, thanks :)
16:57:53 <Sam-I-Am> so maybe its not master
16:58:38 <emagana> ok...
16:58:45 <emagana> happy holidays!
16:59:01 <Sam-I-Am> sc68cal: 6fbf65ea9fba05ea1533c6ad20a973d794f24fd8
16:59:12 <emagana> have a great time, drink a lot and get some energy for the next year!
16:59:12 * sc68cal looks
16:59:24 <Sam-I-Am> john-davidge: also you
16:59:29 <Sam-I-Am> emagana: thanks
16:59:38 <Sam-I-Am> john-davidge sc68cal lets move this to docs channel?
16:59:45 <emagana> #endmeeting