18:35:39 <SridarK> #startmeeting Networking FWaaS
18:35:41 <openstack> Meeting started Wed Nov  4 18:35:39 2015 UTC and is due to finish in 60 minutes.  The chair is SridarK. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:35:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:35:43 <ajmiller> Hi
18:35:44 <openstack> The meeting name has been set to 'networking_fwaas'
18:35:57 <xgerman> thanks!
18:36:02 <SridarK> #chair xgerman sc68cal SridarK
18:36:03 <openstack> Current chairs: SridarK sc68cal xgerman
18:36:31 <SridarK> #topic Bugs
18:37:29 <SridarK> Not sure if anything new came up - not on my radar
18:37:47 <SridarK> bharathm: we did get some comments on the FIP NS bug
18:37:47 <xgerman> well, still need some +2 on https://review.openstack.org/#/c/231246/
18:38:03 <SridarK> xgerman: my bad - will get it in
18:38:09 <xgerman> thanks
18:38:24 <bharathm> SridarK: Yes and I replied more or less with the same info as your comment
18:38:48 <SridarK> bharathm: yes - we shd not be making changes in l3 agent
18:38:56 <xgerman> +!
18:39:02 <SridarK> and i agree - we shd plan for the refactor
18:39:27 <SridarK> i think brocade guys also offered to help, but u wanted to work on this as well correct ?
18:39:44 <SridarK> bharathm: if so i can work with u
18:39:54 <xgerman> I think we need to divvy up the work better
18:39:57 <bharathm> SridarK: yeah.. Is there any IRC/etherpad discussing the observer hierarchy
18:40:16 <SridarK> bharathm: no but pc_m has done this for vpn
18:40:29 <SridarK> xgerman: yes i agree
18:41:40 <SridarK> xgerman: IMO, bharathm: came up with this so he has first shot - i kind of forgot during our summit discussions
18:41:50 <xgerman> yep
18:41:59 <bharathm> Then I shall check the implementation of this in VPN ...
18:42:22 <SridarK> bharathm: surely - i had discussed this with pc_m a while back and we can pull in some context
18:42:28 <xgerman> well, there is also the QoS plugin mechanism we were looking at
18:42:34 <bharathm> Cool..
18:43:12 * pc_m ears perked
18:43:34 <xgerman> nice :-)
18:43:38 <SridarK> xgerman: sorry is this regarding the classifier stuff ?
18:43:55 <sc68cal> sorry, I forgot about daylight savings
18:44:08 <SridarK> sc68cal: hi
18:44:11 <sc68cal> my calendar didn't shift the start time
18:44:13 <xgerman> nope, classifier is a different beast
18:44:25 <SridarK> xgerman: so which thing on QoS ?
18:44:44 <xgerman> how to get ourselves notified of neutron router changes
18:45:11 <xgerman> but I didn’t check that in detail - sc68cal might have more insight
18:45:14 <SridarK> xgerman: ok i was not aware of that, but vpn will work
18:45:28 <SridarK> *vpn model will work as an example
18:45:32 <xgerman> yeah, QoS solves the same problems we have ;-)
18:46:09 <SridarK> xgerman: ok good
18:47:37 <xgerman> I think QoS works on L2… so might not be as applicable for an L3 firewall
18:48:07 <SridarK> xgerman: yes we basically plug in to L3 agent notifications
18:48:42 <SridarK> #action bharathm and SridarK to sync and possibly bug pc_m if needed
18:49:00 <xgerman> yeah, let’s do that before we get a better handle what QoS does
18:49:07 <SridarK> ok
18:49:19 <pc_m> wasn't following the discussion, but if you need notifications of events from neutron, it's easy.
18:49:26 <pc_m> I can provide info as needed.
18:50:25 <SridarK> pc_m: thanks
18:50:48 <bharathm> pc_m: Thats great.. thanks :-)
18:50:54 <SridarK> Any other bugs we need to discuss ?
18:50:55 <sc68cal> someone should put something together in devref
18:51:17 <sc68cal> for registering for notifications
18:51:36 <xgerman> +1
18:52:06 <SridarK> agreed, pc_m: do u know if something exists ?
18:53:09 <SridarK> ok lets move on
18:53:26 <SridarK> #topic Summit Updates
18:53:38 <pc_m> For notification yes there is.
18:53:54 <pc_m> We can change offline or in neutron channel, if you want.
18:54:01 <SridarK> pc_m: +1
18:54:15 * pc_m juggling phone call and IRC :)
18:54:22 <SridarK> sc68cal: would u like to drive ?
18:54:45 <xgerman> First everyone needs to watch our talk ;-)
18:54:50 <sc68cal> I'm currently on mobile, I thought I had an hour
18:54:53 <SridarK> :-)
18:55:15 <SridarK> sc68cal: ok no worries, will update u can chime in
18:55:27 <sc68cal> sounds good, sorry all
18:55:55 <xgerman> #link https://www.openstack.org/summit/tokyo-2015/videos/presentation/openstack-neutron-fwaas-roadmap
18:56:06 <SridarK> Overall Summit Discussions quite fruitful, also met with potential new contributers which is always good
18:56:35 <xgerman> yeah, a lot of people showed interest in refactoring the FWaaS API and functionality a bit
18:56:52 <xgerman> mickeys kept good notes on https://etherpad.openstack.org/p/fwaas-api-evolution-spec
18:56:58 <xgerman> #link https://etherpad.openstack.org/p/fwaas-api-evolution-spec
18:57:14 <SridarK> Priorities: API - we close on overall model and we break out into sub blueprints and start pushing things for Mitaka
18:58:18 <xgerman> yeah, we need to get a spec into the neutron-specs so we can start iterating
18:58:54 <SridarK> Also badveli: on SG - some updates - caution from armax on being careful to keep our focus on API. Also some comments from Ihar on overlap with Classifier model
18:59:25 <xgerman> yeah, sc68cal wrote some classifier code: #link https://github.com/sc68cal/neutron-classifier
18:59:41 <SridarK> badveli: sc68cal replied on thread - so that is something to consider as well in terms of SG overlap with classifier and look for synergy
19:00:09 <xgerman> +1
19:00:55 <SridarK> SG - i meant Service Groups just to be clear
19:01:07 <xgerman> yep :-)
19:01:27 <xgerman> we also had some good chat with the SFC people. That will be important for our future...
19:01:53 <xgerman> and we are completely aligned on moving from router to the Neutron ports
19:01:59 <SridarK> that was a high level view, xgerman: , sc68cal: pls add
19:02:02 <SridarK> xgerman: +1
19:02:24 <sc68cal> good summary
19:02:52 <SridarK> we also discussed some grouping mechanisms (address groups, Port Groups)
19:03:25 <xgerman> also here is the etherapd from the design session #link: https://etherpad.openstack.org/p/mitaka-neutron-next-adv-services
19:04:23 <xgerman> mostly with the new port focus we will leave DVR as is and provide east-west once we can attach to vm ports
19:05:10 <xgerman> there was some talk on the logging API but the first talk was in japanese so I skipped
19:05:23 <SridarK> Some of the DVR folks were also happy to hear that :-)
19:05:44 <xgerman> no kidding :-)
19:05:52 <sc68cal> indeed
19:09:05 <xgerman> ok, if there are no questions let’s move on
19:09:23 <SridarK> #topic Open Discussion
19:09:48 <SridarK> Next week we will probab have all folks back
19:09:56 <xgerman> yeah, I hope so
19:10:36 <sc68cal> probably others got bit by daylight savings and their calendars not being set to UTC
19:10:45 <sc68cal> Google really makes it difficult
19:10:51 <SridarK> sc68cal: i also think so
19:12:49 <SridarK> I think we start thinking abt specs and build off the things we have
19:13:11 <sc68cal> +1
19:13:15 <xgerman> +1
19:13:18 <jwarendt> +1
19:13:29 <annp> +1
19:13:30 <xgerman> I think once we have that in the specs directory it will be easier to iterate
19:13:43 <SridarK> agreed
19:14:55 <SridarK> ok if there is nothing else we can end early and give some time back
19:15:16 <xgerman> +!
19:15:18 <xgerman> +1
19:15:43 <xgerman> #endmeeting