18:02:01 <SumitNaiksatam> #startmeeting Networking FWaaS
18:02:01 <openstack> Meeting started Wed Jan 15 18:02:01 2014 UTC and is due to finish in 60 minutes.  The chair is SumitNaiksatam. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:02:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:02:04 <openstack> The meeting name has been set to 'networking_fwaas'
18:02:33 <SumitNaiksatam> RajeshMohan: waiting for SridarK to join
18:02:46 <SumitNaiksatam> he was going to be running the entire tempests suite
18:02:58 <RajeshMohan> ok
18:03:22 <beyounn> hi there
18:03:25 <SumitNaiksatam> if he is not around, we can have a short meeting
18:03:30 <SumitNaiksatam> beyounn: hi
18:03:32 <RajeshMohan> SumitNaiksatam: ok
18:03:45 <SumitNaiksatam> beyounn: do you know if garyduan is going to be around?
18:03:52 <beyounn> let me check
18:04:04 <SumitNaiksatam> beyounn: thanks
18:04:15 <beyounn> he is not in yet
18:04:37 <SumitNaiksatam> beyounn: ok
18:04:45 <SumitNaiksatam> #topic service_type framework
18:04:54 <SumitNaiksatam> https://review.openstack.org/#/c/60699/
18:04:59 <SumitNaiksatam> #link https://review.openstack.org/#/c/60699/
18:05:12 <SumitNaiksatam> beyounn: garyduan seems to have updated his patch
18:05:31 <SumitNaiksatam> beyounn: could you ask him to recheck, since the devstack-gate failed
18:05:40 <beyounn> sure
18:05:48 <SumitNaiksatam> beyounn: thanks
18:06:11 <SumitNaiksatam> we should all review his patch at the earliest, and push for moving forward
18:07:21 <SumitNaiksatam> beyounn: also, will be a good idea to reach out to enikanorov_ nati_ueno and akihiro to review the patch
18:07:47 <beyounn> ok, I will ask Gary to send a notice to them
18:09:29 <SumitNaiksatam> beyounn: thanks, not sure if he is going to join, lets move on
18:09:37 <beyounn> ok
18:09:48 <SumitNaiksatam> #topic Service Objects
18:09:58 <SumitNaiksatam> beyounn: since you are around, anything you wanted to discuss on this?
18:10:08 <SumitNaiksatam> beyounn: i know we are not targeting this for I2 at least
18:10:23 <beyounn> I have finished the coding on the source object/service group
18:10:33 <beyounn> Currently, working on the unit testing
18:10:51 <SumitNaiksatam> oh sweet
18:10:58 <beyounn> My current design is to make service group a top resource
18:11:05 <SumitNaiksatam> beyounn: perhaps good idea to post the patch
18:11:10 <beyounn> since I think it is a common resource
18:11:37 <SumitNaiksatam> beyounn: ok, easier to understand for everyone once they see the patch
18:11:45 <beyounn> Sure, I just thought it would be better to at least run through the unit test before I submit
18:12:01 <SumitNaiksatam> beyounn: yeah, either way
18:12:16 <beyounn> ok, let me at least go through the basics first
18:12:20 <SumitNaiksatam> beyounn: sure
18:13:25 <beyounn> Sumit: is there a doc to tell about unit testing?
18:13:34 <beyounn> how it works together, and how to write test case?
18:13:56 <SumitNaiksatam> beyounn: the neutron README should have some pointers to running the tests
18:14:14 <SumitNaiksatam> beyounn: other than that i don't know of anything from the top my head
18:14:25 <beyounn> sumit: ok
18:14:42 <SumitNaiksatam> beyounn: best place is to look for existing tests
18:14:58 <SumitNaiksatam> beyounn: i am just stating the obvious, i am sure you are doing that already
18:15:21 <beyounn> Sumit, right
18:16:03 <SumitNaiksatam> beyounn: anything more?
18:16:16 <beyounn> that's it
18:16:25 <SumitNaiksatam> beyounn: thanks
18:16:27 <SumitNaiksatam> #topic Service Insertion and Firewall
18:16:40 <SumitNaiksatam> #link https://review.openstack.org/#/c/62599/
18:17:15 <SumitNaiksatam> RajeshMohan: didn't check the latest patch, did you base it off garyduan's patch?
18:17:46 <RajeshMohan> SumitNaiksatam: Shoudl I make my patch dependent on his?
18:18:06 <SumitNaiksatam> RajeshMohan: good question
18:18:09 <RajeshMohan> For now, I am working on unit tests - off main branch
18:18:15 <SumitNaiksatam> RajeshMohan: ok thats fine
18:18:21 <RajeshMohan> Talked to Nachi on review
18:18:28 <SumitNaiksatam> RajeshMohan: ok good
18:18:35 <RajeshMohan> He said that he was waiting on -2 being removed
18:18:49 <SumitNaiksatam> RajeshMohan: i just wanted to make sure that there are no surprises based on garyduan's patch
18:18:50 <RajeshMohan> So, working on UT to remove -2
18:19:34 <SumitNaiksatam> RajeshMohan: hopefully nothing in garyduan's patch conflicts with what you are doing
18:19:35 <RajeshMohan> SumitNaiksatam: I agree. I should rebase to his patch at the earliest
18:19:51 <SumitNaiksatam> RajeshMohan: i don't want you to have to do the same work twice
18:20:35 <SumitNaiksatam> RajeshMohan: but thanks for following up until this point, lets keep at it, and hopefully there will be more reviewers available post I2
18:20:53 <SumitNaiksatam> RajeshMohan: anything else you wanted to bring up in that context?
18:20:59 <RajeshMohan> SumitNaiksatam: UT is the only blocker for -2, right?
18:21:16 <RajeshMohan> SumitNaiksatam: After some basic UT, we can possibly move to -1
18:21:19 <SumitNaiksatam> RajeshMohan: thats the basic blocker
18:21:33 <SumitNaiksatam> RajeshMohan: i have not seen the latest patch, my apologies
18:22:18 <SumitNaiksatam> RajeshMohan: we have to coordinate with SridarK on the CLI as well
18:22:29 <RajeshMohan> SumitNaiksatam: Yes
18:22:41 <RajeshMohan> I will ping Sridar over email today
18:22:51 <SumitNaiksatam> RajeshMohan: thanks
18:23:12 <SumitNaiksatam> #action RajeshMohan to sync up with SridarK on service insertion CLI
18:23:17 <RajeshMohan> I think Sridar can start on the CLI with the patch that is currently posted
18:23:24 <SumitNaiksatam> RajeshMohan: ok
18:23:38 <SumitNaiksatam> RajeshMohan: at some point we have to start discussing the horizon changes as well
18:23:58 <RajeshMohan> SumitNaiksatam: Can I rebase to garyduan's patch and use the same review?
18:24:01 <SumitNaiksatam> beyounn: you or garyduan interested in the horizon discussion :-)
18:24:14 <SumitNaiksatam> RajeshMohan: i think so
18:24:17 <RajeshMohan> SumitNaiksatam: Or will I be required to create a new review?
18:24:29 <beyounn> Sumit I think so, at least to know how it works
18:24:56 <SumitNaiksatam> beyounn: once you know how it works, you will need to get it work as well :-)
18:25:26 <beyounn> :-)
18:25:35 <SumitNaiksatam> beyounn: we will all need to chip in, this might be helpful for the service objects work later as well
18:26:14 <beyounn> right
18:26:26 <SumitNaiksatam> RajeshMohan: anything more on the service insertion to discuss right now?
18:26:43 <RajeshMohan> SumitNaiksatam: Horizon?
18:27:08 <SumitNaiksatam> RajeshMohan: yeah, i guess we will need to meet for that, right?
18:27:39 <RajeshMohan> SumitNaiksatam: Yes. Maybe after we have initial CLI patch.
18:28:07 <RajeshMohan> SumitNaiksatam: Top of the head, do you know how much time we have before merge?
18:28:59 <SumitNaiksatam> RajeshMohan: thats true, we need client side code before we can do horizon
18:29:17 <SumitNaiksatam> RajeshMohan: we should target first couple of weeks into I3
18:29:32 <SumitNaiksatam> RajeshMohan: garyduan's patch seems to be a gating issue right now
18:30:17 <RajeshMohan> SumitNaiksatam: Second week of Feb?
18:30:28 <RajeshMohan> SumitNaiksatam: I2 is Jan 23rd
18:31:04 <SumitNaiksatam> RajeshMohan: yes and yes
18:31:30 <RajeshMohan> SumitNaiksatam: Thanks for the info
18:31:41 <SumitNaiksatam> RajeshMohan: we can speed things up reviewing on garyduan's patch
18:31:55 <SumitNaiksatam> beyounn: have you looked at RajeshMohan's patch for service insertion
18:32:18 <beyounn> no, I did not get time to do it yet, sorry
18:33:30 <SumitNaiksatam> beyounn: whenever you get a chance, between RajeshMohan and myself we have gone through several iterations on this
18:33:53 <beyounn> sure
18:34:14 <SumitNaiksatam> #topic temptest testing
18:34:38 <SumitNaiksatam> SridarK was running the tests with FWaaS and VPNaaS enabled
18:34:58 <SumitNaiksatam> he is in another meeting, so will follow up with him
18:35:24 <SumitNaiksatam> #action SridarK to provide update on FWaaS + VPNaaS tempest runs
18:36:07 <beyounn> Sumit, if fwaas temptest is not going to be enabled in I2
18:36:13 <SumitNaiksatam> based on his findings we will recommend that FWaaS  be enabled on the gate
18:36:22 <beyounn> Sumit, how should be deal with vendor tests?
18:36:52 <SumitNaiksatam> beyounn: thats a good point
18:37:11 <SumitNaiksatam> beyounn: i believe you are asking in the context of the varmour driver?
18:37:16 <beyounn> right
18:37:49 <SumitNaiksatam> beyounn: interesting situation, unfortunately this did not come up before in the discussions
18:38:34 <SumitNaiksatam> beyounn: but for the third party tests you need to enable fwaas in your setup
18:38:44 <SumitNaiksatam> beyounn: does not have to be in the upstream gate
18:39:30 <beyounn> sumit: do you mean that we don't need to get our temptest ready before I2?
18:40:25 <SumitNaiksatam> beyounn: i meant that you need to get your infra setup for running tempest test which would have fwaas enabled
18:40:36 <beyounn> ok
18:40:53 <SumitNaiksatam> beyounn: but it does not need to be enabled for the tempest tests which are running in the upstream gate
18:41:05 <SumitNaiksatam> beyounn: makes sense, or do you still see an issue?
18:41:41 <beyounn> ok
18:41:46 <beyounn> got it
18:42:15 <SumitNaiksatam> beyounn: are you working towards your CI setup?
18:42:31 <beyounn> Gary is working on it
18:43:50 <SumitNaiksatam> beyounn: okay
18:44:07 <SumitNaiksatam> beyounn RajeshMohan: anything more on tempests tests?
18:44:37 <beyounn> nop
18:44:44 <RajeshMohan> SumitNaiksatam:Same here
18:44:52 <SumitNaiksatam> ok great
18:44:58 <SumitNaiksatam> #topic open discussion
18:45:11 <SumitNaiksatam> anything else that we need to discuss, or we can wrap up early
18:46:50 <SumitNaiksatam> alright, great, thanks beyounn and RajeshMohan for joining!
18:47:09 <SumitNaiksatam> #endmeeting