16:00:46 <neiljerram> #startmeeting networking_calico
16:00:47 <openstack> Meeting started Tue Jul 12 16:00:46 2016 UTC and is due to finish in 60 minutes.  The chair is neiljerram. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:49 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:51 <openstack> The meeting name has been set to 'networking_calico'
16:01:00 <neiljerram> Hi everyone!
16:01:04 <logan-> o/
16:01:47 <neiljerram> Welcome to this first ever networking-calico meeting.
16:02:11 <neiljerram> Also my first time chairing an IRC meeting - so please bear with me if I screw up :-)
16:03:16 <neiljerram> #info Preliminary agenda is at https://wiki.openstack.org/wiki/Meetings/NetworkingCalico
16:03:52 <neiljerram> #topic Introductions / Interested Parties
16:04:05 <neiljerram> Does anyone want to introduce themselves?
16:04:34 <erhudy> erhudy from bloomberg, we are an interested party
16:04:45 <neiljerram> Hi erhudy
16:05:24 <logan-> logan -- using calico in production at lstn.net
16:05:54 <neiljerram> logan-, Hi
16:06:18 <neiljerram> logan-, And many thanks for your ansible integration work
16:06:26 <logan-> thanks for the review Neil!
16:06:48 <logan-> looking forward to it merging :)
16:07:33 <neiljerram> OK, so I'd like to be very open in this meeting.
16:08:20 <neiljerram> The only thing so far on the formal agenda is to do with work needed for compliance with new Neutron stadium requirements.
16:08:57 <neiljerram> But as this is our first meeting, please feel free to raise anything else.
16:09:48 <neiljerram> #topic Work for Neutron Stadium compliance
16:10:03 <neiljerram> I guess it makes sense to cover this first...
16:11:31 <neiljerram> Are people familiar with Armando's recent work to clarify the requirements here?
16:11:52 <logan-> Nope
16:13:49 <neiljerram> My summary would be that the Neutron core team are looking for a greater alignment of implementation practices amongst all the Neutron stadium projects, so that they can properly understand them and take responsibility for them as part of the wider Neutron project.
16:15:04 <neiljerram> #info https://review.openstack.org/#/c/312199/
16:17:46 <neiljerram> We'd like networking-calico to remain as a stadium project, and that requires a little work: 1. setting up CI so that Neutron and networking-calico don't accidentally break each other
16:19:00 <neiljerram> 2. using Neutron code via neutron-lib instead of by importing 'neutron.*' modules - and therefore helping with anything that needs to be moved across to neutron-lib
16:21:18 <neiljerram> 3. continuing to develop networking-calico as an ML2 driver, as that's the most established/central Neutron pattern
16:23:11 <neiljerram> For example, we currently have a beta implementation of floating IPs, but for networking-calico operating as a core plugin.  I think some work will be needed to make that work as an ML2 driver too.
16:24:25 <neiljerram> I believe those are the main things, and we need to deliver those over the next 6 months.
16:24:34 <neiljerram> Any thoughts?
16:26:48 <neiljerram> On the CI front, I've created an experimental job to do DevStack with the networking-calico plugin, and then run some Tempest tests: https://review.openstack.org/#/c/338863/
16:28:41 <neiljerram> That seems to indicate some required fixes to networking-calico's DevStack plugin code, which I've made a start on here: https://review.openstack.org/#/c/339263/.
16:29:13 <matt_dupre> Looks like a good start - do you think we need a multi-host test in OpenStack CI as well?
16:29:21 <neiljerram> But I don't think this is running properly yet.  If anyone else wanted to look at and help there, that would be great.
16:30:18 <neiljerram> matt_dupre, yes, that would be great too; but I'm not sure yet what the 'etiquette' is for using lots of OpenStack CI resources.
16:30:49 <neiljerram> Seems like it makes sense to get a single node test working first.
16:32:47 <neiljerram> Overall, I think it makes sense to get basic CI in place first - then we'll have a useful check for when we tackle the other aspects of stadium compliance.
16:33:07 <neiljerram> #topic Bugs
16:33:59 <neiljerram> This isn't on the agenda, but I think worth mentioning https://bugs.launchpad.net/networking-calico
16:34:20 <neiljerram> Please do feel free to raise anything new there, and/or to pick up and fix things!
16:35:09 <neiljerram> #topic Open Discussion
16:36:10 <neiljerram> Is there anything that someone else would like to say?
16:36:33 <logan-> thanks Neil. glad to see floating ips merged.. I'm interested in testing it out on Mitaka with the 1.4 code but I have not seen any docs for it yet.
16:37:42 <neiljerram> Yes, indeed, I'm afraid that docs are still missing here.
16:37:44 <logan-> also, preliminary reviews are appreciated on https://review.openstack.org/#/c/340175/ and https://review.openstack.org/#/c/340174/. I'm working toward having calico deployment merged into openstack-ansible this cycle
16:38:39 <logan-> the OSA side is mostly done at this point, the only big pieces left are cleanup and multi-os support in the bird/etcd roles
16:39:25 <neiljerram> Cool.  Are you getting good engagement from the Ansible folk there?
16:40:43 <logan-> they probably won't start to review those patches until the WIP tag is gone from the commit. expecting to strip the WIP tag later this week after the etcd/bird stuff is done
16:40:59 <neiljerram> Right, makes sense.
16:41:41 <neiljerram> How easy would it be for someone with no Ansible experience at all (e.g. me) to try out that method of installation, including your patches?
16:41:54 <logan-> but yes OSA is happy to have the plugin added afaik. and it will make deploying calico very easy
16:43:00 <logan-> building an AIO (cloud in a single VM) is simple. so you would just check out the code w/ proposed patches, and run thru the AIO build steps at http://docs.openstack.org/developer/openstack-ansible/developer-docs/quickstart-aio.html
16:43:36 <neiljerram> Cool, I'll maybe give that a go then.
16:44:00 <neiljerram> #action neiljerram to try Ansible install per http://docs.openstack.org/developer/openstack-ansible/developer-docs/quickstart-aio.html
16:44:56 <neiljerram> On the floating IP front, people might wonder why any docs are needed at all - given that it's done through the normal Neutron API - so I'll briefly mention that.
16:46:52 <neiljerram> It's just that the API for creating a floating IP requires a Neutron router - whereas Neutron routers aren't needed for any other Calico function.  So I'm imagining a small addition to http://docs.openstack.org/developer/networking-calico/ to explain and justify that.
16:47:40 <neiljerram> Anything else before we wrap up for today?
16:47:42 <logan-> is a router required per-tenant?
16:49:16 <neiljerram> Well Calico doesn't do per-tenant address spaces - so what aspect of per-tenant are you thinking of?
16:50:07 <logan-> was trying to get an idea of how to configure the environment for floating ips.
16:50:35 <neiljerram> Anyway I think the answer is no.  The floating IP API requires an external net, with the floating IP CIDR defined on it, that is connected through a router to one or more non-external Neutron networks.
16:51:36 <logan-> ok thanks, will give it a try
16:51:57 <neiljerram> Cool.
16:53:10 <neiljerram> Well thanks everyone for coming to this first meeting!
16:53:57 <neiljerram> Please do feel free to add anything to the agenda for two weeks' time, or to raise things before then on the mailing list.
16:54:25 <neiljerram> #info https://wiki.openstack.org/wiki/Meetings/NetworkingCalico
16:55:02 <neiljerram> We know we've been largely a one-company project so far, but are genuinely keen to widen participation here.
16:55:28 <neiljerram> (And many thanks to those who are already doing that!)
16:56:22 <neiljerram> #endmeeting