17:01:20 <SumitNaiksatam> #startmeeting Networking Advanced Services
17:01:21 <openstack> Meeting started Tue Nov 18 17:01:20 2014 UTC and is due to finish in 60 minutes.  The chair is SumitNaiksatam. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:25 <openstack> The meeting name has been set to 'networking_advanced_services'
17:01:32 <johnsom_> o/
17:01:37 <pc_m> SumitNaiksatam: hi
17:02:07 <a2hill> o/
17:02:11 <vishwanathj> hello
17:02:12 <dougwig> what is our agenda today?
17:02:15 <SumitNaiksatam> this discussion is a follow up to some of what happened in the neutron meeting earlier today
17:02:25 <blogan> hello!
17:02:30 <SumitNaiksatam> #info https://wiki.openstack.org/wiki/Meetings/AdvancedServices#Agenda
17:02:31 <rm_work> p/
17:02:34 <rm_work> o/
17:02:46 <SumitNaiksatam> dougwig: the agenda is something that is up for discussion as well
17:03:13 <SumitNaiksatam> for those who missed the Neutron meeting in the morning, the short summary is that - there is no immediate update on the spin out/split
17:03:38 <SumitNaiksatam> the plan is that an email will be sent to the ML with the proposal, and directed to the TC
17:03:46 <SumitNaiksatam> i believe we will proceed from there
17:03:51 <dougwig> #link http://eavesdrop.openstack.org/meetings/networking/2014/networking.2014-11-18-14.02.log.html
17:03:56 <SumitNaiksatam> did i miss anything in that summary?
17:03:57 <dougwig> the log from that meeting
17:04:01 <SumitNaiksatam> dougwig: thanks
17:04:01 <dougwig> no, good summary
17:04:03 * banix listening in from the last row
17:04:11 <SumitNaiksatam> banix: :-)
17:04:26 <vishwanathj> what is the impact to this team?
17:04:27 <s3wong> hello, sorry, a little late
17:04:28 <SumitNaiksatam> the other thing that was dicussed is the charter/agenda for sub-team/groups
17:04:33 <SumitNaiksatam> s3wong: hi
17:04:46 <SumitNaiksatam> vishwanathj: the spin ou/split is in the context of this team
17:04:58 <SumitNaiksatam> vishwanathj: i.e. advanced services spin out
17:05:08 <SumitNaiksatam> vishwanathj: so the impact is entirely on this team :-)
17:05:23 <SumitNaiksatam> okay so regarding the sub-team/group -
17:05:33 <SumitNaiksatam> #topic Team/Meeting logistics - should we be having this meeting
17:06:15 <SumitNaiksatam> so one things, i believe is firmly on the table now is that that services are being spun out in some form
17:06:41 <SumitNaiksatam> and currently we udnerstand this to be a repo split, with a common repo for all the existing advanced services
17:06:54 <SumitNaiksatam> *thing
17:07:33 <SumitNaiksatam> some of us came up with the following mission statement/charter for this new repo/project:
17:07:44 <SumitNaiksatam> To implement services and associated libraries that provide abstractions for advanced network functions beyond basic L2/L3 connectivity and forwarding.
17:08:08 <SumitNaiksatam> the above complements the current charter for neutron
17:08:26 <bobmel> SumitNaiksatam: Sounds pretty good to me,
17:08:29 <pc_m> +1
17:08:41 <SumitNaiksatam> bobmel: pc_m: okay
17:08:44 <blogan> +1
17:08:46 <SridarK> SumitNaiksatam: i think that this is a good first stab it
17:08:49 <dougwig> +`
17:08:49 <glebo> 'lo m8s
17:08:51 <dougwig> +1
17:08:56 <s3wong> +1
17:09:04 <SumitNaiksatam> we also have a critical mass of people working in each of the services and collectively as a services’ team
17:09:06 <sbalukoff> Yup!
17:09:27 <SumitNaiksatam> so i would imagine that we have enough of a charter and team to form a sub-team/group?
17:09:30 * glebo realises he just missed the "good first stab" and wonders if someone will repost via cut-n-paste, pls?
17:09:43 <SumitNaiksatam> glebo: To implement services and associated libraries that provide abstractions for advanced network functions beyond basic L2/L3 connectivity and forwarding.
17:09:47 <pc_m> I think so
17:09:58 <glebo> +1
17:10:04 <glebo> looks great
17:11:08 <SumitNaiksatam> so we agree that going forward we can represent this as a advanced services’ sub-team/group? (this might be obvious to most, but just making it clear)
17:11:11 <glebo> another way to say "advanced network functions" that is a bit more 'standard' jargon is: "service layer networking functions"
17:11:30 <sbalukoff> Sumit: Agreed!
17:11:33 <xgerman> +1
17:11:34 <SumitNaiksatam> glebo: sure, we can discuss tuning the charter offline
17:11:35 <bobmel> +1
17:11:37 <pc_m> SumitNaiksatam: yes
17:11:43 <SridarK> SumitNaiksatam: +1
17:11:45 <s3wong> +1
17:11:47 <glebo> +1
17:11:49 <sbalukoff> glebo: Would 'service layer networking functions' include FWaaS?
17:12:03 <SumitNaiksatam> sbalukoff: sure
17:12:05 <johnsom_> +1
17:12:19 <SumitNaiksatam> okay, so the next part of the team logistics is the meeting
17:12:24 <SumitNaiksatam> *this meeting
17:12:27 <SumitNaiksatam> do we need this meeting?
17:12:36 <sbalukoff> Ok, verbage is important because it's what people unfamiliar with the purpose of the team / project will use as a first introduction of what it's about. :)
17:12:48 <glebo> sbalukoff: yeah, but I take it back. Because if we use Service Layer Networking, then we'd have to change the name from Advanced Services to match, and I think we already have too much marketing familiarity with "advanced services". So let's stick with it
17:12:50 <SumitNaiksatam> sbalukoff: true
17:13:05 <sbalukoff> glebo: Right.
17:13:17 <SridarK> glebo: +1 yes pls lets keep what we have now
17:13:25 <SumitNaiksatam> reiterating my question - do we need this meeting?
17:13:27 <dougwig> SumitNaiksatam: whether we needs this meeting, or can function inside the on-demand section of the neutron meeting, is a question that i don't think we can answer today.  i'd say keep it.
17:13:31 <sbalukoff> Anyway: I think the meeting is important as a way for us to coordinate and make sure we're making progress in the direction we want to go.
17:13:44 <SumitNaiksatam> dougwig: sbalukoff: okay
17:13:45 <sballe> dougwig: +1
17:13:46 <sbalukoff> It could be a short meeting if we aren't making much progress / are blocked on stuff.
17:13:47 <s3wong> SumitNaiksatam: from last experience, this meeting is absolutely needed if we are going to talk about flavor again :-)
17:13:50 <vishwanathj> +1
17:13:55 <s3wong> s/last/past
17:13:56 <SumitNaiksatam> s3wong: :-)
17:13:58 <bobmel> +1
17:14:01 <SridarK> SumitNaiksatam: yes i think this is good as we may not have enough bandwidth to discuss everything in the neutron mtg
17:14:02 <damon__> I think we need, for we have so many advanced services
17:14:08 <xgerman> s3wong +1
17:14:12 <glebo> SumitNaiksatam:  we need this mtg at present to work on the split issues
17:14:13 <sbalukoff> s3wong: +1
17:14:21 <SridarK> s3wong: :-)
17:14:25 <sballe> s3wong: +1
17:14:34 <glebo> split issues first and foremost.
17:14:45 <SumitNaiksatam> okay so i think there is fair agreement that on the team logisitics and this meeeting
17:14:45 <sbalukoff> Yep.
17:14:48 <damon__> And maybe there are more and more advanced services since service chain release
17:14:50 <pc_m> s3wong: +1 :)
17:14:50 <SridarK> s3wong: lets go to Baskin Robbins :-)
17:15:02 <sbalukoff> Haha!
17:15:21 <sballe> SridarK: lol +1
17:15:39 <glebo> we need to get the "right" set of people into this meeting in order to really make progress on the split issue,
17:15:41 <SumitNaiksatam> so i believe we can put this charter and reasoning on the adv services’ meeting and team wiki
17:15:46 <glebo> where "right people" includes
17:15:47 <SumitNaiksatam> glebo: agree
17:16:01 <glebo> some of the other cores and PTL and TC folks that are stake holders
17:16:05 <blogan> charlie sheen?
17:16:12 <SumitNaiksatam> blogan: :-)
17:16:15 <SumitNaiksatam> glebo: that said
17:16:23 <glebo> maybe what we need to do is craft a roster of who are the stake holders and then ensure we get buy in for participation
17:16:27 <sbalukoff> blogan: Charlie Sheen? That's John F. Kennedy!
17:16:34 <SumitNaiksatam> glebo: l believe the suggestion was that we have the discussion regarding the split in the main neutron meeting
17:16:52 <SumitNaiksatam> we use this meeting as a follow up
17:17:03 <glebo> blogan:  charlie sheen:: role: marketing rep
17:17:04 <SumitNaiksatam> to discuss between ourselves as to how to approach the work items
17:17:25 <SumitNaiksatam> since the split involves decisions that impact neutron and openstack as a whole
17:17:25 <sbalukoff> sumit: +1
17:17:40 <glebo> SumitNaiksatam:  airtime and focus will be an issue in main neutron mtg. Just look at what happened today
17:17:46 <SumitNaiksatam> so the discussion in best served in the neutron meeting
17:17:53 <SumitNaiksatam> glebo: i hear you
17:18:14 <SumitNaiksatam> glebo: but still i dont think this is left to us to decide :-)
17:18:28 <SumitNaiksatam> okay moving to the split logistics
17:18:29 <glebo> how do we mitigate that? failure to do so will, I'm afraid, push the split out of kilo
17:18:50 <SumitNaiksatam> glebo: we will mitigate that by making sure we raise this topic during the neutron meeting
17:19:04 <SumitNaiksatam> glebo: and also following up offline with the concerned folks
17:19:07 <s3wong> glebo: you can certainly keep putting adv. services split as an agenda item on Neutron meeting until a point where the cores would have to give it some airtime :-)
17:19:12 <glebo> SumitNaiksatam:  may be insufficient, but lets take it offline
17:19:31 <SumitNaiksatam> the first action item in that context will be to make sure that the email regarding the split gets sent to the ML asap
17:19:36 <SumitNaiksatam> does everyone agree?
17:19:43 <glebo> s3wong:  true, and i think that is the plan so far
17:19:43 <xgerman> +1
17:19:53 <sbalukoff> +1
17:19:58 <damon__> +1
17:20:00 <glebo> +1
17:20:01 <vishwanathj> +1
17:20:05 <sballe> +1
17:20:06 <glebo> item owner?
17:20:07 <xgerman> so how can we help mestery to get that done faster (ghostwrite the e-mail?)
17:20:07 <johnsom_> +1
17:20:15 <SumitNaiksatam> once the email gets sent, we can make enough noise to keep the thread alive and kicking, until everybody is sick and tired of us :-P
17:20:34 <SumitNaiksatam> xgerman: that is certainly an option, if mestery is willing to take it :-)
17:20:35 * glebo is pretty sure everyone is already sick and tired of us
17:20:44 <s3wong> SumitNaiksatam: so based on this morning's meeting, mestery or markmcclain will send it out, according to russelb's request (of having one week ML time before being TC agenda item)
17:20:52 <SumitNaiksatam> s3wong: true
17:21:07 <glebo> xgerman:  we can always provide some text and just say, "this may be of use"
17:21:16 <SumitNaiksatam> xgerman: you want to take the AI to follow up with mestery on that?
17:21:31 <xgerman> sure, I can do that :-)
17:21:34 <SumitNaiksatam> great
17:21:56 <SumitNaiksatam> #action xgerman (among others) to follow up with mestery on sending the email regarding the adv services’ split to the ML
17:22:23 <SumitNaiksatam> so lets say, as a team, we expect the email to be sent by the end of this week, fair?
17:22:56 <glebo> I expect it to be sent tomorrow, latest
17:22:57 <vishwanathj> +1
17:23:08 <glebo> TC needs to get it asap in order to get onto next week's TC calendar
17:23:11 <SumitNaiksatam> glebo: yeah the earlier the better
17:23:15 <SumitNaiksatam> glebo: agree
17:23:18 <glebo> (per comments in Neutron this AM)
17:23:24 <SumitNaiksatam> so latest by the end of this week
17:23:45 <blogan> i expect it later rather than sooner
17:23:52 <SumitNaiksatam> blogan: :-)
17:24:22 <SumitNaiksatam> so anything more to discuss in this specific context (next topic on agenda is about split logisitcs)
17:24:44 <SumitNaiksatam> #topic Project spin out logistics
17:25:08 <blogan> there's a lot of unknowns on this one
17:25:12 <SumitNaiksatam> so we are not taking any decisions here in this meeting (i dont believe we are empowered to either)
17:25:36 <SumitNaiksatam> this is just to get everyone up to speed in terms of what we have set in motion
17:25:46 <dougwig> on the technical side, i've been working with infra and mark on this, and was planning to post a bp/spec with the gory details on friday (i'm traveling back stateside tomorrow/thursday)
17:25:50 <SumitNaiksatam> dougwig: do you want to update the team on the two things you are doing?
17:25:50 <s3wong> any updates from dougwig?
17:26:04 <s3wong> (OK, there it is :-) )
17:26:15 <blogan> dougwig will you give us some updates?
17:26:19 <dougwig> we have an infra patch for the split itself; it is WIP pending knowing the real project name.
17:26:28 <SumitNaiksatam> dougwig: has posted this patch for the split: https://review.openstack.org/#/c/132998/
17:26:38 <SumitNaiksatam> thats the infra patch ^^^
17:27:13 <SumitNaiksatam> he is also working on a script to split the repo (and preserve the git history while doing so)
17:27:28 <xgerman> dougwig is a hero!
17:27:42 <SumitNaiksatam> i believe this has been done before, and is on advice from the infra team
17:27:51 <SumitNaiksatam> dougwig: yay, you rock!
17:27:56 <dougwig> yep, it started from the oslo graduation script.
17:27:58 <blogan> is the split going to be just cloning the neutron repo, or will it actually pull out the advanced services code?
17:28:21 <xgerman> cloning and then delete what we don't need
17:28:42 <dougwig> technically, it's two repos, identifying the files you want from each, and then selectively pruning the history to remove what is no longer relevant.  you end up with two repos with the files you want, each with their own history, and then they diverge from there.
17:29:07 <blogan> okay
17:29:12 <damon__> Good
17:29:21 <SumitNaiksatam> dougwig: so you would end up pruning in both the repos, right?
17:29:26 <dougwig> correct
17:29:52 <SumitNaiksatam> dougwig: okay, so from day one we will support adv services only from the spun out repo?
17:30:14 <dougwig> can you clarify that question?
17:31:15 <dougwig> i think the answer to your question is 'yes', but i can interpret it a few different ways.
17:31:17 <SumitNaiksatam> dougwig: so after you split (assuming it happens in the kilo time frame), we would no longer have the adv services code in the neutron repo, implying that, to deploy any adv services, you would have to use the adv servcies’ repo?
17:31:28 <dougwig> that's correct.
17:31:31 <xgerman> +1
17:31:35 <SumitNaiksatam> okay
17:31:49 <xgerman> but we would still have to backport fixes to the old repo
17:31:56 <SumitNaiksatam> that would save us the trouble of maintaining in two places
17:32:06 <SumitNaiksatam> xgerman: you mean stable branch?
17:32:06 <dougwig> xgerman: for stable/juno, stable/icehouse, yes.
17:32:15 <xgerman> what dougwig says
17:32:36 <SumitNaiksatam> yeah, those branches would still have the adv services code artifacts
17:33:03 <SumitNaiksatam> okay, i think so far the technical plan is clear to most people
17:33:35 <dougwig> there's other stuff, separate db, separate migration, tweak neutron to load out-of-tree plugins, but gerrit is likely a better place to discuss those.
17:33:35 <SumitNaiksatam> non-technical issue - what about naming?
17:33:44 <xgerman> Positron?
17:33:45 <blogan> positron prob won't work
17:33:52 <xgerman> :-(
17:33:55 <SumitNaiksatam> blogan: really??
17:33:57 <blogan> http://www.positronsoftwares.com/
17:33:59 <s3wong> blogan: really, it is already taken?
17:34:23 <a2hill> I couldnt find a class 9 trademark for positron
17:34:28 <SumitNaiksatam> but isnt that different from just “positron”?
17:34:33 <a2hill> some were dead, but none active
17:34:38 <s3wong> I guess that's the reason why only dougwig and I show up on #openstack-positron...
17:34:43 <SumitNaiksatam> a2hill: yey to that!
17:34:46 <SumitNaiksatam> *yay
17:35:05 <xgerman> yay
17:35:12 <blogan> dunno, but from talking to mark he didn't think it was plausible either
17:35:17 <blogan> bc of that website
17:35:29 <blogan> that doesn't mean its final though
17:35:39 <xgerman> well, we need somebody who owns a physics book for more particle names
17:35:49 <SumitNaiksatam> i would imagine there are legal folks employed by the openstack foundation to do this check, right?
17:35:50 <blogan> muon
17:35:54 <blogan> boson
17:35:54 <damon__> :-)
17:36:00 <blogan> quark
17:36:21 <s3wong> or we can go back to name after space/cosmic related stuff
17:36:27 <blogan> SumitNaiksatam: yeah and mark will go through them
17:36:42 <xgerman> http://en.wikipedia.org/wiki/List_of_particles
17:36:46 <SumitNaiksatam> blogan: okay
17:37:03 <xgerman> neutralino :-)
17:37:04 <blogan> he learned some lessons from the quantum name and renaming it
17:37:14 <blogan> it was a cosmic chance that neutron was available
17:37:23 <blogan> neutrino
17:37:44 <SridarK_> I think rackspace offered quark if i am not mistaken
17:38:01 <s3wong> Backspace has trademark right on 'quark'?
17:38:07 <blogan> yeah thats our internal neutron plugin and i'd hate to take it
17:38:08 <s3wong> s/Backspace/Rackspace
17:38:10 <sbalukoff> It's not that hard to do a trademark search, eh.
17:38:14 <SridarK_> s3wong: yes and they offered it
17:38:25 <blogan> that woudl be confusing to us internally!
17:38:49 <a2hill> They said quark was not trademarked yet
17:38:52 <blogan> im easily confused
17:38:57 <xgerman> so am I
17:39:05 <SumitNaiksatam> okay so we can do some more homework on this
17:39:24 <sbalukoff> It's also not that hard to submit a trademark application. ;)
17:39:31 <SumitNaiksatam> be ready with the options so that we can propose them at the right time
17:39:38 <SumitNaiksatam> sbalukoff: want to try positron ;-)
17:39:39 <sbalukoff> (Though it is time consuming)
17:39:40 <a2hill> Using TESS there are live ™ on positron but none for class 9
17:39:51 <a2hill> But, i may be looking at things wrong
17:40:08 <SumitNaiksatam> ok moving on
17:40:44 <SumitNaiksatam> #topic Mid cycle meet up proposal
17:40:58 <SridarK_> #link https://etherpad.openstack.org/p/advanced-services-kilo-midcycle
17:41:09 <SumitNaiksatam> i guess this follows from the discussion with TC etc
17:41:23 <SumitNaiksatam> but we can have a plan ready
17:41:27 <SumitNaiksatam> SridarK_: thanks for the link
17:41:39 <glebo> what did folks think of my suggestion about Dec 11, to ensure we have the right cores and TC and PTL and such?
17:41:50 <blogan> mestery mentioned an email today?
17:41:59 <glebo> (back on name) orgasmatron?
17:42:01 <xgerman> glebo you like skiing?
17:42:07 <SumitNaiksatam> glebo: lol!
17:42:25 <SumitNaiksatam> blogan: email to the ML?
17:42:31 <s3wong> glebo: yeah... that's a REAL name :-)
17:42:37 <dougwig> glebo: i think de-focusing that meetup is not a good idea, nor will it breed goodwill.  we should work to have those cores/ptl in attendance at whatever other meetup we do.
17:42:56 <SumitNaiksatam> blogan: i meant to ask, is the email already sent to the ML?
17:43:03 <glebo> http://en.wikipedia.org/wiki/Orgasmatron_(disambiguation)
17:43:09 <glebo> pretty sure it's not trademarked
17:43:10 <blogan> SumitNaiksatam: no i dont think it has yet, i just understood that is what he menat
17:43:18 <SumitNaiksatam> blogan: ah okay
17:43:23 <glebo> (from a woody allen move, sleeper, 1971)
17:43:28 <glebo> movie
17:43:52 * pc_m can we have one discussion?
17:44:04 <s3wong> glebo: in addition to what dougwig said - after the split, we are independent projects with probably non-100%-overlapping contributors. And there is a great chance that some Neutron cores are just NOT too interested in adv. services
17:44:28 <blogan> s3wong: similar to how it is now :)
17:44:31 <glebo> dougwig:  ack. just thinking that so much travel may not be realistic for normal humans, esp those w/ families
17:44:42 <s3wong> blogan: :-)
17:44:48 <SumitNaiksatam> i would hope that we can collectively decide the logistics of the meetup so as to give everyone’s opinion a fair chance
17:44:55 <xgerman> then we do it in MSP
17:45:06 <SumitNaiksatam> glebo: completely understandable
17:45:14 <glebo> s3wong:  ack. Was hoping the meetup on 11th would be really tightly focused on split execution
17:45:19 <SumitNaiksatam> xgerman: MSP?
17:45:41 <xgerman> Minneapolis -- that's where Kyle lives
17:45:48 <SumitNaiksatam> xgerman: ha :-)
17:45:55 <glebo> xgerman:  ha ha
17:45:58 <dougwig> glebo: i'm really interested in the vendor split, so a split meetup will be, umm, hard.  ;)
17:45:59 <SumitNaiksatam> in -30
17:46:02 <xgerman> I know the US by airport codes
17:46:14 <SridarK_> xgerman: Minneapolis in Dec ?
17:46:24 <SridarK_> :-)
17:46:30 <glebo> dougwig:  ha
17:46:53 <SumitNaiksatam> anyway, we can leverage the above etherpad for some of these discussions as well
17:47:14 <johnsom_> SridarK_ +1
17:47:25 <SumitNaiksatam> so in terms of agenda, i proposed some time for each of the adv services, just to cross-sync
17:47:35 <SumitNaiksatam> i am not sure we have enough time today
17:47:48 <dougwig> for lbaas, just scroll up one hour.  :)
17:47:54 <SumitNaiksatam> may be we can do a quick 2 min rapid fire?
17:47:57 <s3wong> SumitNaiksatam: is VPNaS going to be having their meeting during this hour :-)
17:47:59 <SumitNaiksatam> dougwig: :-)
17:48:07 <SumitNaiksatam> s3wong: no :-)
17:48:14 <SumitNaiksatam> so lets start in reverse order
17:48:19 <dougwig> for flavors, i spoke to eugene and mark, and will be re-proposing mark's spec for kilo/neutron, tweaking it for the feedback he got at the end.
17:48:20 <SumitNaiksatam> #topic VPNaaS update
17:48:24 <SumitNaiksatam> #undo
17:48:26 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0x1dfca50>
17:48:38 <SumitNaiksatam> #topic Flavors
17:48:44 <SumitNaiksatam> dougwig: thanks for that update
17:48:45 <s3wong> dougwig: who is going to pick up flavor in Kilo cycle?
17:48:57 <dougwig> s3wong: me
17:49:03 <dougwig> it's my turn to be full of holes.
17:49:05 <SumitNaiksatam> i also believe there is resistance to using the term “flavors” (sorry for bringing up a naming issue again)
17:49:07 <s3wong> dougwig: because as we talked about during the summit, flavor is going to be part of Neutron instead of Positron
17:49:46 <xgerman> let's call it ice cream then
17:49:50 <SumitNaiksatam> s3wong: “flavor is going to be part of Neutron instead of Positron” which session was this discussed in?
17:50:07 <xgerman> yeah, I also thought we own flavors
17:50:08 <sbalukoff> s3wong: What was the reasoning there? So that people could use multiple types of SDN for layer 2/3 stuff in a single OpenStack installation or something?
17:50:17 <dougwig> i'm going to propose it in neutron-specs, because no other specs repo exists yet.  i was punting on the question of where.
17:50:22 <s3wong> SumitNaiksatam: the Friday one --- it was a 5 minutes discussion, due to the fact that flavor framework will affect L3 services
17:50:41 <xgerman> Friday was very confusing...
17:50:48 <sbalukoff> s3wong: Do you recall how they affect L3 services?
17:51:01 <SumitNaiksatam> s3wong: okay, i would have hoped “flavors” was inside positron, that made more sense to me
17:51:03 <sbalukoff> Yeah, Friday was pretty much useless for me.
17:51:19 <s3wong> sbalukoff: yes, the main reason for that is flavor can affect whether we select a vendor driver that can both be a router and FW, for example
17:51:21 <sbalukoff> I think most if not all of us wanted flavors to be in positron.
17:51:23 <sballe> SumitNaiksatam: +1
17:51:31 <sbalukoff> s3wong. Aah.
17:52:11 <s3wong> sbalukoff, SumitNaiksatam, dougwig: guys, it wasn't my idea :-) it was just being talked about during the meetup on Friday, I just reflected back on this
17:52:11 <xgerman> mmh, but once we spin out that shouldn't be an issue any longer
17:52:18 <sbalukoff> Well, there's always the possibility of making Neutron dependent on a shared flavors library which lives in positron once Neutron is in a position to actually offer that feature. :)
17:52:19 <s3wong> I too would like this in Positron :-)
17:52:21 <SumitNaiksatam> s3wong: to that i would say, we should probably not be ttying “multi-service” appliances to flavors
17:52:41 <SumitNaiksatam> s3wong: understood
17:53:02 <sbalukoff> Sumit: Agreed!
17:53:08 <xgerman> ok, so we assume Friday never happened -- nobody remembers that day anyway :-)
17:53:13 <sbalukoff> Haha!
17:53:15 <SumitNaiksatam> sbalukoff: i like that idea
17:53:15 <sballe> lol
17:53:16 <bobmel> SumitNaiksatam: What do you mean by the multi-service statement?
17:53:31 <SumitNaiksatam> bobmel: router + fw
17:53:45 <s3wong> xgerman: well, when we get to FWaaS segment, the Friday meeting did have some important implication on what the FWaaS team needs to do prior to the split
17:53:50 <SumitNaiksatam> the simpler thing to do would be to have “flavors” per service-type
17:54:05 <sbalukoff> Also not a terrible idea.
17:54:05 <s3wong> so there is still important things coming out of that Friday meetup :-)
17:54:23 <xgerman> I have a selective memory
17:54:29 <sbalukoff> The flavor framework *ought* to be pretty light-weight.
17:54:33 <s3wong> dougwig: is flavor per service-type the design now?
17:54:40 <sbalukoff> But then, I could be horribly underestimating that
17:54:46 <dougwig> SumitNaiksatam: can you explain what you mean by that?  isn't the current proposal a per-service thing already?
17:54:51 <sballe> Do we want to discuss  to have “flavors” per service-type?
17:54:54 <SumitNaiksatam> sbalukoff: there could be a path for evolution :-)
17:55:19 <dougwig> s3wong: yes, flavors specify a service, and a number of attached service profiles (meta-data configs)
17:55:19 <SumitNaiksatam> dougwig: if its per-service, then it does not address “router + FW” , right?
17:55:41 <s3wong> sballe: flavor discussion is always the safest bet to occupy the ENTIRE meeting time :-)
17:55:43 <dougwig> the service field is a string, and can be anything.
17:55:51 <sbalukoff> Haha
17:55:51 <sballe> s3wong: :-)
17:56:01 <SumitNaiksatam> s3wong: from experience :-)
17:56:11 <bobmel> SumitNaiksatam: Why not? There could be flaovrs for router and flavors for FW
17:56:22 <xgerman> well, let's wait for the proposal to surface so we can discuss it in gerrit
17:56:28 <xgerman> also we are T-4
17:56:35 <s3wong> xgerman: +1
17:56:58 <SumitNaiksatam> bobmel: true, but s3wong was relaying the discussion specifying the need for a flavor which captures, both, a router and a firewall, as a one flavor
17:57:06 <SumitNaiksatam> xgerman: +1
17:57:13 <SumitNaiksatam> #topic open discussion
17:57:18 <SumitNaiksatam> we have 3 mins
17:57:26 <s3wong> SumitNaiksatam: that said, if we use flavor to select L3 service also, the argument remains
17:57:34 <bobmel> I think it is preferable to keep flavors per service and not flavors that combines multiple services
17:57:35 <SumitNaiksatam> so skipped the per service update (thanks to flavors!)
17:57:44 <SumitNaiksatam> bobmel: okay
17:57:52 <SumitNaiksatam> s3wong: yeah, something to consider
17:57:59 <s3wong> anyway, let's get some quick updates on FWaaS --- the per-router work as well as the service group work, how are these going?
17:58:09 <SumitNaiksatam> s3wong: sure
17:58:15 <igordcard> What about more general flavors that combine service flavors?
17:58:25 <SumitNaiksatam> the team has met on a couple of occasions to discuss this
17:58:58 <SumitNaiksatam> SridarK_: will is in the process of translating this into a spec (i am referring to the FWaaS insertion)
17:59:11 <SridarK_> SumitNaiksatam: and all yes working thru that
17:59:14 <SumitNaiksatam> we will also follow up on this topic on tomorrow’s FWaaS meeting, more details there
17:59:34 <SridarK_> would prefer a more generic model (perhaps ports) rather than just a router_id
17:59:45 <xgerman> +1
17:59:47 <SumitNaiksatam> service groups spec is in review
17:59:53 <SumitNaiksatam> SridarK_: +1
18:00:25 <s3wong> SridarK_: I (along with Kanzhe) vowed to NOT submit a service insertion spec unless and until Positron is spun off
18:00:40 <SridarK_> s3wong: :-)
18:01:00 <SumitNaiksatam> service groups: #link https://review.openstack.org/#/c/131596/
18:01:01 <xgerman> bye
18:01:08 <SumitNaiksatam> alright thanks everyone
18:01:10 <SumitNaiksatam> bye!
18:01:12 <SumitNaiksatam> #endmeeting