17:32:16 <SumitNaiksatam> #startmeeting Networking Advanced Services
17:32:17 <openstack> Meeting started Wed Aug 27 17:32:16 2014 UTC and is due to finish in 60 minutes.  The chair is SumitNaiksatam. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:32:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:32:20 <openstack> The meeting name has been set to 'networking_advanced_services'
17:33:02 <SumitNaiksatam> i think everyone is busy with the J3 deadline, reviewing patches, or posting responses, or both
17:33:26 <SumitNaiksatam> so perhaps we can have a shorted meeting to let people go back and focus on meeting the J3 milestone
17:34:03 <SumitNaiksatam> #topic Flavors
17:34:20 <SumitNaiksatam> enikanorov__: markmcclain: any update on this?
17:34:36 <enikanorov__> SumitNaiksatam: no
17:34:47 <enikanorov__> i have a feeling this is postponed
17:34:56 <SumitNaiksatam> enikanorov__: okay :-(
17:35:11 <SumitNaiksatam> spec: #link https://review.openstack.org/#/c/102723
17:35:30 <SumitNaiksatam> impl: #link https://review.openstack.org/#/c/105982
17:35:50 <SumitNaiksatam> anyone else have any questions or like to discuss anything specific on this?
17:36:39 <SumitNaiksatam> enikanorov__: thanks
17:36:43 <SumitNaiksatam> #topic Service base and insertion implementation update
17:36:56 <SumitNaiksatam> s3wong: kanzhe: hi
17:37:23 <s3wong> so kanzhe and I posted our patches (barely) on Thursday night
17:37:28 <SumitNaiksatam> #link https://review.openstack.org/#/c/116090
17:37:36 <SumitNaiksatam> #link https://review.openstack.org/#/c/113975
17:37:50 <s3wong> we both got -1 from Ann on db migration related stuff
17:38:05 <s3wong> for mine, particularly, I need to also tighten up the unit tests
17:38:27 <SumitNaiksatam> s3wong: okay
17:38:41 <SumitNaiksatam> s3wong: i think the -1 will prevent other folks from reviewing
17:38:54 <SumitNaiksatam> prevent -> discourage
17:38:59 <s3wong> marios: apology to marios - since kanzhe and I spent Thursday afternoon on a f2f code splint, we didn't get a chance to integrate with your patch
17:39:27 <marios> s3wong: i was waiting for appropriate time to comment. so i apologise that i've been sucked into a vortex at work this last week or so so haven't been following progress
17:39:33 <s3wong> SumitNaiksatam: I believe so, meant to fix it - but for mine, I need some work done also for unit test, so it takes time...
17:39:41 <marios> i am fairly confident that i can update my review to match the stuff you're doing s3wong
17:40:05 <SumitNaiksatam> marios: thanks, we were looking for you last week as well :-P
17:40:20 <marios> SumitNaiksatam: i know, my apologies
17:40:26 <SumitNaiksatam> marios: but fully understand since this is the crunch time
17:40:29 <s3wong> marios: sure, you can take a look at how we finalize stuff
17:40:46 * SumitNaiksatam realizes that marios is busy with tripelo stuff as well
17:40:52 <marios> s3wong: sure thing
17:40:52 <s3wong> marios: kanzhe's patch, in particular, has some sample code on vpnaas also
17:41:07 <marios> s3wong: perfect thx
17:41:30 <marios> did we make any progress wrt the 'will this fly with core' issues?
17:41:32 <s3wong> SumitNaiksatam: that's it for me (and kanzhe)
17:41:32 <marios> (btw)
17:41:35 <SumitNaiksatam> #action s3wong marios kanzhe to coordinate on any issues for the service insertion patches
17:42:08 <s3wong> marios: yes?
17:42:20 <marios> or is the fact that we're still pursuing this for J indication enough. or we'll see/best effort (which is also a perfectly valid answer)
17:42:39 <marios> s3wong:did we make any progress wrt the 'will this fly with core' issues?
17:42:56 <s3wong> marios: let's be honest - from the ML, it seems like cores will only allow Nova parity and Neutron scalability fixes
17:43:03 <SumitNaiksatam> marios: i am going by the opinion expressed by s3wong that he felt confident that he would be able to land everthing in time for the FPF
17:43:21 <marios> SumitNaiksatam: s3wong: ok thanks i understand, please feel free to move on
17:43:22 <SumitNaiksatam> marios: so i left that the three of you deserved a chance at the review after all the hard work you put in
17:43:56 <SumitNaiksatam> of course we also need to balance the attention/focus of the reviewer’s so as not create a distraction if this is not a priority
17:44:00 <s3wong> marios: if enikanorov__ 's flavor stuff can't make it, I don't think our chance is all that great
17:44:07 <s3wong> marios: but we do what we can :-)
17:44:08 <marios> s3wong: ack
17:44:26 <SumitNaiksatam> #topic Service Chaining
17:44:41 <SumitNaiksatam> songole: hi
17:44:46 <songole> SumitNaiksatam: hellow
17:44:48 <SumitNaiksatam> #link https://review.openstack.org/#/c/113737/
17:44:53 <SumitNaiksatam> #link https://review.openstack.org/#/c/113738/
17:44:53 <songole> Patches are in review
17:45:02 <songole> we got -2 from Maru
17:45:15 <SumitNaiksatam> songole: lucky you! :-)
17:45:34 <songole> SumitNaiksatam: :-)
17:45:47 <SumitNaiksatam> songole: so any follow up with on the -2?
17:46:14 <songole> Yes, he thinks it is a big change in terms of lines of code.
17:46:20 <SumitNaiksatam> songole: hmmm
17:46:48 <songole> And, it has a dependency on flavors
17:47:04 <SumitNaiksatam> and i am guessing that if you break it down into two patches, it will be argued that it was done too late
17:47:08 <songole> We are taking service-type in place of flavor
17:47:19 <SumitNaiksatam> songole: okay
17:47:30 <s3wong> Kanzhe: I did our update for us already - anything you want to add in particular?
17:47:53 <SumitNaiksatam> songole: so the other two options are to move to kilo and/or move this to the “incubator” (or labs)
17:48:25 <songole> okay. what do you recommend?
17:48:34 <s3wong> SumitNaiksatam: does it have any Neutron core class/module change? is integrating features like this still a question mark for incubator?
17:48:40 <Kanzhe> s3wong: Nothing else.
17:48:51 <s3wong> Kanzhe: sorry, we should have waited for you :-)
17:48:58 <Kanzhe> I will push a new version to address review comments.
17:49:05 <LouisF> songole: is service chain node creation actually intended to create a service?
17:49:28 <songole> yes, but at the time of instance creation.
17:49:36 <SumitNaiksatam> s3wong: i dont see any dependencies
17:49:43 <s3wong> Kanzhe: I will also do the vpnaas removal call via my patch - though unit test is going to be a bit hairy, it will look more like functional test :-(
17:50:11 <s3wong> SumitNaiksatam: cool. Wish I can say the same thing for service insertion framework
17:50:29 <SumitNaiksatam> s3wong: agreed
17:50:59 <SumitNaiksatam> any other questions/feedback for songole?
17:51:00 <songole> LouisF: servicechain node is a definition of a service. doesn't instantiate a service
17:51:38 <LouisF> songole: thx
17:51:50 <songole> SumitNaiksatam: should we split into multiple patches?
17:52:18 <SumitNaiksatam> songole: not a bad idea to do that anyway
17:52:37 <songole> okay.
17:52:45 <SumitNaiksatam> songole: perhaps extension definition is one patch, and db + plugin is another patch
17:52:59 <SumitNaiksatam> songole: the latter can be broken down further
17:53:09 <songole> ok
17:53:26 <SumitNaiksatam> songole: just need to strike the balance between making it easier for reviews versus adding too much overhead in managing patches
17:54:01 <SumitNaiksatam> #topic Kilo targeted features
17:54:13 <songole> okay. but they need to review all the patches anyway.
17:54:21 <SumitNaiksatam> songole: yes :-)
17:54:59 <SumitNaiksatam> just wanted to quickly check if check if cgoncalves, vinay_yadhav, anil_rao were here
17:55:18 <SumitNaiksatam> to discuss anything relevant to Traffic Steering and Tap
17:55:40 <SumitNaiksatam> perhaps not
17:55:46 <SumitNaiksatam> #topic Open Discussion
17:56:07 <SumitNaiksatam> anything else? or else we can get back 35 mins!
17:56:43 <SumitNaiksatam> ok thanks everyone for joining
17:56:46 <SumitNaiksatam> bye
17:56:47 <s3wong> SumitNaiksatam: amazing how fast a meeting can be without talking too much about flavor :-)
17:56:49 <SumitNaiksatam> #endmeeting