14:00:07 <haleyb> #startmeeting networking
14:00:07 <opendevmeet> Meeting started Tue Feb 13 14:00:07 2024 UTC and is due to finish in 60 minutes.  The chair is haleyb. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:07 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:07 <opendevmeet> The meeting name has been set to 'networking'
14:00:08 <haleyb> Ping list: bcafarel, elvira, frickler, mlavalle, mtomaska, obondarev, slaweq, tobias-urdin, ykarel, lajoskatona, jlibosva, averdagu, amotoki
14:00:09 <mlavalle> \o
14:00:17 <slaweq> o/
14:00:18 <obondarev> hi
14:00:20 <bcafarel> o/
14:00:21 <ykarel> o/
14:00:24 <mtomaska> o/
14:00:44 <rubasov> o/
14:01:28 <haleyb> hi everyone, lets get started
14:01:31 <haleyb> #topic announcements
14:01:47 <haleyb> #link https://releases.openstack.org/caracal/schedule.html
14:01:54 <lajoskatona> o/
14:02:22 <haleyb> we are getting late in C-3 cycle
14:02:45 <haleyb> and i hope everyone saw thierry's email about the release countdown
14:02:49 <haleyb> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/AJPHUQGBT7BET2CR5Z7MXI7GN4RE7TCB/
14:02:58 <haleyb> Oslo libraries are entering feature freeze next week, February 15, 2024
14:03:05 <haleyb> General libraries (except client libraries) need to have their last feature release before Non-client library freeze (February 22, 2024)
14:03:12 <haleyb> Client libraries (think python-*client libraries) need to have their last feature release before Client library freeze (February 29, 2024)
14:03:21 <haleyb> Feb 26th-Mar 1st is C-3 milestone / feature freeze / requirements freeze
14:03:38 <haleyb> so what this means is we should land any neutron-lib changes this week
14:03:40 <ralonsoh> hello (late)
14:04:41 <ihrachys> o/
14:05:05 <haleyb> #link https://review.opendev.org/q/project:openstack/neutron-lib+status:open
14:05:33 <haleyb> so please update and/or ask for reviews on anything that's ready there ^^
14:06:36 <haleyb> i think that was the main thing for announcements, does anyone have more?
14:06:52 <lajoskatona> perhaps the unmaintained thing
14:07:02 <lajoskatona> so unmaintained/yoga is out there
14:07:35 <haleyb> lajoskatona: right, go ahead
14:07:37 <lajoskatona> thigs are broken mostly (for example grenade for zed and 2023.1)
14:08:19 <lajoskatona> for that ralonsoh opened a bug: https://bugs.launchpad.net/neutron/+bug/2052915 I suppose there will be more
14:09:05 <lajoskatona> another thing is that at the moment any change landing on unmaintained/yoga is not visible on irc, for that we have to agree to have the notification here in #neutron channel
14:09:34 <haleyb> and the neutron cores do not have +2 either
14:09:39 <lajoskatona> and another thing is that there is "global" unmaintained group for merging patches on unmaintained branches
14:09:42 <lajoskatona> yes exactly
14:10:14 <haleyb> the intention was for "some group" to propose owning these unmaintained branches, and step-up to get superpowers
14:10:21 <ralonsoh> I added this topic in the on-demand section
14:10:25 <lajoskatona> perhaps slaweq have some more background on this but if I understand well we can have a neutron-unmaintaned group or similar and than the global group will not care about these patches
14:10:36 <lajoskatona> but perhaps I misunderstood the policy
14:11:05 <lajoskatona> ralonsoh: ok, sorry I haevnt checked the agenda before (palm-face....)
14:11:24 <ralonsoh> we can create a new groups
14:11:27 <ralonsoh> example: https://review.opendev.org/c/openstack/project-config/+/902796
14:11:35 <lajoskatona> +1
14:11:45 <ralonsoh> and we can also add the patches events to our channel
14:11:46 <lajoskatona> I am happy to be in it
14:11:50 <ralonsoh> https://opendev.org/openstack/project-config/src/branch/master/gerritbot/channels.yaml#L927-L929
14:12:05 <lajoskatona> https://review.opendev.org/c/openstack/project-config/+/908606
14:12:13 <lajoskatona> I prepared the notification patch
14:12:30 <ralonsoh> +1 to the notification
14:12:49 <ralonsoh> I'll send a patch to create the um neutron group
14:13:01 <lajoskatona> so basically I just wanted to make it visible for everybody that this new policy changes our ways of working
14:13:35 <lajoskatona> and the default option is that we do not care about unmaintained branches
14:13:41 <lajoskatona> ralonsoh: thanks
14:13:52 <ralonsoh> please vote in https://review.opendev.org/c/openstack/project-config/+/908606
14:14:52 <lajoskatona> that's it from me for this topic
14:14:58 <haleyb> so is the consensus that we care about unmaintained branches? i.e. we want to keep them working, etc?
14:15:18 <haleyb> i was thinking about the impact to me downstream but didn't know about rhat, etc
14:15:30 <ralonsoh> well, at least we want to be able to merge patches
14:15:38 <ralonsoh> to fix possible issues
14:15:50 <ralonsoh> that doesn't mean we are going to care them as new ones
14:15:59 <ralonsoh> actually we are removing support from n-t-p
14:16:33 <ralonsoh> the point is if we (neutron cores) don't take care of them, probably nobody will
14:16:38 <haleyb> right, the testing will be the hard part
14:16:55 <mlavalle> agree with ralonsoh
14:17:10 <lajoskatona> yes I am sure nobody will care :-)
14:17:14 <mlavalle> I don't see hordes of people coming to help
14:17:54 <haleyb> i only see people wanting to propose patches, but maybe don't have the expertise to maintain the branch (yet)
14:18:55 <bcafarel> +1 being able to merge patches if we ever get some will be useful, but not actually maintaining them (so we can mostly skip them in CI meeting for example?)
14:19:19 <haleyb> and i agree it would be good to keep alive, but maybe we have to think about what we merge? like high priority or above, if we are treating it like an lts branch
14:19:27 <lajoskatona> good point
14:21:27 <haleyb> and i guess if it comes to it, we can add others to the "neutron-unmaintained-core" group that can help
14:21:59 * haleyb is just guessing on the name there based on the ironic change
14:22:26 <lajoskatona> yes any volunteers can come and do it :-)
14:23:00 <haleyb> like bcafarel does today with stable
14:23:52 <haleyb> so we should probably add something to the neutron docs on our policy, or at least a rough outline
14:24:21 <mlavalle> maybe a recruitment session during the PTG?
14:24:26 <haleyb> #action haleyb to propose a doc update on unmaintained branch
14:24:27 <lajoskatona> hmm, good idea
14:24:46 <mlavalle> we can send a message to the ML advertising it
14:24:50 <haleyb> mlavalle: there will be a line out the door! :)
14:24:56 <mlavalle> and see how many people show up
14:25:20 <mlavalle> at least we gauge the level of interest
14:25:36 <haleyb> i will float this downstream here, it might actually help us
14:25:36 <mlavalle> the result of the experiment might be no interest whatsoever
14:25:59 <haleyb> and sorry, my sarcasm meter is always on high
14:26:00 <mlavalle> but we might be pleasently surprised
14:26:22 <mlavalle> haleyb: that's perfectly fine. just proposing ideas
14:26:36 <mlavalle> I know you New Englanders
14:26:52 <haleyb> yup, and i'm too old to change
14:27:17 <lajoskatona> :-)
14:27:36 <mlavalle> ;-)
14:28:54 <haleyb> great, so everyone look at the project-config change mentioned and the core group review when it's out
14:29:51 <haleyb> anything else on this topic? we still have on-demand later
14:30:24 <lajoskatona> I finished, thanks for the attention
14:30:39 <haleyb> ok, moving on
14:30:51 <haleyb> and thanks lajoskatona for bringing it up
14:30:56 <haleyb> #topic bugs
14:31:08 <haleyb> ralonsoh was the deputy last week
14:31:12 <haleyb> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/4IU5JHBWEJDAARMY5Z7QX2FZX3RSHHO5/
14:31:53 <haleyb> there were some un-owned bugs we can go through
14:32:10 <haleyb> #link https://bugs.launchpad.net/neutron/+bug/2052821
14:32:17 <haleyb> [OVN] Pin a Logical_Router to a chassis when the external network is tunnelled
14:32:21 <ralonsoh> no no sorry
14:32:24 <ralonsoh> that one is mine
14:32:43 <ralonsoh> (I already have a patch)
14:33:14 <haleyb> ralonsoh: ack, just assigned
14:33:42 <haleyb> next one
14:33:46 <haleyb> #link https://bugs.launchpad.net/neutron/+bug/2052681
14:33:51 <haleyb> Many stale neutron-keepalived-state-change processes left after upgrade to native pyroute2 state-change
14:34:15 <haleyb> liu filed this, i had a follow-up if he would fix it as there is not much info there
14:34:59 <ralonsoh> that's weird: the "ip -o monitor" is a process dependant on the keepalived-state-change service
14:35:15 <ralonsoh> if the parent one is stopped, the child processes should too
14:35:22 <ralonsoh> unless you kill the parent process
14:36:04 <ralonsoh> in other words: it doesn't matter if you upgrade or not the k-s-c code or not
14:36:16 <ralonsoh> if you kill it, the monitor will stay there
14:37:24 <haleyb> ralonsoh: can you add those comments to the bug? it is only one sentence at the moment
14:37:50 <ralonsoh> sure and I'll test it too in an old environment before
14:38:41 <haleyb> great, moving on to next one
14:38:46 <haleyb> #link https://bugs.launchpad.net/neutron/+bug/2052508
14:38:54 <haleyb> [doc][troubleshooting] how to enable ovs vswitchd debug logs
14:39:20 <bbezak> o/
14:39:31 <haleyb> ykarel: can i assign this to you? i see there is already a functional patch
14:39:39 <ykarel> yes sure
14:40:19 <haleyb> great
14:40:56 <haleyb> i think all the other bugs have owners and/or patches, any someone needs to discuss?
14:41:03 <bbezak> #link https://bugs.launchpad.net/neutron/+bug/2052937
14:41:23 <bbezak> slaweq: Bence marked it invalid
14:41:25 <bbezak> :)
14:41:41 <rubasov> I hope it can be configured
14:41:43 <ralonsoh> yeah, I was going to say that. Please check Bence's comment
14:41:46 <slaweq> bbezak I will still need to check it
14:42:03 <rubasov> and the default may be right as it is
14:42:22 <slaweq> of course it can be customized but from quick look default value for this API req may not be correct
14:42:28 <bbezak> I think service role user should be able to do it with default policy
14:42:41 <bbezak> as in kolla-ansible we're using default policies by design
14:43:05 <slaweq> and probably calls to port['binding:profile'] should be for service user available by default
14:43:14 <slaweq> but I had no chance to check it really yet
14:43:38 <rubasov> I changed it back to alive then :-)
14:43:51 <slaweq> thx rubasov :)
14:43:58 <bbezak> cool, thx
14:44:23 <slaweq> I assigned it to myself and should have time for it on Thursday morning probably
14:44:33 <bbezak> lovely, thank you rubasov slaweq
14:44:41 <rubasov> thanks slaweq
14:45:14 <haleyb> great, just some bug housekeeping if there is nothing else
14:45:18 <haleyb> Current bug count this week: 770, up 11 from last week
14:45:37 <haleyb> i see today it's down a few, so good job on fixing things
14:45:57 <haleyb> This week rubasov is the bug deputy, next week will be lucasgomes
14:46:07 <rubasov> on it
14:46:32 <haleyb> and i see rubasov has been busy (thanks!)
14:46:51 <haleyb> i don't see lucas here
14:47:23 <ykarel> he is on pto today, will be back tomorrow
14:47:55 <haleyb> ykarel: ack, i'll ping him later this week to make sure he can be deputy
14:47:56 <ykarel> i will remind him once he is back
14:48:00 <haleyb> +1
14:48:19 <haleyb> topic #specs
14:48:24 <haleyb> #link https://review.opendev.org/q/project:openstack%252Fneutron-specs+status:open
14:48:47 <haleyb> i see the OVN I-C spec has merged, and i believe i've seen one patch
14:50:03 <haleyb> the other two remaining just need some more +2's, else we'll have to move to next cycle directory
14:50:54 <haleyb> #topic community_goals
14:51:06 <haleyb> #link https://review.opendev.org/c/openstack/horizon/+/891205
14:51:47 <haleyb> lajoskatona: it's still fighting you
14:51:52 <lajoskatona> The issue which I found is that I an't use SDK and keystoneauth to have https
14:52:48 <lajoskatona> yes, I tried to have some help on sdk channel but perhaps I have to find directly some guys who has deeper keystoenauth and SDK background
14:53:18 <lajoskatona> that's where I am at the moment
14:53:52 <lajoskatona> I can't create a keystoneauth session and an SDK client from that that workswell with https endpoints
14:54:18 <lajoskatona> the terrible is that it appears on;y if pagination is on, so .....
14:54:19 <haleyb> lajoskatona: ack, it has not been easy :(
14:54:29 <haleyb> there isn't an existing session it can use?
14:55:12 <lajoskatona> no this is the first SDK usage in horizon, only the old python-xclients are there
14:56:36 <haleyb> hopefully you figure it out
14:56:43 <haleyb> #topic on_demand
14:57:02 <haleyb> we are almost out of time, any on-demand topics?
14:57:07 <ralonsoh> no, thanks
14:57:18 <haleyb> and there is the ci meeting in a few minutes, irc this time i believe
14:57:23 <mlavalle> I think we discussed what ralonsoh proposed
14:57:27 <mlavalle> already
14:57:29 <ykarel> yeap CI meeting in 3 minutes :), over irc today
14:58:02 <bcafarel> ack
14:58:04 <haleyb> ok, thanks everyone for attending, review away!
14:58:09 <haleyb> #endmeeting