21:00:26 <mlavalle> #startmeeting networking
21:00:26 <openstack> Meeting started Mon Apr  2 21:00:26 2018 UTC and is due to finish in 60 minutes.  The chair is mlavalle. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:29 <openstack> The meeting name has been set to 'networking'
21:00:47 <mlavalle> Hi there!
21:00:47 <slaweq> o/
21:01:37 <haleyb> hi
21:02:00 <mlavalle> Might still be a slow day after Easter celebrations
21:02:09 <mlavalle> #topic Announcements
21:02:31 <Swami> hi
21:03:12 <mlavalle> We are a little more of two weeks from our first Rocky milestone, April 16 - 20
21:03:27 <mlavalle> The entire release schedule is here:
21:03:43 <mlavalle> #link https://releases.openstack.org/rocky/schedule.html
21:04:20 <mlavalle> Also approacjing fast is the Vancouver Summit:
21:05:02 <mlavalle> #link https://www.openstack.org/summit/vancouver-2018/
21:05:42 <mlavalle> Looking forward to see some of you there. Vancouver is a very pretty location, especially during Spring
21:06:14 <mlavalle> With the Summit, also comes the Forum:
21:06:21 <mlavalle> #link https://wiki.openstack.org/wiki/Forum
21:09:12 <mlavalle> We have deadline of April 15th to propose topics for the Forum:
21:09:12 <mlavalle> #link https://wiki.openstack.org/wiki/Forum/Vancouver2018#Etherpads_from_Teams.2C_Working_Groups.2C_and_SIGs
21:09:12 <mlavalle> As you can see there, we have an etherpad to propose Forum topics for Neutron:
21:09:12 <mlavalle> #link https://etherpad.openstack.org/p/YVR-neutron-brainstorming
21:09:12 <mlavalle> Or you can go directly to the Foundation to propose a topic:
21:09:12 <mlavalle> #link http://forumtopics.openstack.org/
21:10:05 <mlavalle> Last announcement for today is that we are looking for a release team liaison. armax has been fulfilling these roll for the past two cycles, but he has now other commitments
21:10:31 <armax> mlavalle, that’s gracious of you! :)
21:10:47 <mlavalle> If you are interested in being our liaison, please ping me
21:11:42 <mlavalle> armax: Thanks for all your help and guidance for son long.... We are not off the hook, though. We will find ways to pull you back every now and then to play with us ;-)
21:11:56 <mlavalle> You are not oof the hook ^^^
21:12:03 <armax> thanks, I’ll gladly provide input as I can
21:12:31 <mlavalle> Any other announcements from the team?
21:13:42 <mlavalle> Ok, moving on
21:14:04 <mlavalle> #topic Blueprints
21:14:22 <mlavalle> These are the blueprints we are tracking now:
21:14:30 <mlavalle> #link https://launchpad.net/neutron/+milestone/rocky-1
21:14:45 <mlavalle> Does anyone have updates on blueprints?
21:15:08 <boden> mlavalle hi, does the neutron-lib decouple db count?
21:16:08 <mlavalle> boden: Yes, I will add a Launchpad blueprint for it and add it to the dashboard
21:16:14 <mlavalle> so it shows up every week
21:16:49 <boden> mlavalle so all (or most) of the plumbing code for neutron-lib in those specs is out for review now FYI
21:17:00 <mlavalle> wow!
21:17:06 <boden> https://review.openstack.org/#/q/topic:bp/neutronlib-decouple-db+(status:open+OR+status:merged)  has everything, including the specs (not yet approved)
21:17:40 <boden> plubming is quick/easy part :) consuming might be a diff story
21:17:46 <mlavalle> #action mlavalle to create blueprint for neutron-lib decouple
21:18:10 <mlavalle> #action mlavalle to review this week neutron-lib db de-couple
21:18:17 <mlavalle> doeas that help?
21:18:29 <boden> yes, thanks mlavalle, sorry to make more work for you
21:19:03 <mlavalle> I'm here to serve the team. Thanks for your follow up on this topic :-)
21:19:54 <mlavalle> I have an update to the team on https://blueprints.launchpad.net/neutron/+spec/strict-minimum-bandwidth-support
21:21:01 <mlavalle> Last week I had a few days of heated conversation / discussion with gibi_away and rubasov on the best way to create the data structures in the Placement service to enable this functionality
21:22:02 <mlavalle> There were some unexpected complications but I think we have arrived at a feasible model and will probably bring this conversation to closure this week so we can davance the specs both in the Nova and the Neutron side
21:22:49 <mlavalle> Does anyone have any other blueprints to discuss?
21:23:44 <mlavalle> Ok, moving on
21:23:56 <mlavalle> #topic Community Goals
21:24:31 <mlavalle> Does anyone have updates on this topic?
21:24:46 <slaweq> according to https://governance.openstack.org/tc/goals/rocky/enable-mutable-configuration.html
21:25:03 <slaweq> patch in Neutron is merged: https://review.openstack.org/#/c/554259/
21:25:09 <slaweq> thx for reviews :)
21:25:16 <mlavalle> yeas, thanks for that :-)
21:25:21 <slaweq> I didn't have time to check stadium projects yet
21:25:39 <slaweq> but I have it in my mind so I will try to do it in next few days
21:25:47 <slaweq> that's all from my side
21:26:00 <mlavalle> Great, I was going to ask about them
21:26:11 <slaweq> :)
21:26:22 <mlavalle> amotoki: you around with any updates?
21:28:04 <mlavalle> ok, I guess not
21:28:50 <mlavalle> #topic Starter Approved RFEs
21:29:25 <mlavalle> During the last Drivers meeting, we approved this RFE:
21:29:41 <mlavalle> #link https://bugs.launchpad.net/neutron/+bug/1745192
21:29:42 <openstack> Launchpad bug 1745192 in neutron "Can't create a vlan transparent network in mixed driver environment" [Wishlist,Confirmed]
21:30:37 <mlavalle> We consider it a starter blueprint. So if you are a newbie in the Neutron team, take advantage of this fresh off the oven RFE
21:30:54 <mlavalle> #topic Bugs
21:31:20 <mlavalle> Last week we were in the capable hands of Swami for bug triaging
21:31:37 <Swami> mlavalle: Here is the bug summary for last week . https://docs.google.com/spreadsheets/d/1xP0QWZZuKyCf1vKMbCFN9haFqfVXlqyjBVfUc3COb3M/edit#gid=0
21:31:43 <mlavalle> :-)
21:32:24 <Swami> We had 1-High, 1-Critical, 10-Medium, 2-Low, and we still 2 bugs need triaging.
21:32:29 <mlavalle> do you one to walk us thorugh the report Swami or highlight something?
21:32:35 <Swami> All Critical and High bugs, patches were released.
21:32:48 <mlavalle> \o/
21:33:18 <Swami> #link https://bugs.launchpad.net/neutron/+bug/1760320
21:33:19 <openstack> Launchpad bug 1760320 in neutron "vpnaas unit test is broken with no such option metadata_access_mark in group [DEFAULT]" [Critical,Fix released] - Assigned to Akihiro Motoki (amotoki)
21:33:35 <haleyb> oops, that was my fault
21:33:46 <Swami> Vpnaas unit test failure. This was fixed and I think here is the patch link  https://review.openstack.org/558060
21:34:14 <mlavalle> Yeah, I think it just merged last night
21:34:15 <Swami> There was another gate-failure bug. #link https://bugs.launchpad.net/neutron/+bug/1759345
21:34:15 <openstack> Launchpad bug 1759345 in neutron "-with-oslo-master job fails with DuplicateOptError: duplicate option: polling_interval" [Medium,Fix released] - Assigned to Ihar Hrachyshka (ihar-hrachyshka)
21:34:31 <Swami> Fix was released #link https://review.openstack.org/557003
21:34:58 <Swami> #link https://bugs.launchpad.net/neutron/+bug/1758786 - FWaaS test failure.
21:34:59 <openstack> Launchpad bug 1758786 in neutron "neutron db migration failed in subproject neutron-fwaas" [High,Fix released] - Assigned to Yushiro FURUKAWA (y-furukawa-2)
21:35:13 <Swami> Fix was released - #link https://review.openstack.org/556739
21:35:30 <Swami> There are still three bugs that need triaging.
21:35:44 <Swami> #link https://bugs.launchpad.net/neutron/+bug/1760047
21:35:45 <openstack> Launchpad bug 1760047 in neutron "some ports does not become ACTIVE during provisioning" [Undecided,New]
21:36:17 <Swami> This seems to be a case where 100VMs comes up and some of the ports are not becoming ACTIVE.
21:36:44 <Swami> I was not able to triage it. So if anyone have the Scale to test it they can test and validate it.
21:37:42 <Swami> There was one RFE that was filed. May be you can take up for discussion in the Drivers meeting.
21:37:45 <Swami> #link https://bugs.launchpad.net/neutron/+bug/1759790
21:37:46 <openstack> Launchpad bug 1759790 in neutron "[RFE] metric for the route" [Wishlist,Confirmed] - Assigned to zhangyanxian (zhang-yanxian)
21:38:30 <mlavalle> Swami: yes, I will take a look at the RFE
21:38:36 <Swami> mlavalle: thanks
21:38:51 <Swami> mlavalle: that's all I have on bugs.
21:39:09 <mlavalle> Thak you very much Swami. Great job
21:39:28 <Swami> mlavalle: your welcome
21:40:38 <mlavalle> Our bugs deputy for this week is lujinluo. She is based out of Tokyo, so it is probably Tuesday very early in the morning for her. I'll ping her later tonight to make sure she is aware
21:41:18 <mlavalle> Any other bugs we should discuss today?
21:41:42 <mlavalle> ok, moving on
21:41:49 <mlavalle> #topic Docs
21:42:10 <mlavalle> Any updates on Docs this week?
21:42:39 <boden> nothing from me
21:43:24 <mlavalle> ok, let's move on
21:43:53 <mlavalle> #topic neutron-lib
21:44:05 <mlavalle> Any updtes on neutron-lib?
21:44:11 <boden> mlavalle hi
21:44:27 <boden> so I already mentioned the db spec work, but I also just want to mention 1 FYI
21:44:36 <mlavalle> ok
21:44:54 <boden> there’s some neutron-lib work on https://review.openstack.org/#/q/status:open+project:openstack/neutron-lib+branch:master+topic:neutron-lib-sfc-api that introduces some new API attributes
21:45:03 <boden> it would be nice to get some core weigh-in on them at some point
21:45:31 <boden> and that’s all the exciting news ATM from me
21:45:45 <mlavalle> I will take a look this week, bode
21:45:48 <mlavalle> boden
21:45:56 <boden> mlavalle; thanks
21:46:16 <mlavalle> #topic Clients
21:46:31 <mlavalle> I don't see amotoki around
21:46:45 <mlavalle> Does anyone have anything to say on this topic?
21:47:13 <slaweq> I started moving some missing features to openstacksdk repo
21:47:40 <slaweq> I moved only trunk for now: https://review.openstack.org/#/c/556089/
21:47:58 <slaweq> I need to check if that should be ported to shade repo also
21:48:27 <slaweq> and then I will try to do some next parts also according to https://etherpad.openstack.org/p/neutron-openstacksdk-migration
21:48:42 <slaweq> just FYI :)
21:48:54 <mlavalle> Tjhanks for the update slaweq!
21:49:01 <mlavalle> Highly appreciated
21:49:26 <slaweq> Your welcome
21:50:00 <mlavalle> Ok, moving on
21:50:07 <mlavalle> #topic On demand agenda
21:50:11 <toshii> hi
21:50:16 <mlavalle> hi
21:50:20 <slaweq> hi
21:50:22 <mlavalle> I was going to ping you
21:50:24 <toshii> https://etherpad.openstack.org/p/neutron-ryu-future-plans
21:50:38 <toshii> future plans for ryu
21:51:39 <toshii> do you have any good idea? if the neutron team or somewhere in openstack.org can be a new home for ryu, that'd be great
21:52:24 <mlavalle> mhhh It probably would have to be a sub-project
21:52:39 <mlavalle> maybe similar to Ovsdbapp or os-vif
21:53:27 <mlavalle> toshii: but more than where the repo resides, the question is how long is ryuy going to be maintanied?
21:54:51 <toshii> it's ok this year. future is not clear
21:55:40 <mlavalle> toshii: so we should have a plan for ryu or a replacement by the beginning of 2019. Would that summarize the situation?
21:55:55 <toshii> mlavalle, yes
21:56:34 <mlavalle> toshii: got it. would you be our primary contact with the Ryu team the rest of this eyar?
21:56:39 <toshii> switching over (of maintainers or code) is better done earlier, so that I can help
21:57:00 <toshii> mlavalle, yes
21:57:02 <mlavalle> toshii: ok, so you are available to help us
21:57:55 <mlavalle> toshii: we appreciate the early heads up. You are right. We better start thinking about this sooner rather than later :-)
21:58:37 <toshii> adopting ryu was multi-year effort so it would be great ryu will continue to be used. but we will need to think on maintenance cost
21:59:05 <mlavalle> yeah, I hear you
21:59:17 <mlavalle> ok, we arn out of time
21:59:25 <mlavalle> Thanks for showing up
21:59:34 <mlavalle> #endmeeting