14:00:00 <jlibosva> #startmeeting networking
14:00:01 <openstack> Meeting started Tue Mar 28 14:00:00 2017 UTC and is due to finish in 60 minutes.  The chair is jlibosva. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:02 <dasm> o/
14:00:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:04 <openstack> The meeting name has been set to 'networking'
14:00:10 <jlibosva> Hello everybody
14:00:15 <john-davidge> hi
14:00:20 <rossella_s> hi
14:00:32 <boden> howdy
14:00:33 <electrocucaracha> o/
14:00:38 <jlibosva> #topic Announcements
14:00:46 <dalvarez> o/
14:01:01 <dasm> 14:00:00         jlibosva | #startmeeting networking
14:01:06 <dasm> jlibosva: i envy your punctuality :)
14:01:10 <jlibosva> I don't remember this being announced anywhere - so native ovsdb interface has been pulled from Neutron and has its own repo now
14:01:16 <hichihara> hi
14:01:23 <jlibosva> dasm: :D I actually see it 59:59 :)
14:01:23 <boden> yay
14:01:30 <jlibosva> #link http://git.openstack.org/cgit/openstack/ovsdbapp
14:01:44 <reedip> o/
14:01:46 <jlibosva> Neutron still uses in-tree code for interface but there is already a WIP: https://review.openstack.org/#/c/438087/
14:01:48 <haleyb> hi
14:02:09 <annp_> hi
14:02:09 <ihrachys> jlibosva: what was the plan? do we switch right away or let it bake?
14:02:43 <bcafarel> hi
14:02:47 <jlibosva> ihrachys: I think the plan is to switch during pike, maybe pike-1. Don't remember. I should be able to find it in PTG summaries
14:03:06 <ihrachys> pike1 would be great, though it's around the corner
14:03:12 <jlibosva> 3 weeks?
14:03:28 <ihrachys> yeah, around that time.
14:03:31 <dasm> Apr 10 - Apr 14 == Pike1
14:03:47 <ihrachys> so 2 weeks
14:03:57 <hichihara> This is neutron stadium, right?
14:04:02 <jlibosva> I think it would make sense to switch early as currently we need to maintain 'almost' same thing in two places
14:04:02 <ihrachys> otherwiseguy: are there obstacles to get the patch not WIP?
14:04:05 <dasm> hichihara: yes, it is
14:04:07 <jlibosva> hichihara: yes
14:04:22 <jlibosva> ihrachys: I don't think he's online :)
14:04:23 <andreas_s> hi
14:04:23 <hichihara> I see
14:04:56 <ihrachys> ok nevermind
14:04:57 <jlibosva> #action jlibosva to sync with otherwiseguy on the plan of ovsdbapp switch
14:05:43 <jlibosva> This has been announced last week but for those who missed it: post mortem Ocata got merged: https://review.openstack.org/#/c/425990/
14:06:25 <jlibosva> Boston summit Forum sessions should be announced on April 10, deadline for proposals is April 2.
14:07:01 <jlibosva> Anything else to announce?
14:07:03 <ihrachys> what's the fate of Monday meeting? I saw revert from armax: https://review.openstack.org/#/c/448886/ but it never got merged.
14:07:40 <jlibosva> ihrachys: IIRC last week it was agreed to move monday
14:07:54 <dasm> ihrachys: http://lists.openstack.org/pipermail/openstack-dev/2017-March/114527.html
14:08:01 <dasm> > Proposed revert in [1] to give time and opportunity to comment on whether
14:08:02 <dasm> the new time works for the majority of folks.
14:08:20 <dasm> but i didn't see any follow-up to this
14:08:22 <ihrachys> jlibosva: and then armax said it was not properly discussed and proposed revert
14:08:38 <ihrachys> that's a bit of a mess :)
14:10:32 <jlibosva> so maybe the revert patch would be the best place to discuss
14:10:40 <jlibosva> as I think lot of ppl who attend monday are not here
14:10:52 <john-davidge> the new earlier times are definitely better for me personally
14:11:07 <jlibosva> I can't attend neither so I deffer :)
14:11:10 <john-davidge> will look out for objections from others
14:11:41 <hichihara> maybe new time will affect East-Asia ;)
14:12:01 <ihrachys> I don't think we will resolve it here, just wanted folks to be aware
14:12:19 <jlibosva> good
14:12:27 <hichihara> I agree
14:12:37 <jlibosva> if there is nothing else to announce we shall move on
14:12:45 <jlibosva> #topic Blueprints
14:12:50 <jlibosva> #link https://launchpad.net/neutron/+milestone/pike-1
14:12:51 <reedip> it does :)
14:13:07 <jlibosva> So as mentioned, we're 2 weeks from p1
14:14:17 <jlibosva> Does anybody has anything to raise here regarding to work on a blueprint?
14:14:23 <jlibosva> any blockers or anything?
14:15:41 <jlibosva> seems everything goes smooth then
14:15:46 <john-davidge> Any movement on approval of https://bugs.launchpad.net/neutron/+bug/1667329 ?
14:15:46 <openstack> Launchpad bug 1667329 in neutron "[RFE] Floating IP Subnets on Routed Provider Networks" [Undecided,Triaged]
14:15:53 <john-davidge> I was away last week
14:16:18 <ihrachys> john-davidge: that's a question to drivers team, but as you can see, there is nothing in LP, which means there was no discussion
14:16:30 <ihrachys> the prev drivers meeting was cancelled I believe because of the meeting shift mess
14:16:55 <jlibosva> and I can't find it mentioned in drivers meeting logs
14:17:02 <john-davidge> ihrachys: Ok, hopefully the new drivers meeting time will stick so I can finally attend :)
14:17:18 <ihrachys> people are advised to comment in the bug if they have thoughts, and ofc join the next drivers meeting.
14:18:20 <jlibosva> maybe there could be a section in driver's meeting wiki to put a note/question when someone can't attend the meeting due to TZ
14:18:50 <reedip> jlibosva : +1
14:19:23 <ihrachys> LP is the place where we track all info related to RFE bugs
14:20:25 <jlibosva> ihrachys: so if someone writes "Any news?" to LP, it'll get attention?
14:21:19 <ihrachys> no, RFEs get attention in order
14:21:49 <ihrachys> ofc you can vouch for special attention for specific bug, but that will need some personal communication :)
14:23:24 <jlibosva> alright
14:23:27 <jlibosva> let's move on
14:23:34 <jlibosva> #topic Bugs and gate failures
14:24:01 <ihrachys> I was the deputy this week
14:24:02 <jlibosva> I see a spike in all jobs that happened yesterday. Given that it's in all jobs I assume some infra issue. I haven't seen any email nor bug report though.
14:24:22 <jlibosva> ok, let's do the deputy first
14:24:32 <ihrachys> ok
14:24:48 <ihrachys> nothing major happened, business as usual
14:25:01 <ihrachys> I marked some bugs as needs-attention where I saw fit
14:25:12 <ihrachys> also cleaned up old needs-attention tagged bugs
14:25:18 <ihrachys> the resulting list is https://bugs.launchpad.net/neutron/+bugs?field.tag=needs-attention
14:26:02 <ihrachys> most of those still probably need some discussion, f.e. in https://bugs.launchpad.net/neutron/+bug/1585907 it's not clear the intended behaviour of availability API
14:26:02 <openstack> Launchpad bug 1585907 in neutron "'used_ips' field of 'net-ip-availability-list' command increased by 1 when subnet added into router,In fact, Before subnet added into the router ,'total_ips' of network does not contain 'gateway_ip'." [Medium,In progress] - Assigned to QunyingRan (ran-qunying)
14:26:27 <ihrachys> others, like https://bugs.launchpad.net/neutron/+bug/1674889, affect other projects (this one is OVN) and will probably need champions from those communities
14:26:28 <openstack> Launchpad bug 1674889 in neutron "Fix get_schema_helper bug in some case" [Undecided,Incomplete] - Assigned to Dong Jun (dongj)
14:26:51 <ihrachys> I don't think there is a huge reason to go through each of them; instead I will ask folks to eyeball the list and contribute to discussions where due
14:27:21 <ihrachys> <EOM>
14:28:34 <jlibosva> ihrachys: good, thanks for report
14:29:33 <jlibosva> as per gate failure I mentioned earlier - does anybody have any information of what happened? was that an infra issue?
14:29:48 <jlibosva> the curve went down, so we're good by now
14:30:07 <ihrachys> no idea, I probably missed it while sleeping ;)
14:30:33 <jlibosva> :)
14:30:54 <jlibosva> alright, we have a special price here which is a bug deputy role for this week
14:30:59 <jlibosva> any volunteers?
14:31:54 <haleyb> i can volunteer, haven't done it for a bit
14:32:11 <ihrachys> \o/ \o/ go go haleyb go go \o/ \o/
14:32:23 <jlibosva> haleyb: yay! thanks
14:32:42 <jlibosva> haleyb: now I feel like my car-selling skills improved too :)
14:32:59 <jlibosva> #info haleyb is a bug deputy for week of Mar 27
14:33:01 <haleyb> i'll buy the car too :)
14:33:18 <ihrachys> jlibosva: see? he hasn't even asked the price
14:33:20 <amotoki> I can be bug dupty next week
14:33:22 <reedip> congrats on the new car haleyb
14:33:23 <reedip> :)
14:33:27 <jlibosva> ihrachys: the price was the role
14:33:38 * haleyb assumes it's an older ferarri
14:33:39 <jlibosva> amotoki: thanks!
14:33:48 <john-davidge> haleyb: Congrats! Now follow me to the finance department...
14:33:54 <dalvarez> lol
14:34:01 <jlibosva> #info amotoki is a bug deputy for a week of Apr 3
14:34:08 <ihrachys> that was gold john-davidge
14:34:47 <john-davidge> ihrachys: So are our interest rates! 1lb of gold per day.
14:36:04 <jlibosva> if there is nothing else to discuss beside haleyb
14:36:08 <jlibosva> 's car
14:36:11 <jlibosva> we can jump to docs
14:36:14 <jlibosva> #topic Docs
14:36:19 <jlibosva> john-davidge: yo
14:36:31 <john-davidge> jlibosva: yo yo
14:36:50 <john-davidge> jlibosva: Nothing significant from me actually, just returned from a week of PTO
14:37:03 <jlibosva> oh, so I hope you had a good time :)
14:37:13 <john-davidge> jlibosva: I notice lots of OSC conversion patches for review thought, so thanks all for those
14:37:27 <john-davidge> jlibosva: Thank you, I did :)
14:37:40 <jlibosva> john-davidge: so we can move on, right?
14:37:51 <john-davidge> jlibosva: Yes, go ahead
14:37:53 <jlibosva> #topic Transition to OSC
14:37:57 <jlibosva> amotoki: hi, do you have anything?
14:38:28 <amotoki> nothing to report. the progress is steady
14:38:43 <jlibosva> amotoki: cool, thanks
14:38:46 <jlibosva> that's fast today :D
14:38:52 <jlibosva> #topic Neutron-lib
14:39:06 <jlibosva> boden: hi :)
14:39:14 <boden> hi
14:39:25 <jlibosva> boden: any updates to neutron-lib
14:39:27 <jlibosva> ?
14:40:14 <boden> we are still working through the rehoming patches for neutron core API resources and api attributes that I mentioned last week
14:40:31 <boden> hopefully we can have those in better shape by next week
14:40:33 <ihrachys> boden: do we plan a release in next days? because I really want one to move forward with https://review.openstack.org/#/c/448671/ and https://review.openstack.org/#/c/446730/ (that will allow to kill translation markers in trees)
14:40:57 <ihrachys> I need a release with 1st included (it's already merged) to proceed with cleanup
14:41:21 <ihrachys> and then we will be able to land the 2nd and fix periodic jobs and finally release another one with no-log-translation enforced
14:41:53 <boden> ihrachys: it’ll be more than a few days for the patches I mentioned I think, but I don’t have any objections to a release in the meatime
14:42:16 <boden> obviously we need to make sure the periodic jobs are green, etc..
14:42:21 <ihrachys> sure
14:42:39 <ihrachys> dasm: could you follow up on it? or should I post request myself?
14:42:55 <dasm> ihrachys: i'll prepare a release
14:42:59 <ihrachys> tnx!
14:43:23 <boden> also
14:43:36 <boden> there are a few patches in neutron that consume lib updates that could use review
14:43:40 <dasm> boden: ihrachys fyi, currently there are 3 jobs failing. i'll look into that and will report back to you
14:43:47 <jlibosva> boden: do you have links handy?
14:43:49 <boden> dasm: ack
14:44:01 <boden> #link https://review.openstack.org/#/q/status:open+message:%22NeutronLibImpact%22+project:openstack/neutron
14:44:35 <jlibosva> boden: thanks!
14:44:36 <boden> the patches to use portbindings and providernet API defs from lib have been out there for awhile
14:44:43 <boden> please have a looksee if you get a few min :)
14:44:49 <ihrachys> will do
14:45:04 <hichihara> boden: Why do some patches have branch name "bp/neutron-lib-networking-ovn"?
14:45:20 <boden> hichihara: technically they are part of that effort
14:45:29 <boden> rehoming dependencies ovn has on neutron
14:45:51 <hichihara> boden: I got it
14:45:58 <boden> I was trying to track the related patches in the BP, but if that’s just confusing it doesn’t matter to me
14:46:37 <boden> If it gets confusing using that topic, just let me know and I’ll stop
14:46:57 <jlibosva> boden: thanks for updates, I hope more cores will jump on the api-def patches
14:47:00 <boden> I don’t have much else to add, unless others do
14:47:05 <jlibosva> anything else neutron-lib related?
14:47:07 <jlibosva> ok
14:47:14 <mlavalle> boden: the topic is useful. keep it up
14:47:18 <jlibosva> let's move on
14:47:21 <jlibosva> #Disable IPv6 forwarding on backup HA routers
14:47:30 <jlibosva> the stage is yours dalvarez :)
14:47:38 <dalvarez> jlibosva, thanks!
14:47:40 <hichihara> boden: Don't mind my question
14:47:48 <dasm> jlibosva: topic change?
14:47:51 <ihrachys> jlibosva: topic missing
14:47:54 <jlibosva> whoops
14:47:57 <jlibosva> dasm: ihrachys thanks :)
14:48:00 <jlibosva> #topic Disable IPv6 forwarding on backup HA routers
14:48:19 <dalvarez> https://review.openstack.org/#/c/442518/
14:48:29 <jlibosva> #link https://review.openstack.org/#/c/442518/
14:48:38 <ihrachys> is it just a request for review?
14:48:52 <dalvarez> i wanted to bring this up in order to move the patch forward
14:49:24 <ihrachys> oh ok. you could probably just ping some of us in irc and get the same. :)
14:49:40 <haleyb> dalvarez: do you want to mention the issue you saw yesterday wrt /proc entry, etc
14:49:41 <jlibosva> should we aim the bug to p1 then?
14:49:44 <dalvarez> oh i was about to elaborate a bit further, but essentialy
14:50:01 <dalvarez> what I want to bring up is that if we go ahead with this bug we'll make us dependent on the l3 agent for IPv6 failover
14:50:25 <dalvarez> haleyb, i actually found out that this is a bug on 3.10 kernels so procfs entry should still be there
14:50:59 <dalvarez> ihrachys, yeah thanks i have done it but it doesn't seem to get traction... I just wanted to know what you guys think about making us dependent on the l3-agent running for Ipv6 failover
14:51:22 <ihrachys> dalvarez: oh you mean that data plane correctness will depend on l3 agent disabling forwarding on failover?
14:51:30 <dalvarez> ihrachys, that's it
14:51:48 <dalvarez> ihrachys, and actually re-enabling it when an instance transitions from backup to master
14:53:09 <ihrachys> we already have some bits in the agent that work in sync with keepalived
14:53:09 <ihrachys> f.e. we send gARPs for it
14:53:29 <dalvarez> but the thing is that I can't think of any other solutions since, right now, ipv6 forwarding is enabled by default on namespaces and that makes it joining different multicast groups and thus responding to queries coming from the outside
14:53:36 <ihrachys> here https://github.com/openstack/neutron/blob/master/neutron/agent/l3/keepalived_state_change.py#L87
14:53:56 <ihrachys> it would be either keepalived doing it, or smth on top
14:54:11 <ihrachys> if keepalived doesn't, I don't see an alternative
14:54:15 <dalvarez> ihrachys, ack so you think it's not a big issue to depend on l3 agent running, right?
14:54:18 <dalvarez> ack
14:54:28 <haleyb> i think it's the kernel joining the mcast groups, right?
14:54:45 <dalvarez> haleyb, correct. that happens automatically when ipv6 forwarding is enabled
14:54:53 <dalvarez> and those are left when disabled
14:54:58 <ihrachys> dalvarez: I don't see a big difference architecturally between l3 agent doing it or a daemon under its control
14:55:22 <dalvarez> ihrachys, the daemon is monitorized by the agent
14:55:29 <ihrachys> the only issue I see is additional complexity in the agent, and the fact that it may not react to failover as quick as keepalived could
14:56:05 <ihrachys> but that sounds like keepalived bug/missing feature we try to work around
14:56:16 <ihrachys> which is not news for the implementation :) [see the garp]
14:56:16 <haleyb> dalvarez: keepalived is moving the LLA, right?
14:56:23 <dalvarez> haleyb, it is
14:56:42 <haleyb> then maybe when it moves, forwarding moves?
14:56:55 <dalvarez> ihrachys, yes... i think the reaction time is not a big deal here since those changes shouldn't occur too often and the only drawback may be disrupting the traffic until l3 agent reacts
14:57:05 <haleyb> btw, if we run out of time can move to other channel, or continue in L3 meeting thursday
14:57:09 <dalvarez> haleyb, that's something that keepalived doesn't do I guess
14:57:26 <dalvarez> haleyb, yes!
14:57:31 <dalvarez> ihrachys, haleyb thanks a lot guys :)
14:57:41 <jlibosva> good
14:57:43 <dalvarez> i think we're good to go if we aim for p1 with this bug
14:57:47 <jlibosva> we're almost out of time
14:57:59 <jlibosva> is there any other quick thing to discuss?
14:58:06 <jlibosva> or we could get 2 minutes back
14:58:08 <ihrachys> just a shout out for jlibosva chairing those meetings for us. kudos!
14:58:14 <dalvarez> \o/
14:58:16 <jlibosva> lol
14:58:30 <dalvarez> jlibosva, brought some beers?
14:58:32 <jlibosva> ihrachys: and you're always here anyway :D
14:58:36 <jlibosva> which is good!
14:58:48 <ihrachys> that was part of the plan of deceit
14:58:56 <mlavalle> jlibosva: yeah, thanks for chairing this meeting
14:58:56 <jlibosva> :)
14:59:09 <jlibosva> ok, thanks all for showing up
14:59:15 <jlibosva> #endmeeting