21:00:11 <armax> #startmeeting networking
21:00:13 <openstack> Meeting started Mon Nov 28 21:00:11 2016 UTC and is due to finish in 60 minutes.  The chair is armax. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:16 <openstack> The meeting name has been set to 'networking'
21:00:20 <armax> haleyb: thanks, appreciate it
21:00:22 <mlavalle> o/
21:00:30 <hichihara> o/
21:00:35 <njohnston> o/
21:01:06 <HenryG> o/
21:01:09 <kevinbenton> \o
21:01:16 <armax> hello everyone
21:01:49 <dasanind_> hi
21:01:51 <armax> let’s dive in
21:01:59 <armax> #topic Announcements
21:02:09 <armax> I have a couple of things newsworthy
21:02:47 <armax> #link there’s a thread started on the ML about including vendor-specific driver code into the big tent
21:02:51 <armax> #undo
21:02:52 <openstack> Removing item from minutes: <ircmeeting.items.Link object at 0x7fbb93dcd110>
21:02:59 <armax> #link http://lists.openstack.org/pipermail/openstack-dev/2016-November/108074.html
21:03:43 <armax> if you work for an employer that has such repos, I’d suggest you stay plugged in the conversations
21:03:50 <armax> that are gonna spur from that thread
21:04:15 <Sukhdev> armax : thank for sharing - I had missed that
21:04:19 <armax> otherwise you might wake up one day and find out that the world around you has changed
21:04:36 <armax> Sukhdev: it’s fresh, I am sure you would have caught up to it
21:04:38 <dasm> o/
21:05:33 <armax> another announcement I wanted to make is related to core team attrition
21:05:54 <armax> most of you might have noticed by now that we’ve had a number of folks stepping down
21:05:58 <dasm> :(
21:06:07 <hichihara> ;(
21:06:08 <armax> carl_baldwin, HenryG and amuller most recently
21:06:20 <electrocucaracha> :(
21:06:35 <HenryG> don't forget dougwig
21:06:49 <armax> HenryG: he’s still core
21:07:00 <armax> he’s stepped down from the drivers team
21:07:07 <armax> at least that’s what I have heard :)
21:07:10 <armax> anyhoo
21:07:24 <armax> dougwig too has taken somewhat of a backseat
21:07:33 <sc68cal> last one out turn off the lights
21:07:34 <armax> I have invited these folks to advise me and the team to identify whom have worked closely with them and that they feel they can step in and replace them
21:07:53 <dougwig> o/
21:08:40 <armax> ultimately nominating people’s replacements is something that has to find the nominee agreeing in taking on more responsibility
21:09:05 <armax> in the core of neutron
21:09:25 <armax> and neutron-lib as well
21:10:00 <armax> while this gets figured out, if you are an existing core, please try to make up for the loss of review bandwidth if you can
21:10:50 <hichihara> :)
21:10:53 <armax> please don’t forget the current backlog
21:11:22 <armax> and the dashboard that should help us keep a focussed review attention
21:11:23 <armax> #link http://status.openstack.org/reviews/
21:11:25 <armax> top link
21:11:38 <kevinbenton> i think we have several people ready to be cores soon so it's not the end of the world yet :)
21:12:01 <Sukhdev> If somebody helps coach me, I could help out
21:12:23 <armax> kevinbenton: I never thought we had reached the end of the world
21:12:29 <armax> kevinbenton: even when the US elections were over
21:12:36 <armax> but I digres
21:12:37 <armax> s
21:12:39 <kevinbenton> armax: based on how you always talk i assume you think it's the end of the world :P
21:12:52 <Sukhdev> :-)
21:13:29 <armax> kevinbenton: ok
21:13:47 <armax> kevinbenton: don’t quite know how to understand your comment
21:14:11 <armax> let’s move on, unless someone has any other announcement he/she will like to make
21:14:22 <Sukhdev> armax : he is being sarcastic - just ignore him :-)
21:14:26 <mlavalle> Remind the team about the PTG
21:14:34 <mlavalle> #link https://www.openstack.org/ptg/
21:14:49 <mlavalle> Registration is open
21:15:02 <Sukhdev> I heard it is limited to 500 people only
21:15:03 <armax> mlavalle: thanks
21:15:03 <kevinbenton> can that thing sell out?
21:15:06 <kevinbenton> :/
21:15:11 <kevinbenton> well that's annoying
21:15:22 <dasm> kevinbenton: good question. do we have any limits, time cap?
21:15:37 <dasm> ok, see 500 people.
21:15:48 <Sukhdev> I was told in another meeting that 500 was the limit
21:16:03 <Sukhdev> in fact, when you register, it tells you how many seats are left
21:16:13 <armax> 348 now
21:16:14 <johnsom> There are still ~348 seats open per the above page
21:16:17 <dasm> armax: thanks
21:16:24 <dasm> johnsom: thx
21:16:32 <armax> it’s also no longer free for ATCs
21:16:49 <Sukhdev> that kinda sucks :-0
21:16:49 <armax> though the fee is modest and set to $100
21:17:05 <electrocucaracha> but you can transfer your registration right?
21:17:28 <Sukhdev> electrocucaracha : yes, and it is refundable
21:18:04 <mlavalle> Sukhdev: that's good news
21:18:34 <Sukhdev> mlavalle : I only deliver good news - bad news comes from armax :):-)
21:18:43 <armax> ok, anything else to remind?
21:18:56 <armax> if this negativity keeps getting at me, I am gonna have to step down too
21:18:57 <armax> :)
21:19:06 <armax> I am clearly the bad mojo to the project
21:19:28 <Sukhdev> armax : I was kidding - sorry :-)
21:19:34 <mlavalle> armax: you are clearly not :-)
21:19:38 <armax> Sukhdev: no offence taken
21:19:44 <Sukhdev> armax : you are the force, sir!!!
21:19:45 <armax> #topic blueprints
21:19:58 <armax> Sukhdev: here’s one more
21:20:19 <armax> we have laguished as far as completing blueprints and reviewing RFEs
21:20:32 <armax> we are in Ocata 2, with 3 weeks to Christmas
21:20:47 <armax> don’t forget that FF is a month earlier this cycle
21:21:20 <armax> at the pace we are going we might as well close 0 blueprints this cycle
21:21:42 <armax> #link https://launchpad.net/neutron/+milestone/ocata-2
21:22:19 <armax> if you are an assignee and/or an approver of any of the targeted blueprint/rfe please be proactive and help identify any blocker
21:22:25 <kevinbenton> armax: people have been working on things...
21:22:31 <kevinbenton> armax: i'm sure we'll get something
21:22:41 <armax> in case the person you’re supposed to work with is either moved on or swamped
21:23:12 <boden> armax: https://review.openstack.org/#/c/308973/ I think amuller was supposed to help drive this… I beleive you recently said he was moving away from neutron
21:23:14 <armax> kevinbenton: I am gonna have to set a gloomy picture on everything I say, otherwise how am I gonna get a bad reputation?
21:23:30 <armax> boden: correct, I asked amuller to reach out to you
21:23:35 <armax> boden: has he done that/
21:23:36 <armax> ?
21:23:42 <boden> armax: not that I know of
21:23:55 <armax> ok, today it’s just Monday after a binge weekend
21:24:36 <armax> I’d suggest to reach out to him instead, but he’s the approver for that blueprint and I hope he’ll help identify the fate of that effort
21:24:47 <boden> armax: ack
21:26:22 <armax> as far as the OVO/no API downtime effort, I see no patches being flagged on the team meeting page
21:26:31 <armax> anyone has anything to share?
21:26:42 <armax> #topic OVO/no API downtime?
21:26:59 <mlavalle> maybe electrocucaracha can provide status?
21:27:30 <electrocucaracha> haha maybe, thanks mlavalle
21:28:08 <electrocucaracha> we have some progress on OVO classes that don't have too much dependencies
21:28:36 <armax> electrocucaracha: you have links to patches that are close to landing?
21:28:37 <electrocucaracha> jschwarz is working on grenade jobs
21:28:56 <electrocucaracha> armax: I have an updated spreadsheet
21:29:15 <electrocucaracha> #link https://docs.google.com/spreadsheets/d/1FeeQlQITsZSj_wpOXiLbS36dirb_arX0XEWBdFVPMB8/edit#gid=1434170112
21:29:17 <armax> electrocucaracha: thanks
21:30:35 <armax> electrocucaracha: one thing that would be nice is to provide a filter so that patches can be sorted in term of ‘readiness’
21:30:36 <electrocucaracha> Ihar has made special emphasis on taking a look of the plan https://review.openstack.org/#/c/386685/
21:31:12 <electrocucaracha> armax: I can include something there
21:31:33 <armax> electrocucaracha: if nothing else, to identify more easily what to review first, if it makes sense
21:32:52 <armax> ok, if there’s nothing else, let’s move to the next item in the agenda
21:33:05 <armax> #topic Bugs and Gate issues
21:33:40 <armax> don’t forget of the looming switch to xenial as default node for newton+
21:34:21 <armax> so please think about the CI jobs for the repos you fancy
21:34:26 <armax> and help out with the switch
21:34:43 <armax> in neutron/neutron-lib we have nearly completed the switch
21:35:02 <armax> there are a few CI jobs that needs switching for the python-neutronclient repo
21:36:02 <johnsom> I am working on LBaaS, FYI
21:36:22 <njohnston> I'll take a look for FWaaS
21:36:25 <kevinbenton> how are we doing with the gate failure rates?
21:36:59 <armax> kevinbenton: http://grafana.openstack.org/dashboard/db/neutron-failure-rate
21:37:16 <armax> kevinbenton: things may be skewed by the fact that we had a not so busy time recently
21:37:57 <kevinbenton> armax: ack
21:38:57 <armax> my gut tells me that something has caused a recent spikes in failures for grenade and multinode jobs
21:39:14 <armax> but it’s on speculations at this point, I have no hard data to back my claim up
21:39:37 <armax> we have a deputy of this week, we’d need a deputy for next week
21:39:45 <armax> starting Monday 5th
21:39:49 <armax> any takers?
21:40:16 <mlavalle> I can do it next week
21:40:18 <haleyb> i can volunteer
21:40:21 <haleyb> doh
21:40:24 <armax> mlavalle: goes first
21:40:31 <armax> haleyb: you ok with Dec 12?
21:40:55 <mlavalle> haleyb: I can switch if that fits you
21:41:09 <haleyb> armax: should be fine, just out starting 16th
21:41:29 <mlavalle> ok
21:41:30 <armax> k
21:41:45 <armax> #action mlavalle and haleyb deputies for the weeks of 12/05 and 12/12
21:41:54 <armax> thanks guys
21:42:17 <kevinbenton> there weren't any showstopper bugs last week
21:42:18 <armax> next topic
21:42:36 <armax> they were eating turkey too I guess
21:42:47 <mlavalle> and stuffing
21:42:49 <armax> #topic Docs
21:43:09 <armax> I believe newton branch has been cut for docs
21:43:26 <armax> not sure how and if any docs changes in flight can be backported
21:43:34 <armax> it’d be good to find out
21:44:23 <armax> looks like tehre’s nothing pressing to talk about docs
21:44:25 <armax> moving on
21:44:39 <armax> #topic OSC transition
21:45:04 <armax> amotoki has not been around lately and he was the one particularly active on neutronclient
21:45:13 <armax> helping with reviews etc
21:45:35 <armax> anyone has spare cycles to help out on this front?
21:46:12 <armax> o.k.
21:46:12 <kevinbenton> reviews or code?
21:46:17 <armax> kevinbenton: reviews
21:46:24 <kevinbenton> i can do some reviews
21:46:28 <kevinbenton> is there a topic to look for?
21:46:40 <armax> not that I know of
21:46:51 <armax> but there’s a blueprint
21:47:01 <armax> and if that’s referenced in the patches, you should look for
21:47:04 <electrocucaracha> afaik they have a etherpad for that
21:47:13 <armax> sorry
21:47:18 <armax> I mean bug 1521291
21:47:18 <openstack> bug 1521291 in neutron "[RFE] Transition neutron CLI from python-neutronclient to python-openstackclient" [Wishlist,Triaged] https://launchpad.net/bugs/1521291 - Assigned to Akihiro Motoki (amotoki)
21:47:27 <mlavalle> armax: I will also take a look
21:47:37 <hichihara> I can help too.
21:48:11 <armax> bear in mind that python-neutronclient CLI development is froken from now on
21:48:44 <dasm> freaken?
21:48:46 <dasm> freakin?
21:48:48 <dasm> or frozen?
21:48:49 <armax> frozen
21:49:14 <armax> so patches/bugs etc should target either the API client or existing CLI functionality or a translation to OSC CLIs commands
21:49:27 <dasanind_> armax: etherpads for osc https://etherpad.openstack.org/p/osc-neutron-support  https://etherpad.openstack.org/p/osc-network-command-sdk-support
21:49:35 <armax> dasanind_: thanks!
21:50:16 <armax> ok, moving on
21:50:24 <armax> #topic Neutron-lib and planned neutron refactoring
21:51:05 <armax> boden has a change out that is documenting how the development workflow for neutron-lib takes place
21:51:51 <boden> it landed already.. #link https://github.com/openstack/neutron-lib/blob/master/doc/source/contributing.rst
21:52:04 <armax> one of the things highlighted in that document is the introduction of a tag ‘NeutronLibImpact’ we’re gonna be using to capture any patch in flight that may have an effect on neutron and its repos
21:52:06 <armax> boden: thanks
21:52:27 <armax> so it’s easy to have a view of what’s about to land
21:52:30 <armax> #link https://review.openstack.org/#/q/status:open+message:%22NeutronLibImpact%22
21:52:33 <armax> or landed
21:52:42 <armax> #link https://review.openstack.org/#/q/status:merged+message:%22NeutronLibImpact%22
21:53:04 <armax> we need to be particularly careful at landing code in an orderly fashion
21:53:21 <armax> because if we land two breaking changes at once we end up causing a jam in our gates
21:54:25 <armax> last week I reverted https://review.openstack.org/#/c/402155/
21:54:42 <armax> well
21:55:07 <kevinbenton> hopefully it gets better the more we rip out
21:55:08 <armax> I issued revert https://review.openstack.org/#/c/401377/
21:55:18 <armax> to unjam the situatiion
21:55:33 <armax> and since that landed I am hoping we can reland 402155
21:56:06 <armax> kevinbenton: yes, I think there’s gonna be some interim pain for long term gain
21:56:46 <armax> HenryG: what do you rather land this week?
21:57:02 <armax> from least impactful to most impactful?
21:57:21 <armax> PLURALS eviction ‘seem’s the least impactful
21:58:43 <armax> btw
21:58:45 <armax> we’re 2 minutes to the top of the hour, we’ll have to skip the open discussion section
21:59:16 <mlavalle> armax: haleyb and I are switching our bug deputies weeks
21:59:22 <armax> mlavalle: ok
21:59:49 <electrocucaracha> well, I was just think about the impact of OSC transition on documentation, e. g. http://docs.openstack.org/newton/networking-guide
21:59:57 <armax> as for the libimpact changes, my suggestion would be to go slow for now and try to space out the merging on changes that may have an impact
22:00:19 <armax> to ensure we don’t have too much on our plate at any given time
22:00:25 <armax> gotta free up the slot
22:00:28 <armax> #endmeeting