21:02:18 <armax> #startmeeting networking
21:02:19 <openstack> Meeting started Mon Oct  3 21:02:18 2016 UTC and is due to finish in 60 minutes.  The chair is armax. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:02:22 <openstack> The meeting name has been set to 'networking'
21:02:24 <njohnston> o/
21:02:37 <armax> thanks for joining
21:02:47 <pc_m> o/
21:02:57 <blogan> o/
21:03:00 <armax> as usual
21:03:02 <armax> #link https://wiki.openstack.org/wiki/Network/Meetings
21:03:21 <armax> let’s go over the announcements of the week
21:03:24 <alraddarla> o/
21:03:26 <armax> #topic Announcements
21:03:53 <armax> this week we will release Newton
21:03:55 <armax> #link http://lists.openstack.org/pipermail/openstack-dev/2016-September/104809.html
21:04:20 <armax> we have release an RC3 build last week
21:04:46 <armax> and it is to be considered *the* Newton release unless something catastrophic happens
21:05:31 <Sukhdev> o/
21:05:43 <armax> at this point every bug report/fix should be targeted for O-1
21:05:49 <armax> and backported in due course
21:05:55 <armax> we will have a patch release for Newton soonish
21:06:11 <armax> do you have release questions  so far?
21:07:05 <armax> as you might have heard, Ihar is stepping down from release liaison
21:07:16 <armax> by default the role falls back to the PTL
21:07:26 <armax> if you are interested please, reach out to your PTL
21:08:13 <Sukhdev> armax : are you considering going for PTL for another term?
21:08:31 <armax> Sukhdev: I am thinking about it
21:08:46 <armax> Sukhdev: :)
21:08:55 <armax> Sukhdev: are you talking about Ocata or Pike?
21:09:08 <dasm> Newton :P
21:09:10 <Sukhdev> thinking is a good thing to do, armax
21:09:37 <Sukhdev> armax : both :-)
21:10:18 <armax> Sukhdev: the good news is that Ocata PTL nomination/election time is long gone
21:10:35 <armax> Sukhdev: and that the Pike ones won’t be long upon us again
21:10:50 <armax> Sukhdev: the bad news is that you’re stuck with me for at least Ocata
21:11:05 <Sukhdev> I was on vacation for few weeks - look what vacation does to you :-)
21:11:15 <armax> :)
21:11:26 <Sukhdev> armax : ha ha - armax tells good jokes :-)
21:12:26 <armax> anyhow, if any of you is interested in stepping up their upstream duties by playing release God, please reach out
21:12:38 <armax> next announcement
21:12:49 <armax> the newton postmortem
21:12:50 <armax> #link https://review.openstack.org/#/c/360207/
21:13:07 <armax> is ready as far as I am concerned
21:13:25 <armax> thanks to everyone who has looked/reviewed/provided feedback
21:14:27 <carl_baldwin> ++ I like having it.
21:14:28 <armax> if you can spare a few more minutes, please go over it once more or if you haven’t at all, please do
21:15:24 <armax> last announcement but not least
21:15:29 <armax> #link http://lists.openstack.org/pipermail/openstack-dev/2016-September/104668.html
21:15:35 <armax> the summit is only a few weeks away
21:16:05 <armax> bear in mind that the Ocata cycle is rather shorter than the release cycle as we know it
21:16:16 <armax> #link https://releases.openstack.org/ocata/schedule.html
21:16:36 <armax> so we want to take that into consideration when planning for sessions
21:16:57 <armax> the danger of overcommitting this cycle is even greater so we may want to scale back on our ambitions
21:17:40 <armax> no more announcements from me, anything that I might have missed?
21:18:04 <Sukhdev> armax : can I make one?
21:18:20 <armax> Sukhdev: that’s what I am asking! Fire away
21:18:45 <Sukhdev> Just to let everybody know that Ironic support for neutron network was finally released
21:19:06 <Sukhdev> now BM and VM use the neutron networks in an identical fashion
21:19:13 <armax> Sukhdev: do you have anything official that we can read?
21:19:31 <armax> like release notes, docs, etc?
21:19:37 <Sukhdev> armax : lots of documentation - I will dig up and post
21:19:59 <armax> ok thanks
21:21:04 <armax> ok
21:21:07 <armax> moving on
21:21:22 <armax> we are now in full motion in Ocata
21:21:38 <Sukhdev> #link - https://specs.openstack.org/openstack/nova-specs/specs/mitaka/approved/ironic-networks-support.html
21:21:53 <armax> there is quite a backlog
21:21:55 <armax> #link https://launchpad.net/neutron/+milestone/ocata-1
21:22:27 <armax> between this week and the next, as well as at the summit we will polish up what we can realistically expect during the Ocata timeframe
21:22:52 <armax> #topic Bugs
21:23:15 <armax> #link http://grafana.openstack.org/dashboard/db/neutron-failure-rate
21:23:39 <armax> it looks like there was something infra related that broke our builds a few hours ago
21:23:48 <armax> but I missed the fun by the looks of it
21:23:51 <armax> does anyone know more?
21:24:24 <HenryG> There was an email thread about it
21:25:08 <dasm> HenryG: that one? http://lists.openstack.org/pipermail/openstack-dev/2016-October/104909.html
21:25:20 <HenryG> dasm: yes
21:25:35 <armax> that’s the one
21:25:43 <armax> thanks HenryG and dasm
21:25:47 <HenryG> But it's fixed now so let's move on
21:26:16 <armax> I wasn’t going to drag
21:26:17 <armax> :)
21:26:45 <armax> Neutron needs a bug deputy this week
21:26:56 <clarkb> multinode testing is completely broken in osic which provides most of our test capacity
21:26:56 <armax> anyone willing to volunteer?
21:27:10 <clarkb> neutron was recently removed from the bug but it would be great if neutron could work with the qa/devstack team to get that fixed soon
21:27:21 <clarkb> since the underlying issue is related to enabling subnet pools in neutron
21:27:21 <armax> clarkb: link?
21:27:35 <clarkb> https://bugs.launchpad.net/bugs/1629133
21:27:36 <openstack> Launchpad bug 1629133 in devstack "New neutron subnet pool support breaks multinode testing." [Critical,In progress] - Assigned to Dr. Jens Rosenboom (j-rosenboom-j)
21:27:58 <clarkb> there is some back and forth over how we should fix it. Would be good to get that decided and do it soon
21:28:17 <armax> clarkb: thanks for the pointer, I will look into it right after this meeting
21:28:22 <clarkb> tyty
21:28:29 <armax> clarkb: so you say it’s only multinode on OSIC?
21:28:47 <clarkb> right now yes beacuse the route for 10/8 only adversely affects networking on OSIC instances
21:29:00 <armax> clarkb: ack
21:29:11 <dougwig> armax: i can do bug deputy, but i'm traveling fri-sun.
21:29:12 <armax> clarkb: bear with me while I ramp up, I was off last week
21:29:29 <armax> dougwig: I take it nonetheless
21:29:40 <clarkb> amakarov: no problem. let me know if you have more questions. It is being worked but there are concerns over the size of networks in the fix and so on. I think we likely just need to have a direct dialog between neutron and qa to sort it out
21:29:42 <armax> #action dougwig deputy for the week of Oct 3
21:29:58 <armax> clarkb: understood
21:30:07 <clarkb> er sorry amakarov meant to ping armax
21:30:13 <armax> clarkb: I’ll ping you in the infra channel if I need more
21:31:38 <armax> next topic
21:31:41 <armax> #topic Docs
21:32:32 <armax> If you are listening/reading and you have worked on a feature/bug or anything worth documenting, please work with us to ensure that your work is properly represented in the appropriate documentation
21:33:03 <armax> the networking guide, the neutron devref, api-ref etc
21:33:33 <armax> this list is still huge
21:33:35 <armax> #link https://bugs.launchpad.net/neutron/+bugs?field.status%3Alist=NEW&field.status%3Alist=CONFIRMED&field.tag=doc
21:34:09 <armax> and yet it should be empty at this time of the year
21:34:35 <HenryG> Also please review https://review.openstack.org/372857
21:35:01 <armax> HenryG: ack
21:36:12 <hichihara> HenryG: Added it on my todo list :)
21:37:26 <armax> next topic
21:37:30 <armax> #topic OSC efforts
21:37:31 <carl_baldwin> HenryG: ack
21:37:48 <armax> amotoki: ping
21:40:02 <armax> it was a long shot, it’s kinda early for amotoki
21:40:12 <armax> #topic neutron-lib
21:40:18 <armax> HenryG, dougwig: ping
21:41:44 <armax> crickets
21:41:49 <dasm> netsplit?
21:42:17 <armax> possibly :)
21:42:22 <armax> oh well moving on
21:42:32 <armax> #topic Open Discussion
21:42:42 <armax> there’s a long list of topics
21:42:47 <armax> some are stale, some are new
21:43:30 <jschwarz> I would like to address the "Recompiling a Cirros fork at the gate" topic that was recently added
21:43:43 <HenryG> armax: sorry, got called on the phone
21:44:27 <armax> HenryG: too late, you lost your spot
21:44:36 <armax> jschwarz: I’ll go over the etherpad
21:44:46 <HenryG> armax: np, neutron-lib work has been on hiatus during the release weeks
21:45:12 <armax> jschwarz: asides how to get to a good build, have we resolved where to host the image?
21:45:29 <jschwarz> armax, not that I'm aware of yet
21:45:54 <jschwarz> armax, I heard there were talks of hosting it someplace in Infra and I think it's already being done someplace by some other project
21:46:08 <jschwarz> it's a matter of talking to the right people or finding the correct piece of code imo
21:46:16 <armax> jschwarz: the craziest place I could think of is hosting directly in the neutron repo
21:46:29 <HenryG> ewwww
21:46:35 <armax> but hosting binary files is kinda frowned upon
21:46:38 <jschwarz> armax, ajo_ was talking about an openstack/cirros repo
21:46:56 <armax> either way, it’s a technicality
21:47:21 <johnsom> We (Octavia) opted to not host a binary image, but provide a build script and build in in the gate.  It uses DIB.
21:47:27 <armax> HenryG: don’t get all judgemental, you never put binary artifacts under version control, ever?
21:47:41 <HenryG> never!
21:47:47 <armax> HenryG: I don’t believe you
21:47:53 <jschwarz> aye. I would like to avoid binding ourselves to something that is project dependent and instead put in a generic solution
21:48:15 <jschwarz> johnsom, do you happen to know how long it takes to build these on the gate at run time?
21:48:41 <johnsom> jschwarx 10-15 minutes, but we are also using the bloated Ubuntu cloud image
21:49:31 <jschwarz> In that case, surely there exists some place where infra can store their images and files internally without pulling the cirros from "the interwebz" every time
21:49:37 <armax> johnsom: thanks for the tip, it’s worth mentioning it on the etherpad
21:49:42 <armax> #link v
21:49:45 <armax> #undo
21:49:45 <jschwarz> 10-15 minutes addition per tempest job sounds like a lot
21:49:45 <openstack> Removing item from minutes: <ircmeeting.items.Link object at 0x7f66f5fc4e50>
21:49:47 <armax> #link https://etherpad.openstack.org/p/cirros-respin
21:50:11 <armax> jschwarz: right now it would only be the scenario jobs
21:50:24 <jschwarz> armax, agreed
21:50:26 <armax> which ran pretty fast so it might not be the end of the word to start with
21:51:00 <jschwarz> then I'll dig into the Octavia code and see if we can make something generic out of it for the first few builds
21:51:22 <armax> jschwarz: anyhoo this is something worth brainstorming over at the summit
21:51:52 <armax> as far as the other bullet point ‘Distributed gateway for optimized local SNAT’
21:51:58 <jschwarz> armax, a fishbowl session or a friday sitdown?
21:52:07 <armax> jschwarz: we’ll work that out
21:52:12 <armax> the schedule is still WIP
21:52:13 <jschwarz> sounds good to me
21:52:22 <jschwarz> thanks for entertaining me :)
21:52:28 <armax> someone complained about blueprints being marked obsolete
21:52:30 <armax> jschwarz: no worries
21:52:35 <armax> tjat
21:53:02 <armax> whoever files blueprints without following the RFE process will see their blueprint marked obsolete
21:53:41 <armax> #link https://launchpad.net/neutron clearly states
21:53:47 <armax> For submitting blueprints/RFE and defect reports please follow instructions at: http://docs.openstack.org/developer/neutron/policies/blueprints.html
21:55:08 <Sukhdev> I mentioned during announcements that Ironic-Neutron integration work has been released - please see documentation here (earlier document was not correct) -
21:55:15 <Sukhdev> #link: https://specs.openstack.org/openstack/ironic-specs/specs/not-implemented/ironic-ml2-integration.html
21:55:35 <armax> thanks Sukhdev
21:55:52 <armax> the other topics on the agenda will probably need to be crunched offline
21:56:19 <armax> let’s take 5 minutes back
21:56:21 <armax> #endmeeting