21:00:48 <armax> #startmeeting networking
21:00:49 <openstack> Meeting started Mon Mar  7 21:00:48 2016 UTC and is due to finish in 60 minutes.  The chair is armax. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:50 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:53 <openstack> The meeting name has been set to 'networking'
21:00:56 <johnsom> Shortest neutron meeting ever
21:00:57 <njohnston> o/
21:00:58 <mlavalle> ihrachys: you have my admiration
21:01:25 <armax> for those of you who joined: welcome
21:01:52 <armax> to this another exciting episode of ‘neutron team meeting’
21:02:03 <armax> we’re getting to the season finale
21:02:32 <armax> so stay tuned to see what to expect in next season
21:02:44 * armax stops talking nonsense
21:02:55 <armax> the agenda for the week
21:03:02 <armax> erm, meeting
21:03:07 <mhickey> hello
21:03:08 <armax> #link https://wiki.openstack.org/wiki/Network/Meetings
21:03:11 <kevinbenton> hi
21:03:21 <armax> #topic Announcements/Reminders
21:03:23 <Swami> hi
21:03:42 <armax> I am pretty sure you’re all aware…we cut M-3 last week
21:04:07 <armax> #link http://lists.openstack.org/pipermail/openstack-announce/2016-March/001002.html
21:04:24 <armax> link https://launchpad.net/neutron/+milestone/mitaka-3
21:05:24 <armax> and we also realease python-neutronclient 4.1.1
21:05:52 <armax> this means we’re in feature freeze, so from now on nothing gets merged if it doesn’t have the seal of approval
21:06:15 <armax> you might ask, whose seal of approval
21:06:21 <armax> anyone cares to venture a guess?
21:06:38 <ihrachys> groundhog?
21:06:51 <armax> ihrachys: no, but close
21:06:52 <njohnston> "The PTL's seal" roars the crowd
21:07:13 <armax> njohnston: I wish I had that respect, but no
21:07:17 <armax> :)
21:07:21 <ihrachys> well you have
21:07:32 <xgerman> flipping a coin?
21:07:45 <mhickey> armax: you have the power! :)
21:07:46 <armax> xgerman: nope
21:07:49 * njohnston imagines armax giving the thumbs up/thumbs down like the Roman emperors of old.
21:07:50 <ihrachys> that said, we tend to merge some stuff without the seal. is it all times a bad thing? like in case of emergency?
21:07:52 <armax> the answer is:
21:07:59 <armax> anything that has a FFE granted in https://review.openstack.org/#/c/286413/
21:08:25 <armax> plus bug fixes that have been targeted for RC1
21:08:54 <armax> we have time until the end of this week
21:09:06 <HenryG> Are we allowed to make release notes look pretty?
21:09:15 <armax> anything else that’s not targeted or not priority, like trivial fixes, should be banned
21:09:33 <ihrachys> armax: who targets
21:09:38 <armax> I suppose those are fine and they don’t clutter the gate too much
21:09:56 <john-davidge> armax: How should we go about getting a fix targetted?
21:09:58 <armax> ihrachys: it’s any member of the bug team, but we’ll have to use judgement
21:10:20 <ihrachys> ok, so PTL is not a bottleneck for bugs if we all behave sanely
21:10:21 <armax> and consider targeting a bug based on severity
21:10:30 <armax> I am happy to review bugs if necessary
21:10:36 <armax> bear in mind that the gate is like a wood oven
21:10:46 <armax> we may want to keep the fire burning
21:10:50 <mestery> ihrachys: One thing to keep in mind is that I expect we'll keep up our fast stable release, so if a bug misses Mitaka, it can hit Mitaka-1 pretty quick post mitaka release
21:11:04 <armax> so if you feel like there’s a trivial fix that it’s ok to merge, please do check the state of the gate
21:11:10 <ihrachys> mestery: yeah, but I talk more about stuff like 'gate broken'
21:11:24 <armax> if the queue is getting dry (or the fire is about to go out) feed the fire
21:12:04 <armax> so be conscious of the state of the gate whenever you’re considering +A something
21:12:21 <armax> I did pull some stuff out of the queue last week
21:12:33 <armax> we had a very repetetive offenders
21:12:56 <armax> if you strike again, I shall ban from the kingdom for ever, so be careful :)
21:13:06 <armax> *very: few
21:13:44 <salv-orlando> what happens when you're banned?
21:14:04 <Sam-I-Am> hello
21:14:16 <mhickey> salv-orlando: you form a new band!
21:14:28 <armax> salv-orlando: we’ll let you know in due course
21:14:35 <armax> keep an eye on
21:14:38 <armax> #link http://status.openstack.org//elastic-recheck/
21:14:49 <armax> and #link https://review.openstack.org/#/q/status:open+label:Verified-2
21:15:08 <armax> those links should give you a clue of potential gate failures that we may want to be on the lookout for
21:15:15 <salv-orlando> armax: I did relinquish my kingdom membeship long before the revolution. I knew my head would have been among the first to roll on the floor otherwise ;)
21:15:50 <armax> salv-orlando: I would love you back, if you’re willing to be the prodigal son
21:15:53 <armax> salv-orlando: but I digress
21:16:12 <salv-orlando> armax: yes, I guess the gate and the deadlines do not allow for any digression
21:16:41 <armax> so, to recap, check the postmortem for the project, https://review.openstack.org/#/c/286413/ and comment on stuff that you’re called into action
21:16:54 <armax> review targeted stuff
21:16:55 <armax> #link https://launchpad.net/neutron/+milestone/mitaka-rc1
21:17:11 <armax> we have time until the end of the week to cut rc1
21:17:40 <armax> this is doug’s email:
21:17:41 <armax> #link http://lists.openstack.org/pipermail/openstack-dev/2016-March/088452.html
21:17:50 <emagana> need to run but this is in my list of prioritiesI am around if needed!
21:17:57 <armax> for those of you who likes to learn more details about this
21:18:07 <armax> emagana: thanks, will do
21:19:02 <armax> any question so far?
21:19:10 <armax> did I bore you to sleep?
21:19:25 <Sukhdev> :-)
21:19:32 <armax> sounds like yes
21:19:36 <armax> another two reminders
21:19:41 <armax> next week is PTL nomination week
21:19:41 <mlavalle> armax: nope, paying very close attention
21:19:50 <armax> do keep that in mind
21:19:58 <armax> and furthermore, US goes back to daylight saving
21:20:02 <armax> so don’t get caught
21:20:32 <armax> you’ll loose an hour sleep
21:20:45 <Sukhdev> Its already time for PTL nominations - I hope we are not getting any change soon
21:20:49 <john-davidge> But I only just got used to the new meeting times! :(
21:20:58 <ihrachys> armax: you run I suppose ;)
21:20:59 <armax> john-davidge: sorry
21:21:02 <armax> ihrachys: me?
21:21:15 <armax> ihrachys: that’s for the Gods to decide
21:21:26 <Sukhdev> which God?
21:21:35 <ihrachys> armax: not the 'run' part. 'elected' - maybe.
21:21:37 <armax> Sukhdev: it’s more than one
21:21:49 <Sukhdev> I have connections with few Gods :-):-)
21:22:10 <armax> Sukhdev good for you, so you should consider running!
21:22:16 <anteaya> more than the states changes time on the weekend
21:22:19 <armax> any other reminder from people?
21:22:34 <anteaya> thank goodness for utc meeting times
21:22:38 <armax> anteaya: thanks, Canada too, I suppose?
21:22:52 <anteaya> we do
21:22:54 <armax> anteaya: yup, but you’d be amazed how often people get confused
21:23:03 <anteaya> very often, yes
21:23:10 <Sukhdev> first few weeks are bad
21:23:18 <armax> anyhow, my conscience is clean :) I warned folks, so…
21:23:53 <mhickey> anteaya: howdy
21:24:01 <armax> any other reminder from folks?
21:24:01 <anteaya> mhickey: hey there :)
21:24:06 <armax> before we move on?
21:24:58 <armax> #topic Blueprints
21:25:01 <armax> #link https://launchpad.net/neutron/+milestone/newton-1
21:25:09 <armax> I optmistically moved some stuff to this dashboard
21:25:35 <armax> we’ll get to it as soon as master opens up
21:25:58 <ihrachys> ...which will happen start of next week
21:26:06 <armax> bear in mind that if you have a spec that failed to be submitted in Mitaka or merged in Mitaka but didn’t make it
21:26:12 <armax> it’ll need to be resubmitted
21:26:17 <armax> be aware of this one:
21:26:19 <armax> #link https://review.openstack.org/#/c/283383/
21:28:11 <armax> next topic
21:28:17 <armax> #topic Bugs
21:29:00 <armax> I know andreas is not around
21:29:00 <mhickey> armax: if you have -2 patches, will you roll them back?
21:29:12 <armax> mhickey: meaning taking the -2 off?
21:29:16 <mhickey> yes
21:29:36 <armax> mhickey: I’ll do that for those that need to go in Mitaka, and will lift it entirely as soon as Newton opens up
21:29:59 <mhickey> armax: grt, thanks. first full release! :)
21:29:59 <armax> if I miss one, do ping me
21:30:04 <mhickey> ok
21:31:10 <armax> scheuran is not online, but he was on top of it last week
21:31:19 <ihrachys> btw I cover this week
21:31:26 <armax> he updated the deputy guide here: https://review.openstack.org/#/c/287844/
21:31:37 <armax> ihrachys: no new volunteers?
21:31:50 <armax> give someone new a chance, if not, I’d happy to have you back to it
21:32:11 <ihrachys> armax: I did on previous meeting, no one called his own name ;)
21:32:31 <armax> ihrachys: ack, I am so lagging behind I still haven’t read the meeting logs
21:32:50 <ihrachys> also, we already had like 20+ people on the list
21:33:05 <armax> let see if I may be more convincing
21:33:34 <armax> anyone who gets to be deputy next week gets to have a picture with me at the next summit?
21:33:54 <armax> signed and all of it
21:33:55 <anteaya> woooooo
21:33:57 <armax> no-one?
21:34:04 <armax> come on!
21:34:06 * ihrachys !
21:34:11 <ihrachys> :D
21:34:34 <armax> it comes in a frame to
21:34:35 <armax> o
21:34:41 <armax> oh well
21:34:48 <hichihara> Next week? I will
21:34:56 <armax> hichihara: cool
21:34:57 <armax> thanks!
21:35:09 <mhickey> stop the lights! :) That is pure gold!
21:35:11 <ihrachys> armax: hm. next week == this week?
21:35:12 <hichihara> :)
21:35:23 <armax> #action hichihara to be deputy for the week of…
21:35:50 <armax> hichihara: can you run this week and maybe ihrachys is the backup for next week?
21:36:04 <armax> hichihara: or did you mean the week starting today
21:36:33 <hichihara> armax: I mean next week but I can from today
21:36:33 <mhickey> ihrachys is going to be busy next week?
21:36:49 <armax> hichihara: that’s ok, let’s have ihrachys do this week
21:36:54 <armax> and hichihara you do the next
21:37:01 <armax> sounds good?
21:37:06 <hichihara> armax: I got it :)
21:37:26 <ihrachys> yeah, I am not ok for next week, we have a code sprint.
21:37:28 <armax> thanks to you both
21:37:36 <ihrachys> armax: I get my picture right?
21:37:43 <armax> ihrachys: of course you do!
21:37:50 <ihrachys> YES
21:37:53 <armax> :)
21:38:23 <armax> #action hichihara to be deputy for the week of Mar 14th
21:38:37 <armax> next topic
21:38:45 <armax> but before diving to it
21:38:54 <armax> do watch out these two links
21:38:57 <armax> #link https://bugs.launchpad.net/neutron/+bugs?field.status%3Alist=NEW&field.status%3Alist=CONFIRMED&field.tag=gate-failure
21:39:09 <armax> that’s confirmed gate failures which we should look into
21:39:21 <armax> confirmed and new
21:39:43 <armax> so please, if you can, do take some time to see if you can provide help on those, especially if new ones come up
21:40:06 <armax> the other one is
21:40:08 <armax> #link https://bugs.launchpad.net/neutron/+bugs?field.tag=doc
21:40:20 <ihrachys> armax: there are some in progress, I think we should point to those too
21:40:29 <armax> those are bugs filed post-merge due to changes with commit messages decorated with a DocImpact
21:40:33 <armax> ihrachys: ack
21:41:30 <armax> #link https://bugs.launchpad.net/neutron/+bugs?field.status%3Alist=NEW&field.status%3Alist=INPROGRESS&field.status%3Alist=CONFIRMED&field.tag=gate-failure
21:41:57 <armax> so for those bugs created and tagged with doc
21:42:14 <armax> make sure we have an entry (even if work in progress) that target our doc repositories
21:42:38 <armax> and on this I pass the baton to our doc guy in charge Sam-I-Am
21:42:44 <armax> #topic Documentation
21:42:47 <armax> Sam-I-Am: you’re up
21:42:56 * armax shuts up for a sec
21:43:00 <armax> or two\
21:43:09 <Sam-I-Am> hi
21:43:42 <Sam-I-Am> not much from here. trying to review networking guide patches as i have time, but mostly buried in downstream work.
21:44:09 <anteaya> :(
21:44:59 <armax> anything you’d like to offload?
21:45:07 <armax> as far as upstream goes?
21:45:35 <Sam-I-Am> updating the networking guide scenarios for mitaka
21:45:47 <Sam-I-Am> at a minimum, config changes
21:46:26 <johnsom> I am still hoping to hear back on how the octavia config can be restored after it was deleted from the docs.
21:46:57 <armax> Sam-I-Am: I already saw the config change come in
21:47:10 <Sam-I-Am> armax: which one?
21:47:56 <armax> Sam-I-Am: I might be confusing this with the one that refreshed the client commands
21:47:59 <armax> never mind
21:48:01 <Sam-I-Am> probably
21:48:40 <armax> ok, if there’s nothing else and you guys don’t want to get 12 minutes back there’s the...
21:48:46 <armax> #topic Open Discussion
21:49:30 <ihrachys> ok. I really encourage parties involved in discussions around DSCP patches to get to clearing all concerns earlier
21:49:46 <njohnston> +1
21:50:54 <hichihara> I have a question about DocImpact.
21:51:01 <hichihara> My patch with DocImpact was merged but I cannot see filed doc bug.
21:51:12 <hichihara> I thought bug triager automaticallyfiles doc bug on Launchpad...
21:51:23 <armax> hichihara: I wonder if that got lost somehow
21:51:25 <Sam-I-Am> it should, in the neutron repo
21:51:28 <armax> hichihara: link to patch?
21:51:46 <hichihara> that is https://review.openstack.org/#/c/273881/
21:52:20 <hichihara> Did I miss anything?
21:53:14 <HenryG> hichihara: https://bugs.launchpad.net/bugs/1552487
21:53:14 <openstack> Launchpad bug 1552487 in openstack-manuals " Add tag mechanism for network resources" [Low,Confirmed]
21:53:41 <armax> HenryG: thanks
21:53:46 <hichihara> HenryG: Thanks!
21:54:16 <hichihara> My searching was too bad ;)
21:54:55 <armax> ok, if there’s nothing else, I’ll be magnanimous and give you a few minutes back
21:55:00 <armax> #endmeeting