14:00:51 <armax> #startmeeting networking
14:00:52 <haleyb> hi
14:00:52 <openstack> Meeting started Tue Dec 15 14:00:51 2015 UTC and is due to finish in 60 minutes.  The chair is armax. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:53 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:53 <kevinbenton> hi
14:00:55 <openstack> The meeting name has been set to 'networking'
14:01:02 * regXboi is here but a little busy for the first 30 minutes or so :(
14:01:03 <dasm> hello o/
14:01:06 <Sam-I-Am> howdy
14:01:07 <annp> Hi all,
14:01:08 <garyk> hi all
14:01:08 <carl_baldwin> Hi
14:01:11 <HenryG> o/
14:01:11 <ajo> o/ hi
14:01:12 * Sam-I-Am is here but pre-coffee
14:01:25 <garyk> Sam-I-Am: tmi
14:01:31 <Sam-I-Am> garyk: ha
14:01:32 * ajo is in post-lunch coffee
14:01:40 <Sam-I-Am> garyk: be very afraid
14:01:40 <johnsom> o/
14:01:48 <garyk> Sam-I-Am: :)
14:01:49 <rtheis> hi
14:01:50 <armax> last week we started going over the blueprint and RFE backlog
14:01:56 * regXboi asks "what is coffee?"
14:01:57 <armax> we only managed to go through half
14:02:02 <garyk> i am only afraid of the wrath of the ptl ...
14:02:07 <mestery> lol
14:02:12 <Sam-I-Am> armax: isnt it super early for you?
14:02:14 <armax> it was decided to go over the other half this time
14:02:19 <armax> Sam-I-Am: yes it is
14:02:21 <dougwig> o/
14:02:24 <akamyshnikova> hi
14:02:36 <armax> garyk: you experienced nothing of my wrath yet
14:02:44 <garyk> :)
14:02:44 <armax> garyk: you’ll see
14:02:50 <obondarev_afk> o/
14:02:58 <armax> so before we dive in
14:03:00 <sbelous_> hi there
14:03:10 <armax> I’ll like to summon HenryG
14:03:11 <Vikram___> Hi
14:03:16 <armax> as he was the deputy for last week
14:03:19 <armax> #topic Bugs
14:03:21 <Vikram___> Sorry to be late
14:03:23 <garyk> HenryG: chop chop
14:03:53 <garyk> on that note, if people are away next week i can take the role
14:04:00 <armax> before HenryG refreshed his memory
14:04:09 <armax> this week’s deputy is carl_baldwin
14:04:20 <ajo> carl_baldwin++
14:04:25 <carl_baldwin> Hi
14:04:26 <armax> the next couple of weeks I expect are gonna be quite
14:04:41 <armax> but we’re uncovered
14:04:51 <russellb> hi
14:04:54 <armax> anyone (who hasn’t done it before) willing to volunteer?
14:05:00 <HenryG> sorry I didn't realize we were startgin with bugs
14:05:08 <kevinbenton> me
14:05:08 <amotoki> next week? I can
14:05:09 <dougwig> Every Tim a bug is filed, drink a glass of egg nog.
14:05:09 <HenryG> There is not much to report
14:05:16 <dougwig> Time
14:05:22 <Sam-I-Am> dougwig: i like your thinking
14:05:35 <armax> amotoki: ok
14:05:36 <ajo> I will be PTO'ing from Dec 21st to Jan 4th but It'd be glad to take another slot afterwards
14:06:02 <armax> #action amotoki deputy for the week of Dec 21
14:07:24 <HenryG> I will note there is no critical gate bug, yet the need to do rechecks remains uncomfortably high
14:07:25 <armax> HenryG: ok, not even a little gossip?
14:07:44 <armax> HenryG: I noticed there was a gate failure with linuxbridge
14:07:53 <armax> but it didn’t seem to occur often in the gate
14:08:04 <Sam-I-Am> armax: master or another branch?
14:08:07 <armax> the new logstash UI and way to share urls is appalling to say the least
14:08:14 <armax> Sam-I-Am: I think it was master
14:08:23 <Sam-I-Am> hmm odd, we found some problems in stable/liberty last week
14:08:24 <dougwig> Do we need to file something for that? Who is on that?
14:08:27 <armax> Sam-I-Am: I know that stable broke at one point
14:08:38 <Sam-I-Am> HenryG: can you feed me a link to a broken patch?
14:08:50 <armax> Sam-I-Am: it’s on the bug report
14:08:51 <armax> hang on
14:08:52 <HenryG> I think we're being dragged down by multiple low-frequency issues
14:09:11 <armax> http://logs.openstack.org/66/254166/2/gate/gate-tempest-dsvm-neutron-linuxbridge/350516d/
14:09:11 <mhickey> clear
14:09:24 <mhickey> sorry
14:09:28 <armax> Sam-I-Am: it was master
14:09:41 <armax> HenryG: where?
14:10:06 <Sam-I-Am> armax: i'll poke at this
14:10:21 <HenryG> armax: just in general
14:10:43 <armax> I added the linuxbridge job to the dashboard, the failure rate seems relatively under control
14:10:46 <armax> we’ll keep on monitoring it
14:10:50 <HenryG> armax: I wish it were easy to pin down
14:10:51 <armax> HenryG: ok
14:11:11 <armax> HenryG: yes, it can be very dauting to pinpoint where issues lie
14:11:14 <armax> anyhow
14:11:18 <armax> thanks HenryG!
14:11:20 <armax> let’s move on
14:11:23 <armax> #topic Blueprints
14:11:57 <armax> last week we finished with the autogen of config files
14:12:04 <ihrachys> mhickey++
14:12:04 <Sam-I-Am> yay
14:12:16 <armax> next up is
14:12:18 <armax> #link https://blueprints.launchpad.net/neutron/+spec/ml2-lb-ratelimit-support
14:12:18 <Sam-I-Am> i'm working through the docimpact bugs for those
14:12:32 <armax> ihrachys: ping
14:12:52 <armax> whiteboard is langhishing
14:13:09 <ihrachys> armax: we have some patches up, but needed to accommodate for common l2 agent code work by Andreas
14:13:20 <armax> the only patch I can see is this one:
14:13:21 <armax> https://review.openstack.org/#/c/236210/
14:13:29 <ihrachys> also LB fullstack/functional tests are needed, Slawek is working on them
14:13:36 <armax> ihrachys: ok
14:13:43 <ihrachys> you better check all work by Slawek: https://review.openstack.org/#/q/owner:slawek%2540kaplonski.pl+status:open,n,z
14:13:50 <ihrachys> he seems to work on this stuff only
14:14:05 <ihrachys> so there is work ongoing, hopefully, M2
14:14:18 <armax> ihrachys: ok cool
14:15:16 <armax> next
14:15:24 <armax> #link https://blueprints.launchpad.net/neutron/+spec/add-availability-zone
14:15:35 <armax> hichihara and armax are tagged on this one
14:15:37 <armax> I can give an update
14:15:52 <armax> this is mostly complete: we need tests to merge and docs to go in
14:16:03 <armax> there was a performance issue
14:16:04 <hichihara> Yes!
14:16:06 <armax> introduced lately
14:16:13 <armax> but kevinbenton is working on it
14:16:13 <garyk> what was nice about this one is that all of the release notes were added with the patches :)
14:16:36 <armax> yes, mestery is thankful for that and all the patches that do provide notes
14:16:49 <mestery> Indeed
14:16:55 <armax> there was another issue discovered with the way agents were balanced
14:17:03 <hichihara> Please review https://review.openstack.org/#/c/210977/ :) And I also upload doc patch tomorrow.
14:17:10 <armax> so it looks like the feature is being looked at and issues are being discovered
14:17:18 * carl_baldwin notes to add release notes to some patches
14:18:10 <armax> next up
14:18:12 <xiaohhui> Another issue for AZ needs review
14:18:12 <armax> #link https://blueprints.launchpad.net/neutron/+spec/network-ip-usage-api
14:18:13 <xiaohhui> https://review.openstack.org/#/c/253330/
14:18:33 <armax> xiaohhui: yes, that’s the one I was referring to
14:18:36 <armax> kevinbenton: you up?
14:18:50 <kevinbenton> yes
14:18:56 <hichihara> xiaohhui: Thank you for your help. It's ready for me.
14:19:03 <armax> attaboy
14:19:14 <armax> what’s up with this one?
14:19:17 <xiaohhui> np :)
14:19:43 <armax> kevinbenton: looks like the spec is still churning
14:19:47 <kevinbenton> the network-usage-api?
14:19:54 <armax> kevinbenton: ya
14:20:02 <Sam-I-Am> looks like we need more paint
14:20:07 <kevinbenton> there was some confusion about whether to put the REST API in the spec
14:20:22 <armax> https://review.openstack.org/#/c/180803/
14:20:58 <armax> ok
14:21:18 <armax> I’ll look into it, typically some rest snippets can be helpful for the conversation
14:21:38 <armax> but as usual in openstack we’re not consistent
14:21:41 <armax> and there’s no enforcement
14:22:08 <armax> kevinbenton: any code ready to be reviewed?
14:22:47 <kevinbenton> armax: i'm not sure. i think there was something they had floating around a while ago but i'm not sure it has been updated
14:23:09 <armax> kevinbenton: can you find out, please?
14:23:42 <kevinbenton> armax: ok
14:23:48 <armax> kevinbenton: is there david around?
14:23:58 <kevinbenton> armax: i don't know
14:24:05 <armax> between you and him, we should be able to find out anything there is to know about the blueprint
14:24:18 <armax> approver and assignee should got it covered
14:24:21 <armax> anyway
14:24:23 <armax> next up
14:24:27 <armax> #link https://blueprints.launchpad.net/neutron/+spec/select-active-l3-agent
14:24:46 <xiaohhui> I am working on this one
14:24:47 <armax> amuller, anything worthy?
14:24:53 <armax> of sharing
14:25:09 <armax> xiaohhui: ok
14:25:11 <amuller> there's a new revision from like 2 minutes ago, haven't had the chance to review it
14:25:16 <armax> amuller:
14:25:18 <armax> great
14:25:36 <armax> xiaohhui: link?
14:25:41 <xiaohhui> https://review.openstack.org/#/c/257299/
14:26:09 <xiaohhui> I just addressed some of martin's comment
14:26:12 <armax> ok
14:26:20 <armax> so you’re still in the specification phase
14:26:31 <xiaohhui> yes~
14:26:57 <Sam-I-Am> xiaohhui: why not just use standard vrrp priorities?
14:27:28 <amuller> adding a new API that is specific to a particular flavor of routers is kinda meh, so we'll have to weigh that in when reviewing the pros and cons of the spec
14:27:39 <armax> amuller: ok
14:27:42 <xiaohhui> Don't want to make it too complicated
14:27:46 <Sam-I-Am> this seems overly complex?
14:27:50 <armax> #link https://blueprints.launchpad.net/neutron/+spec/address-scopes
14:28:06 <armax> carl_baldwin ping
14:28:40 <carl_baldwin> Hi
14:29:06 <armax> this looks to have a long history of reviews
14:29:07 <carl_baldwin> going well I think.  one more patch merged
14:29:16 <armax> carl_baldwin: any more left?
14:29:53 <carl_baldwin> 3 main ones.  next one is close.  I need to address one thing today.
14:30:12 <armax> they are all server side?
14:30:29 <carl_baldwin> one is.  other two are agent side
14:31:04 <armax> https://review.openstack.org/#/q/topic:bp/address-scopes+status:open,n,z
14:31:06 <armax> gives me 7 patches
14:31:26 <armax> they all seem to be current
14:31:35 <carl_baldwin> oh, there is a small fix from tidwellr and a client patch for it
14:31:45 <armax> carl_baldwin: cool, I shall be able to help with that one
14:31:47 <armax> with amotoki
14:31:54 <armax> in fact
14:31:57 <armax> it’s already approved
14:32:05 <armax> but it needs a rebase
14:32:21 <armax> I’ll touch base with salv
14:32:30 <carl_baldwin> start here: https://review.openstack.org/#/c/189500/
14:33:00 <armax> carl_baldwin: cool
14:33:03 <armax> next one
14:33:05 <armax> #link https://blueprints.launchpad.net/neutron/+spec/rbac-qos
14:33:30 <armax> ajo: news?
14:33:35 <ajo> hi
14:33:45 <ajo> hdaniel has posted a spec, 1 sec
14:34:08 <armax> ajo: need help with the spec?
14:34:08 <ajo> https://review.openstack.org/#/c/254224/
14:34:32 <ajo> may be some kevinbenton's eyes would be great on it
14:34:40 <armax> kevinbenton: you’re the man
14:34:52 <armax> can you spare a few moments? you’re the RBAC father
14:34:54 <ajo> it's looking good to me already, but it's likely I could be missing simething
14:34:58 <ajo> something
14:35:03 <kevinbenton> yeah, i'll take a look
14:35:11 <armax> RBAC’s papa
14:35:15 <ajo> :-D
14:35:48 <armax> cool
14:36:00 <armax> ajo: what about the code?
14:36:04 <armax> I see lots of red
14:36:10 <ajo> we have code, https://review.openstack.org/#/c/250081/ and ...
14:36:18 <ajo> https://review.openstack.org/#/c/250082/
14:36:30 <ajo> but as you said, lot's of red, haim focused on the spec
14:36:44 <ajo> and stopped that until we make sure everything looks right, AFAIK
14:36:47 <armax> ok
14:37:00 <ajo> but, it didn't seem complicated give kevinbenton's framework :)
14:37:01 <armax> next one
14:37:18 <armax> kevinbenton does spawn well when he does
14:37:25 <armax> #link https://blueprints.launchpad.net/neutron/+spec/bgp-dynamic-routing
14:37:25 <ajo> :)
14:37:39 <armax> carl_baldwin: yello
14:38:11 <carl_baldwin> Hi, I sense this has stalled a bit but tidwellr has been away
14:38:25 <Vikram___> Hi
14:38:30 <Sam-I-Am> carl_baldwin: this one looks interesting
14:38:34 <carl_baldwin> Vikram___: how are things?
14:38:42 <Vikram___> It's good
14:38:46 <armax> do we have a sense on how far we are
14:39:07 <Vikram___> We expect reviews to be opened by this week
14:39:14 <carl_baldwin> I have been in a holding pattern.  should I be reviewing now?
14:39:17 <Sam-I-Am> should be interesting to gate this
14:39:21 <Vikram___> Just Ryan need to catch up a little
14:39:28 <armax> https://review.openstack.org/#/q/topic:bp/bgp-dynamic-routing+status:open,n,z
14:39:45 <armax> seems there’s a bit of work to do
14:40:10 <Vikram___> Address-scope and DVR stuff is pending
14:40:17 <armax> Vikram___: links?
14:40:22 <Vikram___> Everything else is ready
14:40:33 <armax> Vikram___: ready to review?
14:40:47 <Vikram___> armax: 1 sec
14:41:08 <armax> I see merge conflicts all over the place
14:41:14 <Sam-I-Am> doesnt look ready to me
14:41:29 <armax> me neither
14:41:36 <armax> ok this needs some love
14:41:56 <Vikram___> https://review.openstack.org/#/q/status:open+project:openstack/neutron+branch:master+topic:bp/bgp-dynamic-routing,n,z
14:42:10 <Vikram___> Just got to polish a bit
14:42:19 <Sam-I-Am> i see red
14:42:19 <Vikram___> Will resolve by this week
14:42:29 <armax> next one
14:42:37 <armax> #link https://blueprints.launchpad.net/neutron/+spec/vlan-aware-vms
14:42:53 <armax> I have looked at this quite a bit
14:42:58 <armax> rossella_s too I believe
14:43:01 <armax> and a few others
14:43:15 <armax> we’re back to revising the model being proposed
14:43:23 <rossella_s> yep
14:43:40 <armax> I need to review the latest revision
14:44:03 <armax> but it does look like we might have resolved the conondrum that held us back
14:44:06 <armax> we’ll have to look at the code
14:44:10 <armax> is bence around?
14:44:43 <armax> rossella_s: you aware of any current code being posted?
14:44:50 <rubasov> I'm here
14:45:02 <armax> rubasov: hi
14:45:11 <rubasov> hi armax
14:45:14 <russellb> latest version looking pretty good to me
14:45:22 <rossella_s> armax, AFAIK there was code posted, based on the old spec. I don't know of any patch for this "new" spec
14:45:34 <rubasov> I hope we can finalize it soon, so we can start coding
14:45:34 <Sam-I-Am> curious how this works with ovs
14:45:45 <armax> rossella_s, rubasov: I think it’s safe to start
14:45:55 <russellb> Sam-I-Am: code doesn't exist yet :)  but i can explain out of meeting
14:46:02 <Sam-I-Am> russellb: yes, lets chat
14:46:06 <armax> unless a train wreck hits us, there should not be major changes disrupting the work
14:46:19 <rossella_s> finally!! yuppie :)
14:46:27 <rubasov> rossella: yes we need to abandon the old patches and write new stuff now
14:46:39 <armax> I’ll ask someone from nova to make sure they are happy with the final outcome
14:46:44 <armax> rubasov: please do
14:46:50 <rossella_s> armax, good point, thanks
14:46:58 <rubasov> will do, thanks
14:47:51 <armax> rubasov, russellb who is in charge of the nova side change
14:47:56 <armax> to deal with the bridge creation?
14:48:11 <russellb> in theory the only change is to allow neutron to tell nova the name of the bridge to use
14:48:23 <russellb> instead of only supporting a single bridge, with a name from nova.conf
14:48:28 <russellb> i filed a blueprint for that, which was approved
14:48:35 <armax> russellb: right
14:48:36 <russellb> so in theory i'm in charge of the nova side of the code
14:48:41 <armax> russellb: there you go!
14:48:42 <russellb> i'm planning on implementing it
14:48:51 <russellb> it should be a relatively small patch, i think :)
14:48:58 <armax> you’d think?
14:48:58 <armax> :)
14:49:04 <Sam-I-Am> russellb: can i quote you on that?
14:49:09 <armax> that hust require changes neutron side too
14:49:09 <russellb> Sam-I-Am: sure!
14:49:12 <armax> should
14:49:14 <russellb> yes
14:49:18 <armax> link?
14:49:23 <armax> I don’t have it handy now
14:49:28 <russellb> https://blueprints.launchpad.net/nova/+spec/neutron-ovs-bridge-name
14:49:45 <armax> russellb: obregado
14:50:07 <russellb> i was planning on doing it very soon to have it in place
14:50:24 <russellb> but i got sidetracked adding Python 3 support to the Python ovs library
14:50:26 <armax> russellb: We’ll track this neutron side too
14:50:31 <russellb> armax: sounds good
14:50:42 <Sam-I-Am> russellb: can we talk about this too?
14:50:43 <armax> next up
14:50:50 <russellb> Sam-I-Am: we can talk about ALL THE THINGS!
14:50:52 <armax> https://blueprints.launchpad.net/neutron/+spec/add-neutron-extension-resource-timestamp
14:50:55 <armax> #link v
14:50:57 <armax> #undo
14:50:57 <openstack> Removing item from minutes: <ircmeeting.items.Link object at 0xa80f490>
14:50:59 <armax> #link https://blueprints.launchpad.net/neutron/+spec/add-neutron-extension-resource-timestamp
14:51:16 <armax> kevinbenton: I know there was some friction with this one
14:52:09 <armax> this one seems to be releted https://blueprints.launchpad.net/neutron/+spec/add-port-timestamp
14:52:27 <armax> we should be able to collapse the two
14:52:35 <armax> I smell some planning failure here
14:52:58 <kevinbenton> i didn't even realize there were two separate blueprints until now
14:53:36 <armax> ok, let’s take this offline and you and I should be able to figure this out
14:54:00 <armax> ok folks, we have gone through the entire list of blueprints
14:54:11 <ajo> there's a missing one :)
14:54:16 <armax> ajo: which one?
14:54:28 <ajo> sorry, I lost the link
14:54:32 <armax> doh
14:54:35 <ajo> the connectivity without l3 address
14:54:42 <armax> we talked about it last week
14:54:43 <armax> didn’t we?
14:54:46 <ajo> correct
14:54:47 <ajo> sorry
14:54:51 <armax> so that’s it
14:54:51 <ajo> I thought we went over all of them
14:54:56 <armax> :)
14:54:59 <ajo> I'd like some help from carl_baldwin on reviewing one of the patches
14:54:59 <ajo> :)
14:55:07 <armax> we’ll do this exercise again post M2
14:55:12 <ajo> ack
14:55:17 <armax> 5 minutes to spare
14:55:18 <armax> go nuts
14:55:20 <armax> #endmeeting