21:00:31 <armax> #startmeeting networking
21:00:31 <regXboi> you choose which :)
21:00:33 <openstack> Meeting started Mon Nov 23 21:00:31 2015 UTC and is due to finish in 60 minutes.  The chair is armax. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:34 <ihrachys> trying to keep myself awake
21:00:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:37 <openstack> The meeting name has been set to 'networking'
21:00:38 <garyk> hi
21:00:44 <markmcclain> o/
21:00:45 <rossella_s> hi
21:00:49 <mhickey> hi
21:00:50 <hoangcx> hi
21:00:58 <HenryG> o/
21:01:16 <armax> #link https://wiki.openstack.org/wiki/Network/Meetings
21:01:18 <manjeets> hi
21:01:28 <armax> this may end up being a short meeting…but let’s see
21:01:30 <dougwig> o/
21:01:50 <sc68cal> o/
21:02:10 <mlavalle> armax: don't jinx it....
21:02:10 <armax> no announcements/reminders on the agenda
21:02:13 <mestery> armax: You just jinxed yourself
21:02:13 <armax> however
21:02:20 <amotoki> hi
21:02:30 <armax> there’s a couple of things worth announcing
21:02:41 * regXboi looks for the murphy lightning bolts to land...
21:03:03 <armax> tehre’s an ongoing conversation on how to deal with development vs release cycle
21:03:31 <armax> there are some big-tent/stadium initiatives that are trying to figure out what’s the best way to develop/release their code
21:03:52 <amotoki> http://lists.openstack.org/pipermail/openstack-dev/2015-November/080233.html
21:03:55 <edgar> hello all!
21:03:55 <armax> I am not sure of any outcome yet
21:04:06 <ajmiller> Hi
21:04:26 <armax> amotoki: that was initiated by this one I believe
21:04:28 <armax> #link http://lists.openstack.org/pipermail/openstack-dev/2015-November/079773.html
21:04:28 <neiljerram_bb> think I'm one of the guilty parties there
21:04:45 <amotoki> yes, right
21:05:02 <armax> either way, we’ll get to a resolution in the next few days and our release liasion, egregious mestery
21:05:09 <armax> will tell us what to do
21:05:21 <johnbelamaric> certainly networking-infoblox has the same issue others have mentioned - we are coding now but the deliverables will be targeted at Liberty (though we can verify they will work with Mitaka too). Also, we delivered a minimally functional driver and cut a liberty/stable branch, but want to target our more functional version at liberty too
21:05:34 <mestery> I will
21:05:42 <mestery> That's what I do
21:06:17 * regXboi confirms the mestery is egregious :)
21:06:22 <armax> we’ll have to iterate a bit more on what it means to be part of the stadium
21:06:33 <mestery> "The only thing constant in OpenStack is change."
21:06:41 <dougwig> and bikeshedding
21:06:44 <garyk> and process :)
21:06:53 <armax> so that anyone has a clear idea on what are the benefits and the responsabilities
21:07:11 <regXboi> anyone? everyone?
21:07:44 <russellb> anyone that cares to understand it :)
21:07:52 <armax> as of now please be patient and hold on the frustration :)
21:08:09 <armax> mestery: so long changes are for the better
21:08:16 <armax> mestery: then change is welcome
21:08:18 <mestery> armax: We only know if they are after we've tested them
21:08:32 <armax> mestery: aye
21:08:51 <salv-orlando> we need to change everything to make sure things stay the same
21:08:52 <armax> anyone else has anything to announce? weddings, parties?
21:09:22 <manjeets> armax: only openstack or neutron wedding and parties here
21:09:25 <kevinbenton> Party at Armandos house
21:09:34 <regXboi> kevinbenton: on thursday, even?
21:09:44 <mestery> kevinbenton: Is armax buying the drinks too?
21:09:45 <mlavalle> armax: remind the team mitaka-1 is next week
21:09:48 <ihrachys> big tent!
21:09:52 <armax> mlavalle: indeed
21:09:58 <armax> #topic blueprints
21:10:03 <ihrachys> :(
21:10:26 <armax> #link https://blueprints.launchpad.net/neutron/+assignments
21:10:38 <armax> #undo
21:10:39 <openstack> Removing item from minutes: <ircmeeting.items.Link object at 0x8fd3590>
21:10:54 <armax> #link https://blueprints.launchpad.net/neutron/mitaka/+assignments
21:11:11 <armax> we have a couple of blueprints that have no assignee/approers
21:11:17 <armax> *approvers
21:11:25 <armax> in particular
21:11:36 <armax> #link https://blueprints.launchpad.net/neutron/+spec/add-tags-to-core-resources
21:11:43 <armax> anyone interested in taking it?
21:11:48 <garyk> armax: that would be gal
21:11:55 <armax> garyk: as approver
21:12:03 <ihrachys> that's an interesting one. does it depend on kevinbenton's attr table work though?
21:12:12 <armax> ihrachys: it does
21:12:25 <armax> kevinbenton’s change should be in the oven as we speak I think
21:12:35 <garyk> i would be happy to sponsir that one as i think that it is super importnat
21:12:37 <armax> kevinbenton: unless something catastrophic happened
21:12:43 <ihrachys> I could look at it since I looked at attrs these days already.
21:12:58 <ihrachys> but I already have two (though mostly on hold/handled)
21:12:59 <armax> ihrachys: you got 2, gary got 0
21:13:07 <dougwig> did we decide to allow arbitrary vendor fuckage, err, i mean, tags?
21:13:07 <armax> garyk wins
21:13:10 <armax> :)
21:13:12 <armax> either way
21:13:15 <garyk> i think that kevins lacks a lot of explanation and it may not cater for the tags
21:13:15 <armax> let’s pin this to gary
21:13:16 <ihrachys> armax: 'xactly
21:13:25 <armax> ihrachys: but you’re more than welcome to eyeball it
21:13:30 <mestery> dougwig: I hope not
21:13:57 <armax> then there’s regXboi’s instrumentation one
21:14:08 <kevinbenton> garyk: what is the issue?
21:14:10 <ihrachys> armax: I will eyeroll it :)
21:14:24 <garyk> kevinbenton: please see comments on the bug
21:14:24 <xgerman> mestery: +1
21:14:29 * regXboi want's to see ihrachys show an eyeroll on IRC
21:14:55 <amotoki> dougwig: the proposal is to add tags for API consumers, not for back-ends
21:15:10 <garyk> amotoki: +1
21:15:25 <armax> anyone is interested in taking regXboi’s bp?
21:15:29 <mestery> garyk amotoki: +1
21:15:36 <mestery> armax: The instrumentation one? I could work with regXboi on that one.
21:15:38 <armax> then we need assignee and approver for the fwaas v2
21:15:53 <sc68cal> that's me and xgearman?
21:15:58 <xgerman> Yep
21:16:10 <armax> mestery: you sure?
21:16:30 <mestery> armax: I've got one, and between dougwig and HenryG, that one is under control
21:16:31 <armax> you already have neutron-lib one
21:16:35 <salv-orlando> amotoki, dougwig: indeed the idea is to not pass the tags down to the plugin. Of course, eventually someone will find this extremely unfair and then we'll allow that, but that's for another release ;)
21:16:38 <mestery> Right, and it's going swimingly
21:16:48 <armax> is he? oh boy
21:16:51 <armax> is it
21:16:59 <mestery> Yes
21:17:00 <mestery> It is
21:17:01 <mestery> Thank you :)
21:17:06 <armax> mestery: :)
21:17:15 <armax> sc68cal: ok, ack
21:17:18 <dougwig> i'd volunteer to be approver for fw v2, since sean and xgerman will be submitters?
21:17:22 <amotoki> salv-orlando:  that's a fair concern :(
21:17:33 <armax> I also assigned get-me-network to HenryG
21:17:34 <xgerman> dougwig: awesome
21:17:45 <armax> russellb is neck deep with vlan-aware-vms
21:17:51 <russellb> drowning
21:17:53 <russellb> :-p
21:18:21 <regXboi> russellb: there are still bubbles at the surface, it can't be that bad :-P
21:18:25 <armax> sc68cal: who is going to do the bulk of the code for fwaas v2 you know?
21:18:27 <salv-orlando> I've looked at vlan-aware-vms today. It seems to me it mostly just a russellb vs armax thing now
21:18:38 * russellb hugs aranjan
21:18:40 <xgerman> Aish
21:18:41 <russellb> err, sorry aranjan
21:18:44 * russellb hugs armax
21:18:53 <armax> last man standing wins
21:18:56 <sc68cal> xgearman: uhhhh
21:18:58 <russellb> :)
21:19:04 * armax hugs russellb
21:19:09 <armax> :)
21:19:24 <armax> sc68cal: ok
21:19:25 <mestery> lots of love today
21:19:28 <sc68cal> armax: we have not determined it yet. Aish is not primary assignee
21:19:28 <garyk> vlnas are so 80's
21:19:39 <garyk> vlans
21:19:41 <amuller> garyk: they made a return with containers
21:19:43 <xgerman> Yep
21:19:59 <garyk> the return of the mainframe :)
21:20:05 <mestery> garyk: Hey! I resent that!
21:20:07 <mestery> ;)
21:20:12 <armax> sc68cal: ah ok, I got it wrong…let’s take this offline
21:20:18 <sc68cal> can we keep the cross talk to a minimum?
21:20:20 <russellb> would you rather we go with mpls-aware-vms?
21:20:24 <russellb> i could propose that instead
21:20:25 * regXboi hears faint strains of "the empire march"
21:20:31 <mestery> russellb: ++
21:20:41 <garyk> yeah that works for me
21:20:44 * regXboi is so glad he isn't drinking anything - the computer would be drenched
21:20:46 <salv-orlando> russellb: why not sentient vms?
21:20:53 <russellb> (vlan-aware-vms supports that as an additional segmentation_type actually :-)
21:20:54 <manjeets> russellb: mpls ?
21:21:04 <russellb> manjeets: don't mind me
21:21:07 <xgerman> Token ring?
21:21:09 <manjeets> ok
21:21:10 <armax> there was a thread on review focus
21:21:18 <armax> and work being targeted for mitaka
21:21:32 <armax> rossella_s was working on a nice dashboard to keep us in check
21:21:36 <regXboi> how about slotted aloha?
21:21:50 <armax> #link http://lists.openstack.org/pipermail/openstack-dev/2015-November/079816.html
21:21:56 <rossella_s> armax yes! feedback is welcome :)
21:22:12 <ihrachys> we seem to start getting lots of tools using launchpadlib lately
21:22:14 <amotoki> i see https://blueprints.launchpad.net/neutron/+spec/rename-tenant-to-project at the bottom of the list.
21:22:37 <regXboi> is there a link for the dashboard?
21:22:48 <armax> rossella_s: I did provide some…btw if the assignee keeps the bp whiteboard current, then the approver should have an easy life to know what to review
21:22:57 <amotoki> do we have a plan to tackle this in mitaka?
21:23:00 <mestery> armax: +100000 to that
21:23:18 <dougwig> i'd volunteer for the tenant one, but i think i'll have my hands full with neutron-lib. and i think that one is a sleeper.
21:23:23 <armax> amotoki: as of the keystone v3 one, there’s a bug assigned to mordred
21:23:41 <armax> that would make neutron work with v3
21:23:54 <armax> I initially thought that v2 was going away but then I found out that it’s no longer the case
21:23:59 <armax> russellb can vouch for that
21:24:01 <armax> I believe
21:24:26 <amotoki> armax: got it. thanks
21:24:36 <dasm> armax: yeah. both v2 and v3 in keystone ought to be supported
21:24:37 <armax> having API consistency across the wider ecosystem is nice though
21:25:08 <armax> but I don’t see any volunteers stepping up
21:25:13 <russellb> nice to knock that out earlier, rather than being a straggler (says the guy not volunteering for it)
21:25:34 <armax> even though from what I can see we should have fire power in order to handle it
21:25:48 <armax> I look here:
21:25:49 <armax> https://blueprints.launchpad.net/neutron/mitaka/+assignments
21:25:59 <armax> and I see lots of core dudes and gals missing
21:26:26 <armax> gals meaning ladies not gal sagie
21:26:29 <ihrachys> I hope we don't need to call out names ;)
21:26:35 <armax> ihrachys: no need
21:26:43 <armax> ihrachys: names are right there for anyone to see :)
21:26:53 <mestery> lol
21:26:57 <armax> or not
21:26:58 <ihrachys> armax: no, those names are NOT there
21:27:08 <armax> ihrachys: right, same difference
21:27:19 <ihrachys> and that's exactly the issue
21:27:38 <salv-orlando> ihrachys: well, call out names then ;)
21:27:50 <kevinbenton> Salvatore!
21:27:52 <armax> truth to be told the assignments do not capture the whole story
21:28:00 <ihrachys> salv-orlando: I am still young to believe in humanity
21:28:07 <mestery> armax: There are subtleties?
21:28:07 <armax> so let’s move on, I did say this meeting was indeed going to be short
21:28:13 <dasm> armax: if no one wants to look at renaming tenant to projects, i can try to do this.
21:28:37 <armax> dasm: devising a plan to start with would be helpful
21:28:43 <armax> we don’t even have that at the moment
21:28:50 <dougwig> dasm: several of us want to, but are over-subscribed. i'd be happy to review.
21:28:50 <dasm> +1
21:29:11 <armax> dasm is your LP handle?
21:29:17 <dasm> smigiel-dariusz
21:29:42 <amotoki> dasm: thanks for taking it. my idea is that API accepts both (project/tenant_id).
21:29:57 <garyk> i am sorry to push the process here but i think that we need a spec for the tenant-id <=> project
21:30:07 <armax> it’s right here:
21:30:08 <garyk> it requires discussion and there are a lot of implications here
21:30:11 <armax> https://blueprints.launchpad.net/neutron/+spec/rename-tenant-to-project
21:30:21 <manjeets> will it restricted to project only or both will be supported ?
21:30:36 <garyk> that is just the BP and it does not really discuss things
21:30:40 <salv-orlando> I think this has been discussed for quite some time. The first time was back in Portland.
21:30:42 <dougwig> i think armax referred to needing a plan first.  whether that's a spec, or devref, or ML thread, we can discuss there.
21:30:52 <armax> we’ll have to elaborate on the plan and a spec is most likely the place where the discussion will happen
21:30:58 <salv-orlando> but we never managed to put a plan together
21:31:33 <armax> salv-orlando: we never wanted to
21:31:45 <salv-orlando> armax: that is true as well.
21:31:51 <mestery> armax: Someone's gotta actually sign up, propose a plan, and then do it.
21:31:51 <armax> salv-orlando: :)
21:32:12 <dougwig> and not mess up the delicate things like upgrade and db migrations.  :)
21:32:16 <armax> mestery: I am mulling over some retaliation strategy :)
21:32:17 <salv-orlando> as you know this is a merge conflict train wreck. If it were me doing this, I would limit myself to the API level change
21:32:21 <mestery> dougwig: Details, details
21:32:28 <salv-orlando> leaving 'tenant' in all internal data structures and in the db schema
21:32:50 * armax digresses
21:32:53 <russellb> salv-orlando: +1
21:32:57 <dougwig> column rename will obliterate rolling upgrade, but that's a digression for another time.
21:33:08 <salv-orlando> but since it is not me doing this... meh! I'll just pick up a paintbrush and a random color ;)
21:33:16 <mestery> lol
21:33:16 <amotoki> i like salv-orlando's idea as a first step.
21:33:18 <ihrachys> it is also an expensive unneeded contract migration.
21:33:21 <dasm> salv-orlando: xD
21:33:39 <mestery> armax: I thought you said this meeting would be short?
21:33:42 <mordred> just reading the blueprint now
21:33:48 <mordred> (hey all)
21:33:48 <armax> mestery: it’s still 33 minutes pat
21:33:49 <armax> past
21:33:52 * mestery waves at mordred
21:33:52 <regXboi> mestery: he jinxed it
21:34:05 <carl_baldwin> api only sounds good to me too
21:34:15 <armax> mordred: hi, I shamlessly pulled you in for bug 1503428
21:34:15 <openstack> bug 1503428 in neutron "Support keystone V3 API" [Medium,Confirmed] https://launchpad.net/bugs/1503428 - Assigned to Monty Taylor (mordred)
21:34:16 <mordred> I don't think updating the schema is particularly as useful as adding support for the word project to the API
21:34:25 <mordred> armax: yup. ossum
21:34:26 <armax> mordred: +1
21:34:41 <mordred> I'm guessing there are places in teh neutron api where tenant is used then?
21:34:52 <armax> mordred: yes there are
21:34:56 <mordred> _awesome_
21:35:43 <armax> let’s have dasm look into it
21:35:48 <mordred> woot
21:35:55 * mordred hands dasm a nice ham
21:35:56 <armax> and we’ll discuss during next week’s meeting
21:36:09 <dasm> agree
21:36:16 <armax> thanks dasm!
21:36:30 <armax> #topic Bugs!!!
21:36:51 <armax> garyk: it looks like it was a quite week? What’s your take?
21:36:56 * armax hands over the mic
21:37:03 <garyk> ok, a few things:
21:37:11 <garyk> last week the majority of bugs were lbaas
21:37:18 <mestery> yay for lbaas!
21:37:22 <garyk> this week they were access-control (aka rbac)
21:37:27 <garyk> kevin was on top of most
21:37:42 <garyk> there is one that is blocking - https://review.openstack.org/247019
21:37:54 <garyk> https://launchpad.net/bugs/1514810
21:37:54 <openstack> Launchpad bug 1514810 in neutron "Turning on 'enable_dhcp' on subnet update cause request failure for pluggable IPAM" [High,In progress] - Assigned to Gary Kotton (garyk)
21:37:54 <armax> I noticed we got a lot fewer bug reports than usual
21:38:21 * armax looks
21:38:38 <garyk> i still feel like we should have separate bugs repos for each stadioum project
21:38:44 <garyk> stadium project
21:38:56 <armax> garyk: blocking how?
21:39:09 <armax> garyk: you mean it’s a gate failure?
21:39:22 <neiljerram_bb> I thought we already have per-project bug repos
21:39:35 <garyk> what i means is that is some one decide to create a subnet without dhcp and then wants to enable it they cannot when using ipam
21:39:45 <armax> neiljerram_bb: we do, but neutron + neutron *-aas is a single deliverable
21:39:46 <salv-orlando> neiljerram_bb: perhaps it was meant to be "reps" not "repos"
21:39:52 <garyk> neiljerram_bb: no, not for lbaas, fwaas, etc.
21:39:56 <armax> and as such they are tracked with a single LP project
21:40:13 <armax> garyk as per governance current status
21:40:15 <neiljerram_bb> Ah yes, I remember that case now
21:40:16 <mestery> Yes, the single LP project keeps it simple
21:40:22 <armax> gary should that change, we’ll revisit
21:40:29 <armax> but as of now, one LP project it is
21:40:39 <garyk> mestery: i think that it complicates the triage and gives a misrepresentation of the core neutron bugs.
21:40:54 <armax> it doesn’t complicates it
21:40:57 <armax> bugs are bugs
21:40:59 <mestery> garyk: How so? I don't agree
21:41:00 <mestery> right
21:41:06 <armax> whether they target one project or another
21:41:07 <salv-orlando> armax: yeah but regardless of how they're tracked I think that from the neutron perspective it might make sense to have bug deputys which are comfortable enough with the subject matter. I just don't know if the community has enough volunteer
21:41:21 <garyk> when say 70% are lbass, fwaas and vpaas are those core?
21:41:41 * salv-orlando I shot the sheriff, but I did shot no deputy
21:41:41 <dougwig> i'm not sure that's a typical week, is it? if so, that's surprising.
21:41:52 <armax> salv-orlando: the deputy should reach out the sme in the areas to get help
21:42:04 <salv-orlando> armax: makes sense
21:42:08 <armax> no-one is asking a single individual to do the whole heavy-lifting
21:42:08 <garyk> anyways, i pass the baton on to …?
21:42:22 <garyk> rossella_s: ?
21:42:23 <armax> as soon as you can see that a bug affects, let’s say vpnaas
21:42:30 <armax> what’s so complicated about it?
21:42:38 <rossella_s> garyk, yes
21:42:40 * salv-orlando this is thanksgiving week... it's going to be lighter ;)
21:42:43 <garyk> cool
21:42:44 <dougwig> garyk: find the LT for that area, pass on the triage.
21:42:46 <armax> having a different project would only make the bug report go to a differnt project
21:42:53 <manjeets> i thinks tags is enough for now
21:42:55 <armax> actually
21:43:22 <armax> I almost wonder if we should fold the client bug reports into the neutron
21:43:24 <armax> but let
21:43:30 <armax> but let’s not go there
21:43:49 <salv-orlando> armax: as the client has a different release model that might be tricky
21:43:54 <armax> salv-orlando: right
21:43:55 <dougwig> since the interface always get the filing, i can see the 'almost', yeah.
21:44:07 <armax> salv-orlando: that’s why I am saying…let’s not go there
21:44:29 <armax> garyk: anything else worth raising besides the blocker bug you pointed out?
21:44:49 <garyk> manjeets: fixed a bug that would have broken the gate if the client got updated.
21:44:53 <armax> as for splitting the LP project into the aas ones
21:45:07 <armax> prolly the best course of action is to start bike shedding on a governance patch change
21:45:10 <garyk> i am in a minority here. moving on douglass
21:45:13 <armax> garyk: feel free to post it
21:45:55 <armax> and then we can see whether we can split the LP projects
21:45:55 <garyk> nope, no more updates on the bugs.
21:46:20 <armax> but without that I think we’d be putting the kart ahead of the horse
21:46:29 <armax> garyk: ok, cool thanks very much for your help this week
21:46:33 <armax> next week deputy is rossella_s
21:46:40 <armax> what about the week after that
21:46:42 <armax> any takers?
21:46:54 <armax> come on, you know you want to
21:46:57 <dougwig> i can
21:47:06 <regXboi> armax: pass around the straws - short one gets the node
21:47:16 <armax> we have a winner of a $100 amazon gift card!
21:47:24 <manjeets> who
21:47:50 <Sukhdev> wow!!! do I hear bribes going on here?
21:47:55 <armax> you didn’t see that coming did you?
21:48:15 <armax> #action dougwig bug deputy for teh week of Nov-30
21:48:21 <armax> Sukhdev: not bribes
21:48:22 <regXboi> armax: is that gift card branded with Monty Python's Inquisition?
21:48:23 <armax> incentives
21:48:26 * ihrachys is back to being highly motivated
21:48:30 <dasm> Sukhdev: it's after volunteering, so it's _probably_ not a bribe
21:48:46 <armax> moving on
21:48:50 <armax> #topic Docs
21:48:57 <armax> emagana is not here :(
21:49:20 <armax> #topic Open Discussion
21:49:30 <armax> dougwig: you’re up
21:49:35 * armax hands over the mike
21:50:00 <edgar> armax: I am actually here!
21:50:03 <kevinbenton> i think dougwig is gone
21:50:06 <dougwig> work on neutron-lib has started, and we pulled over neutron.i18n, because so many use it.  amotoki mentioned that each repo needs its own, so it gets its own catalog.  but we have not been doing that.  it's only about six lines of code, so i'm cool either way, but what do the i18n folks have to say?
21:50:14 <armax> edgar: oops
21:50:19 <dougwig> kevinbenton: no, dougwig is driving through nevada, hoping his LTE connection holds
21:50:21 <edgar> armax: n.p.
21:50:26 <edgar> dont want to change the meeting
21:50:30 <edgar> just keep going
21:50:43 <amotoki> dougwig: that is my understanding on i18n. I need to investigate more.
21:50:45 <armax> edgar: ok, feel free to chime in, I didn’t see your usual handle
21:51:06 <ihrachys> I believe catalog is defined by a string. so I would have a wrapper that gets the string and does remaining magic.
21:51:11 <edgar> armax: yeap.. I got a new laptop and all needs to be re-configured!
21:51:24 <amotoki> dougwig: it is not a blocker at the moment. I can investigate the right approach.
21:51:29 <dougwig> amotoki: we'll need to merge the one in neutron-lib either way; the question is whether we export it for other projects to use. and if we go fix all the subprojects that are grabbing it from neutron.
21:51:41 <dougwig> amotoki: ok, thanks.
21:51:44 <armax> dougwig: as far as I can tell it makes sense to move it, I have seen many projects using it
21:51:51 <amotoki> dougwig: my vote is to leave i18n stuff as-is.
21:51:55 <armax> dougwig: I wonder if it needs to be wrapped as ihrachys suggested
21:52:20 <dougwig> amotoki: it's not a leave or not issue.  it's a use it once from neutron-lib, or clone it everywhere.  because they all have strings, even the lib.
21:52:24 <armax> dougwig: what I mean, is we can have one in neutron-lib that neutron will eventually move on to
21:52:41 <dougwig> armax: right, the old entry point sticks around until N no matter what.
21:52:50 <armax> dougwig: and anything else that cares about it can use it from there
21:53:37 <ihrachys> well my understanding of i18n stuff from old times when I did led some i18n work suggests that every project should have its own catalog, otherwise there is no way for them to provide translations because you don't merge compiled i18n .mo files, so they just use whatever is translated for neutron, and nothing for their own unique messages, and most of their i18n marks are wasted.
21:54:06 <dougwig> armax: i think the point is how we libify in a way that lets neutron and networking-vendorA have different message catalogs. not how we invoke the code. and i'm not clear enough on openstack i18n to know the answer.
21:54:15 <ihrachys> I guess each repo should have its own catalog, *aas repos included.
21:54:32 <dougwig> ihrachys: and is it the gettext call in the base __init__ that sets that up? or something else?
21:54:47 <armax> dougwig: do we know who would know the answer to this question?
21:55:02 <armax> dougwig: perhaps we’re not even the right crowd
21:55:06 <dougwig> armax: no, i was hoping someone here would know, or who to ask. i'll head to the ML next, if not.
21:55:14 <dougwig> but amotoki volunteered to research
21:55:48 <armax> dougwig: ok cool
21:55:51 <amotoki> dougwig: you can go :-)
21:56:07 <dougwig> haha, ok.
21:56:18 <dougwig> i think we can move to the next topic now.
21:56:23 <dougwig> ooh, down to one bar of signal.
21:56:33 <armax> dougwig: text and drive?
21:56:39 <armax> not good
21:56:40 <dougwig> armax: rose is driving.
21:56:44 <armax> dougwig: ah ok
21:56:46 <ihrachys> dougwig: https://github.com/openstack/neutron/blob/master/neutron/i18n.py#L17 all that is different per project is that domain= string. so that should be a param for the wrapper that would probably return a set of _L* functions.
21:57:25 <armax> we got 4 mins left to what seemed to be a very short meeting for me
21:57:26 * armax ducks
21:57:45 <armax> anyone else has to mention anything else? wedding, parties?
21:57:47 <mlavalle> armax: you jinxed it
21:57:53 <armax> mlavalle: I did it on purpose
21:57:59 <mlavalle> LOL
21:58:10 <ihrachys> they always say that afterwards
21:58:22 <armax> mlavalle: what would I do otherwise? I though the PTL dude only chore was startmeeting/stopmeeting on irc
21:58:52 <neiljerram_bb> That sounds like your cue for...
21:58:58 <armax> #endmeeting