21:00:42 <armax> #startmeeting networking
21:00:44 <openstack> Meeting started Mon Aug 17 21:00:42 2015 UTC and is due to finish in 60 minutes.  The chair is armax. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:45 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:48 <openstack> The meeting name has been set to 'networking'
21:01:17 <dougwig> o/
21:01:18 <anteaya> <-- sitting in a plane, waiting to take off
21:01:29 <armax> #link https://wiki.openstack.org/wiki/Network/Meetings Agenda
21:01:45 <Sukhdev> anteaya: have a safe flight
21:01:54 <anteaya> Sukhdev: thanks
21:02:20 <armax> #topic Announcements
21:02:34 <armax> #link https://wiki.openstack.org/wiki/Liberty_Release_Schedule
21:02:42 <yamahata> hi
21:02:51 <armax> Liberty-3 is 2 weeks away
21:03:28 <HenryG> Does that count for stadium repos too?
21:03:34 <armax> #link https://wiki.openstack.org/wiki/ReleaseNotes/Liberty#OpenStack_Liberty_Release_Notes
21:03:52 <armax> HenryG: I wouldn’t think so
21:04:17 <armax> HenryG: each repo has its own release schedule
21:04:23 <armax> HenryG: so it depends
21:04:40 <dougwig> HenryG: you can look at the repo tags in the governance file to see which is which w.r.t. release
21:04:48 <Sukhdev> armax: I thought they will tag the repos along with the main release, no?
21:04:57 <armax> #link https://github.com/openstack/governance/blob/master/reference/projects.yaml#L1241
21:05:09 <salv-orl_> Sukhdev: where they are?
21:05:31 <salv-orl_> sorry I mean what do you meant by "they"
21:05:38 <Sukhdev> salv-orl_: the infra folks - I thought they will be tagging the releases
21:05:39 <armax> HenryG, Sukhdev look for the release tag
21:05:46 <anteaya> the release team taeks care of what they are responsible fore
21:05:59 <anteaya> infra tags zero releases
21:06:08 <anteaya> well except for infra tools
21:06:32 <salv-orl_> I think openstack-infra has already thousands of duties. They surely don't want to fiddle with release tags too
21:06:35 <armax> the Neutron stable team might, but I understand that the process is still happening
21:06:56 <armax> when mestery is around he’ll be able to provide more input
21:07:22 <armax> #action mestery to clarify release process for neutron stadium repos
21:07:48 <armax> he’ll probably need to file a patch to http://git.openstack.org/cgit/openstack/neutron/tree/doc/source/policies
21:08:21 <armax> #link http://git.openstack.org/cgit/openstack/neutron/tree/doc/source/policies/office-hours.rst
21:08:27 <armax> looks interesting
21:08:46 <armax> anyhoo moving on?
21:09:21 <armax> moving on...
21:09:22 <armax> #topic Bugs
21:09:24 <salv-orl_> yes moooooooving on
21:09:33 <salv-orl_> baaaaaaags ;)
21:10:00 <armax> we got a number of baaaaags to look at
21:10:25 <armax> bug 1404743
21:10:25 <openstack> bug 1404743 in neutron "sporadic test failures due to VMs not getting a DHCP lease" [Critical,In progress] https://launchpad.net/bugs/1404743 - Assigned to Ryan Moats (rmoats)
21:10:31 <regXboi> yes?
21:10:44 <regXboi> I'm preparing to call this closable
21:10:59 <armax> ok
21:11:09 <regXboi> I've not seen spurious SSH timeouts since 8/11 - it looks like infra's fix of the nodepool bug got this one as well
21:11:15 <armax> regXboi: no longer lurking around?
21:11:28 <regXboi> regXboi: I'm always lurking :)
21:11:59 <regXboi> armax: I'm still seeing the timeouts - but in general, that's because the code is messed up, not the infra
21:12:03 <armax> regXboi: there was a fix from kevinbenton
21:12:06 <armax> #link https://review.openstack.org/#/c/181674/
21:12:39 <regXboi> armax: I don't think that's necessary at this time
21:12:45 <armax> that was supposed to synchronize l2 and dhcp, perhaps it’s worh a look in this context?
21:13:06 <armax> regXboi: not exactly the same failure mode
21:13:24 <regXboi> armax: no, not exactly the same failure mode, but I'm not seeing it either
21:13:26 <armax> sorry I mean root cause, but same failure mode?
21:13:56 <regXboi> so, bottom line is that I have to update the bug (assuming the 7d kibana clears)
21:14:01 <regXboi> and declare it closable for now
21:14:08 <regXboi> and if it comes back, we hunt it some more
21:14:14 <armax> ultimately all issues lead to lack of connectivity
21:14:14 <armax> ok
21:14:52 <armax> bug 1477192
21:14:52 <openstack> bug 1477192 in neutron "neutron test_multi_prefix_slaac failing in the gate with ping failures starting around 7/22" [High,Confirmed] https://launchpad.net/bugs/1477192 - Assigned to Henry Gessau (gessau)
21:14:56 <armax> HenryG: you’re up
21:15:07 <HenryG> The logstash query was wrong
21:15:17 <HenryG> https://review.openstack.org/212180
21:15:30 <HenryG> AFAICT the bug is no longer happening
21:15:42 <HenryG> But I don't know when it stopped or what fixed it
21:15:53 <armax> HenryG: don’t you love when bugs just go away on their own?
21:16:06 <HenryG> they are the best and the worst
21:16:17 <armax> mlavalle: same faith to bug 1461172?
21:16:17 <openstack> bug 1461172 in neutron "neutron.tests.functional.agent.test_l3_agent.MetadataL3AgentTestCase.test_access_to_metadata_proxy times out intermittently" [High,Confirmed] https://launchpad.net/bugs/1461172 - Assigned to Miguel Lavalle (minsel)
21:16:17 <anteaya> when the pop up again
21:16:19 <salv-orl_> armax: I think we're old enough to know that it's not true
21:16:32 * mestery wanders in late
21:16:34 <armax> salv-orl_: I was making a joke ;)
21:16:36 <mlavalle> armax: I just started looking at this bug this morning
21:16:38 <salv-orl_> bugs tend to hide very well to stab you in the back when you less expect it
21:17:10 <mlavalle> armax: I haven't been able to reproduce in my local system.... I've been running it all day long
21:17:23 <mlavalle> so it is going to take some "sleuthing"
21:17:28 <armax> #chair mestery
21:17:29 <openstack> Current chairs: armax mestery
21:17:38 <mestery> armax: Thanks ... I think o_O
21:17:57 <armax> mestery: I bow and get myself at ease
21:18:08 <mestery> armax: Where are we in the agenda now?
21:18:15 <regXboi> folks ... remember that infra had a bug in nodepool where multiple nodes would get the same IP address
21:18:15 <mestery> Apologies for being late, had a late lunch at Linuxcon today ;)
21:18:17 <armax> mestery: bugs
21:18:19 <salv-orl_> mestery: roaches
21:18:27 <regXboi> ALL of these sound like they could have been caused by this
21:18:38 <armax> mestery: we at at number 4 of the lot
21:18:54 <mestery> armax: OK, shall we move on to #5 now?
21:19:05 <ihrachyshka> regXboi, was nodepool fixed? because afaik I see it failing again on that test (the .gitreview patch)
21:19:31 <regXboi> ihrachyshka: my understanding was the particular problem related to IP addresses was fixed
21:19:48 <armax> well bug 1439696 (#4) wasn’t discussed yet
21:19:48 <openstack> bug 1439696 in neutron "Referencing a lb-healthmonitor ID for the first time from Heat would fail" [High,Confirmed] https://launchpad.net/bugs/1439696 - Assigned to Doug Wiegley (dougwig)
21:20:01 <armax> dougwig will probably tell us that the bug no longer shows up?
21:20:44 <salv-orl_> armax: probably dougwig itself no longer show sup ;)
21:21:06 <mestery> Well, with regards to https://bugs.launchpad.net/neutron/+bug/1439696
21:21:06 <openstack> Launchpad bug 1439696 in neutron "Referencing a lb-healthmonitor ID for the first time from Heat would fail" [High,Confirmed] - Assigned to Doug Wiegley (dougwig)
21:21:08 <armax> poor dougwig
21:21:17 <mestery> I know dougwig has been busy saving our stable *aaS lately ;)
21:21:33 <dougwig> i haven't looked at anything but the gate bombs since last week.
21:21:37 <regXboi> mestery: really?!?!?! you'd stoop to that pun?
21:21:38 <dougwig> wow, that was horrible, mestery
21:21:44 <mestery> lol
21:21:52 <mestery> I'm sorry
21:22:03 <mestery> dougwig: Any update on said bug?
21:22:54 <dougwig> this change to neutron-server should fix the gate: https://review.openstack.org/#/c/213750/
21:23:11 <dougwig> waiting for merge to get it into stable, though you can see the build test here https://review.openstack.org/#/c/213751/
21:23:36 <mestery> dougwig: markmcclain and I just sent 213751 iunto hte merge queue once it passes check
21:23:47 * armax gives dougwig  a gold start
21:23:51 <armax> *star
21:24:01 <dougwig> mestery: great, then we can move on to re-peeling that onion in on-crisis.
21:24:03 * regXboi wanted to see a gold start
21:24:05 <mestery> armax: thank goodness for the correctoin, I was wondering what a gold start was
21:24:10 <dougwig> non-crisis, even.
21:24:25 <mestery> dougwig: The entire OpenStack ecosystem owes you a debt of gratitude here (seriously)
21:24:33 <mestery> thanks for being awesome
21:24:43 <mestery> Shall we move along to the next bug in the list?
21:24:54 <armax> dougwig: I am greatly annoyed by the fact that you did not address my comment, but I am moving on
21:25:14 <dougwig> armax: your comment was most excellent, too.
21:25:16 * mestery gives armax a stern look
21:25:20 <armax> dougwig: I know, right?
21:25:36 <mestery> armax: Please, salv-orl_ is our pedantic reviwer, you cannot replace him
21:25:49 * armax feels useless now
21:26:00 * Sukhdev makes observation that everybody is some really good cool-aid...
21:26:01 <regXboi> under the heading of crisis... can we get the dashboard patch merged?
21:26:25 <mestery> regXboi: Link?
21:26:27 * regXboi shuts up until open mike
21:26:36 <mestery> regXboi: I'll +2 that thing so fast you won't know it didn't already have my +2
21:26:50 <regXboi> mestery: you already have +2'd it
21:26:54 <regXboi> https://review.openstack.org/#/c/213141/
21:27:06 <anteaya> regXboi: he speaks truth
21:27:10 <regXboi> #link https://review.openstack.org/#/c/213141/ initial dashboard patch
21:27:12 <mestery> regXboi: armax dougwig carl_baldwin any other voters here?
21:27:24 <mestery> anteaya: lol
21:27:26 <regXboi> mestery: nope ... lots of quiet
21:27:52 <regXboi> I did have a pedantic review from salv-orl_ but that was PS 1 :)
21:28:11 <armax> mestery: I don’t vote to projects that don’t start with n
21:28:27 <armax> mestery: darn
21:28:33 <armax> I shot myself in the foot
21:28:40 <regXboi> anyway.... back to bugs ;)
21:28:45 <salv-orl_> regXboi: still you turned a blind eye to my comment about using hitcound
21:28:49 <salv-orl_> *hitcount
21:28:53 <salv-orl_> but that's ok
21:28:53 <armax> I thought this was some fanky dashboard project
21:29:03 <mestery> armax: busted!
21:29:06 <regXboi> salv-orl_: No - I replied that somebody else was welcome to do that
21:29:19 <regXboi> salv-orl_: I wasn't going to at this point
21:29:43 <salv-orl_> ah I see... regXboi is going to challenge me also as chief neutron procrastinator
21:29:51 <mestery> armax: thanks for merging that one
21:29:56 <mestery> Shall we trot along now?
21:30:00 <dougwig> regXboi: one question, slipped into the wave of +2's.
21:30:05 <armax> mestery: trot away
21:30:13 <mestery> lol
21:30:19 <mestery> dougwig: That's what followups are for
21:30:44 <regXboi> dougwig and haleyb: ack - I'll get them both on the followup
21:30:50 <mestery> haleyb: Nice comment, you're fighting with armax for pedantic commenter of the day ;)
21:30:54 <armax> mestery: by the way important notice
21:31:03 <regXboi> dougwig: and no, it's not machine generated ....
21:31:03 <mestery> armax: ???
21:31:07 <armax> mestery: change https://review.openstack.org/#/c/199672/ is in the merge queue
21:31:14 <dougwig> regXboi: then i fear for your soul. :)
21:31:17 <haleyb> mestery: i can find a nit in a haystack
21:31:23 <armax> mestery: that will bring back pymysql and api_workers > 0
21:31:35 <regXboi> dougwig: I'm not sure I have a soul - you haven't seen some of the evilness I cook up in code
21:31:38 <armax> mestery: which ihrachyshka and sc68cal reverted because it caused havoc
21:31:40 <mestery> armax: I'm unsure how to feel, but I trust in you
21:31:52 * mestery sings the Monkee's "I'm a Believer"
21:31:52 <armax> mestery: allegedly I have a fix
21:32:03 <sc68cal> armax: we'll keep rechecking to verify
21:32:03 <mestery> armax: I knew you did
21:32:11 * regXboi lurks until open mike :)
21:32:30 <armax> mestery: but the culprit is disable now, so we can only wait for other issues to crop up
21:32:43 <ihrachyshka> armax, I hope you will be able to discuss the fwaas fix after the meeting
21:32:45 <mestery> 28 minutes left and some serious things to discuss soon
21:33:16 * salv-orl_ wears his bikeshedder hat
21:33:21 <mestery> Shall we move past bugs and into a docs update from sc68cal?
21:33:23 <regXboi> mestery: summon seriousness
21:33:28 <russellb> nice work on sorting through the pymysql and api_workers stuff
21:33:31 <russellb> really important stuff
21:33:37 <mestery> russellb: ++
21:33:41 <armax> ihrachyshka: I need to dash to a meeting after this, but I am happy to take this offline
21:33:47 <ihrachyshka> armax, ack
21:34:23 <armax> salv-orl_: shed away?
21:34:33 <mestery> yes
21:34:35 <mestery> Lets move along
21:34:41 <mestery> #topic Docs
21:34:47 <mestery> sc68cal: I hear you're going to update this week?
21:34:48 <mestery> Is it so?
21:34:58 <sc68cal> Yes - I think Edgar is AFK
21:35:25 <sc68cal> Sam-I-Am discussed a concern that he has about the networking guide
21:35:27 <armax> sc68cal: by the way, I got like 14 straight passes…but I am sure I’ll be proved wrong when it matters the most
21:35:43 <sc68cal> armax: well even 14 out of 15 LGTM
21:35:48 <sc68cal> anyway
21:36:11 <sc68cal> Sam-I-Am is concerned that (eventually) the networking guide is going to get stale, and he wants more buy-in from the neutron community to help maintain and expand
21:36:28 <sc68cal> we have a lot of holes in the first section of the networking guide where we introduce basic concepts
21:36:36 * anteaya hears the captain say we will be taking off soon
21:36:49 * regXboi waves good bye to anteaya
21:36:56 <sc68cal> I think mestery has a request about doing a deployment scenario where we have a provider net *and* l3 networking via the l3 agent
21:37:04 <anteaya> :)
21:37:20 <mestery> anteaya: Safe travels
21:37:25 <anteaya> mestery: thanks
21:37:33 <sc68cal> mestery: am I also correct that some of the neutron devref has overlap and content that could be moved to the networking guide?
21:37:35 <mestery> sc68cal: Sounds good
21:37:46 <mestery> sc68cal: You are correct, we need to sort that out
21:38:34 <sc68cal> I'm paraphrasing what Sam-I-Am said in an e-mail, so I could be wrong about some things, but I think we have a great piece of docs that has really turned around opinions about neutron
21:38:48 <mestery> sc68cal: Indeed!
21:38:59 <russellb> is devref being in neutron making it easier to keep it up to date?
21:39:03 <mestery> sc68cal: Thanks to efforts of all in the community, the tide is rising now
21:39:14 <russellb> and if so, and if neutron team needs to take more ownership of keeping it up to date, how crazy would it be to bring it into neutron?
21:39:37 <armax> mestery: I don’t have my floaties on
21:39:40 <sc68cal> I think we are getting better at devref
21:39:55 <mestery> armax: You need one of those floaty vests, not just the arm ones
21:39:55 <sc68cal> but for a long time it was fairly neglected - I get to say this since I wrote a big part of it back in the day
21:40:06 <russellb> in the latter comment, i meant bringing the networking guide into neutron
21:40:10 <armax> I have a big belly, it won’t fit
21:40:11 <sc68cal> I don't know if we are going to do better by moving it around
21:40:19 <russellb> sc68cal: ok fair
21:40:32 <russellb> could also try to develop some guidelines around what types of changes should also have networking guide updates
21:40:41 <russellb> and try to make a point of raising a stink about it during code review
21:40:42 <sc68cal> based on my experience, the docs people also need more technical eyes on things
21:40:51 <mestery> armax: moar exercise
21:41:03 <russellb> like, "we won't merge this until you have corresponding networking guide updates too"
21:41:03 <salv-orl_> russellb: even if I see your point I also think that "bringing it into neutron" implies, in some way, that devs will control it.
21:41:03 <mestery> russellb: ++
21:41:17 * regXboi wonders if part of the +2 "doing what needs to be done" should move to watch docs as well as the gate
21:41:21 <russellb> salv-orl_: yeah, that's a problem of moving it
21:41:23 <mestery> If it's a gerrit permission thing, we can work around that
21:41:24 <sc68cal> russellb: I have taken that tact on some patches I've seen
21:41:29 <salv-orl_> and honestly I think devs are not really the right guys to write something like the networking guide
21:41:29 <russellb> sc68cal: nice
21:41:35 <mestery> E.g. give docs devs +2 in Neutron with the trust they will only merge things there
21:41:38 <mestery> Just a thought
21:41:43 * regXboi also realizes that's a big tar baby
21:41:47 <salv-orl_> we need somebody who clearly communicates concepts, problems and solutions ;)
21:41:47 <russellb> salv-orl_: what?! all devs aren't all excellent authors and communicators?  :)
21:41:53 <sc68cal> russellb: mostly just on devref side, but sambetts and john_davidge have done well on the IPv6 PD docs
21:42:04 <mestery> salv-orl_: Unicorns!
21:42:04 <sc68cal> they've been moving along with the actual functionality patches
21:42:14 <salv-orl_> russellb: if by communication you mean entropy and chaos, yes
21:42:22 * mestery notes we have 3 more items on the agenda so in 2.5 minutes we need to keep the train moving along
21:42:33 <sc68cal> salv-orl_: well... I did do a talk at Vancouver about working with docs people and being an SME......
21:42:41 <regXboi> mestery: my wondering above ^^^^^
21:42:42 <russellb> mestery: sir yes sir, i shall sit back down!
21:42:46 <salv-orl_> sc68cal: but you're one of a kind ;)
21:42:48 <mestery> lol
21:43:06 <sc68cal> salv-orl_: haha, that's very kind
21:43:28 <sc68cal> anyawy, that's the big thing I wanted to get out there, and if anyone is interested please talk to Edgar, Sam-I-Am, or I
21:43:40 * sc68cal is ready to move on
21:43:42 <mestery> Thanks sc68cal
21:43:44 <mestery> OK
21:43:46 <mestery> Lets move long
21:44:03 <mestery> #topic Neutron interactions with infra
21:44:08 <mestery> I put this on teh agenda at the request of dougwig
21:44:17 <clarkb> anteaya had to shutdown the laptop but I am lurking
21:44:23 <mestery> tl;dr: We need to cooridnate these interactions through dougwig armax and myself
21:44:25 <mestery> clarkb: Thanks sir!
21:44:29 * regXboi tries to find a deeper hole to lurk in
21:44:40 <dougwig> beginnings of a writeup here: https://review.openstack.org/#/c/212622/
21:44:43 <mestery> Because at best we sometimes end confusing things and at worst we step on each other
21:44:45 <russellb> almost sounds like a liaison
21:44:48 <mestery> #link https://review.openstack.org/#/c/212622/
21:44:52 <sc68cal> russellb: ++
21:44:56 <xgerman> ++
21:45:04 <mestery> russellb: Lieutenants
21:45:05 <mestery> :)
21:45:07 <dougwig> but yeah, the gist is that with our proliferation of repos, so is our load on infra, so we're trying to better utilize our own knowledge before using their time.
21:45:10 <armax> mestery I am still waiting for my pager
21:45:19 <Sukhdev> will this model scale?
21:45:20 <regXboi> so... dougwig, armax, mestery: https://review.openstack.org/#/c/212058 and upcoming similar patch for DVR
21:45:34 <mestery> Sukhdev: Yes
21:45:47 <mestery> regXboi: Get that on armax and dougwig's radar for coordination
21:45:56 <mestery> I think we're still sorting out HOW this interaction will work
21:45:58 <dougwig> Sukhdev: i would argue that what we're doing *right now* is not scaling, so i'd hope so.
21:46:03 <mestery> But we're congizant we need it
21:46:04 <russellb> mestery: so infra lieutenant == liaison to infra :)
21:46:07 <regXboi> mestery: that's what ^^^^^^^ was about
21:46:11 <dougwig> russellb: yes
21:46:11 <mestery> russellb: Yuppers :)
21:46:14 <Sukhdev> mestery: OK - lets give it a try and see how it works out - if none of you reply on IRC, then is it OK to go to inra channel?
21:46:16 <russellb> ++
21:46:32 <mestery> Sukhdev: I gave dougwig a pager, let me get you his number :)
21:46:44 <dougwig> Sukhdev: of course, excepting asking for heroic measures.
21:46:53 <mestery> Right
21:46:53 <Sukhdev> mestery:  ha ha - perfect !!!
21:46:56 <clarkb> should infra expect to not merge random changes related to infra without the liason ACKing them?
21:46:56 * regXboi is suspicious of round robin pager forwarding
21:47:03 <mestery> Lets be reasonable with the requests
21:47:05 <mestery> Only I have dougwig and armax's bat numbers
21:47:15 <mestery> clarkb: I think that makes a lot of sense, yes
21:47:21 <mestery> clarkb: That's one way to coordinate it for sure
21:47:26 <mestery> clarkb: Require a +1 from armax dougwig or me
21:47:35 <clarkb> ok
21:47:44 <clarkb> I will try to advertise that in infra land
21:47:44 <regXboi> mestery: how about 2 +1s ?
21:47:45 <mestery> dougwig armax: Sound reasonable?
21:47:47 <russellb> presumably for the core neutron jobs / configs right?
21:47:48 <armax> seems reasonable
21:47:55 <mestery> russellb: Yes
21:47:59 * russellb nods
21:47:59 <clarkb> russellb: ya
21:48:09 <Sukhdev> regXboi: please no
21:48:09 <mestery> Awesome!
21:48:17 <regXboi> Sukhdev: just asking
21:48:22 <neiljerram_bb> Perhaps add sthg to http://docs.openstack.org/infra/manual/creators.html about altered process for Neutron stadium projects?
21:48:33 <mestery> #action Infra to not merge neutron job / config changes without +1 votes from armax dougwig and / or mestery
21:48:37 <Sukhdev> regXboi: those kind of questions are banned here :-):-)
21:48:51 <salv-orl_> regXboi: I will call mestery's law of transitional trust to assert that 2 +1s are not necessary
21:48:53 * regXboi is going to be *SO* banned then
21:48:55 <dougwig> mestery: let's make sure that makes it into the devref review.
21:49:25 <Sukhdev> regXboi: you are not banned - those kinds of question are banned :-)
21:49:32 <mestery> dougwig: ++
21:49:34 <mestery> neiljerram_bb: Good idea
21:49:37 <russellb> thanks for taking on this responsibility guys :)
21:49:43 <mestery> :)
21:49:45 <markmcclain> mestery: shouldn't that be "#agreed" ?
21:49:51 <mestery> #undo
21:49:52 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0xa0c1150>
21:49:58 <johnsom> dougwig We have an open add Octavia to projects list: https://review.openstack.org/#/c/211319/1
21:50:04 <mestery> #agreed Infra to not merge neutron job / config changes without +1 votes from armax dougwig and / or mestery
21:50:04 <mestery> thanks markmcclain :)
21:50:11 <mestery> OK 10 minutes left
21:50:19 <mestery> 2 agenda items and a possible ninja merge request coming up ...
21:50:21 <mestery> Lets move along
21:50:24 <clarkb> keep in mind we may merge things without the +1 in an emergency
21:50:34 <clarkb> but business as usual should be to incoporate the liason feedback
21:50:48 <mestery> clarkb: Yyp
21:50:50 <mestery> *Yup
21:51:01 <dougwig> clarkb: of course.
21:51:03 <mestery> #topic Vendor Decomposition
21:51:05 <mestery> armax HenryG: Is this your section?
21:51:19 <russellb> split out all the codes!
21:51:39 <mestery> Or did you guys not add this to the agenda?
21:51:40 <HenryG> Yes, I wanted to know if we need to keep the requirements.txt files around?
21:51:44 <salv-orl_> clarkb: if an emergency comes up during US zzzz times the infra folks down under can ping me
21:51:46 <regXboi> dougwig: devref updated
21:52:22 <Sukhdev> What is the answer to HenryG's question?
21:52:29 <HenryG> There were some packaging concerns which I don't understand
21:52:42 <mestery> HenryG: What is the question?
21:52:54 <salv-orl_> HenryG: the requirements.txt in the plugins' path in openstack/neutron ?
21:52:57 <Sukhdev> those requirement files were placed there to deal with the distro issues
21:53:10 <Sukhdev> salv-orl_: yes
21:53:10 <amotoki> requirements.txt in vendor dirs are used to declare which vender lib should be used.
21:53:24 <russellb> move them to external repo, right?
21:53:30 <russellb> what's the issue?
21:53:35 <salv-orl_> I think they can go as they serve no purpose. Distro packagers can add more but I really feel there's no use for the,
21:53:37 <mestery> Yes, I don't follow the issue either
21:53:47 <salv-orl_> and the external repos have their own requirements.txt
21:53:49 <amotoki> these are for distributros and users. I think it can be covered by external repos or docs.
21:53:51 <HenryG> russellb: moving them makes them self-referential
21:54:01 <russellb> oh, then they don't sound useful
21:54:13 <ihrachyshka> yeah, RDO does not rely on those at all. and it's assumed that it's fine to take a vendor release of corresponding branch
21:54:28 <HenryG> Great, let's nuke 'em
21:54:29 <salv-orl_> they were established to pin specific versions of the plugin library
21:54:42 <salv-orl_> but there is no way to enforce them without triggering a circular reference
21:54:47 <mestery> HenryG: ++
21:54:57 <Sukhdev> ihrachyshka: earlier, it was understood that RDO looks at these requirement files and pulls the appropriate code from the respective repos
21:55:01 <russellb> salv-orl_: plugins need to make sane releases that line up to neutron releases in some way that makes sense, i'd say :)
21:55:14 <armax> those files were purely informational
21:55:15 <Sukhdev> ihrachyshka: so, we are saying that understanding is inaccurate?
21:55:19 <russellb> requirements files are just docs as far as distros are concerned
21:55:20 <ihrachyshka> salv-orl_, yeap. and pinning is usually effectively based on which branch you release from.
21:55:24 <russellb> not directly consumed
21:55:29 <armax> if no-one is consuming them, then they might as well go
21:55:35 <ihrachyshka> Sukhdev, I don't believe there is any automation around it.
21:55:44 <salv-orl_> ok so nobody disagrees with removing the
21:55:46 <salv-orl_> them
21:55:46 <regXboi> mestery: open mike?
21:55:54 <amotoki> +1 for removing
21:55:55 <mestery> regXboi: Almost
21:55:57 * salv-orl_ thinks there 1 more item
21:55:57 <russellb> violent agreement to remove :)
21:56:15 <mestery> #agreed Nuke vendor requirements.txt files
21:56:16 <salv-orl_> russellb: but we can still bikeshed on how to remove them
21:56:27 <mestery> OK, lets move along
21:56:28 <russellb> ha
21:56:38 <armax> mestery: please tag me along the the review when that happens
21:56:48 <ihrachyshka> I suggest to ask other packagers though
21:56:50 <mestery> armax: Absolutely my lord
21:57:03 <mestery> ihrachyshka: ML post?
21:57:05 <russellb> might be worth talking about some release coordination around all the separate plugin repos
21:57:10 <ihrachyshka> mestery, yes, with [packaging]
21:57:12 <russellb> but that can be a topic for later ...
21:57:15 <mestery> russellb: Taht's the next tiem on the agenda
21:57:17 <emagana> I just was able to get online!  My apologies folks!
21:57:20 <russellb> mestery: ha!
21:57:22 <mestery> Though 3 mintues left
21:57:22 <russellb> amazing.
21:57:25 <mestery> Not enough time I think
21:57:33 <mestery> russellb: It's like I planted that one with you! ;)
21:57:35 <mestery> OK
21:57:46 <mestery> We will ahve to discuss release coordination of networking projects next week
21:57:47 <salv-orl_> mestery: we can agree that we should coordinate. And next week we can decide how
21:57:49 <mestery> As we have 2 minutes left
21:57:53 <mestery> salv-orl_: ++
21:57:56 <mestery> #topic Open Discussion
21:57:57 <russellb> tag/release all with neutron?  (that want to opt  in to that) ?
21:58:03 <mestery> 2 minutes left ...
21:58:04 <dougwig> how many of you will be at ops meetup?
21:58:11 <russellb> at linuxcon instead
21:58:17 <mestery> +1 to Linuxcon
21:58:28 <dougwig> enjoy your container-mania.
21:58:29 <emagana> I will be hosting a neutron feedback session
21:58:48 <russellb> linuxkvmxenmesosopencloudstackcontainerconforumsummit
21:58:56 <armax> emagana: that’s on wednesday right?
21:59:00 <regXboi> all... https://review.openstack.org/#/c/213474/ - the first instrumentation WiP is out there
21:59:03 <emagana> armax: Yes, it is.
21:59:03 <mestery> russellb: you forgot mesos I think
21:59:06 <dougwig> emagana: i'll be in the room, somewhere.
21:59:08 <russellb> mestery: it's in there!
21:59:09 <yushiro> mestery: I'd like to tell you some information fo my patch. https://review.openstack.org/#/c/203509/
21:59:14 <russellb> i'd love to see notes from ops feedback
21:59:16 <mestery> armax: You're representing for us too?
21:59:22 <emagana> armax: Actually is more about the networking model used by operators
21:59:24 <mestery> 30 seconds folks
21:59:28 <armax> I am popping by if something else doesn’t come up
21:59:31 <emagana> dougwig: Nice!
21:59:42 <mestery> yushiro: Lets do it on the review or #openstack-neutron
21:59:43 <armax> dougwig: make sure to say hello
21:59:43 <mestery> Out of time
21:59:46 <mestery> Thanks for attending everyoen!
21:59:51 <dougwig> armax, emagana: definitely
21:59:53 <armax> bye
21:59:54 <mestery> armax emagana: Knock them dead at the Ops Meetup this week :)
21:59:56 <Sukhdev> bye
21:59:57 <russellb> o/
22:00:00 <Swami> bye
22:00:03 <mestery> MOAR NEUTRON!
22:00:04 <mestery> #endmeeting