14:01:45 <mestery> #startmeeting networking
14:01:46 <openstack> Meeting started Tue Sep  9 14:01:45 2014 UTC and is due to finish in 60 minutes.  The chair is mestery. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:47 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:49 <openstack> The meeting name has been set to 'networking'
14:02:02 <mestery> First, I'd like to welcome everyone to the first neutron meeting at 1400UTC! :)
14:02:13 <mestery> #link https://wiki.openstack.org/wiki/Network/Meetings Agenda
14:02:14 <jschwarz> woooo ;p
14:02:17 <jschwarz> we appreciate it
14:02:20 <obondarev> o/
14:02:26 <mestery> #topic Announcements
14:02:30 * dougwig waves groggily.
14:02:31 <mestery> Juno-3 was released last week
14:02:47 <mestery> #link https://launchpad.net/neutron/juno/juno-3/+download/neutron-2014.2.b3.tar.gz
14:02:55 <mestery> Thanks to the team for some awesome work here!
14:03:13 <mestery> We really pulled together, I'm happy and proud of the work everyone did!
14:03:17 <jckasper_> fyi:  wiki still states Tuesdays at 1400 UTC (#openstack-meeting-alt)
14:03:28 <mestery> jckasper_: Will update (or please do yourself, thanks!)
14:03:51 <mestery> We're now onto the first RC
14:04:02 <mestery> #link https://launchpad.net/neutron/+milestone/juno-rc1
14:04:33 <mestery> We'll cover the FFEs for RC1 coming up in the agenda.
14:04:37 <mestery> Any other announcements for the team?
14:05:24 <mestery> Moving along then ...
14:05:26 <mestery> #topic Bugs
14:05:26 <rkukura> hi
14:05:28 <mestery> enikanorov: Hi there!
14:05:32 <enikanorov> hi
14:05:38 <ajo> hi :)
14:05:47 <garyk> hi
14:05:56 <garyk> finally a neutron meeting at a time when i am awake
14:05:57 <mestery> garyk: Nice seeing you here ;)
14:06:07 <amotoki> garyk: :-)
14:06:08 <enikanorov> on bugs: i see a spike in gate failures related to DB lockwait timeout and mysql connectivity problems
14:06:11 <garyk> yeah, sorry for missing so many. my humble apologies
14:06:21 <mestery> garyk: Totally understand. :)
14:06:30 <mestery> enikanorov: Link?
14:06:32 <enikanorov> the first one i need to sort out yet - some new lock wait timeouts appeared in -dvr gate job
14:06:46 <enikanorov> i have not filed bugs yet, analysing logstash
14:07:09 <enikanorov> i will file them soon
14:07:42 <enikanorov> and there is another bug i'd like to mention:
14:07:44 <mestery> enikanorov: Thanks!
14:07:45 <enikanorov> #link https://bugs.launchpad.net/neutron/+bug/1323729
14:07:47 <uvirtbot> Launchpad bug 1323729 in neutron "Remove Open vSwitch and Linuxbridge plugins from the Neutron tree" [High,Confirmed]
14:07:56 <mestery> enikanorov: markmcclain is on that one :)
14:08:02 <enikanorov> are we going to do that in J?
14:08:02 <markmcclain> enikanorov: I've got the proposals ready :)
14:08:23 <mestery> I think we're waiting for the cisco plugin removal bug to land first, right markmcclain?
14:08:29 <markmcclain> mestery: correct
14:08:30 <mestery> HenryG: ^^^
14:08:42 <mestery> markmcclain: OK, lets see if we can land that one today and then get LB and OVS removal done.
14:08:53 <HenryG> Yes, it is about ready to get the boot.
14:08:56 <enikanorov> ok, good
14:08:59 <mestery> HenryG: Ha! :)
14:09:04 <markmcclain> mestery: sounds good.. I'll coordinate with HenryG
14:09:09 <enikanorov> that's all from me
14:09:09 <mestery> markmcclain HenryG: Thanks!
14:09:24 <rossella_s> regarding the DB lockwait timeout error, I have a patch that remove most of the locking in the db base plugin. It would be nice to get more feedback https://review.openstack.org/#/c/100963/
14:09:24 <mestery> enikanorov: Thanks for the update on bugs, and keep us updated on the ML around the DB bugs you're triaging now.
14:09:34 <mestery> #link https://review.openstack.org/#/c/100963/
14:09:49 <mestery> rossella_s: Thanks for the patch! Have any cores spent time on this one yet?
14:10:11 <rossella_s> mestery: thanks! yes some core did but I think it needs more eyes on it
14:10:18 <rossella_s> mestery: it is a big change
14:10:29 <markmcclain> mestery, rossella_s: I've spent some time on it, but need to spend more since it is touches many critical paths
14:10:31 <mestery> rossella_s: I see that in looking at it now :)
14:10:48 <garyk> rossella_s: concern is that a lot of the CI's fail.
14:11:10 <marun> rossella_s: As per my review comment, I think more thourough testing is suggested by such a substantive change.
14:11:25 <enikanorov> marun: +1
14:11:27 <mestery> I agree with marun and garyk here.
14:11:28 <rossella_s> garyk: I will have a look at the CI
14:11:32 <amuller> We don't have tests that explicitly test concurrent operations do we?
14:11:32 <amotoki> feel same
14:11:37 <marun> rossella_s: I know that's complicated by the currently poor testing, and I'll be happy to help if you need.
14:11:50 <rossella_s> marun: I added some unit tests, I can add a functional test, I'd appreciate your help
14:11:57 <enikanorov> amuller: tempest, but it still requires a number of runs to be sure
14:12:13 <marun> rossella_s: I'm happy to help.
14:13:07 <rossella_s> marun: thanks
14:13:07 <mestery> #action marun to work with rossella_s to add more testing to the DB locking patch
14:13:12 <mestery> Thanks for the offer of help marun!
14:13:26 <mestery> Any other bugs the team should be aware of now?
14:14:12 <mestery> #topic FFE BP Discussion
14:14:26 <mestery> The list of BPs with a granted FFE are here: https://launchpad.net/neutron/+milestone/juno-rc1
14:14:35 <mestery> I'd like to walk through them and see where they are,
14:14:42 <mestery> We have until Friday to land these.
14:14:49 <mestery> First one: L3 HA
14:14:50 <mestery> #link https://blueprints.launchpad.net/neutron/+spec/l3-high-availability
14:14:59 <mestery> carl_baldwin: You have been sheparding this one, how is it looking?
14:15:04 <marun> url 2
14:15:47 <carl_baldwin> mestery: looking better.  Some refactoring came in recently that I think needs some work.
14:16:00 <carl_baldwin> There are three patches left.
14:16:19 <mestery> carl_baldwin: What is your estimate on if we can land them by Friday? Looking good still?
14:16:52 <carl_baldwin> I think it is looking pretty good.
14:17:13 <mestery> carl_baldwin: Thanks!
14:17:20 <amotoki> is there any wiki (or other) to explain how to test it? I think we need more broader testing.
14:17:25 <marun> amuller has agreed to work with me to work on more substantive functional post-merge.
14:17:47 <amotoki> (though i do testing manually)
14:17:48 <amuller> amotoki: https://wiki.openstack.org/wiki/Meetings/Neutron-L3-Subteam#Blueprint:_l3-high-availability_.28safchain.2C_amuller.29
14:17:59 <marun> the goal will be an automated end-to-end test of l3 ha before release of juno
14:18:02 <carl_baldwin> amuller: thanks for the link
14:18:13 <amotoki> amuller: really useful
14:18:14 <mestery> #link https://wiki.openstack.org/wiki/Meetings/Neutron-L3-Subteam#Blueprint:_l3-high-availability_.28safchain.2C_amuller.29
14:18:36 <mestery> Thanks for the updates on this one! Next on the list is ipset:
14:18:38 <mestery> #link https://blueprints.launchpad.net/neutron/+spec/add-ipset-to-security
14:18:45 <mestery> I believe this one has a single patch left.
14:18:57 <mestery> And the main holdup now is around the possible need for refactoring this.
14:19:10 <mestery> ajo: You've been looking at this one and brought this up with me yesterday I recall.
14:19:12 <garyk> my concern with the l3 HA is scale. have you guys done any scale tests with this? or does it work with devstack ?
14:19:21 <markmcclain> mestery: looks like 2 reviews for IPSet
14:19:34 <markmcclain> #link https://review.openstack.org/#/q/status:open+project:openstack/neutron+branch:master+topic:bp/add-ipset-to-security,n,z
14:19:35 <mestery> markmcclain: I think one is a testing patch and salv has marked that one WIP.
14:19:38 <ajo> mestery, correct
14:19:43 <ajo> I believe it's in very good shape now
14:19:49 <ajo> I just submited the functional testing
14:19:52 <ajo> as a follow up atch
14:19:53 <mestery> markmcclain: Whoops, I'm wrong, sorry :)
14:19:55 <ajo> patch
14:20:06 <mestery> Ah, that explains it then ajo. :)
14:20:06 <amuller> garyk: We normally perform those kind of tests post-merge
14:20:08 <markmcclain> mestery: I plan on reviewing these today
14:20:14 <mestery> markmcclain: Thanks!
14:20:18 <ajo> :-)
14:20:31 <mestery> markmcclain: Note the comments around refactoring and the time left. I was fine with the refactoring happening in kilo, would appreciate your comments there as well!
14:21:01 <markmcclain> mestery: ok
14:21:07 <ajo> mestery, I believe the problem around refactoring into a driver, was problematic with CI & devstack
14:21:14 <ajo> as we would have to point to the new driver once ready.
14:21:14 <mestery> ajo: OK
14:21:21 <ajo> the work was actually easy
14:21:56 <mestery> ajo: Thanks for the update here! I think this one also looks to be in good shape to merge by Friday.
14:22:27 <mestery> Moving on: retargetable functional testing
14:22:28 <ajo> thanks :)
14:22:29 <mestery> #link https://blueprints.launchpad.net/neutron/+spec/retargetable-functional-testing
14:22:45 <mestery> marun: This one is yours, and since it's testing, doesn't need an FFE but does need to merge by Friday.
14:22:49 <mestery> marun: What are your thoughts on this one merging this week yet?
14:23:06 <marun> I'll have an updated patch tomorrow that removes lb and ovs testing and replaces it with ml2.
14:23:27 <mestery> marun: Excellent!
14:23:35 <marun> I've already addressed substantive comments from salv-orlando, so I expect it should be mergeable tomorrow.
14:23:57 <mestery> marun: Thank you! Hopefully we can get it in the merge queue tomorrow then.
14:24:23 <mestery> Next one on the list is FWaaS support for DVR:
14:24:25 <mestery> #link https://blueprints.launchpad.net/neutron/+spec/neutron-dvr-fwaas
14:24:37 <mestery> carl_baldwin: Have you been looking at this one with armax and SumitNaiksatam?
14:25:16 * carl_baldwin looks
14:25:21 <mestery> carl_baldwin: ;)
14:25:27 <carl_baldwin> yes, I’ve had an eye on it.
14:25:44 <mestery> I think armax has also been reviewing this one.
14:26:08 <carl_baldwin> I think it is very close.  Will review again today as my comments from yesterday seem to have been addressed.
14:26:12 <mestery> I'll ping SridarK_ later today for an update on this one as well.
14:26:16 <mestery> carl_baldwin: Thank you!
14:26:28 <SridarK_> mestery: yes all comment addresses as of now
14:26:36 <SridarK_> carl_baldwin: thanks for review
14:26:45 <mestery> SridarK_: Hey! Excellent, thanks! Any ideas on the current Jenkins failure there?
14:27:03 <SridarK_> mestery: seems unrelated - just triggered a recheck
14:27:09 <mestery> SridarK_: thank you!
14:27:18 <SridarK_> mestery: thx
14:27:27 <mestery> OK, next up is migration reorganization:
14:27:28 <mestery> #link https://blueprints.launchpad.net/neutron/+spec/reorganize-migrations
14:27:47 <mestery> I spoke to salv-orlando over the weekend via email, and there is one patch in particular he wants merged out of this series
14:27:55 <mestery> Even if all of them don't make it.
14:28:26 <obondarev> mestery: can you please point the patch?
14:28:36 <mestery> I believe it's this one: https://review.openstack.org/#/c/112732/
14:28:40 <garyk> mestery: salv is also away for a few days.
14:28:44 <mestery> garyk: Yes
14:28:55 <mestery> HenryG: You've been reviewing this one I believe.
14:29:08 <mestery> HenryG: Are you aware of salv's wishes on this BP?
14:29:21 <HenryG> Yup. It's pretty close to go in, I think.
14:29:40 <mestery> HenryG: OK, thanks! I don't think salv can update it this week, is this something you could take on in his abscense?
14:29:48 <HenryG> Sure
14:29:56 <mestery> HenryG: Thanks!
14:29:58 <garyk> great. can you ping me and i will review
14:30:12 <mestery> #action HenryG to take on the DB migration patches from salv-orlando this week
14:30:12 <HenryG> Thanks gary, will do
14:30:17 <amotoki> HenryG: could you share points on what should be reviewed and what points should be checked?
14:30:18 <markmcclain> HenryG: also feel free to ping met oo
14:30:21 <garyk> hemna: dankie
14:30:37 <garyk> HenryG: ^
14:31:09 <HenryG> :)
14:31:12 <mestery> The next one on the list is the L3 metering label changes:
14:31:13 <mestery> #link https://blueprints.launchpad.net/neutron/+spec/l3-metering-mgnt-ext
14:31:18 <mestery> This one has two very small patches
14:31:56 <mestery> amotoki: Looks like you need to sync with brian haley on this one per the review
14:32:01 <mestery> #link https://review.openstack.org/#/c/70090/
14:32:03 <haleyb> My last comment on that patch was a question for amotoki asking for clarification
14:32:08 <mestery> amotoki: Can you do that this week yet?
14:32:14 <mestery> haleyb: Ack
14:32:15 <amotoki> haleyb: will check asfter the meeting.
14:32:21 <mestery> amotoki: Thank you!
14:32:30 <haleyb> ok, or even safchain since he originally did the code
14:33:01 <mestery> The last BP on the FFE list is another testing one, UT test autodeletion:
14:33:02 <mestery> #link https://blueprints.launchpad.net/neutron/+spec/remove-unit-test-autodeletion
14:33:23 <mestery> This one is now in the queue it appears
14:33:33 <SumitNaiksatam> mestery: sorry, I was away afk
14:33:39 <mestery> SumitNaiksatam: no worries :)
14:33:44 <mestery> markmcclain: Thanks for getting that one in the queue this morning!
14:34:01 <markmcclain> mestery: kevinbenton helped too
14:34:11 <mestery> kevinbenton: Thanks for getting that one up this morning!
14:34:17 <mestery> So, that's it for BPs with FFEs.
14:34:22 <mestery> It looks like we're in pretty good shape.
14:34:24 <SumitNaiksatam> mestery: regarding, https://blueprints.launchpad.net/neutron/+spec/neutron-dvr-fwaas SridarK_ and the rest of the fwaas team is currently doing functional testing
14:34:26 <mestery> Remember, these need to merge by Friday.
14:34:35 <mestery> SumitNaiksatam: Ack, thanks for the update there!
14:34:56 <SumitNaiksatam> mestery: all review comments have been addressed last night
14:35:18 <mestery> SumitNaiksatam: Awesome! carl_baldwin is going to look at that one today as well, and hopefully armax can re-review it today as well.
14:35:33 <mestery> OK, moving on in the agenda now.
14:35:35 <SumitNaiksatam> mestery: yeah, thanks armax and carl_baldwin
14:36:07 <mestery> #topic Incubator Update
14:36:08 <carl_baldwin> SumitNaiksatam: ready to +2.  Need to address CI failures.
14:36:29 <markmcclain> mestery: with the extreme gate backlog last week held off adding more work for infra
14:36:31 <mestery> markmcclain: Can you provide an update on the incubator now that Juno-3 has passed and with it the 24hour merge window?
14:36:35 <mestery> markmcclain: Jinx! :)
14:37:08 <ajo> :)
14:37:12 <markmcclain> markmcclain: will resume the work now that higher priority items are merged
14:37:17 <markmcclain> mestery: haha
14:37:19 <mestery> markmcclain: Awesome and thanks!
14:37:42 <mestery> #topic Parity
14:37:47 <mestery> markmcclain: Hi again :)
14:38:21 <markmcclain> mestery: hi.. we have to make a devstack change to address one issue and held off with j-3 rush, so will push that this week
14:38:42 <mestery> markmcclain: I think we should push this patch on the devstack side as well: https://review.openstack.org/#/c/105785/
14:38:47 <mestery> That makes neutron the default in devstack
14:38:48 <mestery> Thoughts?
14:39:12 <markmcclain> mestery: we need to activate grenade testing first which is in the queue
14:39:18 <mestery> markmcclain: Ack
14:39:19 <markmcclain> *my work queue
14:39:28 <markmcclain> and then we can flip the default
14:39:35 <mestery> markmcclain: Sounds good
14:40:17 <garyk> mestery: my only concern with that devstack one is the mad rush for J
14:40:32 <garyk> can we defer it for a week or 2 when the gate is a little less crazy
14:40:37 <mestery> garyk: Agreed, and to be honest, if it slips to post-J, it's not a huge deal.
14:40:38 <mestery> garyk: Ack
14:40:52 <mestery> garyk: It's main purpose is that it's part of the parity plan agreed to with the TC at the start of Juno.
14:41:15 <garyk> i just feel that we are alsways between a rock and a hard place in neutron so it we can just limit the rocks being thrown at us :)
14:41:28 <mestery> less rocks are always better
14:41:34 <markmcclain> ++
14:42:04 <mestery> OK, lets move on now.
14:42:06 <mestery> #topic Docs
14:42:11 <mestery> emagana: Hi! Docs update this week?
14:42:13 <emagana> mestery: Hi
14:42:23 <emagana> mestery: a short one!
14:43:02 <emagana> Folks help us to identify gaps on documentation (specially the new staff), we are using this etherpad: https://etherpad.openstack.org/p/neutron-docs-juno
14:43:04 <emagana> link# https://etherpad.openstack.org/p/neutron-docs-juno
14:43:26 <emagana> ups.. #link https://etherpad.openstack.org/p/neutron-docs-juno
14:43:44 <emagana> So far, I believe only L3 HA is not included
14:44:31 * mestery looks at the etherpad link
14:44:57 <mestery> There is some good stuff in there emagana, I'll eyeball this closer post-meeting, thanks for sharing!
14:45:01 <emagana> nothing more
14:45:07 <mestery> emagana: Are there any deadlines for docs we should be aware of?
14:45:30 <emagana> dont have the deadlines
14:45:41 <mestery> emagana: OK, was just curious. Thanks!
14:45:43 <amotoki> I think one milestone is a month after the release.
14:45:51 <emagana> let me get them from anne and I will update both wiki and etherpad
14:46:06 <mestery> amotoki emagana: Thank you!
14:46:11 <amotoki> (just from our experience from icehouse)
14:46:12 <emagana> Yes, normally Docs are more flexible than the rest of the projects
14:46:54 * mestery doesn't see mlavalle here so will skip Tempest today.
14:46:58 <mestery> #topic L3
14:47:02 <mestery> carl_baldwin: Good morning!
14:47:05 <carl_baldwin> hi
14:47:14 <carl_baldwin> wiki is up to date.
14:47:35 <carl_baldwin> Will post infra changes soon to make dvr job non-voting (from experimental)
14:47:50 <mestery> carl_baldwin: Excellent!
14:47:52 <carl_baldwin> We discussed L3 HA.  I think it is converging.
14:48:20 <carl_baldwin> Need a tempest change to merge to fix experimental job.
14:48:32 <carl_baldwin> #link https://review.openstack.org/#/c/116377/
14:48:43 * mestery looks
14:49:15 <carl_baldwin> That is all I have.  I’ll point readers to the wiki for the rest.
14:49:18 <carl_baldwin> #link https://wiki.openstack.org/wiki/Network/Meetings#L3_.28carl_baldwin.29
14:49:20 <mestery> carl_baldwin: That looks like an innocuous patch to me.
14:49:38 <carl_baldwin> mestery: Yeah, just need some tempest cores to look and accept it.
14:49:57 <carl_baldwin> It should get us clean tempest runs on dvr.
14:50:01 <mestery> carl_baldwin: Maybe ping some folks in #openstack-qa, I bet you could get it in the queue today easily.
14:50:27 <carl_baldwin> #action carl_baldwin will ping #openstack-qa today
14:50:34 <mestery> #topic IPV6
14:50:38 <mestery> sc68cal: Hi! Around?
14:51:53 * mestery thought he saw sc68cal update the IPV6 agenda this week, waits for a moment longer.
14:52:01 <xuhanp> mestery, can I provide one review about IPv6?
14:52:12 <mestery> xuhanp: Please do!
14:52:13 <xuhanp> https://review.openstack.org/103811
14:52:14 <mestery> xuhanp: Thanks!
14:52:25 <xuhanp> I will address the -1 tomorrow, but can get more comments.
14:52:33 <xuhanp> We will need that for DHCPv6 to work
14:52:37 <mestery> #link https://review.openstack.org/103811
14:52:43 <mestery> xuhanp: OK
14:52:50 <xuhanp> mestery, thanks!
14:53:05 <amotoki> xuhanp: are there any reviews we need to take care of before Juno?
14:53:05 <mestery> xuhanp: Anything else in IPV6 area this week?
14:53:15 <amotoki> *any other reviews
14:53:25 <xuhanp> not as I am aware of
14:53:36 <xuhanp> will ping you guys if there are more.
14:53:37 <HenryG> There is the one with the issue regarding HA router failover
14:54:01 <mestery> HenryG: Link?
14:54:09 * HenryG is looking for it ...
14:54:32 <amotoki> I think HenryG is talking about the dev ML topic.
14:54:47 <xuhanp> https://review.openstack.org/114437
14:54:48 <xuhanp> this link?
14:55:09 <HenryG> amotoki: yes, and xuhanp: yes. Thanks.
14:55:21 <amotoki> #link http://lists.openstack.org/pipermail/openstack-dev/2014-September/thread.html#44602
14:55:28 <mestery> That patch is in WIP right now, isn't it?
14:55:53 <mestery> Anyways, lets see if that one can make it as well.
14:56:00 <mestery> amotoki: thanks for the link there!
14:56:04 <xuhanp> We are still trying to figure out the right way to do it for IPv6
14:56:45 <mestery> xuhanp: thanks!
14:56:48 <mestery> #topic Open Discussion
14:57:00 <marios> thanks for the new meeting time
14:57:03 <amotoki> Good news from Horizon. Most planned blueprints (including DVR and IPV6) and bugs have been merged. I will talk with david (ptl) about L3-HA support.
14:57:07 <mestery> marios: you're welcome
14:57:21 <mestery> amotoki: awesome!
14:57:22 <SumitNaiksatam> amotoki: thats wonderful!
14:57:22 <regXboi> mestery: best to remind folks of the next rotating meeting before we are done
14:57:23 <hemanthravi> markmcclain, do you have an approx timeframe for the incubator to be available
14:57:35 <SumitNaiksatam> fyi - group based policy (gbp) has a stackforge repo: https://github.com/stackforge/group-based-policy
14:57:36 <mestery> regXboi: Hey there, and yes!
14:57:52 * regXboi has been lurking the whole meeting
14:58:01 <mestery> #info Neutron meeting rotates, next week is back to Monday at 2000 UTC
14:58:14 <amotoki> 2100UTC?
14:58:22 <mestery> amotoki: Right.
14:58:31 <mestery> #info Neutron meeting rotates, next week is back to Monday at 2100 UTC
14:58:42 * mestery needs to go for more coffee in 2 minutes
14:58:49 <mestery> OK, thanks everyone!
14:58:51 <kevinbenton> hemanthravi: after it finishes incubating :-)
14:59:03 <mestery> I'm glad the new meeting time has allowed some fresh faces to join us!
14:59:08 <amuller> amotoki++
14:59:13 <mestery> We'll see you all on the ML and IRC!
14:59:15 <mestery> #endmeeting