21:03:26 <markmcclain> #startmeeting Networking
21:03:27 <openstack> Meeting started Mon Jul 15 21:03:26 2013 UTC.  The chair is markmcclain. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:03:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:03:30 <openstack> The meeting name has been set to 'networking'
21:04:02 <markmcclain> #link https://wiki.openstack.org/wiki/Network/Meetings#Bugs
21:04:03 <garyk> markmcclain: hi!
21:04:37 <markmcclain> Tomorrow's the H2 cut, so I'd like to spend most of the time talking about reviews we have outstanding
21:05:28 <markmcclain> https://launchpad.net/neutron/+milestone/havana-2
21:05:54 <markmcclain> we still have lot of items inflight
21:06:29 <markmcclain> the good thing is that everything on here was proposed in time, but we don't have to cram it through just to make the h2 cut
21:07:41 <markmcclain> if something needs another 1-2 days to clean up we'll still be ok for the larger Havana schedule
21:07:48 <emagana> hi all, little late!!
21:08:03 * salv-orlando has already removed  hist items which are unlikely to merge soon
21:08:32 <markmcclain> I also want to say thanks to nati_uen_ for tracking down a nasty bug that was breaking the main devstack gate
21:08:55 <markmcclain> #topic Bugs
21:08:59 <nati_uen_> markmcclain: Your welcome
21:09:08 <markmcclain> https://bugs.launchpad.net/neutron/+bug/1194026
21:09:10 <uvirtbot> Launchpad bug 1194026 in neutron "check_public_network_connectivity fails with timeout" [Critical,In progress]
21:09:33 <armax> I have also found this one today: bug #1201478
21:09:35 <uvirtbot> Launchpad bug 1201478 in neutron "OverflowError: timeout is too large in gate-neutron-python26" [Undecided,In progress] https://launchpad.net/bugs/1201478
21:09:40 <armax> it's probably not as nasty
21:09:43 <armax> but still annoying
21:09:49 <markmcclain> nachi has proposed a fix here: https://review.openstack.org/#/c/36890/
21:10:11 <nati_uen_> salv-orlando: could you help me to improve commit message?
21:10:19 <markmcclain> Looks like both amotoki and salv-orlando have been actively reviewing this one
21:10:23 <salv-orlando> I'll send you a draft after the meeting
21:10:38 <salv-orlando> yep, it's good for me. I am pestering nati_uen_ about the commit message
21:10:39 <nati_uen_> salv-orlando: Thanks!
21:10:54 <salv-orlando> because he's the lucky winner of today's pedantry prize
21:10:59 <garyk> :)
21:11:09 <markmcclain> Currently this test cause the infras team to turn off the neutron gate check.  The longer this check is non-voting the greater the chance that bit rot sneaks in
21:11:33 <markmcclain> armax: thanks for pointing out that bug
21:11:46 <nati_uen_> salv-orlando: haha I should still improve my english
21:12:29 <salv-orlando> markmclain: I think we should be able to merge it in the next hours
21:12:35 <armax> markmcclain: np
21:12:43 <salv-orlando> markmcclain: ^^
21:13:04 <markmcclain> salv-orlando: great
21:13:18 <markmcclain> amotoki: would you mind looking at armax's fix?
21:13:42 <amotoki> markmcclain: i haven't checked it yet.
21:14:07 <amotoki> markmcclain: will look it soon.
21:14:14 <markmcclain> amotoki: ok.. it's a small fix
21:14:30 <markmcclain> Any critical bugs the team needs to know about?
21:15:02 <markmcclain> #topic Docs
21:15:02 <armax> yeah…it's non critical but it'd be good to have a look at it as it may cause false positives during the review process
21:15:35 <markmcclain> emagana has updated the docs for neutron rename
21:15:36 <markmcclain> https://review.openstack.org/#/c/36322/
21:15:37 <emagana> on docs I am waiting for reviews on:  https://review.openstack.org/#/c/36322/
21:15:56 <markmcclain> when folks have some time please review as quality docs are critical
21:16:10 <markmcclain> thanks emagana for updating these
21:16:11 <armax> this one would also appreciate some love: https://review.openstack.org/#/c/32979/
21:16:25 <emagana> markmcclain: Thanks!! Please Folks, add your comments!
21:16:48 <armax> it's not strictly neutron…it documents how to pass network info to nova
21:17:22 <markmcclain> armax: right but still impacts us
21:17:30 <armax> yup
21:17:43 <garyk> nati_uen_: please look at my comments for https://review.openstack.org/#/c/36890/
21:17:54 <nati_uen_> garyk: yes sir!
21:18:07 <salv-orlando> armax: I will review that. For some reason I can +2 it.
21:18:14 <armax> nice
21:18:15 <amotoki> how about renaming in other docs? Is anyone working on netconn-api or other guides?
21:18:33 <salv-orlando> amotoki: I will do the netconn-api renaming
21:18:34 <armax> salv-orlando: you the man :)
21:18:47 <amotoki> salv-orlando: thanks
21:18:55 <amotoki> i will do it for ops-guide
21:18:57 <markmcclain> amotoki: I don't think that anyone has doubled checked the netconn-api docs.
21:19:15 <emagana> just one more update, will be adding one more commits for the rest of the manuals (nova, installation, etc..) please, also review them
21:19:26 <salv-orlando> markmcclain: we mostly already used the generic term 'network' there. But something might have been missed.
21:19:32 <amotoki> markmcclain: i am talking about renaming to neutron in netconn-api
21:19:54 <annegentle_> amotoki: there are also bugs https://bugs.launchpad.net/openstack-api-site/+bugs?field.tag=netconn-api but a few in progress, which is good
21:20:13 <salv-orlando> #action salv-orlando to ensure the q-word is not anymore anywhere in netconn-api
21:20:24 <annegentle_> thanks salv-orlando
21:20:26 <markmcclain> salv-orlando: thanks
21:20:30 <enikanorov> q-word lol
21:20:52 <markmcclain> Any other docs related items?
21:21:21 <annegentle_> salv-orlando: https://bugs.launchpad.net/openstack-api-site/+bug/1201596
21:21:23 <uvirtbot> Launchpad bug 1201596 in openstack-api-site "Project rename for netconn-api" [High,Confirmed]
21:21:24 <annegentle_> just for you
21:21:44 <salv-orlando> annegentle_: that's very kind of you :)
21:22:49 <markmcclain> #topic API
21:23:03 <markmcclain> salv-orlando: hi
21:23:59 <salv-orlando> since today is mostly about open reviews
21:24:12 <salv-orlando> the status is that firewall and VPN API patches are very close to merge
21:24:33 <salv-orlando> snaiksatam added something to the firewall patch over the weekend and this triggered another round of review
21:25:16 <salv-orlando> nati_uen_ has just lifted the wip put on the API patch
21:25:30 <SumitNaiksatam> salv-orlando: thanks for the review, this was a pending item per your comment earlier i realized i hadn't added
21:25:33 <salv-orlando> for VPN… so we are ready for another and hopefully last round of review
21:25:46 <salv-orlando> np
21:26:06 <nati_uen_> salv-orlando: I have fixes the code based on Salvatore and Akihiro's comment, and pushed it
21:26:11 <salv-orlando> I think service provider patch is slipping to H-3, unless I hear otherwise from enikanorov_
21:26:21 <salv-orlando> enikanorov: ^^^
21:26:30 <enikanorov> well
21:26:44 <enikanorov> I'd like to hear something from markmcclain since he's still -2 on this patch
21:26:54 <salv-orlando> I have moved the authZ patch to h-3 as the last bit I need to are some changes into the agent mgmt patch and gongysh has just pushed another patch there, so I do not want to interfere
21:27:08 <markmcclain> salv-orlando: enikanorov pinged me about it.. I've got comments to publish on service_types
21:27:14 <enikanorov> I'm ready to resolve any comments (Have updated the wiki with description already)
21:27:37 <markmcclain> it's also a medium feature and I'd like to ensure that VPN and FW get reviewed first with everyone's limited cycles
21:28:02 <markmcclain> #topic VPN
21:28:04 <gongysh> salv-orlando: we can put my patch to h-3
21:28:12 <enikanorov> yep, i think we're in no hurry for service types but i would like to see it merged in early H-3
21:28:14 <nati_uen_> OK we are working on review comment.
21:28:22 <markmcclain> enikanorov: same here
21:28:27 <nati_uen_> salv-orlando: akihiro: and the others thenk you for your reviews
21:28:48 <nati_uen_> Cleanup for API side is finished. Swami is working on Client side.
21:29:00 <nati_uen_> I'll fix the driver side in today
21:29:22 <nati_uen_> One good news is heat support will be come up after we merged the vpn.
21:29:25 <nati_uen_> That's all
21:29:41 <nati_uen_> markmcclain: I have discuss with you namespace wrapper
21:29:56 <markmcclain> nati_uen_: ok.. we can discuss offline
21:30:09 <nati_uen_> markmcclain: OK I put my thought on the gerrit
21:30:13 <nati_uen_> OK thanks
21:30:39 <markmcclain> nati_uen_: who's going to write the api docs for VPN?
21:30:45 <markmcclain> and regular docs?
21:31:16 <nati_uen_> markmcclain: Satich was raised hand
21:31:30 <nati_uen_> markmcclain: But If he don't do that, I'll take it
21:31:30 <emagana> nati_uen_: I can help you on that!
21:31:34 <nati_uen_> emagana: Thanks!
21:31:45 <emagana> nati_uen_: let's touch based offline!
21:31:52 <nati_uen_> emagana: gotcha
21:32:03 <nati_uen_> we have good wiki, so IMO it is easy to write docs
21:32:17 <markmcclain> Ok.. anything about VPNs?
21:32:34 <nati_uen_> markmcclain: That's all.
21:32:45 <emagana> #action emagana create bp on docs for VPNaaS
21:32:54 <markmcclain> nati_uen_: thanks for the update
21:33:05 <markmcclain> #topic FWaaS
21:33:08 <markmcclain> SumitNaiksatam: hi
21:33:12 <SumitNaiksatam> hi
21:33:17 <SumitNaiksatam> All fwaas patches are getting reviews, and we have two or more cores on each. The driver patch needs a little more core review attention.
21:33:27 <SumitNaiksatam> I got great feedback on the API patch.
21:33:34 <SumitNaiksatam> I believe all reviewers' comments have been addressed and I don't think there are outstanding issues.
21:33:36 <salv-orlando> I think I reviewed it but id not left comment
21:33:41 <salv-orlando> the driver patch
21:33:51 <salv-orlando> I will have another look at it.
21:33:54 <SumitNaiksatam> yeah, big thanks to Salvatore, Akihiro, Aaron, Eugene, Oleg and Paul for the continued reviews. Hopefully we can wrap this patch soon.
21:34:03 <SumitNaiksatam> i mean the API patch
21:34:13 <markmcclain> great glad to see we've got good core coverage
21:34:18 <SumitNaiksatam> and hopefully the agent and driver patches as well
21:34:30 <markmcclain> Who's writing api and regular docs for this?
21:34:31 <SumitNaiksatam> Devstack patch (Ravi) is also close to getting pushed, and if it lands soon it might help in reviews.
21:35:23 <gongysh> If you don't mind, I want to help write doc since I am not familiar with fwass.
21:35:32 <SumitNaiksatam> i will start working on the docs with the rest of the team
21:35:38 <SumitNaiksatam> gongysh: yeah sure
21:35:46 <SumitNaiksatam> :#action SumitNaiksatam create bp on docs for FWaaS
21:35:58 <SumitNaiksatam> SridarK (agent patch) has a question on the RPC version
21:36:06 <SumitNaiksatam> SridarK: you there?
21:36:11 <markmcclain> #action SumitNaiksatam create bp on docs for FWaaS
21:36:24 <SridarK> y On RPC - adding a method  for Agent -> Plugin - since it is a new method - backward compatible - so we bump up the minor version on both ends ?
21:36:45 <SumitNaiksatam> the question is more in the context of the L3 agent
21:36:57 <SridarK> got some diff opinions, follwing comments in rpc/dispatcher.py
21:37:08 <nati_uen_> Yes I have some concern
21:37:11 <SumitNaiksatam> since we are using the l3 agent footprint for the firewall agent
21:37:30 <nati_uen_> Current code changes l3-agent directly.
21:37:31 <russellb> ping me if you want me to look at a review WRT rpc versioning ... i added the support for it in the rpc code originally
21:37:58 <SridarK> thanks <russellb>
21:38:56 <SumitNaiksatam> nati_uen_: can you clarify by what you mean by changing code directly?
21:39:33 <nati_uen_> SumitNaiksatam: current code is adding mix in for l3-agent class. IMO, we agreed we don't touch l3-agent in this experimental version of services
21:39:35 <SumitNaiksatam> the fwaas agent functionality kicks in only if the fwaas driver is configured
21:40:19 <enikanorov> so fw and vpn will conflict for l3 agent?
21:40:24 <SridarK> i thought that this is the understanding and we try to look for a common framework across services in H3
21:40:28 <SumitNaiksatam> nati_uen_: i don't recall that we had this agreement, in fact the agreement was to leverage the footprint of the l3 agent using the mixing approach
21:40:44 <nati_uen_> enikanorov: it will not be conflict
21:41:04 <enikanorov> nati_uen_: are you talking about the issue we have discussed today?
21:41:10 <enikanorov> about l3 agent?
21:41:25 <nati_uen_> enikanorov: yes
21:41:42 <nati_uen_> ah IMO, Mark said we should use inherit approach at first.
21:41:52 <enikanorov> by conflict I meant that it would not be possible to configure both vpn and fw at the same time
21:41:54 <nati_uen_> If it is my misunderstandings, it is OK
21:42:19 <markmcclain> inheritance was my preferred path for early development
21:42:37 <nati_uen_> enikanorov: it is not tested, but it looks like we can use both of it. (i'm little bit worrying about iptables though)
21:42:54 <markmcclain> nachi's fix for the gate issues to the l3 agent should land first
21:42:57 <SumitNaiksatam> markmcclain, nati_uen_: we are using inheritance
21:44:04 <nati_uen_> SumitNaiksatam: it looks adding mixin to l3-agent
21:45:01 <markmcclain> ok.. can we chat about this after the meeting?
21:45:49 <SumitNaiksatam> markmcclain: SumitNaiksatam
21:45:52 <SumitNaiksatam> markmcclain: sure
21:46:14 <SumitNaiksatam> any others questions/thoughts on FWaaS?
21:46:14 <markmcclain> ok.. I want to cover the other teams before we run out of time
21:46:20 <nati_uen_> gotcha
21:46:28 <markmcclain> #topic ml2
21:46:35 <markmcclain> rkukura, mestery: hi
21:46:49 <rkukura> hi
21:47:09 <markmcclain> looks like ML2 changes are moving through
21:47:10 <rkukura> the multiple tunnel type patch is in, but needs a quick fix
21:47:27 <rkukura> https://review.openstack.org/#/c/37020/
21:47:35 <rkukura> this fix needs one more core
21:47:58 <rkukura> the GRE and VXLAN type drivers are very close - should get in tomorrow
21:48:11 <markmcclain> I'll take a look at 37020
21:48:23 <rkukura> markmcclain: thanks
21:48:26 <gongysh> thanks
21:48:48 <markmcclain> yeah I know I've reviewed a few iterations of the GRE and VXLAN drivers
21:49:02 <markmcclain> the team has been been super quick at responding to feedback
21:49:38 <markmcclain> anything else for ML2?
21:49:40 <rkukura> the ml2-portbinding BP is moved to h-3, and arosen has been raising questions about the port binding extension and GenericVifDriver stuff it depends on
21:50:17 <markmcclain> #topic LBaaS
21:50:24 <rkukura> also, the MechanismDriver BP is merged, but is not showing this in the BP
21:50:24 <enikanorov> agent scheduling patch is waiting for 3rd week for cores attention.
21:50:50 <enikanorov> I think it has chance to get in for H-2
21:50:57 <gongysh> enikanorov: I will go on with the agent scheduling review.
21:51:06 <enikanorov> gongysh: thanks.
21:51:15 <markmcclain> https://review.openstack.org/#/c/32137/
21:51:59 <enikanorov> that's the most important item for lbaas for the moment.
21:52:20 <gongysh> enikanorov: don't hesitate push me if I am lazy.
21:52:44 <markmcclain> ok.. after gongysh gets done with his review we'll get 2nd core from the others who already looked at it
21:52:49 <markmcclain> enikanorov: thanks for the update
21:52:52 <enikanorov> gongysh: ok =)
21:53:25 <markmcclain> #open discussion
21:53:40 <markmcclain> Any other major H2 items I've skipped?
21:53:40 <enikanorov> markmcclain: today a new bug on lbaas came in
21:53:53 <enikanorov> it was about no namespace support
21:53:53 <markmcclain> enikanorov: which bug
21:53:58 <enikanorov> let me find
21:54:08 <enikanorov> https://bugs.launchpad.net/neutron/+bug/1201249
21:54:09 <uvirtbot> Launchpad bug 1201249 in neutron "quantum-lbaas-agent ignores use_namespaces = False" [Low,In progress]
21:54:27 <jackmccann> https://review.openstack.org/24739 preserve iptables counters is getting close, any chance for H-2?
21:54:31 <enikanorov> so the question would be... if we plan to support such option ever?
21:54:41 <enikanorov> my take was 'no'
21:55:23 <markmcclain> enikanorov: that's correct originally we decided the feature needed namespaces to work
21:56:28 <markmcclain> garyk: can you take a second look at https://review.openstack.org/24739?
21:56:30 <salv-orlando> I struggle to understand how the comment in the review is related to the specific issue reported.
21:56:52 <salv-orlando> I am referring to the review for bug 1201249
21:56:55 <uvirtbot> Launchpad bug 1201249 in neutron "quantum-lbaas-agent ignores use_namespaces = False" [Low,In progress] https://launchpad.net/bugs/1201249
21:57:07 <enikanorov> salv-orlando: reported wants this feature
21:57:16 <enikanorov> that's it, probably
21:57:43 <enikanorov> but i think it only practically solvable via vm or hw appliances
21:58:05 <enikanorov> reported=reporter
21:58:11 <markmcclain> yeah.. the lbaas agent was never designed to work without namespaces
21:58:19 <garyk> markmcclain: sure
21:58:27 <markmcclain> garyk: thanks
21:58:39 <dkehn> markmcclain, thx for the reviews on https://review.openstack.org/#/c/30441/ which are completed, focusing on the front-end https://review.openstack.org/#/c/30447/
21:59:24 <jackmccann> garyk: yes, thanks
21:59:45 <enikanorov> dkehn: last time I checked, there was no test coverage for db-related code
22:00:33 <dkehn> enikanorov, markmcclain indicated taht we usually don't do db related items like cascade, etc
22:01:03 <dkehn> enikanorov, if thats whatt you are refferring to
22:01:33 <enikanorov> i'm refering to unit tests for api of extra dhcp options mixin
22:03:17 <dkehn> enikanorov, will look in it, take we talk off line
22:03:30 <dkehn> enikanorov, can we talk off line
22:03:41 <markmcclain> ok.. anything else?
22:03:55 <amotoki> dkehn: I'll look at your new patch soon.
22:03:57 <enikanorov> dkehn: sure, in about 8 hours.
22:04:17 <dkehn> enikanorov, lol, ok, I'm back in USA tz will ping you tomoroow
22:04:29 <enikanorov> ok
22:04:55 <markmcclain> Thanks to everyone for their hard work on H2.. remember the cut is end of day tomorrow
22:05:02 <markmcclain> #endmeeting